14:02:43 <nikhil_k> #startmeeting glance_artifacts_sub_team
14:02:45 <openstack> Meeting started Mon Oct 12 14:02:43 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:48 <openstack> The meeting name has been set to 'glance_artifacts_sub_team'
14:03:01 <mfedosin_> spent all my time on Nova and trusts :)
14:03:29 <mfedosin_> As far as I know Alex is writing an article about trusts
14:03:34 <nikhil_k> mfedosin: ah I see
14:03:41 <nikhil_k> trusts?
14:03:44 <nikhil_k> or artifacts?
14:03:49 <mfedosin_> oops
14:04:07 <nikhil_k> mfedosin: thank you for the info. I think we should discuss a few action items so that it's logged and we can get to it at some point.
14:04:07 <mfedosin_> artifacts of course
14:04:15 <nikhil_k> #topic agenda
14:04:29 <nikhil_k> there's no official agenda today.
14:04:45 <nikhil_k> Let's log some of the action items discussed during the weekly meeting last week.
14:05:02 <nikhil_k> #topic action items (prior to summit)
14:06:01 <nikhil_k> #action Alex, nikhil, <any_with_ack>: reach out to heat and magnum team to discuss their possibility and intent to use artifacts
14:06:08 <mfedosin_> afair we have to create a record in the 'summit session' etherpad
14:06:38 <nikhil_k> #action Alex: to finish article about artifacts documenting the API and features
14:06:51 <nikhil_k> mfedosin: thanks for the reminder!
14:07:31 <nikhil_k> #action mfedosin, nikhil, Alex, all: create a possible session proposal for mitaka before Tuesday Oct 13th at https://etherpad.openstack.org/p/mitaka-glance-summit-topics
14:08:33 <nikhil_k> #action nikhil: to sync with mfedosin and Alex before release notes are published to ensure integrity of Artifacts impl in Liberty
14:09:08 <mfedosin_> okay, if no one else - I will add a record there :)
14:09:29 <nikhil_k> #action all: find any possible release blockers before rc-final is tagged later this week (most likely Tues Oct 13th)
14:09:39 <nikhil_k> mfedosin: sure please do
14:10:24 <mfedosin_> I think because v3 is experimental and turned off by default there won't be any blockers
14:11:13 <nikhil_k> mfedosin: most likely, though we should avoid any intermittent errors in our tests and that is probable so, just being extra cautious.
14:11:51 <mfedosin_> all tests work fine
14:11:57 <nikhil_k> excellent!
14:12:07 <mfedosin_> or you want to disable tests by default too?
14:12:19 <nikhil_k> no, let's keep them
14:12:31 <nikhil_k> if the code exists, we should keep the tests
14:12:48 <nikhil_k> avoid any sec risks and all, make people be aware of the same
14:12:48 <mfedosin_> it's not hard actually, because it' just one config param there
14:13:10 <mfedosin_> so let's keep them, but if there will be some problems - we can disable them in a moment
14:13:19 <nikhil_k> sounds good
14:13:54 <nikhil_k> mfedosin: I am not sure if run tests is extensively being used, but it's another thing to maintain if we disable in tox
14:14:16 <nikhil_k> mfedosin: did you have any thing to add to action items?
14:15:04 <mfedosin_> I think just assign 'create a record in the etherpad' to me :)
14:15:56 <mfedosin_> and 'read and comment Alex article'
14:16:02 <nikhil_k> mfedosin: it's probably going to create another entry. but your name is first so, you should go ahead and do it. I will add a info item for that.
14:16:33 <nikhil_k> #info mfedosin to take the first go at creating a session proposal for Mitaka
14:16:42 <mfedosin_> cool!
14:16:58 <nikhil_k> #action all: read and comment artifacts related article created by Alex
14:17:33 <nikhil_k> #undo
14:17:33 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x99f4210>
14:17:50 <nikhil_k> #action all: read and comment artifacts related article to be created/published by Alex (soon)
14:17:50 <mfedosin_> haha, I think it was a joke, but yeah, we definitely must do it!
14:18:44 <nikhil_k> That's all I've on artifacts atm
14:19:05 <nikhil_k> Still have a couple of things to wind up for Liberty and I think we should have a final later this week..
14:19:34 <nikhil_k> if nothing else, we'd close the meeting
14:20:08 <mfedosin_> +1, should pay more attention to them, but really have no time :(
14:20:23 <nikhil_k> :)
14:20:32 <nikhil_k> Thanks mfedosin for joining, it was a nice and good one!
14:20:40 <mfedosin_> about Liberty - we've found a bug in schema today
14:20:49 <nikhil_k> eh
14:21:06 <nikhil_k> well good thing we've a experimental API then :)
14:21:08 <mfedosin_> https://bugs.launchpad.net/glance/+bug/1505218
14:21:08 <openstack> Launchpad bug 1505218 in Glance "Image schema doesn't contain 'deactivated' status" [Undecided,New] - Assigned to Mike Fedosin (mfedosin)
14:21:19 <mfedosin_> no, it's not artifact related
14:21:19 <nikhil_k> oh, images one..
14:21:25 <mfedosin_> yup
14:21:25 <nikhil_k> right, we need that in Liberty
14:21:38 <nikhil_k> Thanks for reminding :)
14:21:39 <mfedosin_> and here's the fix https://review.openstack.org/#/c/233608/
14:22:18 <mfedosin_> it must be in Liberty, because it breaks client's validation
14:22:33 <nikhil_k> agreed
14:23:49 <nikhil_k> ok, then. See you on our regular channel. Artifacts updates are pretty much done here, for now.
14:24:00 <nikhil_k> #endmeeting