14:02:20 <nikhil_k> #startmeeting glance_artifacts_sub_team
14:02:21 <openstack> Meeting started Mon Dec 14 14:02:20 2015 UTC and is due to finish in 60 minutes. The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:26 <openstack> The meeting name has been set to 'glance_artifacts_sub_team'
14:02:26 <ativelkov> o/
14:02:33 <sigmavirus24> \o
14:02:38 <nikhil_k> #chair ativelkov nikhil
14:02:39 <openstack> Warning: Nick not in channel: nikhil
14:02:40 <openstack> Current chairs: ativelkov nikhil nikhil_k
14:03:02 <nikhil> welcome everyone
14:03:04 <dshakhray> o/
14:03:05 <mfedosin> o/
14:03:05 <ativelkov> hi folks
14:03:09 <nikhil> #topic agenda
14:03:11 <sigmavirus24> nikhil: were you playing musical chairs just there?
14:03:26 <nikhil> sigmavirus24: haha, something like that :)
14:03:36 <nikhil> we've some items on agenda today
14:03:40 <nikhil> #link https://etherpad.openstack.org/p/glance-artifacts-sub-team-meeting-agenda
14:04:09 <nikhil> let's get started
14:04:22 <nikhil> #topic Glance v3 -> Glare v0.1 Migration
14:04:30 <ativelkov> So, we have a patch for GlanceV3 -> Glave v0.1 migration
14:04:39 <nikhil> #link https://review.openstack.org/#/c/254163/
14:04:52 <ativelkov> The patch is technically ready, but it fails a grenade test
14:05:43 <ativelkov> This happens because liberty glance has a v3 reference in its glance-api-paste.ini
14:05:57 <kairat> o/
14:06:02 <nikhil> ah
14:06:13 <ativelkov> I've removed it in Mitaka, so liberty's paste.ini becomes invalid in Mitaka
14:06:31 <ativelkov> and Grenade assumes that release N should be able to work on N-1 configs
14:06:44 <nikhil> um
14:06:49 <ativelkov> Theoretically there may be exceptions in this rule
14:07:09 <ativelkov> And I believe that removing an experimental API is a good example of such exception
14:07:16 <mfedosin> maybe we can leave v3 api, but make it stub
14:07:17 <nikhil> indeed
14:07:37 <mfedosin> I mean v3 endpoint still will be there
14:07:41 <ativelkov> So, yeah, there are two options
14:07:45 <mfedosin> but there will be warning message
14:08:05 <ativelkov> either leave a code to handle the apiv3app paste section
14:08:15 <mfedosin> where it's said that v3 is not supported and please use glare instead
14:08:27 <ativelkov> or make a patch to grenade to remove that section from the paste
14:08:40 <sigmavirus24> ativelkov: or have the v3 endpoint 301 to the v0.1 endpoint?
14:08:53 <sigmavirus24> A little more code but also a bit more friendly to API consumers as well
14:09:02 <mfedosin> because many vendors curse us for doing that :)
14:09:09 <ativelkov> sigmavirus24: may be an option, yes
14:09:21 <sigmavirus24> mfedosin: my idea?
14:09:52 <ativelkov> sigmavirus24: I believe mfedosin means about the same as you do
14:09:55 <sigmavirus24> But yeah, that will be a problem until we can figure out how to remove the section anyway. Next cycle won't be any easier if it wants glance to use Mitaka's
14:10:06 <mfedosin> sigmavirus24: yes kind of
14:10:11 <sigmavirus24> ativelkov: yeah, makes sense
14:10:35 <ativelkov> sigmavirus24: no, next cycle will be better!
14:10:42 <sigmavirus24> ativelkov: will it?
14:10:48 * sigmavirus24 is maybe missing something
14:10:49 <ativelkov> wel'll remove the apiv3app section from mitaks's paste.ini
14:11:04 <sigmavirus24> okay
14:11:09 * sigmavirus24 trusts you ativelkov :)
14:11:14 <mfedosin> ativelkov: will be better than the cycle after the next one?
14:11:18 * sigmavirus24 also only woke up 30 min ago
14:11:31 <ativelkov> but we will leave the " glance.api.v3.router:API.factory" code module
14:11:44 <ativelkov> this is the module referenced in Liberty's paste.ini
14:12:00 <ativelkov> and this module will return the 301 you speak about
14:12:25 <ativelkov> so, new Mitaka's deployment will have no hint of /v3 in glance-api
14:12:57 <ativelkov> upgrades from Liberty to Mitaka will work but will return 301 if /v3 is accessed
14:13:11 <ativelkov> So, this should work
14:13:40 <ativelkov> OK, I'll update this patch today then
14:13:55 <sigmavirus24> :D
14:13:58 <ativelkov> #agreed to leave a /v3 stub to return a 301 for Liberty->mitaka upgrades
14:14:16 <nikhil> makes sense
14:14:30 <ativelkov> Another question is the version prefix for Glare
14:14:35 <mfedosin> cool :)
14:14:45 <ativelkov> right now in glance we have a v{major} prefix
14:14:52 <ativelkov> i.e. we have /v2/images
14:14:56 <sigmavirus24> Right
14:15:05 <ativelkov> since glare is experimental, it should be v0.x
14:15:08 <mfedosin> v0.1?
14:15:16 <ativelkov> yup, v0.1 currently
14:15:19 <sigmavirus24> ativelkov: if it's any consolation Keystone went from /v2.0 to /v3
14:15:22 <nikhil> yes, only major
14:15:40 <sigmavirus24> So it's not unheard of for APIs to have versioning that is not consistent (although it's not ideal, which i assume is your point)
14:15:41 <ativelkov> so, what should be the prefix in this case? /v0/artifacts or /v0.1/artifacts?
14:16:04 <nikhil> ativelkov: why not just v1 ?
14:16:05 <sigmavirus24> ativelkov: so I think jaypipes has argued against v0 in the past
14:16:14 <mfedosin> v-1 :)
14:16:19 <sigmavirus24> nikhil: isn't v1 deprecated?
14:16:21 <sigmavirus24> :P
14:16:26 <ativelkov> glare v1 :)
14:16:28 <sigmavirus24> nikhil: if v1 is deprecated, why are we adding features to it now
14:16:30 <ativelkov> not glance v1
14:16:35 <mfedosin> no, v1 is bad
14:16:36 <sigmavirus24> oh true
14:16:39 <sigmavirus24> different port
14:16:44 * sigmavirus24 is still tired
14:16:47 <sigmavirus24> sorry again
14:16:54 <mfedosin> it's an experimental api
14:16:59 <nikhil> it will be a separate in keystone one so don't think a problem exists
14:17:28 <nikhil> I think we can propose v1 and see if there's any pushback
14:17:31 <ativelkov> hmm.. but the real version of this API is not v1
14:17:38 <nikhil> rather than assuming worse
14:17:58 <nikhil> ativelkov: oh?
14:18:03 <ativelkov> nikhil: so, you are proposing to keep developing v0.x, but host it under the v1 prefix?
14:18:12 <mfedosin> maybe just "vx" - which means eXperimental
14:18:13 <sigmavirus24> Idk, I like v0.1 to be consistent with our more recent messaging but I don't feel strongly
14:18:24 <sigmavirus24> mfedosin: eh
14:18:52 <ativelkov> nikhil: we are going to address the API-WG and defcore concerns (there is a spec for that already), and it will be a breaking change in glare API
14:18:59 <mfedosin> sigmavirus24: I just like X-men comics
14:19:27 <sigmavirus24> mfedosin: I do too!
14:19:47 <nikhil> ativelkov: I doubt if this should fall in the realm of api version name considerations from those groups
14:20:06 <ativelkov> so, I'd prfer the current API to be called v0.1, have the next version (based on the https://review.openstack.org/#/c/254710/ spec) set to 0.2, and once the API is stable, renabme it to 1.0
14:20:10 <nikhil> mostly because we said it's experimental
14:20:17 <sigmavirus24> nikhil: ativelkov if we're going to break it after mitaka, I'd rather see it as v0.1 honestly
14:20:28 <ativelkov> sigmavirus24: ++
14:20:29 <sigmavirus24> nikhil: what we say, and what people do, do not often match
14:20:31 <nikhil> sigmavirus24: that's true
14:20:40 <nikhil> both :)
14:20:47 <nikhil> ok, I don't mind v0.1
14:20:59 <nikhil> just feels a bit weird
14:21:09 <nikhil> going back to that version after one year
14:21:13 <ativelkov> so, the prefix should it be v0 or v0.1?
14:21:45 <ativelkov> well, it may be v0.94 to reflect the long history of this thing :))
14:21:58 <nikhil> #startvote should prefix be v0 or v0.1? 0, 0.1, NA
14:21:59 <openstack> Begin voting on: should prefix be v0 or v0.1? Valid vote options are 0, 0, 1, NA.
14:22:00 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:22:34 <nikhil> #endvote
14:22:35 <ativelkov> It does not have proper voting options
14:22:35 <openstack> Voted on "should prefix be v0 or v0.1?" Results are
14:22:41 <nikhil> #startvote should prefix be v0 or v0.1? 0, 0-1, NA
14:22:42 <openstack> Begin voting on: should prefix be v0 or v0.1? Valid vote options are 0, 0-1, NA.
14:22:43 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:22:47 <mfedosin> I think in this case 0.1 is preferable
14:22:53 <ativelkov> #vote 0-1
14:22:55 <kairat> # vote 0-1
14:23:00 <kairat> #vote 0-1
14:23:18 <mfedosin> because there may be huge differences between 0.1 and 0.2
14:23:18 <nikhil> #vote NA
14:23:24 <mfedosin> #vote 0-1
14:23:41 <nikhil> sigmavirus24: wanna vote or leaving be?
14:23:42 <sigmavirus24> #vote 0-1
14:23:47 <nikhil> thanks
14:23:51 <sigmavirus24> you're welcome
14:23:51 <nikhil> #endvote
14:23:52 <openstack> Voted on "should prefix be v0 or v0.1?" Results are
14:23:53 <openstack> NA (1): nikhil
14:23:55 <openstack> 0-1 (4): mfedosin, sigmavirus24, kairat, ativelkov
14:24:11 <nikhil> #agreed prefix be v0.1
14:24:11 <ativelkov> #agreed to have version prefix as /v0.1/artifacts
14:24:22 <nikhil> :)
14:24:34 <nikhil> ok, we've a few mins left
14:24:44 <nikhil> is there anything more important on this topic?
14:24:52 <ativelkov> OK, and just as a reminder: I have written a spec for the public API, addressing API-WG and DefCore concerns
14:24:56 <ativelkov> #link https://review.openstack.org/#/c/254710/
14:25:00 <nikhil> anymore important things*
14:25:16 <mfedosin> ativelkov: when a spec about plugins will be published?
14:25:19 <nikhil> #topic Public API spec on review
14:25:26 <nikhil> #link https://review.openstack.org/#/c/254710/
14:25:39 <ativelkov> I just wanted some initial comments from the Glance team on this before I send an email to API-WG ML
14:26:06 <ativelkov> mfedosin: what do you mean by "spec about plugins"?
14:26:23 <mfedosin> oslo.vo
14:26:29 <mfedosin> and other stuff
14:26:35 <mfedosin> will glare support it?
14:27:16 <ativelkov> mfedosin: that's a different story. It will, but I don't want to push with it. We need to agree upon the API. o.vo and other stuff are implementation details
14:28:00 <ativelkov> There will be two sets of API: the public one (i.e. plugin-independent, to complu with defcore's reqs) and the internal one (plugin-driven)
14:28:08 <ativelkov> the public one is covered with the spec
14:28:14 <nikhil> I would love to hear more on this
14:28:31 <ativelkov> nikhil: we are almost out of time, we may proceed in #glance
14:28:40 <nikhil> what do people think of having a video session for one hour instead of the meeting next week?
14:28:47 <mfedosin> yes, but what about the lower part of the iceberg
14:28:56 <ativelkov> nikhil: I like the idea
14:29:08 <nikhil> thanks ativelkov
14:29:12 <mfedosin> don't mind
14:29:21 <nikhil> seems like we've a good number of items to discuss
14:29:31 <sigmavirus24> nikhil: I won't be around so ¯\_(ツ)_/¯
14:29:32 <nikhil> and we have the meeting time set on schedule
14:29:37 <nikhil> oh
14:29:46 <nikhil> ok, then let me setup a doodle
14:29:55 <nikhil> sigmavirus24: not sure if it's vacay?
14:30:09 <nikhil> Let's continue the other convo on -glance
14:30:11 <ativelkov> doodle will be nice, thanks nikhil
14:30:22 <sigmavirus24> nikhil: it is vacation
14:30:32 <sigmavirus24> I've been taking all of my vacation at the end of the year :P
14:30:34 <nikhil> ativelkov: cool
14:30:39 <ativelkov> we are out of time
14:30:44 <nikhil> sigmavirus24: haha, nice. happy vacation
14:30:49 <ativelkov> Thanks everyone
14:30:51 <mfedosin> okay. thanks everyone!
14:30:54 <nikhil> thanks!
14:30:58 <nikhil> #endmeeting