14:04:28 <flaper87> #startmeeting Glance Drivers
14:04:29 <openstack> Meeting started Tue Jan 12 14:04:28 2016 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:32 <flaper87> ops, lost track of time!
14:04:33 <openstack> The meeting name has been set to 'glance_drivers'
14:04:35 <flaper87> sorry about that folks
14:04:42 <flaper87> Anyone around for the drivers meeting?
14:04:46 <jokke_> o/
14:04:52 <flaper87> I know nikhil has an overlapping meeting
14:05:02 * jokke_ is lurking here
14:05:19 * kragniz lurks
14:05:27 * flaper87 will lurk w/ jokke_ and kragniz if no one shows up
14:05:30 <rosmaita> o/
14:05:47 <ativelkov> o/
14:05:57 <rosmaita> i see in #openstack-glance that nikhil said we can assign him action items
14:06:03 <rosmaita> we can't pass up that opportunity!
14:06:07 <jokke_> rosmaita: ++
14:06:39 <flaper87> w000h00
14:06:46 <flaper87> so, assign all the things to nick-ma
14:06:47 <flaper87> ops
14:06:49 <flaper87> nikhil:
14:06:57 <flaper87> #action nikhil to guarantee world peace
14:07:18 <flaper87> we're done! That will keep him busy
14:07:32 <rosmaita> :D
14:07:34 <flaper87> anyway, there's just one item and we could use ativelkov and jokke_ feedback here
14:07:46 <flaper87> #link https://review.openstack.org/#/c/248681/
14:08:01 <flaper87> kairat: sent an exception request for that spec
14:08:07 <flaper87> we're psat the exception request week
14:08:32 <flaper87> but I thought I'd bring him it up anyway as that spec helps completing the trusts work
14:08:37 <mfedosin> hey! we want it be merged :)
14:08:58 <mfedosin> it's the second part that implements trusts in Swift driver
14:09:10 <flaper87> mfedosin: right but the deadline was last week :( I know you were on holidays and I'm taking that under consideration
14:09:26 <flaper87> and the fact that the spec freeze fell right during the new year's eve week
14:09:32 <mclaren> I also have something I'd like considered for FFE fwiw
14:09:39 <mfedosin> maybe we can do an exception
14:09:42 <flaper87> mclaren: oh hello
14:09:46 <flaper87> :D
14:09:48 * flaper87 hugs mclaren
14:09:51 <mfedosin> because Stuart needs it for his work too
14:09:52 * flaper87 won't let go
14:09:58 <mclaren> heh
14:10:05 <mfedosin> hi Stuart :)
14:10:14 <mclaren> howdy
14:10:23 <mfedosin> I want to hug you too
14:10:26 <flaper87> rosmaita: mclaren thoughts on extending the exception week till friday ?
14:10:26 <rosmaita> i think kairat
14:10:27 <jokke_> flaper87: ref 248681 I don't see mattoliverau nor anyone else from swift team (who are the current maintainers of that driver) even in the spec reviewers
14:10:31 <rosmaita> s spec looks good
14:10:36 <flaper87> mfedosin: get out, he's mine
14:10:36 <rosmaita> hmm
14:10:38 <flaper87> >.>
14:10:42 <rosmaita> i think kairat's spec looks good
14:10:52 <jokke_> I'd like to see their input before considering jumping in and refactoring it a lot
14:11:09 <rosmaita> i don't have a problem with extending the exception week
14:11:14 <flaper87> jokke_: good point. I'll add him
14:11:19 <mfedosin> code is done, btw
14:11:54 <flaper87> ok, let's extend the exception week till friday and evaluate requests individually
14:12:03 <rosmaita> ++
14:12:15 <flaper87> mfedosin: mclaren please,  update specs if needed and lets jump on crazy support mode on those specs
14:12:31 <flaper87> If they are swift related, let's ask for mattoliverau's feedback
14:12:37 <rosmaita> mclaren: which is the spec you want an exception for?
14:12:50 <flaper87> I know, I know, I know
14:12:53 <mclaren> same one as last time ;-) https://review.openstack.org/#/c/170564/
14:12:54 <flaper87> but I don't have a link
14:12:56 <flaper87> :P
14:13:04 <flaper87> #link https://review.openstack.org/#/c/170564/
14:14:02 <flaper87> mclaren: could you send an email out asking for the SFE ?
14:14:22 <mclaren> sure, np
14:14:33 <flaper87> mclaren: awesome! thanks
14:14:48 <mclaren> are there two in total? https://review.openstack.org/#/c/170564/ https://review.openstack.org/#/c/248681/ (I missed the start, sorry)
14:14:54 <flaper87> yes
14:15:20 <mfedosin> awesome
14:15:48 <flaper87> coolio
14:15:51 <flaper87> that's all I have
14:15:57 <flaper87> anything else folks want to discuss?
14:16:04 <ativelkov> I do! :)
14:16:09 <flaper87> I'll go through lite-specs myself and bring things up as needed
14:16:11 <flaper87> ativelkov: shoot
14:16:20 <flaper87> ativelkov: want to help with world peace as well?
14:16:32 <flaper87> nikhil: is on it but I'm sure he won't mind if you help
14:16:52 <ativelkov> I wonder what's the fate of the Glare specs :) They obviously felt under the spec freeze (since we couldn't get much feedback on the API part), but I want them to continue moving anyways
14:16:53 <rosmaita> we need people working on world peace in all time zones
14:17:30 <ativelkov> since we have the FastTrack for the glare commits, may we have some special handling for glare specs as well?
14:18:29 <ativelkov> (and since the artifacts are quite universal, I am pretty sure we can implement the World Peace with them, if needed)
14:18:41 <mclaren> you mean openstack/glare? [ducks]
14:18:59 <ativelkov> nope, I mean glance/artifacts :)
14:19:00 <flaper87> mmh, I don't want to block Glare so, I think, during Mitaka, it should be fine to keep the fasttrack
14:19:30 <flaper87> However, I'd like us to work together on revisiting how things are being done on the glare side
14:19:44 <flaper87> Specifically, I'm wondering how we can spread the knowledge of Glare across the team
14:20:09 <flaper87> I'm sure other glance folks won't contribute as much as we might want to glare while the fasttrack is in place
14:20:23 <flaper87> Anyway, we need to move V3 -> glare
14:20:48 <flaper87> if you need an exception for the Glare API, please send an email out
14:20:50 <ativelkov> Yup, and the second part of that spec got frozen as well
14:21:02 <flaper87> Let's follow the process as for every other spec
14:21:12 <mclaren> out of interest, did we ever think about the proc/cons of having the two clients integrated versus seperating them out?
14:21:42 <ativelkov> mclaren: I believe that was discucced in Tokyo, but quite briefly
14:21:57 <mclaren> ok, just curious
14:22:31 <flaper87> mclaren: yeah, we talked about that and the feedback was that one would be better
14:24:02 <flaper87> I think it was in the same glare session
14:24:04 <flaper87> fwiw
14:24:14 * flaper87 will get the etherpad link
14:24:19 <flaper87> anyway, anything else?
14:25:16 <flaper87> oke dokey, I'll take that as no
14:25:25 <flaper87> take care everyone! Thanks for the feedbakc
14:25:29 <flaper87> feedback, even
14:25:36 <flaper87> #endmeeting