#openstack-meeting: gluon

Meeting started by bh526r_ at 18:00:11 UTC (full logs).

Meeting summary

  1. Roll Call (bh526r_, 18:00:24)
    1. Bin Hu (bh526r_, 18:00:30)
    2. Kamil Renczewski (krenczewski, 18:01:29)
    3. Georg Kunz (georgk, 18:01:45)
    4. JinLi (jinli, 18:01:47)

  2. Admin Update (bh526r_, 18:02:16)
    1. Our submission to Forum: (bh526r_, 18:02:29)
    2. http://forumtopics.openstack.org/cfp/details/47 (bh526r_, 18:02:49)
    3. was rejected (bh526r_, 18:02:56)
    4. details of reason can be found in above link (bh526r_, 18:03:12)

  3. Status Update of PoC in OpenStack Summit (bh526r_, 18:03:47)
    1. 1. PoC Scenario Description was agreed a few weeks ago, and it stays the same (bh526r_, 18:04:32)
    2. But we need a documented demo script. Bin will draft it for everyone to review (bh526r_, 18:05:00)
    3. ACTION: Bin draft demo script for PoC in OpenStack Summit (bh526r_, 18:05:21)
    4. 2. Lab in Germany - running stably (bh526r_, 18:05:47)
    5. Nova issue was resolved, and VM can be booted (bh526r_, 18:07:09)
    6. There were problems due to re-installing some OpenStack packages with pip while the services were running (bh526r_, 18:07:41)
    7. restarting the services solved the issue (bh526r_, 18:07:51)
    8. 3. Contrail Status (bh526r_, 18:08:56)
    9. Kamil was able to run Contrail (bh526r_, 18:09:58)
    10. and authenticate with keystone on 192.168.0.6 node (bh526r_, 18:10:24)
    11. Problem was that one of interfaces was up without IP affress and zookeeper couldn't handle this (bh526r_, 18:11:44)
    12. So still need to resolve issue with Service Monitor service (bh526r_, 18:12:01)
    13. Then Kamil will deploy Mechanism Driver (bh526r_, 18:12:14)
    14. 4. L3VPN API - Parameter List for BGP Peering (bh526r_, 18:14:26)
    15. https://review.openstack.org/#/c/450917/ (bh526r_, 18:14:54)
    16. Georg will update the patch based on Jin's comments (bh526r_, 18:15:08)
    17. 5. SFC YAML and API (bh526r_, 18:15:32)
    18. Georg is completing the draft, and under internal review (bh526r_, 18:15:57)
    19. Georg will submit this patch in a few days (bh526r_, 18:16:14)
    20. 6. P2P YAML and API (bh526r_, 18:16:35)
    21. Robert is working on it, and will submit the patch in a few days (bh526r_, 18:16:56)
    22. 7. ELAN YAML and API (bh526r_, 18:17:12)
    23. Eric has provided Ian with the ELAN YANG Model (bh526r_, 18:17:36)
    24. Bin will follow up with Ian on this subject (bh526r_, 18:17:56)
    25. ACTION: Bin follows up with Ian on ELAN YAML and API (bh526r_, 18:18:14)
    26. 8. Misc (bh526r_, 18:18:29)
    27. There is a new patch to support all API YAML Models by default (bh526r_, 18:19:09)
    28. https://review.openstack.org/#/c/456283/ (bh526r_, 18:19:21)
    29. Current code supports net-l3vpn as default. If we add new YAML model, we need to change proton.conf. If someone forgets to change proton.conf, even if new model is added, Proton Server will still only pick up net-l3vpn (bh526r_, 18:20:33)
    30. In order to improve usability and make adding new YAML model and API easier, this patch will support all models by default. Whenever a model is added, Proton Server will pick it up without having to change proton.conf (bh526r_, 18:22:15)
    31. All are encouraged to review and comment the code (bh526r_, 18:22:30)
    32. This will also make demo/PoC easier - only need to add/remove model, rebuild and restart proton-server without changing proton.conf (bh526r_, 18:23:04)

  4. Pike Release and Patches (bh526r_, 18:24:31)
    1. 1. New "Network Type" in Neutron (bh526r_, 18:24:52)
    2. Bin had conversation with Sukhdev yesterday. The idea that Sukhdev proposes will still lead to previous 2 RFEs, i.e. (1) optional Network and Subnet, and (2) new network characteristics attribute (bh526r_, 18:26:17)
    3. Sukhdev will document it, for further review and discussion. But previous 2 RFEs are needed based on conversation (bh526r_, 18:27:31)
    4. 2. Approved patches (bh526r_, 18:27:52)
    5. First is Remove unused import statements (bh526r_, 18:28:14)
    6. https://review.openstack.org/#/c/446776/ (bh526r_, 18:28:29)
    7. It was approved and merged on March 22, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/448775/) (bh526r_, 18:29:05)
    8. Second is Fixing DB test after sqlite_db config option was removed (bh526r_, 18:29:25)
    9. https://review.openstack.org/#/c/451989/ (bh526r_, 18:29:38)
    10. It was approved and merged on March 31, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/452268/) (bh526r_, 18:30:16)
    11. Third is Fixing broken import statement (bh526r_, 18:30:35)
    12. https://review.openstack.org/#/c/451722/ (bh526r_, 18:30:49)
    13. It was approved and merged on March 31, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/452357/) (bh526r_, 18:31:18)
    14. Fourth is Remove translation of log messages from gluon (bh526r_, 18:31:34)
    15. https://review.openstack.org/#/c/453970/ (bh526r_, 18:31:54)
    16. It was approved and merged on April 6, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/454286/) (bh526r_, 18:32:28)
    17. Fifth is Refined installation instructions (bh526r_, 18:34:33)
    18. https://review.openstack.org/#/c/452980/ (bh526r_, 18:34:49)
    19. It was approved and merged on April 6, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/454508/) (bh526r_, 18:35:28)
    20. Sixth is Base URI return values (bh526r_, 18:35:51)
    21. https://review.openstack.org/#/c/453929/ (bh526r_, 18:36:03)
    22. It was approved and merged this morning (April 12), and cherrypicked to stable/ocata (https://review.openstack.org/#/c/456234/) (bh526r_, 18:36:38)
    23. 2. Outstanding Patches (bh526r_, 18:36:52)
    24. There are a few outstanding patches. (bh526r_, 18:37:06)
    25. Two were mentioned when we discussed PoC Status. Please review and comment (bh526r_, 18:37:42)
    26. https://review.openstack.org/#/c/450917/ (bh526r_, 18:38:09)
    27. https://review.openstack.org/#/c/456283/ (bh526r_, 18:38:28)
    28. Others include (bh526r_, 18:38:41)
    29. https://review.openstack.org/#/c/453519/ (bh526r_, 18:39:03)
    30. https://review.openstack.org/#/c/430446/ (bh526r_, 18:39:22)
    31. https://review.openstack.org/#/c/404069/ (bh526r_, 18:39:42)
    32. There are review comments and -1, so authors are expected to resolve the comments and update with new patches (bh526r_, 18:40:15)

  5. AOB (bh526r_, 18:40:36)
    1. Georg updated the patch of Extending L3VPN model to configure BGP peerings. (bh526r_, 18:44:10)
    2. Group agreed to approve it, and Bin takes the action (bh526r_, 18:44:29)
    3. Meeting adjourned (bh526r_, 18:45:57)


Meeting ended at 18:46:19 UTC (full logs).

Action items

  1. Bin draft demo script for PoC in OpenStack Summit
  2. Bin follows up with Ian on ELAN YAML and API


Action items, by person

  1. openstack
    1. Bin draft demo script for PoC in OpenStack Summit


People present (lines said)

  1. bh526r_ (97)
  2. krenczewski (9)
  3. georgk (6)
  4. openstack (3)
  5. jinli (2)


Generated by MeetBot 0.1.4.