16:00:15 <mugsie> #startmeeting GSLB
16:00:15 <openstack> Meeting started Tue Jul 28 16:00:15 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:19 <openstack> The meeting name has been set to 'gslb'
16:00:24 <mugsie> #link https://wiki.openstack.org/wiki/Meetings/GSLB
16:00:34 <mugsie> whos here?
16:01:19 <mugsie> we should give people a few minutes to join
16:02:23 <santosh> Hi All
16:03:27 <mugsie> o/
16:03:38 <KunalGandhi> o/
16:04:13 <xgerman> o/
16:05:26 <mugsie> ok, i think this is it
16:05:36 <mugsie> #topic Core / Drivers
16:05:59 <mugsie> So, in OpenStack we aim for the following for cores:
16:06:14 <mugsie> A history of contributions to OpenStack
16:06:22 <mugsie> A history of good reviews
16:06:45 <mugsie> and a history of being core elsewhere is a nice bonus
16:07:20 <mugsie> so, based on this, I would like to put forward myself and dougwig as the initial cores for the project
16:07:35 <mugsie> (dougwig is currently on a plane, so can't join today)
16:07:47 <xgerman> we have dougwig on Octavia and LBaaS and never get good work out of him :-)
16:08:02 <mugsie> is there any objections, or alternate proposals?
16:08:57 <mugsie> obviously as people are submitting code, and reviewing code the group will be expanded
16:10:10 <mugsie> any feedback at all?
16:10:15 <KunalGandhi> would it help if an end-user is also part of the core ?
16:10:44 <KunalGandhi> we at eBay have been using GSLB for quite sometime and have implemented GSLB as well in our home grown solution
16:10:48 <xgerman> well, dougwig is pretty busy so expecting meaningful contributions is...
16:10:53 <mugsie> KunalGandhi: core is about core review, not direction - that would be the drivers group
16:11:25 <mugsie> about code review*
16:11:29 <johnsom> I can sign up for reviewing
16:11:30 <sballe> o/
16:11:30 <KunalGandhi> @mugsie .. is it about who reviews code ?
16:11:51 <mugsie> KunalGandhi: yes
16:11:57 <KunalGandhi> @mugsie ... ok.
16:12:07 <mugsie> drivers are the people who help guide the project
16:12:27 <mugsie> OK, so we have 3 nominations then.
16:12:28 <KunalGandhi> @ ok.. i thought drivers meant GSLB drivers :)
16:12:41 <mugsie> johnsom, me, and dougwig
16:12:57 <mugsie> KunalGandhi: ah - yes, this could get confusing :)
16:13:07 <KunalGandhi> @mugsie .. is there any way i could help ?.
16:13:26 <mugsie> in the drivers group - 100%
16:13:34 <KunalGandhi> @mugsie ... as part of the project for reviewing or may driver group
16:13:37 <KunalGandhi> ok
16:14:03 <mugsie> is there any -1's on the 3 names?
16:14:19 <KunalGandhi> nope.
16:14:29 <mugsie> I dont think we will have a huge amount of code to review initially, so between 2 there should be more than aneough reviewrs
16:14:47 <KunalGandhi> i can sign up for the driver group
16:15:20 <mugsie> #note GSLB-Core is dougwig mugsie johnsom
16:15:34 <johnsom> Sounds good
16:15:35 <mugsie> So drivers - we have KunalGandhi
16:15:50 <mugsie> anyone else interested? I would like to propose the 3 cores as wll
16:15:58 <mugsie> as well*
16:16:06 <xgerman> Congrats!!
16:16:11 <mugsie> making it KunalGandhi johnsom mugsie dougwig
16:16:15 <mugsie> anyone else interested?
16:16:30 <xgerman> I can throw in my 2 cent + we should get blogan
16:16:35 <mugsie> I think that group should be pretty open, to get as much feedback
16:16:46 <mugsie> xgerman: I had no doubt you would :D
16:16:56 <mugsie> blogan: you interested?
16:17:35 <mugsie> OK - we can extend the invite after the meeting
16:17:49 <mugsie> any other nominations?
16:18:20 <xgerman> yeah, let;s also send that to the ML
16:18:39 <mugsie> xgerman: can I action you to do that?
16:18:52 <johnsom> I can take that
16:19:09 <xgerman> #action jonsom send to ML about nominations for drivers groupo
16:19:26 <mugsie> cool.
16:19:32 <mugsie> are we ok to move on?
16:19:38 <xgerman> yep
16:19:42 <KunalGandhi> @mugsie .. can you briefly explain what each group does and is responsible for ?
16:19:48 <mugsie> KunalGandhi: sure
16:20:14 <mugsie> Cores - cores review the code submitted to the project, and ensure it is of good quality
16:20:56 <mugsie> Drivers - they file / maintain / prioritise and target blueprints and bugs for the project
16:21:26 <mugsie> (i.e. decide on project direction, and what is done in each cycle)
16:21:28 <KunalGandhi> that helps..
16:21:42 <mugsie> #topic API Spec
16:21:57 <mugsie> I moved this to a spec this week, with the feedback from previous meetings
16:22:01 <mugsie> #link https://github.com/gslb/gslb-specs/pull/1
16:22:33 <mugsie> can everyone review, and leave comments. in a few days / week, cores should be looking to merge it
16:22:56 <KunalGandhi> ok..
16:23:18 <KunalGandhi> @mugsie .. do we know when this would be part of gerrit and openstack repo ?
16:23:25 <mugsie> KunalGandhi: I moved pools down to the root, and added linking members and lbs to them
16:23:49 <mugsie> KunalGandhi: not sure yet, we need to get pinging people. might be a week or 2
16:24:42 <xgerman> yah, there is  a lot of commotion on how to do “experimental” projects now as syackforgew is gone
16:24:43 <KunalGandhi> so for contribution, we just fork the repo and send pull requests until then
16:24:54 <mugsie> KunalGandhi: yes
16:25:06 <mugsie> actually - very important note
16:25:24 <mugsie> everyone who submits code must have signed the OpenStack CLA
16:25:49 <mugsie> so cores will need to check this until we get to gerrit, where it is done for us
16:25:55 <KunalGandhi> @mugsie .. i think we need to add the monitor API
16:26:23 <mugsie> KunalGandhi: it is there in the spec (at the bottom)
16:26:31 <mugsie> oh, you mean the JSON snippets?
16:26:38 <mugsie> yes. will do that
16:26:57 <mugsie> anything else on this?
16:27:58 <mugsie> going once ...
16:28:09 <mugsie> twice ...
16:28:17 <mugsie> gone!
16:28:23 <mugsie> #topic Project Name
16:28:23 <KunalGandhi> @mugsie .. stil reading :)
16:28:53 <mugsie> #topic API Spec
16:29:03 <KunalGandhi> @mugsie .. did we add the associate /dissassociate of monitor
16:29:14 <KunalGandhi> i think we had that on the Google doc
16:29:40 <mugsie> that is on the members API
16:29:52 <mugsie> so you add a monitor ID to a pool or pool member
16:31:04 <KunalGandhi> something like PUT /v0.1/pools/<uuid>/pool_members/<uuid>/monitors/monitor_id
16:31:23 <mugsie> yeah, or the monitors will be an array of IDs
16:31:31 <KunalGandhi> ok..
16:31:37 <mugsie> and use PATCH - but that will be im,plementation semantics
16:31:58 <mugsie> #topic Project Name
16:32:01 <KunalGandhi> also the API spec seems to have a LOT of API's
16:32:09 <KunalGandhi> are we going to implement all of them ?
16:32:14 <KunalGandhi> in MVP
16:32:31 <mugsie> there is only really 3, with bits off them. we may decide to drop some of them
16:32:41 <KunalGandhi> ok
16:33:01 <KunalGandhi> i was looking at the endpoints /v0.1/pools/<uuid>/pool_members/<uuid>/monitors
16:33:08 <KunalGandhi> sorry here.. https://github.com/gslb/gslb-specs/commit/d804a67cb893a7954625ec21993815cdfc47c037
16:34:11 <KunalGandhi> i think we need a JSON snippet for monitor as well.
16:35:11 <mugsie> KunalGandhi: OK, I will clarify that
16:35:35 <mugsie> anything else?
16:35:37 <KunalGandhi> thanks.. i can work with you on finalizing the API draft
16:35:47 <mugsie> OK then :)
16:35:48 <KunalGandhi> nopw
16:35:52 <mugsie> #topic Project Name
16:35:57 <mugsie> #link https://etherpad.openstack.org/p/GSLB_project_name_vote
16:36:09 <mugsie> any other suggestions?
16:36:25 <xgerman> did you check copyrights? Quantum Ahem?
16:36:45 <mugsie> not yet
16:36:46 <mugsie> :)
16:37:01 <johnsom> E-mail away...
16:37:25 <KunalGandhi> nope..have not checked for copyright
16:37:27 <xgerman> the ether pad is slow to open for me today :-(
16:37:54 <KunalGandhi> there is a company callled Globalizer
16:37:57 <KunalGandhi> :(
16:38:03 <mugsie> :(
16:38:05 <KunalGandhi> can we use that then if we had to
16:38:47 <mugsie> OK,do we want to leave it open for 1 more week?
16:38:56 <xgerman> yep
16:38:58 <johnsom> Yes
16:39:03 <KunalGandhi> yes
16:39:15 <mugsie> #action loop back to project name next week
16:39:42 <mugsie> #topic AOB (Any Other Buisiness)
16:39:56 <mugsie> any thing else anyone have for the group?
16:40:16 <KunalGandhi> nope..
16:41:17 <mugsie> OK, i think that is it :)
16:41:20 <mugsie> #endmeeting