16:01:29 <mugsie> #startmeeting GSLB
16:01:29 <openstack> Meeting started Tue Aug  4 16:01:29 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:34 <openstack> The meeting name has been set to 'gslb'
16:01:50 <mugsie> so, rollcall - who is here?
16:01:53 <johnsom> o/
16:02:04 <xgerman> o/
16:02:08 <KunalGandhi> o/
16:02:30 <mugsie> #topic API Spec - https://github.com/gslb/gslb-specs/pull/1
16:02:31 <jmcbride> o/ - just eavesdropping
16:02:37 <ag__> o/
16:02:51 <mugsie> johnsom is currently looking at this
16:03:15 <mugsie> dougwig, when you have a chance that would be great
16:03:26 <dougwig> hiya
16:03:35 <mugsie> KunalGandhi: you have additions, right?
16:03:38 <bharath> o/
16:03:42 <dougwig> i looked, tried to merge, but i don't have rights yet.  it's good by me to merge and start iterating on.
16:04:06 <dougwig> infra is also ready to merge our repo patch, but we need to decide on a name first.
16:04:13 <KunalGandhi> yes.. i can provide them as comments to current pull request as well
16:04:30 <KunalGandhi> @mugsie .. let me know what works
16:04:32 <mugsie> dougwig: there should be a invite in your github inbox
16:04:37 <KunalGandhi> best
16:04:39 <johnsom> A couple of comments:
16:04:48 <mugsie> KunalGandhi: if they are small, I can add them after this meeting
16:04:53 <johnsom> We are missing the monitor json
16:05:01 <mugsie> i have to majke chages for johnsom anyway :)
16:05:05 <dougwig> mugsie: found it.
16:05:14 <johnsom> I'm not sure we need a separate status for the pool members
16:05:32 <KunalGandhi> @johnsom .. thanks.. that was one of my feedback points as well :)
16:05:34 <johnsom> And finally, I worry about trying to keep the history for all of the objects
16:05:56 <mugsie> yeah ... for that I was thinkingh of only doing short term history
16:06:03 <mugsie> but I didnt call that out
16:06:20 <mugsie> history may not make MVP anyway
16:06:36 <johnsom> +1 on not MVP
16:06:46 <KunalGandhi> @mugsie ... we are also missing association/dissociation of monitors API
16:06:50 <johnsom> Last status change date/time is handy though
16:07:19 <mugsie> so, can we agree that all comments should be in on the spec by end of day, and we will merge, and iterate on it from now on?
16:07:31 <johnsom> Yeah, I think so
16:07:46 <dougwig> agree
16:07:59 <mugsie> #action all - leave comments by end of day (Pacific)
16:08:14 <mugsie> #topic Polaris Abstract - https://github.com/polaris-gslb/polaris-description
16:08:21 <mugsie> #link https://github.com/polaris-gslb/polaris-description
16:08:30 <mugsie> did anyone have a chance to look at ^
16:09:03 <KunalGandhi> looking at it right now
16:09:14 <dougwig> just scanned. what's the background here?
16:09:24 <mugsie> ag__: you want to give the background?
16:09:31 <johnsom> I took a look.  I didn't have enought time to dig for details.
16:09:41 <xgerman> pretty picture :-)
16:10:11 <mugsie> ok, it seems ag__ is AFK
16:10:18 <ag__> it's a project i'm working on, the plan is to move the dev to github, was wondering ig it could be of any help to the community
16:10:58 <dougwig> it's possible. the name is going to be a trademark issue. any chance we can get a look at the code?
16:11:03 <KunalGandhi> @ag__ .. can you provide some brief description of the project
16:11:16 <mugsie> from discuissions in the #openstack-gslb room, it looks like the most relevent bit is goign to be the status checker
16:11:28 <mugsie> KunalGandhi: the link has a brief overview
16:11:54 <ag__> the description is in the link above, the code should be released soon, waiting for internal approval process to finalize
16:12:29 <dougwig> we do need a reference implementation that's open-source, so it's that, or custom, or some hacky thing using haproxy as our monitor. i'm interesting in us digging further, for sure.
16:12:59 <KunalGandhi> @mugsie .. i was reading through the overview.. but how does this fit with GSLB ?
16:13:24 <ag__> it's a complete GSLB solution, KunalGandhi
16:13:36 <KunalGandhi> @ag__ .. ok
16:13:52 <mugsie> KunalGandhi: some bits of it are relevent to our service - it is similar, there is list of endpoints being monitored, and then DNS entries updated based on monitors
16:14:15 <mugsie> how we load endpioints,m and store data may differ, but there is going to be similarities
16:15:02 <mugsie> OK, I think the general consensuous is we are interesting in looking, but may or may not use it as a base
16:15:10 <mugsie> that sound sane?
16:15:12 <dougwig> +1
16:15:25 <ag__> cool
16:15:48 <mugsie> OK, any other feedback on ^?
16:16:18 <mugsie> OK
16:16:21 <mugsie> #topic Project Name - https://etherpad.openstack.org/p/GSLB_project_name_vote
16:16:29 <mugsie> #link https://etherpad.openstack.org/p/GSLB_project_name_vote
16:16:34 <mugsie> Are we ready to choose?
16:16:46 <johnsom> Sure
16:17:12 <KunalGandhi> yes
16:17:13 <dougwig> i just want it done.  :)
16:17:38 <mugsie> OK
16:17:40 <mugsie> Kosmos : 3
16:17:40 <mugsie> GLBaaS: 3
16:17:40 <mugsie> GSLB: 2
16:17:40 <mugsie> Atlas: 1
16:17:43 <mugsie> Lichtenberg: 1
16:17:46 <mugsie> Gubernator: 1
16:17:52 <mugsie> this is the totals at the moment
16:18:07 <KunalGandhi> There is an LB project called Atlas
16:18:23 <mugsie> yeah, and it was an OpenStack Project
16:18:32 <mugsie> but, I think it is dead / never happened
16:18:43 <mugsie> it was around the time libre came out
16:18:53 <KunalGandhi> Yes.. it was from citrix
16:19:09 <mugsie> but, yeah, I agree, we may want to drop that one
16:19:16 <mugsie> as it does have history
16:19:33 <johnsom> Yeah, libra implemented it's API I think.  In general I think we should avoid Atlas
16:19:42 <xgerman> I remember Atlas was what RAX had
16:19:53 <mugsie> johnsom: bring up bad memories of Libre?
16:20:02 <johnsom> Yes, yes it does...
16:20:03 <KunalGandhi> not sure whether it matters but the project called Atlas-LB.. So not sure if we can just use Atlas
16:20:12 <xgerman> we can always use libra :-)
16:20:15 <mugsie> I think we drop it off the list
16:20:18 <mugsie> xgerman: hahahaha
16:20:20 <mugsie> no
16:20:24 * mugsie shudders
16:20:35 <mugsie> and I didnt even work on it :)
16:20:41 <dougwig> it only has 1 vote anyway, so this is a long argument over it.  :)
16:20:46 <mugsie> :D
16:20:50 <mugsie> Kosmos is the leader
16:20:59 <mugsie> is there any objections?
16:21:29 <mugsie> #startvote Kosmos for project name
16:21:30 <openstack> Unable to parse vote topic and options.
16:21:44 <dougwig> #startvote Kosmos for project name? Yes No
16:21:44 <openstack> Only the meeting chair may start a vote.
16:21:48 <dougwig> copy that ^^
16:21:53 <mugsie> #startvote Kosmos for project name? Yes No
16:21:54 <openstack> Begin voting on: Kosmos for project name? Valid vote options are Yes, No.
16:21:55 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:22:01 <mugsie> dougwig: ty
16:22:06 <johnsom> #vote Yes
16:22:08 <xgerman> #vote Yes
16:22:10 <dougwig> #vote Yes
16:22:10 <KunalGandhi> #vote Yes
16:22:12 <mugsie> #vote Yes
16:22:33 <bharath> #vote Yes
16:22:40 <mugsie> anyone else?
16:23:02 <mugsie> #endvote
16:23:02 <openstack> Voted on "Kosmos for project name?" Results are
16:23:03 <openstack> Yes (6): xgerman, KunalGandhi, dougwig, mugsie, bharath, johnsom
16:23:13 <mugsie> OK, we have agreement
16:23:19 <mugsie> :D
16:23:23 <dougwig> #action dougwig Update project infra patch after meeting
16:23:42 <mugsie> #action mugsie fix repos to have correct module names
16:23:52 <mugsie> #topic AOB (Any Other Business)
16:24:01 <mugsie> any off agenda items?
16:24:40 <johnsom> Nope
16:24:43 <mugsie> going once ...
16:24:51 <mugsie> twice ..
16:24:58 <mugsie> gone!
16:25:02 <mugsie> #endmeeting