16:04:40 <KunalGandhi> #startmeeting GSLB_Discussion
16:04:40 <openstack> Meeting started Tue Jul 21 16:04:40 2015 UTC and is due to finish in 60 minutes.  The chair is KunalGandhi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:44 <openstack> The meeting name has been set to 'gslb_discussion'
16:05:05 <mugsie> #link https://review.openstack.org/#/c/201683/
16:06:09 <KunalGandhi> #chair.. @KunalGandhi
16:06:10 <openstack> Warning: Nick not in channel: ..
16:06:11 <openstack> Warning: Nick not in channel: @KunalGandhi
16:06:12 <openstack> Current chairs: .. @KunalGandhi KunalGandhi
16:06:56 <KunalGandhi> hi everyone.. can we do a roll call for this meeting..
16:07:01 <xgerman> o/
16:07:32 <johnsom> o/
16:07:34 <mugsie> o/
16:08:10 <Santosh> Hi
16:09:37 <KunalGandhi> so we wanted to discuss if there is any thing to be added on the API doc
16:09:38 <KunalGandhi> https://docs.google.com/document/d/1nw5jVn0hjmhlhkZJAohx-gqRkkbVhMMJ79Pogd0ysEk/edit#heading=h.lcnfr8uk78d
16:10:18 <KunalGandhi> @dougwig .. was going to internally discuss the API doc in the LBaaS mid cycle last week and get feedback.
16:10:33 <mugsie> there is also notes from last week - which have not been reflected in the doc yet
16:10:51 <sballe> o/
16:11:18 <xgerman> KunalGandhi dougwig was sick so no discussion
16:11:25 <KunalGandhi> ok..
16:11:34 <xgerman> didn
16:11:46 <xgerman> ’t know it was a topic otherwise would have driven it...
16:12:04 <KunalGandhi> so what is the next step ? do we need to finalize the API for the MVP ?
16:12:52 <xgerman> we should turn the API into a spec
16:12:58 <sballe> +1
16:13:08 <mugsie> ok, so that is on me to update the doc
16:13:17 <mugsie> #action mugsie update API Doc
16:13:40 <xgerman> also for the spec we probably need a git repo with a specs directory :-)
16:13:53 <mugsie> #link http://eavesdrop.openstack.org/meetings/gslb/2015/gslb.2015-07-14-16.00.log.html
16:14:02 <xgerman> so… somebody needs to file the infra request to set that up
16:14:02 <mugsie> has what we discussed last week
16:14:20 <mugsie> xgerman: we need to wait for the current project creation to pass first
16:14:34 <xgerman> agreed
16:15:07 <KunalGandhi> so we need to get an update from @dougwig.. whether he was able to do that lask week
16:15:07 <sballe> can we do it in github for now?
16:15:56 <KunalGandhi> @sballe ... +!
16:15:58 <KunalGandhi> +1
16:16:08 <mugsie> Yeah.
16:16:19 <mugsie> I will create a github org after this
16:16:26 <KunalGandhi> i think we can start with github and then move the doc later to the github..
16:16:31 <KunalGandhi> @mugsie .. thanks..
16:16:33 <sballe> that should allow us to collaborate while waiting for the more official infra
16:16:49 <KunalGandhi> i can follow up with @dougwig on the infra repo
16:17:20 <xgerman> +1
16:17:35 <xgerman> there must be something replacing stackforge
16:17:52 <mugsie> xgerman: there is - "experimental" projects
16:17:53 <sballe> agreed
16:17:58 <mugsie> that is what dougwig filed for
16:18:14 <KunalGandhi> #action KunalGandhi to follow up on infra repo
16:18:52 <mugsie> we are waiting for the "experiment project" spec in openstack-goverence to merge as well
16:19:19 <mugsie> #link https://review.openstack.org/#/c/192016/3
16:19:32 <sballe> ok github sounds like a great idea until they figure out the experimental project stuff
16:19:39 <mugsie> +1
16:20:22 <KunalGandhi> ok.. is there anything else that we would like to discuss about GSLB ?
16:20:29 <Santosh> @Kunal I have a small query .Are we targeting GSLB for liberty? What is expected  schedule for GSLB
16:21:16 <mugsie> MVP for Liberty maybe?
16:21:21 <mugsie> but that is a short timescale
16:21:33 <sballe> +1000 on the MVP for Liberty
16:21:41 <KunalGandhi> @Santosh .. i think the feature freeze date is September 3.. so maybe an MVP.
16:21:49 <mugsie> KunalGandhi: we can be exempt for that
16:21:53 <KunalGandhi> not sure
16:22:11 <mugsie> as the release management team wioll not be doing releases for us
16:22:12 <xgerman> experimental...
16:22:20 <xgerman> we can do whatever we want
16:22:33 <mugsie> so, we can release when ever / whatever
16:22:38 <xgerman> yep
16:22:54 <xgerman> though we should try to have a demo in Tokyo
16:23:05 <KunalGandhi> @mugsie .. ok..i think it is too early.. we need yet need to discuss the technical details
16:23:07 <sballe> +1 on the demo
16:23:17 <KunalGandhi> +1
16:23:26 <sballe> KunalGandhi: +1 on details not sure it is too early
16:23:49 <mugsie> demo
16:23:51 <mugsie> gah
16:23:57 <mugsie> demo is what we shoud be aiming for
16:24:01 <Santosh> I have couple of query wrt coupling vendor specific Neutron-Lbaas driver/LBs and Vendor specific GSLB.
16:24:02 <sballe> +1
16:24:05 <KunalGandhi> @sballe .. i meant to early to know whether we are ready for liberty
16:24:19 <sballe> oh I see. I agree
16:24:20 <mugsie> Santosh: I would push back on that
16:24:30 <mugsie> we should be using the LBaaS V2 API
16:24:34 <sballe> +1
16:24:41 <xgerman> +100
16:24:43 <mugsie> so, whatever is supported in that, we do
16:25:22 <mugsie> Santosh: what did you have in mind?
16:27:01 <Santosh> Currently with neutron-lbaas we have Vendor specific LB configuration
16:27:28 <KunalGandhi> To my understanding the plugin drivers for GSLB and LBaaS would be different right.. since we do not need all entities that LBaaS has in GSLB
16:27:53 <mugsie> yeah. There should be vendor plugins for GSLB drivers
16:28:13 <mugsie> and they can drive LBs, but will have differing features
16:28:19 <Santosh> So GSLB should be aware of Type (vendor) and propagate relevant  information?
16:28:36 <mugsie> Santosh: from the regional LBs?
16:28:41 <Santosh> Yes
16:29:47 <mugsie> unless it is in the LBaaS V2 API, I would say no
16:29:54 <xgerman> +1
16:30:06 <Santosh> Say For a Vendor specific orchestration Layer it should be passing corresponding LB info
16:30:28 <xgerman> I am not following
16:30:32 <mugsie> can you give an example?
16:30:39 <xgerman> so GSLB should go around LBaaS V2?
16:30:44 <KunalGandhi> @Santosh .. this for GSLB to talk to regional LBs ?
16:31:49 <Santosh> Say for regional LB we have neutron-lbaas vendor specific LBs
16:32:10 <KunalGandhi> ok..
16:32:24 <mugsie> Santosh: what sort of information are you thinking should be passed, that is not in the LBaaS V2 API?
16:33:01 <KunalGandhi> @Santosh .. Can you gives us a use case for which GSLB driver needs to talk to the regional LB's ?
16:33:07 <Santosh> and for GSLB vendor specific driver ,it should be able to select/pass from those LBs as regional LBs
16:33:20 <mugsie> ah, I get it
16:33:57 <mugsie> honestly, I would not like that personally. We would be breaking the "same API everywhere" goal of openstack
16:33:58 <sballe> so some sort of scheduler? or selection mechanism to forward requests to the right type of LB?
16:34:19 <sballe> I m just making sure I understand what @Santosh
16:34:21 <sballe> is saying
16:35:47 <mugsie> they could be added as "TCP LB Type", i suppose.
16:36:41 <Santosh> Agree with mugsie , I will update the doc with use case
16:37:05 <mugsie> Santosh: great :)
16:37:06 <KunalGandhi> @Santosh .. +1 a use case would definitely help
16:37:16 <sballe> +1
16:37:26 <xgerman> +1
16:38:30 <mugsie> OK, anything else on the todo list?
16:38:47 <sballe> When are we going ot discuss API?
16:39:17 <mugsie> as an FYI, me, dougwig, and KunalGandhi have put in a talk for tokyo
16:39:48 <KunalGandhi> once we convert the current API doc into an API, we can discuss the API and finalize it for MVP
16:39:52 <mugsie> ah, sballe we can re discuss again, now... but there was a lot of discussion last week, and the doc does not have those updates
16:40:16 <mugsie> is there anything in particualr you want changed sballe ?
16:40:25 <sballe> ok np. Like I said now that I have this meeting in my calendar I will show up every time
16:41:01 <mugsie> i think we are done for today then?
16:41:02 <sballe> @mugsie no I will look it over again and reach out to you if I have nay questions
16:41:28 <KunalGandhi> @mugsie .. yes..
16:42:14 <mugsie> KunalGandhi: can you #endmeeting ?
16:42:23 <mugsie> (has to be the chair)
16:42:25 <KunalGandhi> ok..
16:42:26 <sballe> bye.
16:42:29 <KunalGandhi> #endmeeting