#openstack-meeting: ha

Meeting started by aspiers at 09:03:11 UTC (full logs).

Meeting summary

  1. Current status (progress, issues, roadblocks, further plans) (aspiers, 09:04:21)
  2. OCF RAs and systemd (aspiers, 09:19:16)
    1. https://github.com/rabbitmq/rabbitmq-server/blob/6fd4eb5bcb39be7f5ac26dcc78e3a4b4df4c6fbb/scripts/rabbitmq-server-ha.ocf#L303-L463 (bogdando, 09:35:31)
    2. ACTION: aspiers to write a spec proposing OCF RAs wrap systemd, and possibly a gerrit review showing a PoC (aspiers, 09:35:55)
    3. ACTION: beekhof to give technical details of systemd issues which prevent reliable building of OCF RAs on top of it (aspiers, 09:36:24)
    4. ACTION: bogdando to give some concrete examples where pid files (and perhaps hence systemd) cannot be relied on (aspiers, 09:51:48)
    5. success of systemctl stop is considered very important, to avoid STONITH unless we really need it (aspiers, 09:52:40)
    6. systemd seems to be quite powerful in capabilities for killing misbehaving processes (aspiers, 09:53:00)


Meeting ended at 09:56:09 UTC (full logs).

Action items

  1. aspiers to write a spec proposing OCF RAs wrap systemd, and possibly a gerrit review showing a PoC
  2. beekhof to give technical details of systemd issues which prevent reliable building of OCF RAs on top of it
  3. bogdando to give some concrete examples where pid files (and perhaps hence systemd) cannot be relied on


Action items, by person

  1. aspiers
    1. aspiers to write a spec proposing OCF RAs wrap systemd, and possibly a gerrit review showing a PoC
  2. bogdando
    1. bogdando to give some concrete examples where pid files (and perhaps hence systemd) cannot be relied on


People present (lines said)

  1. aspiers (151)
  2. bogdando (66)
  3. ddeja (16)
  4. _gryf (9)
  5. masahito (7)
  6. kazuIchikawa (3)
  7. openstack (3)


Generated by MeetBot 0.1.4.