09:03:10 <aspiers> #startmeeting ha
09:03:11 <openstack> Meeting started Mon Feb 29 09:03:10 2016 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:03:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:03:15 <openstack> The meeting name has been set to 'ha'
09:03:23 <aspiers> #topic introductions
09:03:43 <aspiers> as we have a couple of new people, maybe we should do quick introductions
09:03:54 <aspiers> bandini, samP: you wanna quickly introduce yourselves?
09:03:57 <bandini> sure thing
09:04:00 <aspiers> or if you prefer you can lurk ;-)
09:04:32 <aspiers> actually maybe we all should, for your benefits
09:04:43 <bandini> my name is Michele Baldessari, I live in the alps and I recently joined RH's HA team. Working on Openstack/HA architecture/installer/bugs whatnot
09:05:01 <bandini> I will come to Austin, so hopefully I will meet some of you ;)
09:05:11 <samP> My name is Sampath and I am working with masa, and kazu at tokyo. mainly fixing masakari now
09:05:15 <aspiers> I'm Adam Spiers, working for SUSE on OpenStack (mainly HA) from London, and I usually moderate this session, and also maintain the openstack-resource-agents project
09:05:21 <beekhof> hey guys
09:05:30 <aspiers> hi beekhof :)
09:05:34 <bandini> oh and beekhof is my tech lead ;)
09:05:39 <aspiers> ahah
09:05:40 * bandini waves
09:05:41 <aspiers> cool
09:05:48 <beekhof> this bandini guy sounds sketchy, i suggest we stear clear of him
09:05:52 <aspiers> great to have you here
09:05:54 <aspiers> haha :)
09:06:04 <bandini> lol, that's why you're the lead, clear ;)
09:06:09 <bandini> *clearly*
09:06:15 <aspiers> that beekhof guy is *definitely* sketchy ;-)
09:06:36 <beekhof> doesn't even own any lego sets
09:06:44 <bandini> rotfl
09:06:52 <ddeja> I'm Dawid Deja, Wworking for Intel on Openstack from Poland, mainly focusing on instances HA right now
09:06:52 <aspiers> :)
09:07:07 * _gryf is wondering what is happening…
09:07:29 <beekhof> hazing the new guy
09:07:32 <aspiers> _gryf: we're doing introductions for the new people
09:08:08 <_gryf> anyway, my name is Roman Dobosz, working at Intel, Gdańsk, Polan. I use to work closely on the tenants HA automation
09:08:36 <aspiers> #info two first-timers to the meeting: bandini (RH) and samP (NTT)
09:08:37 <_gryf> aspiers, no no, the other things ;P
09:08:44 <aspiers> oh :)
09:08:47 <aspiers> ok
09:09:02 <aspiers> #topic Current status (progress, issues, roadblocks, further plans)
09:09:12 <aspiers> quick update from my side
09:09:39 <aspiers> I've been doing some reviews on code submitted to openstack-resource-agents by Norbert Illes
09:09:54 <aspiers> we're working towards getting bashate passing
09:10:02 <aspiers> so we can add some basic CI to the repo
09:10:28 <aspiers> #info work proceeding on https://bugs.launchpad.net/openstack-resource-agents/+bug/1550203
09:10:28 <openstack> Launchpad bug 1550203 in openstack-resource-agents "Bashate violations in OCF scripts" [Medium,In progress] - Assigned to Norbert Illes (nilles)
09:10:46 <aspiers> also, on Thursday I crashed Fuel's weekly team IRC meeting
09:10:57 <aspiers> and asked them about their OCF RA forks
09:11:04 <aspiers> which started sometime in 2013, I think
09:11:26 <aspiers> Basically I asked if they would be interested in reconverging with this new upstream project, and they seemed enthusiastic
09:11:51 <aspiers> #action aspiers to send an email to openstack-dev about reconvergence of Fuel RAs
09:11:56 <beekhof> i saw that meeting go past
09:12:08 <aspiers> we need to form a working group and arrange a meeting
09:12:17 <bandini> that is something I am also interested in
09:12:27 <aspiers> bandini: great!
09:12:33 <beekhof> i tried to get their rabbit agent to converge, but i dont think it went anywhere
09:12:51 <aspiers> ah, well luckily for me, the rabbit RA is out of scope ;-)
09:12:57 <aspiers> since it's not purely openstack-related
09:13:07 <aspiers> although that's slightly sad to hear
09:13:26 <aspiers> also you RH guys should check recent changes upstream to Nova{Compute,Evacuate}
09:13:42 <bandini> beekhof: I thought I saw a moderately recent mail from bogdan about rabbitmq RA..I need to dig it up again
09:13:46 <aspiers> my colleague Vincent Untz made a bunch of fixes for our next release which might help you
09:13:59 <beekhof> probably not many parallels to draw from that experience. the pure openstack agents are significantly simpier
09:14:17 <aspiers> beekhof: I hope you're right
09:14:53 <beekhof> NovaCompute is gone from ours
09:14:53 <aspiers> I'm also very happy to see that ...
09:15:02 <aspiers> #info http://bugs.clusterlabs.org/show_bug.cgi?id=5269 has been fixed
09:15:02 <openstack> bugs.clusterlabs.org bug 5269 in Core "DoS: valid authkey should be required for takeover of a Pacemaker remote" [Normal,Resolved: fixed] - Assigned to ygao
09:15:28 <beekhof> the wait logic is now in a more consistently named agent and we use systemd for starting the compute process
09:15:35 <aspiers> beekhof: oh? perhaps you can give a status report and briefly summarise?
09:16:00 <beekhof> there were issues starting nova-compute from anywhere other than systemd
09:16:16 <aspiers> beekhof: ok. so you renamed NovaEvacuate to nova-evacuate or something?
09:16:23 <beekhof> something to do with the way pacemaker does fork+exec
09:16:55 <beekhof> no, NovaCompute -> nova-compute-wait + systemd:openstack-nova-compute
09:17:23 <beekhof> so instead of fighting it, we just switched to systemd
09:18:06 <aspiers> hmm
09:18:40 <aspiers> worth pushing upstream?
09:18:44 <beekhof> yes
09:18:48 <aspiers> ok
09:19:01 <aspiers> can you or bandini take an AI to kick that process off??
09:19:02 <beekhof> for that start+stop and used OCF for the "wait for evacuations to complete ebfore starting nova
09:19:09 <beekhof> me
09:19:34 <aspiers> interested to see how that works
09:19:42 <beekhof> its not complex
09:19:47 <aspiers> that's good ;-)
09:20:00 <beekhof> #action beekhof to upstream the decomposed NovaCompute agent
09:20:18 <aspiers> #info RH have split NovaCompute into nova-compute-wait + systemd:openstack-nova-compute
09:20:21 <aspiers> great, thanks!
09:20:45 <aspiers> ok. bandini, too early for you to have anything to report?
09:21:11 <bandini> aspiers: yeah, I guess so
09:21:16 <aspiers> no problem
09:21:23 <aspiers> _gryf?
09:21:46 <_gryf> i've been involved in other tasks recently
09:22:00 <_gryf> so nothing to report
09:22:04 <aspiers> ok
09:22:07 <aspiers> ddeja?
09:22:27 <ddeja> I have finished working on auto-evacuate Pacemaker agent for mistral https://github.com/gryf/mistral-evacuate/blob/master/fence_evacuate.py
09:22:43 <aspiers> cool!
09:22:47 <ddeja> so I can say that PoC stage is finished
09:23:09 <aspiers> awesome :)
09:23:19 <aspiers> #info Mistral PoC has been completed
09:23:31 <aspiers> will there be any kind of demo to share?
09:23:53 <beekhof> that would be good
09:24:20 <ddeja> I can prepare one, but it's hard for me to imagine, how it should look like..
09:24:33 <beekhof> maybe we can interrupt the regular schedule to have a demo-off between mistral and masakari
09:24:47 <aspiers> lol
09:24:53 <beekhof> next week i mean
09:25:04 <aspiers> demos are welcome in my book
09:25:13 <aspiers> although I don't think they need to be done as a competition ;-)
09:25:30 <aspiers> ddeja: maybe have a think, and let us know if you have any ideas
09:25:37 <aspiers> ddeja: even a 3 min youtube video would be great
09:26:00 <ddeja> aspiers: ok
09:26:03 <aspiers> thanks!
09:26:11 <beekhof> well at some point we need to decide which approach to throw our collective weight behind
09:26:18 <aspiers> #action ddeja will have a think if there's an easy way to do demos
09:26:23 <beekhof> maybe austin is a good time for that
09:26:36 <aspiers> beekhof: agreed, and yeah we can definitely discuss more in Austin
09:26:37 <ddeja> btw. I will not do much work this week, since I'm on medical leave
09:26:53 <aspiers> ddeja: ok. hope you're alright!
09:27:07 <aspiers> samP: you want to report anything? it's optional ;-)
09:27:31 <samP> still workin on masakari, sqlalchemy and some patches for masakari to work with centos
09:27:36 * beekhof has to run, i'll read the scrollback
09:27:45 <aspiers> cya beekhof, thanks for joining!
09:28:22 <aspiers> beekhof, bandini: check for recent changes to NovaEvacuate, I think there have been some you could use
09:28:31 <bandini> aspiers: ack, thanks
09:28:55 <aspiers> samP: sounds good
09:29:02 <samP> hopefully I can finish them before next meeting
09:29:07 <aspiers> cool
09:29:12 <aspiers> ok, I think we're done with status updates?
09:29:22 <aspiers> anyone have any other topics they wanna raise?
09:29:31 <aspiers> I think we should talk about Austin briefly
09:29:40 <aspiers> hopefully most of us will be there
09:29:55 * bandini nods
09:30:01 <aspiers> I'm still waiting for confirmation, but if any of my talks get accepted I'm definitely going
09:30:17 <aspiers> #topic Austin summit
09:30:37 <_gryf> aspiers, is there any session reserved for ha topics?
09:30:45 <aspiers> I think we should aim to get a more formal platform for HA BoF design sessions
09:30:50 <aspiers> _gryf: not that I'm aware of
09:30:56 <_gryf> mhm
09:31:04 <aspiers> it's been a complaint of mine for every single summit since San Diego
09:31:16 <aspiers> there was one in San Francisco (Folsom) but that's the last one I can remember
09:32:05 <_gryf> it should be some kind of procedure to have a reservation and time on the schedule I think
09:32:10 <aspiers> any opinions on whether we should aim forr multiple design sessions?
09:32:12 <aspiers> yeah
09:32:21 <aspiers> e.g. we could ask the nova guys for a session on compute HA
09:32:31 <aspiers> and maybe one for neutron too
09:32:42 <aspiers> could even have a cross-project one
09:32:57 <aspiers> for topics like reconnections in oslodb
09:33:05 <_gryf> aspiers, that's what i thinking as well - to have a cross-project session
09:33:59 <aspiers> ok, I'll raise on openstack-dev@ and cc thingee (Mike Perez, cross-project guy)
09:34:13 <_gryf> +1
09:34:17 <bandini> aspiers: sounds like a plan
09:34:40 <aspiers> we should definitely have demos of masakari and mistral PoC in Austin too :)
09:34:55 <_gryf> aspiers, you mean - live?
09:34:57 <_gryf> :>
09:35:02 <aspiers> sure! :)
09:35:07 <_gryf> oh my :)
09:35:16 <aspiers> don't worry it's the design summit, so noone will expect demos to work ;-)
09:35:37 <aspiers> I don't even expect demos in the keynote sessions to work ;-)
09:35:45 <bandini> lol
09:35:54 <_gryf> I'm not sure if I'm going to be in Austin - decission is not taken yet by my boss (this is also true for ddeja)
09:36:02 <aspiers> same here
09:36:03 <ddeja> yup
09:36:07 <aspiers> travel budget, blah blah :(
09:36:14 <_gryf> right.
09:36:35 <aspiers> but if I organise some design sessions then it's a lot easier ;-)
09:36:48 <_gryf> heh :)
09:36:55 <aspiers> ok, anything else to discuss on Austin?
09:38:23 * _gryf have nothing than that.
09:38:27 <bandini> not that I can think of now
09:38:41 <aspiers> #topic AOB (Any Other Business)
09:38:55 <aspiers> the floor is open :) anything else?
09:39:24 <aspiers> BTW openstack-ha-guide project seems very active, I guess more reviewers are always welcome there
09:40:16 <bandini> yes, I try to review there from time to time
09:40:52 <aspiers> cool
09:41:11 <aspiers> ok, if nothing else we can finish early. going once ...
09:41:31 <aspiers> going twice ...
09:41:54 <aspiers> sold! thanks all for coming, and hope to see you next week :)
09:41:58 <_gryf> ok, thanks!
09:42:04 <samP> Thx...
09:42:11 <bandini> thanks!
09:42:22 <aspiers> #endmeeting