09:02:22 <aspiers> #startmeeting ha
09:02:23 <openstack> Meeting started Mon Mar 14 09:02:22 2016 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:26 <openstack> The meeting name has been set to 'ha'
09:02:40 <aspiers> alright
09:02:41 <kazuIchikawa> hi
09:02:47 <aspiers> hi kazuIchikawa :)
09:03:40 <aspiers> #topic Current status (progress, issues, roadblocks, further plans)
09:03:55 <aspiers> not too much to report from my side
09:04:20 <kazuIchikawa> masa and samP skip this meeting, I will talk on behalf of them too.
09:04:21 <aspiers> but thanks to collaboration with Norbert Illes we are now very close to having all CI pass on openstack-resource-agents
09:04:30 <aspiers> you can see the reviews on gerrit
09:04:46 <aspiers> when that's done, I will introduce automated CI
09:04:57 <aspiers> at the moment we still have to run manually via tox
09:05:23 <aspiers> I've also been working on the neutron-ha-tool OCF RA, but I guess noone outside SUSE uses that
09:05:31 <aspiers> so I won't go into details here
09:05:44 <aspiers> feel free to ask me about it later if you are curious
09:06:06 <aspiers> #info openstack-resource-agent tox is now very close to passing all tests
09:06:18 <aspiers> haukebruno: anything you want to report?
09:06:26 <haukebruno> sadly not :/
09:06:30 <aspiers> no problem :)
09:06:36 <aspiers> _gryf: ?
09:06:51 <_gryf> ddeja is not here today, he is taking trainig couple hours long today
09:06:55 <aspiers> ok
09:07:09 <_gryf> he was working on the preparation of the mistral demo
09:07:46 <_gryf> however wasn't finished yet. due to other important activities
09:08:17 <aspiers> ok
09:08:26 <aspiers> would be cool to show that in Austin
09:08:35 <_gryf> :)
09:08:51 <aspiers> anything else?
09:09:29 <_gryf> aspiers, I thought, the plan was to show it live ;)
09:09:41 <aspiers> yes, it is :)
09:09:59 <_gryf> so for that part, I think we are set
09:10:03 <aspiers> great!
09:10:31 <aspiers> kazuIchikawa: anything from your side to report?
09:10:39 <kazuIchikawa> yes.
09:11:08 <kazuIchikawa> we almost complete the task to support CentOS compute node, https://github.com/ntt-sic/masakari/pull/21
09:11:17 <kazuIchikawa> for masakari.
09:11:58 <kazuIchikawa> So far, it was officially only on ubuntu, but we modified and tested on CentOS as well.
09:12:02 <aspiers> cool
09:12:19 <aspiers> #info masakari is almost ready for use on CentOS
09:12:32 <kazuIchikawa> ya, that's something we were oftenly asked some members in community.
09:13:21 <kazuIchikawa> And, masa just started to replace some codes to use python-novaclinet.
09:13:42 <aspiers> before it was using the CLI?
09:13:52 <kazuIchikawa> Currently it's using curl ugly...
09:13:59 <aspiers> ah ;-)
09:14:37 <aspiers> does masakari automatically create pacemaker resources?
09:14:53 <kazuIchikawa> No.
09:15:09 <kazuIchikawa> It's not a part of Masakari yet.
09:15:32 <aspiers> oh yeah, pacemaker is just for host monitoring?
09:15:57 <kazuIchikawa> It's supposed to set up pacemaker by admin so that hostmonitor can detect the host failure.
09:16:13 <kazuIchikawa> as well as STONITH.
09:16:24 <aspiers> yeah, I just remembered the architecture :)
09:16:33 <aspiers> ok
09:16:42 <aspiers> any other statuses to report from anyone?
09:16:49 <aspiers> otherwise I would like to discuss Austin briefly
09:16:51 <_gryf> kazuIchikawa, did you guys managed to switch to pacemaker_remote for the compute nodes?
09:16:58 <aspiers> _gryf: oh yeah, good question
09:17:26 <kazuIchikawa> masakari supports pacemaker_remote for compute node.
09:17:33 <kazuIchikawa> it's done already.
09:17:39 <_gryf> kazuIchikawa, ok, cool
09:17:41 <aspiers> so what sets up the remote primitives?
09:18:25 <kazuIchikawa> detail: https://github.com/ntt-sic/masakari/pull/11
09:19:39 <aspiers> ok so they have to be set up manually?
09:19:48 <kazuIchikawa> it just reads the status of each node, which shown as RemoteOnline of RemoteOffline.
09:20:03 <kazuIchikawa> Yes, you have to set up by manual
09:20:11 <aspiers> ok
09:21:05 <aspiers> #topic Austin summit
09:21:25 <kazuIchikawa> We have some scripts to set up pacemaker but it depends on our environment, system configuration... so looking for a good way...
09:21:34 <aspiers> I see
09:21:46 <aspiers> so ddeja and I got our talk accepted
09:21:59 <kazuIchikawa> Congrat!
09:22:04 <aspiers> thanks :)
09:22:45 <aspiers> #info talk of ddeja and aspiers got accepted: https://www.openstack.org/summit/austin-2016/summit-schedule/events/7327
09:22:57 <_gryf> \o/
09:23:11 <aspiers> the bad news is, now we have to prepare it ;-)
09:23:22 <kazuIchikawa> lol
09:23:24 <haukebruno> lo
09:23:25 <aspiers> kazuIchikawa: does NTT have any talks related to HA?
09:23:26 <haukebruno> l
09:23:48 <kazuIchikawa> No, we don't have any presentation related to HA.
09:23:56 <aspiers> OK
09:24:05 <aspiers> well we will definitely talk about masakari
09:24:25 <aspiers> maybe it would be possible for you to build a short demo video we could show?
09:24:49 <kazuIchikawa> we (masa, samP and myself) will join Authin summit.
09:24:53 <aspiers> although I definitely want to show the mistral demo
09:25:06 <aspiers> and maybe also the Red Hat / SUSE way
09:25:24 <kazuIchikawa> Sure. We can do anything to support you.
09:25:25 <aspiers> if the demo videos are only 1-2 mins each then it will be possible to show them all
09:25:57 <aspiers> although it is in the architecture track, so I need to think how appropriate demos are
09:26:24 <aspiers> but at least we will be talking about all the approaches positively :) they all have different benefits
09:26:35 <kazuIchikawa> We will record the demo video once you decide the scenario.
09:26:40 <aspiers> ok
09:26:49 <aspiers> thanks :) I'll discuss with ddeja and let you know
09:27:06 <kazuIchikawa> I see.
09:27:25 <aspiers> #action aspiers/ddeja to decide how many demos are appropriate, and then coordinate recording of videos
09:27:42 <aspiers> I know videos are a bit of a cheat, but the sessions are short and internet is very unreliable usually
09:27:53 <aspiers> I don't want to risk the quality of a session just for that
09:28:00 <kazuIchikawa> I agree it's safe way. live demo is live demo...
09:28:06 <_gryf> aspiers, +1
09:28:10 <aspiers> we can always show live demos at the vendors booths for people who want to see them
09:28:42 <aspiers> any other Austin topics to discuss?
09:29:01 <aspiers> we still don't have an official time/place to meet
09:29:08 <aspiers> but I will try to set one up
09:29:08 <_gryf> aspiers, so the demos not necessary contain an aurio track, right?
09:29:15 <aspiers> _gryf: correct, no audio
09:29:50 <aspiers> although it's fine to include audio, then we will just use it for learning, and in the real session we can mute it and talk over the video
09:29:57 <_gryf> initially ddeja planned to add some voice comment on what is happening on the screen
09:30:11 <_gryf> aspiers, allrighty
09:30:20 <aspiers> _gryf: actually I think that's a good idea, because it will help get the timing right
09:30:32 <aspiers> but it doesn't have to sound polished
09:30:41 <aspiers> since we won't play the audio
09:30:54 <_gryf> aspiers, right
09:31:06 <aspiers> #action aspiers to try to set up an official HA meeting time/place
09:31:43 <aspiers> anything else?
09:33:21 <aspiers> I guess not
09:33:29 <aspiers> #topic cross-project meeting tomorrow
09:33:44 <aspiers> so I think tomorrow's cross-project meeting will be about automatic evacuation
09:33:53 <aspiers> although I haven't had confirmation yet
09:33:55 <aspiers> https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
09:34:04 <haukebruno> sounds interesting, I try to make it also tomorrow
09:34:15 <aspiers> oh, I did get confirmation :)
09:34:18 * _gryf also try to be there
09:34:18 <aspiers> just saw in my email
09:34:38 <aspiers> cool
09:34:51 <aspiers> #info tomorrow's cross-project meeting will be about automatic evacuation
09:35:04 <aspiers> I will add it to the wiki
09:35:14 <haukebruno> oh 6 a.m. for me. I will _try_ to join ;-)
09:35:15 <aspiers> please tell your colleagues about it
09:35:18 <aspiers> haukebruno: ugh :-(
09:35:31 <aspiers> haukebruno: 9pm isn't great for me either, but not as bad as 6am ;-)
09:35:51 <haukebruno> well lets see wether my alarm clock is doing fine or not :p
09:36:29 <aspiers> #action everyone please review http://specs.openstack.org/openstack/openstack-user-stories/user-stories/draft/ha_vm.html before the meeting
09:36:41 <aspiers> #action also https://review.openstack.org/#/c/257809/2
09:37:07 <aspiers> I am not sure who else will attend, but I expect probably a large group
09:38:00 <aspiers> I hope beekhof, ddeja, masahito etc. can join
09:38:09 <aspiers> please remind them ;-)
09:38:36 <aspiers> #topic AOB (Any Other Business)
09:38:43 <aspiers> anything else from anyone?
09:39:42 <haukebruno> yes. for me - just a beginner of the whole community stuff - it is curious _how_ to start contributing stuff
09:39:50 <haukebruno> especially for the ha team ;)
09:40:15 <aspiers> #topic how newcomers can contribute
09:40:16 <haukebruno> is there any print/slideshow outthere catching that topic?
09:40:43 <aspiers> not specifically for HA
09:40:52 <aspiers> but there is a whole summit track about that
09:40:57 <aspiers> https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=How%20to%20Contribute
09:41:08 <aspiers> and you can find videos from previous summits
09:41:20 <haukebruno> ah cool, then I will check out this talk and look for the older ones
09:41:27 <aspiers> first step is really to decide how you want to help
09:41:43 <aspiers> in the HA world, certainly the ha-guide project needs reviewers
09:41:53 <aspiers> and that would be a good way of learning more about OpenStack HA
09:42:06 <haukebruno> I see. sounds good
09:42:17 <aspiers> although it only covers control plane HA so far
09:42:26 <aspiers> since compute HA is still work in progress
09:43:12 <haukebruno> this week will be easy for me, I'm looking forward to check that out, read the guide and stuff
09:43:17 <aspiers> nice
09:43:28 <aspiers> haukebruno: just ask on #openstack-ha if you have any questions
09:43:39 <haukebruno> I will ;)
09:43:40 <aspiers> or #openstack-dev, of course
09:43:48 <aspiers> ok
09:43:51 <aspiers> any other topics?
09:43:56 <aspiers> if not we can finish early
09:44:25 <haukebruno> I am just in discussions with my bosses wether I can make it to the april manchester HA meetup :)
09:44:30 <haukebruno> hopefully I can
09:44:57 <aspiers> oh! is there a date fixed for that?
09:45:18 <aspiers> I am supposed to be speaking at it
09:45:20 <haukebruno> http://www.meetup.com/Manchester-OpenStack-Meetup/events/229510407/ sounds so
09:45:38 <aspiers> haha, looks like I am definitely speaking at it then ;-)
09:45:50 <haukebruno> lol
09:46:44 <aspiers> #info aspiers speaking about compute HA at April OpenStack Meetup in Manchester, UK
09:46:54 <aspiers> haukebruno: hopefully see you there!!
09:47:00 <aspiers> haukebruno: please come and say hi
09:47:37 <haukebruno> yeah hopefully, in april I am back in germany so it could also be ok for just joining without companys sponsoring :p
09:47:50 <aspiers> yup
09:47:53 <aspiers> ok anything else from anyone?
09:47:58 <haukebruno> nope
09:48:16 <_gryf> nope
09:48:30 <kazuIchikawa> no
09:48:31 <aspiers> alright, let's finish early :)
09:48:36 <aspiers> thanks everyone and see you next week!
09:48:45 <aspiers> or on #openstack-ha, of course :)
09:48:49 <haukebruno> thanks and cya \o/
09:48:54 <aspiers> bye for now \o
09:49:06 <_gryf> bye
09:49:15 <aspiers> #endmeeting