09:03:37 <aspiers> #startmeeting ha
09:03:38 <openstack> Meeting started Mon Apr 11 09:03:37 2016 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:03:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:03:42 <openstack> The meeting name has been set to 'ha'
09:03:51 <aspiers> hello all, and sorry for the timing confusion
09:04:02 <aspiers> let's deal with that first
09:04:09 <aspiers> #topic time(zone) for meeting
09:04:19 <aspiers> so currently it's scheduled for 9am UTC
09:04:35 <aspiers> but that means for anyone with daylight saving timezones, the meeting time shifts twice a year
09:04:41 <aspiers> which does not sound like a good idea to me
09:04:52 <aspiers> how many of us are in daylight saving timezones?
09:04:57 <aspiers> o/
09:05:52 <aspiers> ddeja, samP, masahito?
09:06:04 <samP> samP, masahito is not
09:06:12 * aspiers puts up a o/ on behalf of beekhof
09:08:24 * aspiers puts up a o/ on behalf of ddeja
09:08:28 <ddeja> o/
09:08:31 <aspiers> :)
09:08:42 <ddeja> sorry, I'm on 2 meetings in the same time
09:08:44 <ddeja> ;)
09:08:45 <aspiers> no problem :)
09:09:24 <aspiers> hmm, if there is no daylight savings in Japan then it sounds we have a split down the middle of the group :-/
09:09:38 <ddeja> I don't think so
09:09:47 <ddeja> aspiers: masahito was there last week
09:09:55 <aspiers> oh
09:10:00 <aspiers> what about bogdando?
09:10:24 <aspiers> and haukebruno?
09:10:34 <ddeja> haukebruno was there, bogdano not
09:11:01 <aspiers> hmm, so it's not easy to decide this now
09:11:19 <aspiers> let's postpone the decision and I will try to poll everybody's preference before next week
09:11:24 <haukebruno> \o/ hello
09:11:43 <ddeja> ok
09:11:46 <aspiers> oh hi haukebruno
09:11:51 <aspiers> which timezone are you in?
09:11:57 <haukebruno> ah wait. we are 1 hour late? I hate that bloody summer/winter time crap
09:12:06 <aspiers> haukebruno: that's the current topic ;-)
09:12:12 <haukebruno> aspiers, currently CEST
09:12:15 <aspiers> ok
09:12:41 <aspiers> #idea change meeting time from 9am UTC to 9am Europe/London
09:12:54 <aspiers> #action aspiers to find out if anyone has any major objections to this
09:13:07 <aspiers> #topic Current status (progress, issues, roadblocks, further plans)
09:13:23 <aspiers> so ddeja and I have been working on preparing our Austin talk
09:13:29 <bogdando> here. hi
09:13:32 <aspiers> and I spent the whole weekend working with reveal.js
09:13:45 <aspiers> oh hi bogdando - are you in a timezone with DST?
09:13:54 <bogdando> no, UTC+1 :)
09:14:07 <bogdando> ah, yes I have DST enabled
09:14:13 <aspiers> ok
09:14:25 <aspiers> bogdando: where do you live? just curious :)
09:14:39 <bogdando> curently in Poznan
09:14:50 <aspiers> ah ok
09:15:00 <ddeja> bogdano - we are now +2 in Poland
09:15:05 <aspiers> :)
09:15:06 <ddeja> Gdansk here ;)
09:15:18 <haukebruno> I love gdansk. sorry for offtopic :p
09:15:22 <bogdando> :)
09:15:22 <aspiers> lol
09:15:28 <aspiers> so, back to my status
09:15:55 <aspiers> other than that, I was working on debugging a neutron HA failover issue
09:16:09 <aspiers> the same issue I've been working on for at least 4-6 weeks
09:16:34 <aspiers> but it's resolved now, and relevant patches are upstream
09:17:20 <aspiers> https://github.com/openstack/openstack-resource-agents/blob/master/ocf/neutron-ha-tool
09:17:28 <aspiers> in case anyone is curious
09:17:45 <aspiers> I also started looking at DVR and HA
09:18:02 <aspiers> too early to share anything useful though
09:18:37 <aspiers> ddeja: since you are in two meetings at once, feel free to share status at any point, or not at all :)
09:18:48 <aspiers> bogdando: anything to report?
09:18:53 <bogdando> I have yet a time to start working on the HA guide for computes. Instead I've been learning the jepsen framework
09:19:00 <aspiers> ok
09:19:04 <haukebruno> aspiers, just curious: what kind of HA related to DVR? local failover on compute nodes and stuff?
09:19:09 <bogdando> and I have a custom test for the rabbit HA
09:19:10 <bogdando> http://lists.openstack.org/pipermail/openstack-dev/2016-April/091763.html
09:19:15 <aspiers> bogdando: as you saw, we've had one or two people visit the channel asking for those docs
09:19:20 <bogdando> we could reuse that later for any test cases
09:19:37 <bogdando> as you may know, jepsen allows to crash your cluster in many many interesting ways
09:19:42 <aspiers> haukebruno: e.g. how to handle failure on nodes hosting SNAT routers
09:19:52 <haukebruno> ah, cool
09:20:14 <bogdando> so perhaps we could write tests to check HA for OpenStack components, like neutron HA or DLM later
09:20:18 <aspiers> bogdando: yes I saw that and added it to our long TODO list of things to look into :)
09:20:24 <bogdando> ;)
09:20:28 <ddeja> my status: Working on Austin presentation and some internal intel staff
09:21:20 <aspiers> ddeja: ok thanks - I have a reveal.js skeleton for the presentation now
09:21:27 <aspiers> bogdando: jepsen is new to me
09:21:54 <bogdando> I believe it is very nice for HA verification
09:21:56 <haukebruno> to me too
09:21:58 <aspiers> bogdando: I think this is the best way to go for HA integration tests https://github.com/cisco-oss-eng/Cloud99
09:21:59 <bogdando> I'd say the best one
09:22:05 <bogdando> but I know not much alts
09:22:14 <bogdando> yup
09:22:18 <aspiers> Cloud99 seems to do exactly what we need
09:22:19 <bogdando> the best, it is
09:22:58 <aspiers> it was presented in Vancouver
09:23:00 <bogdando> and we could split pacemaker+remote to network partitions to check instanves evac a swell
09:23:27 <aspiers> https://www.openstack.org/summit/vancouver-2015/summit-videos/presentation/high-availability-and-resiliency-testing-strategies-for-openstack-clouds
09:23:56 <aspiers> maybe someone should write a spec for HA testing
09:24:10 <aspiers> BTW I have still not finished creating an openstack-resource-agents-specs repo
09:24:15 <aspiers> but I will do that very soon, maybe today
09:24:34 <aspiers> haukebruno: anything to report from you?
09:24:46 <aspiers> or from samP or masahito?
09:24:58 <haukebruno> nothing interesting. I am still fighting with the whole git + gerrit stuff for contributing to the guide in the future :p
09:25:07 <aspiers> haukebruno: ok good luck with that ;-)
09:25:20 <aspiers> haukebruno: that's definitely worth investing time into
09:25:29 <samP> nothing from our side ...(masa?)
09:25:34 <masahito> nothing specially from us.
09:25:36 <aspiers> ok
09:25:47 <aspiers> #topic specs
09:25:58 <aspiers> so there are a few specs which need to be written
09:26:29 <aspiers> one is related to a long outstanding action for me to get a working group together to work on reconverging Fuel OCF RAs with upstream
09:26:43 <aspiers> I promised to do that during a weekly Fuel meeting a month or two ago
09:26:47 <aspiers> but did not manage to do it yet
09:27:00 <aspiers> the plan was to develop some specs to plan the reconvergence
09:27:07 <aspiers> but first obviously we need a specs repo
09:27:31 <aspiers> secondly, we need a spec to ensure that RAs are synchronous, since that is required by Pacemaker
09:27:43 <aspiers> and I suspect that many of them aren't
09:27:53 <aspiers> although I didn't check yet
09:28:12 <aspiers> thirdly, I want to write a spec proposing that OCF RAs wrap around service(8)
09:28:39 <beekhof> oh, timezones
09:28:49 <beekhof> meeting starts at 7 now?
09:28:51 <aspiers> that third one is specially for beekhof ;-)
09:29:06 <aspiers> beekhof: scroll up to the first topic discussed ;-)
09:29:12 <beekhof> i will hunt you down
09:29:16 <aspiers> lol
09:29:29 <aspiers> we probably also want specs for designing CI etc.
09:29:41 <aspiers> but I guess they will come more naturally, once we have the -specs repo
09:30:06 <aspiers> we could also use it for new compute HA specs potentially
09:30:08 <beekhof> +1hr works for me
09:30:15 <aspiers> beekhof: ok thanks, noted
09:31:02 <aspiers> #action aspiers to finish creating openstack-resource-agents-specs repo
09:31:20 <aspiers> #link https://review.openstack.org/#/c/296144/
09:31:33 <aspiers> ok, anyone want to say anything else relating to specs?
09:31:46 <masahito> is the spec repo for OCF or for VM HA?
09:32:12 <aspiers> for OCF RAs
09:32:26 <masahito> ok.
09:32:27 <aspiers> but we could also use it for VM HA, if the VM HA solution uses at least one RA :)
09:33:19 <masahito> nice. thanks to the offer.
09:33:36 <aspiers> #topic VM HA user story
09:33:56 <aspiers> more feedback has been requested for this
09:33:59 <aspiers> #link https://review.openstack.org/#/c/289469/
09:34:13 <aspiers> someone at Intel is working on it, IIRC
09:34:42 <aspiers> also, I heard that the PWG (Product Working Group) have identified VM HA as a very important feature :)
09:34:52 <haukebruno> +1 :)
09:34:55 <aspiers> so I guess the spotlight is on us a bit more now :)
09:35:11 <aspiers> I expect there will be some really interesting conversations in Austin
09:35:44 <aspiers> #action anyone interested to review that user story
09:35:57 <aspiers> #topic AOB (Any Other Business)
09:36:02 <aspiers> ok, anything else to raise?
09:36:28 <masahito> our meeting time in Austin
09:36:45 <aspiers> yeah, I didn't make any progress on that yet :-/
09:37:24 <aspiers> TBH I'm not sure how best to arrange
09:37:27 <aspiers> suggestions welcome
09:37:39 <aspiers> but ideally it would be a semi-official session
09:37:47 <masahito> I saw a proposal for cross-project slot, but we were not able to get time slot ;<
09:37:52 <aspiers> masahito: right
09:38:05 <aspiers> masahito: I suspect we're not broad enough for c-p yet
09:38:30 <aspiers> I didn't see any requests for design summit proposals
09:38:36 <aspiers> I guess I must have missed it
09:39:30 <aspiers> I'll ask some of my Foundation contacts for advice
09:39:58 <masahito> So I think we should get together anywhere at sometime.
09:40:06 <aspiers> masahito: sure, we can do that
09:40:16 <aspiers> masahito: but it would be nicer if it was on the official schedule somehow
09:40:20 <aspiers> masahito: to attract new people
09:40:28 <masahito> aspiers: right
09:41:11 <aspiers> #action aspiers to continue looking into scheduling semi-official VM HA meeting in Austin
09:41:21 <aspiers> anything else
09:45:36 <aspiers> ok sounds like we can close for todaya
09:45:51 <aspiers> sorry for the timezone confusion earlier
09:46:15 <haukebruno> so will we meet at 9utc next week or not?
09:46:20 <haukebruno> I am still confused :D
09:46:30 <aspiers> haukebruno: we didn't decide yet
09:46:33 <haukebruno> ah ok
09:46:51 <aspiers> it seems that everyone is in daylight countries except for Japan
09:47:32 <aspiers> masahito, samP: would 8am UTC work for you next week?
09:47:55 <masahito> it works for us.
09:47:57 <samP> that would be 5pm in jp,
09:48:03 <samP> ok
09:48:06 <aspiers> ok great!
09:48:27 <aspiers> so it sounds like 9am Europe/London (which is currently 8am UTC) will work
09:48:34 <samP> +1
09:48:50 <aspiers> I will adjust the wiki and meetings project
09:50:59 <aspiers> alright, thanks everyone and see you next week at 9am Europe/London!
09:51:04 <aspiers> bye for now
09:51:07 <ddeja> bye
09:51:12 <haukebruno> thanks + bye o/
09:51:32 <masahito> bye
09:52:41 <samP> bye
09:52:48 <aspiers> #endmeeting