08:03:19 <aspiers> #startmeeting ha
08:03:20 <openstack> Meeting started Mon Jul 25 08:03:19 2016 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:03:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:03:24 <openstack> The meeting name has been set to 'ha'
08:03:25 <aspiers> hi everyone
08:03:31 <samP> hi all
08:03:47 <aspiers> #topic Current status (progress, issues, roadblocks, further plans)
08:03:59 <aspiers> let's do a quick round as usual - I'll start
08:04:14 <aspiers> I finished setting up the specs repo
08:04:24 <samP> thank you
08:04:26 <aspiers> so it is ready to use now
08:04:29 <aspiers> sorry it took so long
08:04:51 <aspiers> next thing will be to start submitting specs
08:04:52 <samP> I will send the spec today
08:04:56 <aspiers> cool, thanks!
08:05:05 <samP> Oh.. do we need BPs
08:05:07 <samP> ?
08:05:08 <aspiers> also I reviewed the cross-project spec
08:05:20 <aspiers> I don't think we need them
08:05:30 <aspiers> unless you can think of a reason?
08:05:44 <rsjethani> specs should be enough
08:05:51 <aspiers> #info openstack-resource-agents-specs is ready for submissions
08:05:58 <samP> I can think any reason, so ,
08:06:07 <samP> no BPs for specs
08:06:13 <aspiers> OK :)
08:06:27 <aspiers> #info we won't use Blueprints (at least until we can think of a good reason to)
08:07:06 <aspiers> here is the cross-project spec https://review.openstack.org/#/c/257809/
08:07:17 <aspiers> it has been open for a long time I think
08:07:31 <aspiers> and currently it doesn't provide much value in addition to the user story
08:07:42 <aspiers> but in the future it can link to all the individual specs
08:08:11 <aspiers> it does talk about implementation details a bit
08:08:18 <samP> aspiers: Are we using this as a reference?
08:08:18 <aspiers> but it's mostly wrong
08:08:33 <aspiers> e.g. suggesting tooz can replace fencing
08:09:12 <aspiers> samP: I think we need to either fix the x-p spec, or remove it
08:09:24 <aspiers> samP: and I think the workflow the PWG requested is to fix it
08:09:38 <aspiers> it can talk about implementation details / architecture at a high level, which might be helpful
08:10:27 <aspiers> other than that, I have been busy catching up from holiday backlog
08:10:39 <samP> aspiers: originally, Timofey Durakov had a different way to implement the Instance HA
08:10:51 <aspiers> and I also started to discuss with beekhof about his blog post
08:11:03 <aspiers> samP: oh?
08:12:22 <aspiers> well, we can discuss after the status round
08:12:34 <aspiers> who wants to go next?
08:12:35 <samP> aspiers: No I mean, use Ceilometer+Mistral. which is fine.
08:12:50 <aspiers> oh, yeah
08:12:53 <samP> Ok, from my side,
08:13:00 <aspiers> the ceilometer discussion is ongoing in the spec review ...
08:13:44 <samP> Im working on 2 specs VM monitoring and VM recovery. Hope fully I will push them today and tomorrow.
08:14:04 <aspiers> great!
08:14:21 <samP> thatz all from my side.
08:14:29 <aspiers> thanks
08:14:38 <aspiers> anyone else?
08:15:23 <rsjethani> nothing from my side
08:15:50 <Dinesh_Bhor> from me too
08:15:55 <aspiers> ok
08:16:03 <aspiers> #topic HA guide
08:16:16 <aspiers> so there was some discussion on the list about the future of the guide
08:16:38 <samP> could you please update or give some ref
08:16:49 <aspiers> let me try to find
08:17:12 <samP> aspiers: thanks
08:17:13 <aspiers> hmm, I was wrong - it was a private thread
08:17:19 <aspiers> but I can summarise here
08:17:20 <samP> ah..
08:17:40 <aspiers> Lana Brindley said it was quite out of date (I'm not sure if this is entirely true) and they were thinking about deprecating
08:17:57 <aspiers> since bogdando is no longer able to look after it
08:18:06 <aspiers> the good news is beekhof volunteered
08:18:10 <aspiers> and I will also try to help him
08:18:16 <samP> great!
08:18:25 <aspiers> but of course any help is welcome
08:18:39 <samP> I can help
08:18:45 <aspiers> #info beekhof is taking over maintenance of the HA guide from bogdando; all help is still welcome
08:19:50 <aspiers> Lana said she'd make an announcement but I don't think it happened yet
08:20:06 <aspiers> #topic AOB
08:20:27 <aspiers> rsjethani: so we can talk about consul if you want?
08:20:33 <rsjethani> ya sure
08:20:40 <aspiers> #topic Consul
08:20:47 <aspiers> I don't know much about it
08:20:55 <rsjethani> I was just going throughit: https://www.consul.io/intro/
08:21:04 <aspiers> right
08:21:20 <aspiers> it doesn't look like it can automate recovery
08:21:33 <aspiers> or do fencing
08:21:46 <aspiers> I think it's probably mainly for active/active services where fencing is not required
08:21:51 <rsjethani> ya that was my first guess too
08:21:54 <aspiers> and for non-HA services
08:22:05 <aspiers> but ICBW
08:22:07 <rsjethani> still i thought to sk you guys
08:22:13 <aspiers> sure
08:22:22 <aspiers> please feel free to investigate more and confirm with a Consul expert
08:22:34 <rsjethani> ok
08:22:35 <aspiers> if you do, it would be great if you could let us know the outcome
08:22:41 <aspiers> it's always good to be aware of all the options
08:22:50 <rsjethani> they do have the concept of watchers
08:23:17 <rsjethani> and monitors which may be used for recovery etc.
08:23:24 <aspiers> there's Serf too
08:23:43 <rsjethani> ya consul is a superset fo serf
08:23:56 <rsjethani> it uses serf only
08:24:01 <aspiers> but if there is no native support for fencing then it's not a full solution for HA cluster management
08:24:18 <aspiers> #topic AOB
08:24:20 <samP> as aspiers mentioned above, I cant find any thing related to fence or auto recovery. maybe need to dig more
08:24:26 <aspiers> yep
08:24:31 <aspiers> anything else?
08:24:39 <rsjethani> ya i will look further
08:24:44 <samP> I will attend to PWG mid
08:24:53 <samP> at 8/22 inNY
08:24:59 <aspiers> oh - probably bad news about Barcelona. the chairman of the OpenStack board asked on our behalf if there could be an HA track
08:25:09 <aspiers> but he didn't get any reply :-(
08:25:24 <aspiers> samP: cool!
08:25:32 <samP> cause I will go to ops meetup
08:25:46 <aspiers> samP: maybe you could look out for any of the Foundation people there, and pester them about an HA track?
08:26:15 <samP> aspiers: sure
08:27:00 <samP> aspiers: I will try.
08:27:06 <aspiers> thanks :)
08:27:16 <aspiers> I will keep trying to
08:27:17 <samP> aspiers: may be we can get some help from ops side too
08:27:22 <aspiers> yes, great idea
08:27:31 <aspiers> I will mail openstack-operators and -dev
08:27:46 <samP> gret, that will be really helpful
08:27:47 <aspiers> #action aspiers to email openstack-{operators,dev} about Barcelona HA track
08:28:36 <aspiers> any other topics?
08:28:44 <rsjethani> anyone using pcs on ubuntu?
08:28:51 <samP> Not from my side
08:28:58 <aspiers> rsjethani: use crmsh ;-)
08:29:09 <samP> use crmsh
08:29:21 <aspiers> https://crmsh.github.io/
08:29:22 <rsjethani> ok :)
08:30:17 <aspiers> ok, last call for other topics :)
08:30:28 <aspiers> otherwise we can end nice and early :)
08:30:43 <rsjethani> I am done
08:31:05 <samP> thank you all...
08:31:16 <aspiers> ok thanks everyone!
08:31:18 <aspiers> #endmeeting