09:20:49 <aspiers> #startmeeting ha
09:20:50 <openstack> Meeting started Wed Jun 14 09:20:49 2017 UTC and is due to finish in 60 minutes.  The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:20:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:20:53 <openstack> The meeting name has been set to 'ha'
09:20:56 <aspiers> hi
09:20:58 <samP> hi
09:21:04 <aspiers> just a quick update from my side
09:21:16 <aspiers> #topic update of converged architecture diagrams
09:21:28 <aspiers> I repeated our Boston talk at OpenStack Day in Israel
09:21:35 <samP> great..
09:21:40 <aspiers> https://aspiers.github.io/openstack-day-israel-2017-compute-ha/
09:21:52 <aspiers> and I made some improvements to the diagrams
09:22:04 <samP> I will check that.. thanks
09:22:12 <aspiers> https://aspiers.github.io/openstack-day-israel-2017-compute-ha/#/existing-architecture
09:22:58 <aspiers> thanks, would be great if you could sanity check that when you have a moment
09:23:15 <aspiers> I noticed there was a mistake in the previous version, where NovaCompute and NovaEvacuate were the wrong way around
09:23:48 <samP> aspiers: sure, I will check that
09:23:52 <aspiers> beekhof: when you see this, hopefully you can sanity check too :)
09:24:02 <aspiers> samP: great thanks
09:24:04 <beekhof> i have no sanity left
09:24:07 <aspiers> #topic masakari packages
09:24:17 <aspiers> ah yes, I should have remembered that ;-)
09:24:43 <aspiers> also, all three masakari repos are covered by rpm-packaging now
09:25:06 <aspiers> https://github.com/openstack/rpm-packaging/tree/master/openstack
09:25:23 <samP> aspiers: thanks.. but you request some version fix, right?
09:25:36 <beekhof> looks about right
09:25:56 <beekhof> we should never have combined the two fence_compute functions into a single agent
09:26:08 <aspiers> samP: the version fix will help, but I found a workaround in the meanwhile
09:26:12 <aspiers> beekhof: right
09:26:25 <aspiers> beekhof: I realise the diagram is out of date with respect to nova-compute-wait
09:26:32 <aspiers> beekhof: but we still haven't switched to that yet
09:26:40 <beekhof> its close enough
09:26:49 <aspiers> beekhof: yeah, it's just a detail
09:26:57 <samP> aspiers: OK, anyway I have to do that. I will do that today
09:26:58 <beekhof> hopefully we can throw the lot out and use masakari one day soon
09:27:15 <aspiers> but that also cleans the diagram up nicely, since then NovaCompute will remain on the monitoring side
09:27:34 <aspiers> and nova-compute-wait will be on the recovery side, IIUC
09:28:10 <aspiers> #topic proposed new working group
09:28:25 <aspiers> also, in Israel I met Ifat who is PTL of Vitrage
09:28:39 <aspiers> and we had a really nice discussion about the synergies between related projects
09:29:10 <aspiers> there is an obvious link between (say) Vitrage and masakari
09:29:23 <aspiers> e.g. if you want to deduplicate failures from alarms
09:29:26 <samP> aspiers: yep..
09:29:27 <aspiers> Vitrage would help with that
09:29:42 <aspiers> since it can understand that VM failures originate from the failure of the underlying compute host
09:29:46 <aspiers> and stuff like that
09:30:06 <aspiers> she thought it would be possible for masakari to query Vitrage's API for this kind of logic
09:30:34 <aspiers> so then masakari knows the root cause of an issue, and only does recovery targetting the root problem, not the symptoms
09:30:47 <aspiers> also, there are other projects which eventually could be integrated
09:31:10 <aspiers> e.g. mistral, congress, monasca, watcher, senlin ...
09:31:19 <aspiers> so I had the idea of creating a working group
09:31:20 <samP> aspiers: agree
09:31:32 <aspiers> which involves representatives from all these projects
09:31:44 <aspiers> and we could agree on how to integrate them all together
09:32:34 <aspiers> Ifat and Jonathan Bryce both thought this was worth proposing to openstack-dev, so I will do that
09:32:45 <aspiers> any suggestions for a name for the WG?
09:33:25 <samP> aspiers: what is the scope of this WG? it is about VMHA or much wider scope?
09:33:42 <aspiers> samP: wider
09:34:02 <aspiers> samP: everything which involves monitoring OpenStack and then taking automatic action based on events
09:34:12 <samP> aspiers: great..
09:34:39 <aspiers> where the events are hard failures, soft failures (e.g. bad performance), or just sub-optimal states which need optimising (Watcher)
09:37:59 <samP> aspiers: monitoring something and taking automatic action upon those; HA is a subset of that..
09:38:17 <samP> aspiers: we could start with our HA issues..
09:39:49 <aspiers> samP: exactly, HA is a subset
09:40:36 <aspiers> samP, beekhof: I'll send a mail to openstack-dev and see what people think
09:41:30 <samP> aspiers: thanks..i am happy to be involved
09:41:36 <aspiers> samP: great :)
09:41:56 <aspiers> that's all I had for today, anything else from your side? otherwise we can finish
09:42:19 <samP> we have 2 specs in masakari,
09:42:28 <samP> #link https://review.openstack.org/#/c/469070/
09:43:55 <samP> which propose intrusive instance monitoring
09:44:05 <samP> #link https://review.openstack.org/#/c/458023/
09:45:09 <samP> which propose Recovery method customization, had some comment about Mistral, We could use Mistral, but still in discussion
09:45:16 <samP> thatz all from my side
09:46:02 <samP> BTW, please review them when you have spare time..
09:47:53 <aspiers> yes, I am following those reviews
09:47:59 <samP> aspiers: thanks
09:48:06 <aspiers> I think I already reviewed the first one, but not the latest changeset
09:48:20 <aspiers> same for the other one too, actually
09:48:40 <aspiers> #topic meeting time
09:48:54 <aspiers> samP: I just remembered, we need to decide what to do about the meeting time
09:49:02 <aspiers> currently it's useless for Americans
09:49:16 <samP> aspiers: yes..
09:49:41 <aspiers> http://lists.openstack.org/pipermail/openstack-dev/2017-May/116703.html
09:49:59 <aspiers> #action aspiers to email openstack-dev proposing a new working group
09:50:11 <aspiers> I didn't get any reply to that though :-/
09:50:36 <samP> aspiers: can we find good time slot?
09:50:53 <aspiers> there is no good timeslot which includes everyone :-(
09:51:26 <aspiers> beekhof: are you still wanting to be able to join these meetings? are you still focused on HA, or have you gone over to the wonderful world of containers?
09:51:28 <samP> aspiers: thtz true. I can join in late time slots, in that case
09:57:01 <aspiers> ok
09:57:12 <aspiers> closing this meeting for now, we can continue in #openstack-ha if necessary
09:57:15 <aspiers> thanks guys!
09:57:17 <aspiers> #endmeeting