09:05:54 <aspiers> #startmeeting ha
09:05:55 <openstack> Meeting started Wed Jul 26 09:05:54 2017 UTC and is due to finish in 60 minutes. The chair is aspiers. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:05:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:05:59 <openstack> The meeting name has been set to 'ha'
09:06:06 <aspiers> hi
09:06:09 <samP> hi
09:06:16 <rkmrHonjo> Hello
09:06:19 <aspiers> samP: anything to discuss today? not much from my side
09:06:21 <aspiers> hi rkmrHonjo
09:06:40 <samP> I would like to introduce rkmrHonjo from masakari
09:07:33 <rkmrHonjo> samP: thanks.
09:07:45 <samP> He will be working on converting masakari monitors to RA with moduler architecture
09:08:26 <aspiers> cool!
09:08:38 <aspiers> rkmrHonjo: nice to meet you :)
09:08:49 <aspiers> #topic modular architecture
09:09:03 <rkmrHonjo> aspiers: Nice to meet you. I've checked openstack-ra repository.
09:09:13 <aspiers> rkmrHonjo: let me know if I can help
09:10:09 <rkmrHonjo> aspiers: Thanks a lot! I'll ask to you if I have any questions.
09:10:10 <aspiers> rkmrHonjo: do you know which bit you want to work on first?
09:10:37 <samP> aspiers: can you share the link for latest link for modular architecture?
09:11:32 <aspiers> #link https://aspiers.github.io/openstack-day-israel-2017-compute-ha/#/modular
09:11:45 <samP> aspiers: thanks.
09:11:53 <aspiers> press Space to go through the slides
09:12:00 <rkmrHonjo> thanks...
09:12:53 <aspiers> rkmrHonjo: are you going to Denver PTG?
09:12:54 <rkmrHonjo> OK, I read it after that.
09:13:22 <rkmrHonjo> aspiers: Sorry, I won't participate.
09:14:04 <samP> aspiers: Which part would you think is best to start? Host monitor?
09:14:26 <samP> aspiers: Are you already working on some of those?
09:15:18 <aspiers> samP: yes I think host monitor is probably best
09:21:27 <samP> aspiers: OK then, me and rkmrHonjo can start creating PoC on Host monitoring part.
09:21:27 <aspiers> I haven't had a chance to do anything significant on it yet, since we are busy with the HPE merger :-/
09:21:27 <samP> aspiers: NP
09:21:27 <aspiers> samP: I guess the first step is to update the spec
09:21:27 <samP> aspiers: sure
09:21:27 <aspiers> https://github.com/openstack/openstack-resource-agents-specs/blob/master/specs/newton/approved/newton-instance-ha-host-recovery.rst
09:21:27 <aspiers> it would describe https://aspiers.github.io/openstack-day-israel-2017-compute-ha/#/nova-host-alerter
09:21:27 <samP> aspiers: spec for "nova-host-alerter" will be in instance-ha-host-recovery spec?
09:21:27 <samP> aspiers: or will it be a separate spec for modular architecture?
09:21:27 <aspiers> well, technically we also need a instance-ha-host-monitoring spec
09:21:27 <aspiers> since nova-host-alerter is in the top half of the diagram (monitoring) not the bottom (recovery)
09:21:27 <samP> aspiers: agree
09:21:34 <aspiers> see https://etherpad.openstack.org/p/newton-instance-ha line 119
09:21:39 <aspiers> line 124 is out of date now
09:21:50 <rkmrHonjo> samP, aspiers: OK. I start to design host monitor at first.
09:21:50 <rkmrHonjo> Should I design RA monitor with moduler architecture now? or, without it until completing implementation?
09:21:51 <aspiers> previously we thought that Pacemaker would do all the monitoring
09:22:22 <aspiers> rkmrHonjo: I think we should finish the two host monitoring/recovery specs first, to make sure we all agree on the design
09:23:17 <rkmrHonjo> aspires: OK.
09:23:23 <aspiers> so the monitoring part is pacemaker + pacemaker_remote + fence_compute + nova-host-alerter
09:23:38 <samP> aspiers: agree
09:23:45 <aspiers> great
09:24:32 <samP> aspiers: however, "nova-host-alerter" or something like that would be common for all the monitors?
09:25:39 <aspiers> you mean for VM monitoring/recovery?
09:25:47 <samP> aspiers: yes
09:26:00 <aspiers> maybe eventually, but I think it is good enough to stick with masakari-vmmonitor for now
09:26:17 <samP> aspiers: ok
09:26:24 <aspiers> if there are other VM recovery services in the future, we could extend masakari-vmmonitor to talk to them
09:28:20 <aspiers> I guess there's no advantage to generalising VM monitoring while there is only one option :)
09:28:32 <samP> aspiers: got it..
09:29:21 <samP> aspiers: let's update the spec first. Once things get fixed in the spec, rkmrHonjo and me can start the PoC for this.
09:30:33 <aspiers> sounds perfect, thanks a lot!
09:32:04 <samP> aspiers: will you be able to update the spec? or should I start working on that?
09:34:09 <aspiers> samP: there's already https://review.openstack.org/#/c/406659/
09:34:33 <aspiers> it is not merged yet, so we can update to include nova-host-alerter
09:35:04 <aspiers> which is what ddeja's final comment suggested, anyway :)
09:35:17 <samP> aspiers: yep
09:36:24 <aspiers> I will update that
09:36:51 <samP> aspiers: great..thanks
09:36:58 <aspiers> and we also need to update https://github.com/openstack/openstack-resource-agents-specs/blob/master/specs/newton/approved/newton-instance-ha-host-recovery.rst
09:37:11 <rkmrHonjo> aspiers: thank you...
09:37:27 <aspiers> rkmrHonjo: thank you for joining :)
09:39:31 <rkmrHonjo> aspiers: You're welcome.
09:41:09 <samP> aspiers: OK, if ddeja wouldn't mind, I can take over this..
09:41:10 <aspiers> samP: ok I guess we're done, unless you have anything else today?
09:41:21 <aspiers> samP: I'm sure ddeja wouldn't mind
09:41:35 <samP> aspiers: ok then I will fix that
09:41:39 <aspiers> great, thanks!
09:41:54 <aspiers> alright. I will work on the monitoring spec ASAP
09:41:55 <samP> aspiers: session proposed for Ops Meetup in MEX
09:42:02 <aspiers> oh nice!
09:42:03 <samP> #link https://etherpad.openstack.org/p/MEX-ops-meetup
09:42:13 <aspiers> #action aspiers to update https://review.openstack.org/#/c/406659/ to latest architecture
09:42:22 <aspiers> #action samP to update https://github.com/openstack/openstack-resource-agents-specs/blob/master/specs/newton/approved/newton-instance-ha-host-recovery.rst to latest architecture
09:42:25 <samP> I will update you about ops meetup
09:42:28 <aspiers> great
09:42:39 <aspiers> my manager is finding out whether I can go to Denver
09:42:47 <aspiers> will you be there?
09:42:55 <samP> aspiers: yes, I will be there..
09:42:59 <aspiers> cool
09:43:07 <aspiers> fingers crossed I can go :)
09:43:39 <rkmrHonjo__> Sorry, my network is unstable today.
09:43:49 <aspiers> rkmrHonjo__: np
09:43:59 <samP> aspiers: ok then, nothing else from my side
09:44:04 <aspiers> rkmrHonjo__: http://eavesdrop.openstack.org/meetings/ha/2017/ha.2017-07-26-09.05.log.txt
09:44:21 <samP> aspiers: I will update you on ML about ops and other topics
09:44:27 <aspiers> perfect
09:44:39 <aspiers> ok, so we can close the meeting - thanks a lot both, and see you on #openstack-ha!
09:44:49 <samP> aspiers: thank you..
09:44:55 <samP> rkmrHonjo__: thank you
09:45:04 <aspiers> #endmeeting