21:06:23 <nickchase> #startmeeting HA Guide
21:06:24 <openstack> Meeting started Thu Feb  5 21:06:23 2015 UTC and is due to finish in 60 minutes.  The chair is nickchase. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:06:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:06:27 <openstack> The meeting name has been set to 'ha_guide'
21:06:38 <nickchase> That was easy. :)
21:06:51 <mattgriffin> excellent!
21:07:04 <vmorris> #agreed
21:07:07 <mattgriffin> :)
21:07:51 <mattgriffin> i think there are a few things to bring up this week...
21:08:27 <mattgriffin> 1. continue to look for bugs. here's some useful tips - https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Bug_Bash
21:08:53 <mattgriffin> i see the Docs team doing some triaging and tagging
21:09:13 <mattgriffin> 2. content structure changes
21:09:15 <nickchase> Mirantis people have been going through as well.
21:09:21 <mattgriffin> nickchase, cool
21:09:29 <nickchase> So on structure:
21:09:40 <nickchase> megm and I were talking about the install guide issue
21:09:59 <nickchase> and we were thinking that perhaps it would be best if we did the following:
21:10:10 <nickchase> In the HA Guide, we start with...
21:10:45 <nickchase> a general overview of the install steps, with a link to where to get more information, and a note about any steps that require special treatment for HA (with a link to that section of the guide).
21:10:55 <nickchase> That sets the context.  Then ...
21:11:17 <nickchase> In the install guide, any places where HA makes a difference, we make a note and link them back to the HA Guide.
21:11:49 <Shamail> nickchase: +1, I like the idea since both documents are no longer stand-alone docs that users have to find/parse individually.
21:11:54 <mattgriffin> makes sense to me
21:12:19 <Shamail> plus it would be bad to find conflicting information (or missing steps in install that prevent HA later), etc
21:12:31 <nickchase> right.
21:12:31 <mattgriffin> no need to repeat info and maintain it
21:12:38 <megm> Yes, they need tobe intertwined...
21:12:52 <megm> +1, matt!
21:12:54 <nickchase> but this enables us to decouple them as much as possible.
21:12:58 <nickchase> (but no more :))
21:14:15 <mattgriffin> shall we put it to an official meetbot vote? i think we should run this by the docs team though
21:14:23 <megm> What about information about how to manage HA after initial configuration?
21:14:49 <megm> e.g. I have HA configured, a server crashed, how do I replace it, etc?
21:15:18 <nickchase> So an HA operations section
21:15:22 <nickchase> I think that would be good to have
21:15:43 <nickchase> but as far as voting or running by the docs team...
21:15:47 <Shamail> I had proposed that as a change to include "recovery" information (e.g. how do I get my availability or operations back to my desired availability/performance)
21:16:02 <megm> But does it go in HA Guide or does HA Guide point to other guides?
21:16:18 <nickchase> I think that we should just make a decision here -- does anybody object? -- and then provide a summary set of minutes to the list as a decision people can dispute if they want to.  I don't think they will.
21:16:22 <Shamail> I think that it might be a nice to have since it is subject to qualitative guidelines or best practice recommendations.
21:16:28 <Shamail> mattgriffin: thoughts?
21:16:50 <nickchase> I think that recovery information is definitely crucial.
21:17:09 <mattgriffin> Shamail, nickchase yes. i wonder how much is included in the Ops Guide though
21:17:13 <nickchase> Whether it goes here or in the Operations Guide... that's a differen tquestion
21:17:16 <nickchase> :)
21:17:24 <Shamail> mattgriffin: should I take the action item to parse through Ops guide?
21:17:25 <nickchase> So we need to find out.
21:17:39 <mattgriffin> Shamail, that would be great
21:17:57 <nickchase> #action Shamail Parse Ops guide for recovery information.
21:18:05 <Shamail> alright, I'll take the first stab and report back to the team.
21:18:33 <nickchase> (Not sure why an action item wasn't generated.)
21:18:50 <nickchase> But mattgriffin, are you taking notes for minutes or should I?
21:19:35 <mattgriffin> nickchase, hadn't started so please do
21:19:46 <nickchase> k
21:20:40 <Shamail> I think the bot should handle it since we formally started the meeting but good backup plan nonetheless.
21:21:08 <nickchase> The bot will do the log.  I'm talking about a simplified version to post to the openstack-docs list.
21:21:59 <Shamail> oh, I get it.  Sorry!
21:22:25 <mattgriffin> nickchase, you'll run with outlining the structure approach and sending to the list?
21:22:50 <nickchase> yes.
21:22:59 <mattgriffin> cool. thank you
21:23:04 <nickchase> or I can send it to you and you can send it to the list.  either way.
21:23:13 <mattgriffin> nah. go for it
21:23:17 <nickchase> :)  NP
21:23:25 <vmorris> is there a place to request access to the mailing list or just let you know my address?
21:23:46 <nickchase> #link http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-docs
21:24:01 <vmorris> ty
21:24:19 <nickchase> OK, so what's next, mattgriffin?
21:24:29 <Shamail> We are using [ha-guide] for our prefix in the same ML right?
21:24:47 <mattgriffin> nickchase, as an action item, should we start to map out the points to cross guides?
21:25:18 <nickchase> shamail yes
21:25:30 <nickchase> mattgriffin yes, I think we need to do that.  At the very least....
21:25:42 <nickchase> we need the basic install guide steps
21:25:47 <nickchase> any volunteers...?
21:26:31 <Shamail> Unfortunately, I don't want to over-commit.  I can help with this (if it's not done) after going through Ops Guide
21:27:06 <nickchase> I think we can set it as a "to do"
21:27:31 <mattgriffin> nickchase, yes. i wonder if that list isn't captured in the http://docs.openstack.org/juno/install-guide/install/apt/content/
21:28:05 <nickchase> It may be.  I suppose the question may be...
21:28:21 <nickchase> the granularity.  I mean, we could have "Install Keystone" as a step. :)
21:28:31 <mattgriffin> ack
21:28:59 <nickchase> Yeah, I think maybe a bit TOO chunky. :)
21:29:10 <mattgriffin> i can take that action item
21:29:36 <nickchase> great.
21:29:44 <mattgriffin> i'll just be using an etherpad so i'll email [ha-guide] with the link to contribute, follow along, criticize :)
21:30:00 <nickchase> #action mattgriffin Define install steps in an etherpad.
21:30:08 <nickchase> :)
21:30:25 <mattgriffin> cool. i think that's the agenda
21:30:40 <mattgriffin> if there isn't anything else to cover, then i think we can end this meeting
21:30:53 <nickchase> Just to note that we still need to restructure the overall TOC.
21:31:04 <mattgriffin> ack
21:31:12 <nickchase> maybe after the install step?
21:31:22 <mattgriffin> yeah. let's do that
21:31:51 <nickchase> ok, so let's keep it on the agenda
21:31:55 <megm> And the introductory material is good but it needs to go a little farther.
21:32:03 <mattgriffin> great
21:32:22 <mattgriffin> end meeting?
21:32:31 <mattgriffin> #endmeeting
21:32:38 <megm> bye
21:32:42 <nickchase> thanks, all!
21:32:48 <vmorris> thanks, bye
21:32:52 <mattgriffin> nickchase, i think you have to do that
21:32:59 <mattgriffin> since you started the meting
22:51:22 <pjnaik1990> Hi, I am new to openstack. I liked the idea of Congress project and would like to contribute to it. Could anybody suggest me few ideas/modules in congress project where I could work for a span of 2-3 months?
23:31:15 <fungi> #endmeeting