21:11:00 <nickchase> #startmeeting HA Guide
21:11:01 <openstack> Meeting started Thu Feb 26 21:11:00 2015 UTC and is due to finish in 60 minutes.  The chair is nickchase. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:11:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:11:04 <nickchase> there we go.
21:11:05 <openstack> The meeting name has been set to 'ha_guide'
21:11:25 <nickchase> OK, then, so let me grab last week's notes, one moment
21:11:31 <Shamail> perfect.
21:12:19 <nickchase> OK, so we had no "official" action items from last week, but I know that megm was filling in links to existing material in the TOC.  (digging...)
21:12:37 <nickchase> https://wiki.openstack.org/wiki/HAGuideImprovements/TOC
21:13:04 <nickchase> she said that she's not quite finished yet
21:13:22 <Shamail> I have an update on this "topic" (loosely coupled)
21:13:23 <nickchase> Also do we have any of the mirantis team here (besides me)?
21:13:34 <nickchase> awesome, go, Shamail
21:13:38 <Sam-I-Am> yeah, the big one was updating the ToC
21:13:47 <Sam-I-Am> with a secondary of seeing what was re-usable
21:13:49 <nickchase> great so let's stick with that.
21:14:02 <Shamail> I told the win the enterprise team that we are trying to establish scope for the HA-Guide....
21:14:22 <Shamail> For example is it just instructions or should it help people establish a HA strategy as well
21:14:33 <Shamail> This will probably impact ToC as well
21:14:45 <Sam-I-Am> nickchase: i'm going to the ops mid-cycle and plan to see what people are using for HA
21:14:51 <Sam-I-Am> nickchase: so this should help the ToC
21:15:01 <Shamail> Sam-I-Am: that is awesome
21:15:16 <nickchase> great.
21:15:25 <Shamail> What is our stance on the topic I mentioned related to scope?
21:15:30 <Sam-I-Am> i added/removed a few things since last week
21:15:32 <nickchase> so one thing at a time:  Shamail:  I think it should talk about strategy
21:16:11 <nickchase> Sam-I-Am: what do you think?
21:16:18 <Sam-I-Am> sure
21:16:23 <Shamail> nickchase: agreed, but I have not seen much content discussion around strategy versus tactical execution of HA
21:16:41 <nickchase> That's fine, we need to get it in there, then.
21:17:11 <nickchase> #agreed We need to add strategy information to the TOC.
21:17:14 <Shamail> The current version of HA-Guide assumes that people understand HA (and implications) and simply need instructions on how to implement
21:17:44 <nickchase> So I will get some structure in for strategy if  nobody else wants it.
21:18:04 <nickchase> going once ... going twice...
21:18:09 <Sam-I-Am> we dont want to re-invent someone else's docs... so imho, for things like galera, we should point people at the galera docs
21:18:15 <Shamail> I'd like to help with that (as a co-developer or reviewer)
21:18:19 <nickchase> Sure.
21:18:21 <Sam-I-Am> however, how to implement galera with openstack is our thing.
21:18:25 <nickchase> ok, great.
21:18:27 <nickchase> yes.
21:18:35 <Shamail> I agree Sam-I-Am
21:18:41 <nickchase> #action nickchase Add structure for HA strategy.
21:18:55 <Sam-I-Am> nickchase: hey this is already better than the docs meeting today :)
21:18:57 <nickchase> #agreed We don't want to duplicate existing docs (ie, for Galera)
21:19:12 <nickchase> Sam-I-Am:  I can start a fist fight if you want. :)
21:19:17 <Sam-I-Am> nickchase: can we make the ha guide pretty? :)
21:19:21 <Shamail> Did Matt do a read-out for his task of reviewing the install-guide?
21:19:24 <nickchase> :)
21:19:27 <Sam-I-Am> nickchase: i prefer dumpster fires
21:19:39 <nickchase> Shamail: my understanding is he's still working on it.
21:20:06 <Shamail> Cool.  I missed last week so wasn't sure (I could've reviewed notes)
21:20:25 <nickchase> so moving on...
21:20:26 <nickchase> OK, so the Mirantis guys are looking at which topics they think they can complete quickly and efficiently and let us know.
21:20:52 <nickchase> so between that and the existing content, that'll give us some structure for figuring out what we still need to assign.
21:21:08 <Shamail> Please let me know which topics are "up for grabs" as well.  I'm willing and able. :)
21:21:36 <nickchase> Great.
21:21:58 <nickchase> OK, so do we have an actual agenda (he said, slapping his forehead)?
21:22:24 <Shamail> Not sure, although I did want to mention my task and its lack of completion. :)
21:22:32 <Sam-I-Am> not much beyond task updates from last meeting
21:22:45 <Sam-I-Am> and maybe that we'll do this in rst :)
21:23:01 <nickchase> apparently it's TBD. :)
21:23:07 <Shamail> Hehe
21:23:10 <nickchase> I'm fine to do it in RST now that we know how. :)
21:23:16 <nickchase> it's easy peasy to get it set up.
21:23:31 <nickchase> Even if I do seem to be giving Andreas hives. :)
21:23:33 <Shamail> Someone fill me in!  I'm all for it.
21:23:48 <nickchase> what, how to do RST?
21:24:11 <Sam-I-Am> probably a good thing to determine early so we don't get another network guide fiasco
21:24:35 <Shamail> No, switching. :-)
21:24:46 <nickchase> we haven't decided, to the best of my knowledge.
21:25:05 <nickchase> and I don't think we should without Matt here.
21:25:15 <nickchase> Discussion for the mailing list, perhaps?
21:25:34 <Sam-I-Am> nickchase: yes
21:25:35 <nickchase> any objections to discussing on the ML?
21:25:41 <nickchase> great.
21:25:49 <Shamail> Nope
21:26:02 <nickchase> #agreed We'll take the discussion of RST vs Docbook to the mailing list.
21:26:19 <nickchase> OK, so do we have anything else right now?
21:26:28 <Shamail> So, as Matt was reviewing install-guide, I have volunteered to review ops-guide.  The intention was to review it to determine whether it contains "recovery" information from failures.  I was out of the office last week but I wanted to let everyone know that I am still planning to go through all 300+ pages.
21:26:41 <nickchase> excellent.
21:26:45 <Sam-I-Am> i dont think there's much in the ops guide about ha
21:26:58 <Sam-I-Am> but you never know. such is the problem with a lot of different-but-not-really guides
21:26:59 <Shamail> I don't think so either but should it?
21:27:00 <nickchase> #action Shamail Review the ops guide for any references that are relevant to HA.
21:27:17 <nickchase> #action Sam-I-Am Review the install guide for any references that are relevant to HA.
21:27:21 <Shamail> I'm going to steal that term Sam-I-Am
21:27:40 <Sam-I-Am> oh, was that MY thing, or matt's thing :) lol
21:27:44 <nickchase> I think that in places where it's relevant we should link it over ot the HA guide.
21:27:45 <Sam-I-Am> sometimes i'm sam, sometimes i'm not
21:27:57 <Shamail> lol
21:28:10 <nickchase> :)
21:28:15 <nickchase> what else we got?
21:28:23 <Sam-I-Am> so i'm doing the install guide bits?
21:28:31 <Sam-I-Am> where should we log these things, an etherpad?
21:28:49 <nickchase> If you prefer.  I like the wiki better but I'm not in charge.
21:28:52 <Shamail> Do we know which sessions were proposed for Vancouver in relation to HA?
21:29:00 <nickchase> I do not.
21:29:03 <Shamail> I submitted one but wasn't sure if others did
21:29:21 <Sam-I-Am> i dont either. probably best to wait until they're voted on.
21:29:23 <nickchase> I was woefully under-diligent in voting.
21:29:27 <Shamail> I prefer wiki as well
21:29:32 <Sam-I-Am> then maybe some of us can hit those sessions
21:29:35 <nickchase> you're outvoted, matt. :)
21:29:52 <Sam-I-Am> wiki is fine
21:30:11 <Sam-I-Am> i spent half a day voting and only got through maybe 1/4 of them
21:30:20 <nickchase> you want to create wiki pages and link them to the main page or do you want me to?
21:30:29 <Sam-I-Am> nickchase: you can do it, managerate!
21:30:33 <nickchase> I cherry-picked the ones that looked interesting.
21:30:37 <nickchase> :)
21:31:02 <nickchase> #action nickchase Create wiki pages for the install guide and ops guide notes and link them from the main HA guide page.
21:31:22 <nickchase> next?
21:31:58 <Shamail> I'm done :)
21:32:10 <nickchase> Sam-I-Am?
21:32:18 <Sam-I-Am> i think we're good, sir
21:32:22 <nickchase> excellent.
21:32:28 <Sam-I-Am> make sure you send an update e-mail with our tasks :)
21:32:31 <nickchase> I hereby return the next 28 mintues.
21:32:36 <nickchase> :)
21:32:43 <nickchase> I managerated them properly in the bot, I hope.
21:32:46 <Sam-I-Am> i'll see you tomorrow for Yet Another Meeting
21:32:46 <nickchase> #endmeeting