21:02:05 <mattgriffin> #startmeeting HA-Guide
21:02:06 <openstack> Meeting started Thu Mar 26 21:02:05 2015 UTC and is due to finish in 60 minutes.  The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:10 <openstack> The meeting name has been set to 'ha_guide'
21:02:36 <mattgriffin> i going to need to step away in a few min. shouldn't be long
21:02:48 <mattgriffin> hi megm_
21:02:48 <Shamail> seems like a small crowd today anyway :)
21:02:58 <Shamail> but we are a small team anyway, so...
21:03:01 <mattgriffin> Sam-I-Am, you around?
21:03:37 <mattgriffin> here's the agenda for today: https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:03:39 <mattgriffin> #link https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:04:07 <mattgriffin> any other items to discuss?
21:04:31 <Shamail> I would like an update on whether people reviewed TOC and when can we consider it finalized to start making further progress
21:04:53 <mattgriffin> Shamail, ok
21:04:53 <Shamail> I added some comments in the TOC (that was our established plan during the last meeting)
21:05:06 <mattgriffin> Shamail, saw those. thank you
21:05:15 <megm_> Yes, good stuff.
21:05:41 <megm_> I assume that, as we get into the real writing, we'll need to adjust the structure slightly.
21:05:55 <mattgriffin> #topic Terminology question: "storage provider" or "storage backend"?
21:06:02 <megm_> So with that hypothesis, it seems like a good outline
21:06:37 <mattgriffin> re: terminology, i don't mind either option
21:06:52 <mattgriffin> brb
21:06:55 <Shamail> I don't think we do either, we just wanted to standardize on one.
21:06:58 <Shamail> okay
21:07:15 <megm_> Shamail, since it's just us...
21:07:55 <megm_> So is EMC a storage provider/backend or another layer
21:08:35 <Shamail> It would be provider/backend
21:08:58 <megm_> So I would choose between, say, Cinder LVM, Ceph, or EMC?
21:09:04 <Shamail> Exactly
21:09:19 <Shamail> They would all still leverage Cinder volume and scheduler services
21:09:42 <megm_> And does EMC also work with Glance and for ephemeral storage?
21:10:57 <Shamail> Sorry
21:11:01 <Shamail> got distratced for a secon
21:11:13 <megm_> Terminology...  I'm guessing that the engineers working on the OpenStack infrastructure favor "storage backend"
21:11:15 <Shamail> Yes, it does.. however the way to interface with all of those service varies
21:11:36 <megm_> and companies that are selling alternatives prefer "storage provider", right?
21:11:49 <Shamail> Nope, even vendors are fine with both terms.
21:12:01 <megm_> np -- and, of course, the interface details work with both.
21:12:04 <Shamail> I'm fine with either
21:12:15 <Shamail> If backend is more common then that should be what we use as well
21:12:37 <mattgriffin> cool. so "storage backend"
21:12:48 <megm_> I wish we had a larger quorum for opinions here...  My exposure is limited and perhaps biased
21:12:59 <Shamail> I just checked, ops guide uses backend. :)
21:13:09 <mattgriffin> Shamail, cool
21:13:28 <megm_> So are we good with "storage backend"?
21:13:31 <mattgriffin> +1
21:13:34 <Shamail> +1
21:13:44 <mattgriffin> cool... next topic
21:13:55 <megm_> I prefer that -- and it means we can talk about "third party storage providers such as EMC, etc ;-)
21:14:05 <mattgriffin> :)
21:14:06 <mattgriffin> #topic Action items from last meeting
21:14:20 <mattgriffin> reminder: http://eavesdrop.openstack.org/meetings/ha_guide_update/2015/ha_guide_update.2015-03-19-21.01.html
21:14:22 <mattgriffin> #link http://eavesdrop.openstack.org/meetings/ha_guide_update/2015/ha_guide_update.2015-03-19-21.01.html
21:14:38 <mattgriffin> doesn't look like nick is around
21:15:16 <megm_> And I didn't hear from him about setting up the files and converting
21:15:47 <mattgriffin> megm_, ok. let's keep that on the agenda b/c it's important to clarify
21:15:52 <megm_> I did update the Wiki piece about moving to the standard repo
21:16:05 <mattgriffin> megm_, great
21:16:10 <megm_> Yes, we need to set things up so we can start writing.
21:16:24 <mattgriffin> megm_, where is that update?
21:16:50 <megm_> https://etherpad.openstack.org/p/ha-guide-march-2015-update
21:16:55 <megm_> next-to-last paragraph
21:17:30 <mattgriffin> megm_, cool
21:18:24 <mattgriffin> i think there's still some prodding to get some more reviews of the TOC
21:18:41 <mattgriffin> i'm interested to hear if Sam-I-Am (hint hint) has more feedback on the networking section
21:19:31 <megm_> Have the network-guide people agreed to cover HA in their guide?
21:19:56 <mattgriffin> megm_, don't think so but would be good to get confirmation
21:20:08 <mattgriffin> i'll make that an action item
21:20:36 <mattgriffin> #action check if the network-guide people have agreed to cover HA in their guide
21:20:46 <megm_> I'm also concerned about some other projects -- like Sahara.  Right now, their docs don't say anything
21:21:17 <megm_> And that could be gnarly because Hadoop has its own HA implementation so somewhere we need to document
21:21:25 <megm_> how that works with OpenStack HA
21:22:26 <Shamail> megm_: it would be a similar concept to how we are approaching storage backends
21:23:02 <Shamail> We need to cover HA from an OpenStack services perspective... anything beyond this should be noted and explained a high-level but ultimately deferred to an implementation choice
21:23:20 <Shamail> at a high-level*
21:23:24 <megm_> Really?  So we should provide some info about Sahara HA?  It would be fun but I'm not sure it's the right approach.
21:23:58 <megm_> The HA Guide could get bogged down with even high-level discussions of all these "peripheral" projects, couldn't it?
21:23:59 <Shamail> I think anything that has the integrated tag should be fair game, no?
21:24:08 <Shamail> just integrated-release ones
21:24:49 <Shamail> We are already covering (based on TOC) Keystone, Glance, Nova, Cinder, Swift, Heat, Ceilometer, and Trove
21:24:59 <megm_> That could be a good demarkation...
21:25:16 <mattgriffin> i think that's a good list for now
21:25:38 <mattgriffin> much more known and documented already about those projects
21:26:13 <megm_> We are going to need some help from the Sahara people for this, right?
21:26:37 <Shamail> so our demarkation point is "integrated + significant deployments"?
21:26:46 <Shamail> # of deployments
21:27:07 <mattgriffin> i think so. at least to determine priorities. may change as we really get into updates/writing
21:27:24 <Shamail> Cool
21:28:24 <megm_> Sounds good to me -- how do we get the Sahara people onboard?
21:28:45 <mattgriffin> you guys involved with Sahara at all?
21:29:08 <megm_> I'm not
21:29:41 <megm_> But I think it's interesting ;-)
21:29:47 <Shamail> Negative
21:30:12 <mattgriffin> let's see if nick or Sam-I-Am can provide some direction on Sahara, yes?
21:30:35 <Shamail> Sounds good...
21:30:58 <mattgriffin> #action check with nick and Sam-I-Am on inclusion (how/if) of Sahara in HA Guide
21:31:38 <mattgriffin> Shamail, move on to your topic?
21:31:43 <megm_> Here is their wiki: https://wiki.openstack.org/wiki/Sahara -- I don't see meetings or HA but maybe if I look more closely
21:31:56 <mattgriffin> megm_, :)
21:32:11 <megm_> Yes, move on
21:32:18 <mattgriffin> #topic update on whether people reviewed TOC and when can we consider it finalized to start making further progress
21:32:29 <Shamail> Sounds good... I think without Nick or Sam-I-Am we might need to extend the deadline for TOC review?  Or are we good to go with the one we have right now?
21:32:44 <mattgriffin> after looking over the guide another time. i think it's in pretty good shape to begin...
21:32:48 <mattgriffin> but good point on nick and Sam-I-Am
21:32:49 <Shamail> I think so too
21:33:05 <mattgriffin> let's extend to 1 more week
21:33:20 <megm_> Once we agree on the TOC, how immutable is it?
21:33:29 <Shamail> That works for me.  megm_ and I have lots to discuss on storage anyway. :)
21:34:07 <megm_> +1
21:34:19 <mattgriffin> megm_, i think we should expect it to change but only in terms of the details. the structure seems sound to me
21:34:35 <megm_> mattgriffin +1
21:35:03 <Shamail> What will be the process for adding additional topics in the future?  (e.g. if a project team wants to get involved)
21:35:05 <mattgriffin> cool. so we will extend for 1 more week and poke others to give their +1s or comments
21:35:10 <Shamail> We can just add something to our wiki
21:35:30 <mattgriffin> Shamail, works for me... and join this meeting and tell us or ask for our help
21:35:37 <Shamail> Exactly
21:35:53 <Shamail> We want to keep an open door policy for inclusion so we'll tell them to stop by and discuss
21:36:05 <mattgriffin> #action annoy nick and Sam-I-Am to look at TOC one more time
21:36:12 <mattgriffin> Shamail, +1
21:36:32 <megm_> +1 to everything said
21:36:36 <mattgriffin> ok. any other business to discuss?
21:36:44 <megm_> not here
21:36:46 <Shamail> Just a quick comment
21:36:48 <mattgriffin> sure
21:36:56 <Shamail> I have a session (along with Cloud Don and Sriram) at the summmit
21:37:02 <Shamail> HA: Theory to Reality
21:37:05 <mattgriffin> Shamail, congrats
21:37:13 <Shamail> It will definitely reference our guide
21:37:13 <megm_> Ooh, sounds interesting!
21:37:19 <Shamail> so just wanted to let the team know
21:37:32 <Shamail> Cloud Don and Gerd, lol
21:37:38 <Shamail> not his two alter egos
21:37:54 <megm_> ;-)
21:38:02 <mattgriffin> Shamail, that's great! please see if you can recruit some contributors :)
21:38:12 <Shamail> Absolutely!!!
21:38:17 <mattgriffin> fantastic
21:38:29 <Shamail> cya mattgriffin and megm_
21:38:35 <mattgriffin> ok. if there isn't any other business, i'm going to endmeeting
21:38:36 <mattgriffin> later Shamail
21:38:39 <mattgriffin> #endmeeting