21:01:05 <mattgriffin> #startmeeting HA-Guide
21:01:06 <openstack> Meeting started Thu Apr  2 21:01:05 2015 UTC and is due to finish in 60 minutes.  The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:09 <openstack> The meeting name has been set to 'ha_guide'
21:01:40 <mattgriffin> megm_, i had a couple of items on the agenda for today: https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:02:39 <megm_> Is nick here?
21:02:54 <mattgriffin> megm_, don't think so. said he was in a sprint for the First App
21:03:25 <megm_> Ah, I didn't realize that meant he wasn't joining us...
21:03:55 <mattgriffin> action item from last week... check if the network-guide people have agreed to cover HA in their guide
21:04:04 <Sam-I-Am> howdy
21:04:11 <mattgriffin> heh.. hey Sam-I-Am !!!
21:04:19 <megm_> And Nick says yes.
21:04:20 <mattgriffin> was just about to share what you emailed me :)
21:04:23 * Sam-I-Am sotired
21:04:28 <mattgriffin> :)
21:04:41 <mattgriffin> re: if HA was going to be included in the Networking Guide
21:04:57 <megm_> Anyone connect with Sahara people?  I looked around and can't even figure out who/where they are
21:05:10 <Sam-I-Am> mattgriffin: did my reply make sense?
21:05:11 <megm_> Why so tired, Sam-I-Am?
21:05:27 <mattgriffin> megm_, didn't connect. don't know who to contact
21:05:28 <Sam-I-Am> megm_: overwhelmed
21:05:37 <Sam-I-Am> tis the season for release
21:05:48 <Sam-I-Am> hey its a nick
21:05:50 <mattgriffin> welcome nickchase
21:05:55 <nickchase> Hey, all, so sorry I'm late.
21:05:58 <mattgriffin> np
21:06:00 <nickchase> hey, guys
21:06:04 <megm_> Ah yes, Sam-I-Am...  I hope the adreneline holds out ;-)
21:06:09 <megm_> Hi, Nick
21:06:11 <Sam-I-Am> at least i'm not the latest one here
21:06:19 <megm_> Sahara is secondary importance...
21:06:23 <nickchase> :)  Hi, megm
21:06:27 <nickchase> I agree on Sahara.
21:06:32 <mattgriffin> +1
21:06:44 <megm_> We need conversion/file set-up to proceed, though
21:06:45 <mattgriffin> let's hold off
21:06:56 <mattgriffin> nickchase, ^ re: conversion
21:07:03 <nickchase> oh, heavens, I think I dropped the ball on that before I went on vacation
21:07:05 <nickchase> I'm sorry
21:07:08 <nickchase> let me do that right now.
21:07:13 <mattgriffin> cool
21:08:27 <megm_> nick, +1
21:09:10 <mattgriffin> megm_, nickchase just routed you an email from Sam-I-Am with a few answers to questions
21:09:34 <megm_> looking...
21:09:40 <mattgriffin> re: networking, Sam-I-Am's advice is to include the basics. the Networking Guide will cover HA
21:09:55 <mattgriffin> Sam-I-Am, sit back and relax. i'll type everything for you today :)
21:10:31 <Sam-I-Am> mattgriffin: ha
21:10:39 <megm_> Sounds like we're close to a +2 on TOC?
21:10:57 <Sam-I-Am> yes, minus a few ordering things and minor topic tuning
21:11:22 <Sam-I-Am> things that will most likely happen during content generation
21:11:27 <Sam-I-Am> "oh hmmm we should do this"
21:11:31 <Shamail> hello!
21:11:33 <megm_> Sam-I-Am, please fix (or tell me how to fix) anything you see in TOC.
21:11:33 <mattgriffin> Sam-I-Am, aye
21:11:40 <mattgriffin> Shamail, hello!
21:12:05 <Sam-I-Am> megm_: nothing seems to need fixing yet
21:12:11 <mattgriffin> Shamail, agenda: https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:12:48 <nickchase> I'm close to +1 on TOC, I just need confirmation from Bogdan.  as I was saying I am meeting with him probably tomorrow or Monday
21:13:02 <mattgriffin> nickchase, ok. great
21:13:16 <megm_> The ordering has me concerned -- and yes, we will certainly modify it during development, but we should start as good as we can.  I'm concerned that we've got something like Step 3 stuff that presupposes Step 8 stuff...
21:13:34 <Sam-I-Am> the sections are pretty independent
21:13:42 <Shamail> FWIW (which isn't much), I'm +1 on TOC already
21:13:45 <Sam-I-Am> meaning someone can HA keystone without the nova content
21:13:59 <Sam-I-Am> or write how to HA all the apis without other stuff
21:14:30 <Shamail> But Sam-I-Am, do we plan on going into project-specific HA details for each component?  We also had a discussion last week on inclusion... Integrated-release projects only for the first re-vamp?
21:14:30 <Sam-I-Am> there's a few things with question marks like "glance with swift or ceph backend?"
21:14:44 <Sam-I-Am> glance doesnt work redundant without a redundant backend, so we need something there.
21:14:58 <Shamail> HA for Keystone will be different for HA for HEAT, etc
21:15:08 <Shamail> from* not for
21:15:32 <nickchase> I'm for limiting scope as much as possible for first go-round.
21:15:33 <megm_> Ooh, I should fix that.  I think we've added a separate section about "Storage backends" that will cover the swift/ceph/etc issues
21:15:59 <Sam-I-Am> seems to be that swift is more 'in-tree' than ceph, so it would be used first
21:16:11 <mattgriffin> Sam-I-Am, +1
21:16:20 <megm_> So we handle control plane for data and data plane separately -- this should be cleaner.
21:16:51 <Shamail> megm_: +1
21:17:46 <Sam-I-Am> people still tend to think if it on a service basis
21:17:48 <megm_> But Ceph really is an HA storage backend with redundant storage and all that...  And it handles image, object, and ephemeral storage.
21:18:04 <Shamail> as do many options....
21:18:32 <Shamail> this is why decoupling project/service level HA guidelines from the impact infrastructure decisions have is necessary
21:18:35 <nickchase> Until Ceph is an "official" OpenStack project Swift needs to take precedence.
21:18:52 <Sam-I-Am> or $openstackproject
21:19:05 <nickchase> Not that we shouldn't cover it ever, but Swift needs to come first, for better or worse.
21:19:11 <mattgriffin> +1. that should be our go-to answer when this comes up... b/c it will again
21:19:21 <nickchase> Indeed it will.
21:19:46 <Shamail> Agreed, I could make a counter-point about how Manila supports NFS via Cinder and LVM.
21:19:54 <Shamail> but +1 on swift
21:19:59 <megm_> We need good, detailed info about making the control planes highly-available, then a separate discussion about making sure that I DON'T LOSE MY DATA.
21:20:09 <Sam-I-Am> so, in order of priority, i think the infra stuff is most important (because everything relies on it), followed by keystone, followed by everything else.
21:20:33 <Shamail> I missed the beginning, what is infra stuff?  data plane?
21:20:43 <megm_> And that will be more high-level and conceptual with links elsewhere for configuration details.  We also need to mention stuff like Netapps, remote backup with NFS, EMC, et cetera
21:20:51 <Sam-I-Am> and some of the "everything else" might have a line like "requires swift, you might want to HA it first"
21:21:10 <Sam-I-Am> Shamail: sql db, rabbit, memcache, and host-level things
21:21:18 <Shamail> got it Sam-I-Am, +1
21:21:42 <Sam-I-Am> then keystone, because everything uses it
21:21:48 <Shamail> yep
21:22:24 <Sam-I-Am> if we decide glance relies on swift for ha, we should build out the swift ha content first.
21:22:25 <megm_> And HAProxy or an appropriate switch seems part of infra
21:22:33 <Sam-I-Am> yeah, haproxy is infra too
21:22:41 <Sam-I-Am> since you'll be adding things to it as you add services
21:22:57 <Sam-I-Am> $loadbal
21:23:10 <Shamail> This is a useful graphic from a blog post for this convo: http://www.joinfu.com/wp-content/uploads/2014/09/OpenStack-Non-library-Project-Dependency-Graph.png
21:23:10 <megm_> So people need to really pick apart the "Basic Environment" and "Basic HA facilities" sections in the TOC
21:23:29 <Shamail> We could prioritize based on hard dependencies
21:23:44 <Sam-I-Am> Shamail: something like that
21:24:11 <megm_> We have some info about Pacemaker/Corosync but someone (bogdan?) said we need to also include LSB/upstart/systemd alternative
21:24:17 <mattgriffin> based on this discussion, sounds like the ToC needs a little more polish (reordering, focus on swift, etc.)
21:25:14 <Sam-I-Am> perhaps more like order of priority of work, not necessarily order of presentation
21:25:16 <megm_> We do not have any existing information about that and it's probably important to get that in sooner rather than later -- it may trickle down into the rest of the doc...
21:25:49 <mattgriffin> nickchase, ^ can you bring that up when you chat with Bogdan?
21:26:06 <megm_> I think priority of work is: 1) set up files 2) convert existing material 3) update info about infra components
21:26:36 <nickchase> mattgriffin yes I will
21:26:41 <megm_> Other pieces can be worked in parallel, because updating existing material also needs to be a priority
21:26:54 <mattgriffin> megm_, that sounds like a good process
21:27:05 <megm_> We don't want to go forward with erroneous info; missing info is more tolerable, albeit noxious ;-)
21:27:19 <Sam-I-Am> also remove defunct material so people dont wor kon it
21:28:24 <megm_> But all that can be done in parallel, and we need the basic infra structure stuff in place before we can thoroughly develop/test any of the other pieces, including Swift
21:29:08 <Shamail> Did we decide on A/A and A/P?  Per section or a section on its own?
21:29:22 <Shamail> I don't even know how it could be own its own.
21:29:26 <mattgriffin> per section i believe
21:29:29 <Sam-I-Am> active active whenever possible
21:29:40 <mattgriffin> Sam-I-Am, +1
21:29:44 <Shamail> Sounds good, so we want to be opinionated.
21:29:45 <Shamail> +1
21:30:13 <Sam-I-Am> when isnt openstack opinionated? heh
21:30:17 <mattgriffin> so next steps...
21:30:18 <Shamail> :)
21:30:22 <megm_> Shamail, we want to be avuncular and offer good advice whenever possible ;-)
21:30:31 <Sam-I-Am> basically a "well tested, well documented happy patch"
21:30:38 <Sam-I-Am> path
21:30:50 <Sam-I-Am> and of course over time things will change
21:30:57 <mattgriffin> while nickchase is talking to Bogdan, perhaps we should take one more look at the ToC content
21:31:33 <mattgriffin> nickchase, was also going to look into converting the content, yes?
21:31:54 <nickchase> I'm making the framework right now
21:31:54 <Shamail> mattgriffin: +1 but lets close this topic soon to start making progess.  Files could be created in parallel.  I think the priorities outlined by megm_ look good.
21:32:01 <megm_> What is the nick-bogdan conversation?  If Bogdan is going to look at the TOC in detail, that should be pretty reliable
21:32:09 <nickchase> (And I do literally mean right now.)
21:32:18 <nickchase> Yes, he's going to look at it in detail.
21:32:59 <megm_> If Nick gets the basics set up and converts the text, I can work on the clean-up of both RST code and prose -- assuming I can get past my gerrit woes, which is a sine qua non
21:33:14 <mattgriffin> so if Bogdan's review is positive, i don't see any reason why we can't start with megm_ 's proposed 1, 2, 3 steps next week
21:33:40 <nickchase> agreed.
21:33:48 <Shamail> mattgriffin: +1
21:33:55 <megm_> So we're actually going to write this thing?  And not just talk about it more?  ;-)
21:33:59 <mattgriffin> :)
21:34:08 <megm_> I'm so excited!
21:34:53 <mattgriffin> how do you want to handle responsibilities for the different sections?
21:35:17 <mattgriffin> just thinking about how to efficiently proceed through it and use all of the resources at our disposal (and identify gaps)
21:35:19 <Sam-I-Am> firs tthing is prioritizing them
21:36:28 <mattgriffin> Sam-I-Am, can we do that now based on the section numbers in https://wiki.openstack.org/wiki/HAGuideImprovements/TOC ?
21:36:28 <Sam-I-Am> so i'd say adding priority tags to the roc
21:36:32 <Sam-I-Am> toc
21:36:40 <mattgriffin> ack
21:37:11 <Shamail> prioritizing should be a good next step
21:37:13 <Sam-I-Am> mattgriffin: its pretty close, but i bet swift comes before glance
21:37:15 <megm_> Priority for verifying (or fixing) accuracy of old material is high for everything
21:37:36 <megm_> Priority for developing new material can be established...
21:37:58 <mattgriffin> perhaps adding a P1, P2, P3 next to each section title? just to keep it simple
21:38:15 <Sam-I-Am> sure
21:38:18 <mattgriffin> probably a few P1s and mostly P2s
21:38:41 <Sam-I-Am> P1 would be infra stuff
21:38:42 <megm_> What about testing the procedures as we get them written?  How do we handle that?  Does anyone have adequate hardware?
21:38:44 <mattgriffin> #action nickchase work on converting docs
21:38:56 <mattgriffin> #action nickchase review ToC with Bogdan
21:39:26 <mattgriffin> #action add priorities (P1, P2, P3, etc) next to each section title in the ToC
21:39:46 <megm_> Who adds priorities?
21:40:26 <mattgriffin> Sam-I-Am, can you own that? ^
21:40:55 <mattgriffin> at least to get us moving forward (they might change)
21:40:56 <Sam-I-Am> yeah, i can tag them for the most part
21:40:59 <mattgriffin> thanks
21:41:11 <Sam-I-Am> but i really cant do much more until kilo
21:41:17 <Sam-I-Am> i have too much on my plate
21:41:21 <mattgriffin> Sam-I-Am, ack
21:41:32 <Sam-I-Am> as it seems i'm the only guy updating the install guide for kilo :/
21:41:39 <nickchase> We can tag them wen we go through it with Biogdan as well.
21:41:43 <megm_> Nick, be sure that Bogdan looks at the "Other" section at the end -- some of those items are P1, others are P2 and P3
21:41:47 <Shamail> Sam-I-Am: ouch
21:41:55 <mattgriffin> nickchase, great
21:42:13 <Shamail> thanks nickchase
21:42:28 <Shamail> can we make that an agenda item for next week? review tags as a group
21:42:32 <megm_> And some are out of order -- basically, that "Other" section should go away and the items in it be put in appropriate locations
21:42:40 <mattgriffin> Shamail, yes. good idea
21:42:43 <Sam-I-Am> i wont be here next week... traveling
21:42:55 <Shamail> Sam-I-Am: good to know
21:43:02 <nickchase> megm will do
21:43:57 <mattgriffin> any other action items?
21:44:02 <Sam-I-Am> so, i take it my job is doing base prio on the toc
21:44:11 <mattgriffin> Sam-I-Am, aye
21:44:16 <Shamail> yessir
21:44:19 <mattgriffin> please
21:44:47 <nickchase> sam-i-am I will also ask Bogdan
21:44:51 <nickchase> so you won't beon yoru own there
21:45:11 <Sam-I-Am> ok
21:45:12 <mattgriffin> nickchase, can you email around after you do the conversion with info on how to access? i'm a newbie in this area and would like to play a bit to get up to speed
21:45:33 <megm_> Also everyone think about which pieces they want to own...  I can help with writing/coding of anything
21:45:34 <Shamail> same here plz
21:45:46 <mattgriffin> megm_, will do
21:46:07 <nickchase> absolutely
21:46:13 <mattgriffin> any other items to discuss for today?
21:46:19 <nickchase> I finished the framework but need to get it into gerrit
21:46:24 <mattgriffin> :)
21:46:34 <megm_> It would be good if everyone did conversion "clean-up" on one section just to get a feel for what is there...
21:47:33 <nickchase> definitely
21:47:46 <nickchase> I would be more than happy to leave the actual conversion to other people. :)
21:47:46 <Shamail> megm_:  I can try one but might need help
21:47:50 <megm_> I have nothing more for today...
21:47:57 <nickchase> me neither
21:48:03 <mattgrif_> bah... starbucks wifi
21:48:08 <Shamail> lol
21:48:09 <megm_> We can all help each other, right?
21:48:12 <Shamail> nothing more here either
21:48:28 <mattgrif_> cool. thanks everyone. going to end the meeting. notes will be available at https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Past_Meetings soon
21:48:35 <mattgrif_> #endmeeting
21:48:35 <nickchase> thanks
21:48:36 <nickchase> later!
21:48:43 <Sam-I-Am> excellent
21:48:49 <Shamail> Do we want to have some time to meet in person at the summit?
21:48:50 <Sam-I-Am> see y'all in the future
21:48:51 <megm_> Have a great week everyone!
21:48:53 <mattgriffin> #endmeeting