20:13:20 <mattgriffin> #startmeeting ha-guide
20:13:20 <openstack> Meeting started Thu May  7 20:13:20 2015 UTC and is due to finish in 60 minutes.  The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:13:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:13:23 <openstack> The meeting name has been set to 'ha_guide'
20:17:23 <megm_> Hello?
20:19:02 <mattgriffin> megm_, hi. ok. ready
20:19:38 <mattgriffin> megm_, ok. first review the TOC and most recent changes?
20:20:03 <mattgriffin> #link https://wiki.openstack.org/wiki/HAGuideImprovements/TOC
20:20:42 <megm_> I'm concerned about including all the controller details in the intro.
20:21:18 <megm_> Also, the info about stateless/stateful, etc is now an xref to the old ha-guide that this document is replacing
20:21:48 <megm_> And a link to Mirantis Fuel doc for the HA Controller role description
20:23:33 <mattgriffin> megm_, gotcha. i think the TOC seems to be turning somewhat into the actual HA Guide document
20:24:09 <megm_> Yes, and some great additions.  But we need an agreed-on structure to set up the files
20:25:50 <mattgriffin> megm_, is your concern about the controller details found in this section? https://wiki.openstack.org/wiki/HAGuideImprovements/TOC#Redundancy_and_failover
20:25:55 <megm_> I'm thinking that we should move everything from "Controller node" to the "Stateless/stateful..." section to a separate "HA Controller Node Intro"
20:26:52 <megm_> Yes.  And, do we have the intro to the HA controller before the "Basic Environment" and "Basic HA facilites" sections?
20:28:05 <mattgriffin> no. i think the HA Controller content should be after the Basic Environment and Basic HA Facilities sections
20:28:29 <megm_> I've been concerned about the details of Basic HA facilities.  Perhaps that section should be "Making the Controller Highly Available"?
20:28:37 <mattgriffin> seems better to cover the basics first and then drill into the components
20:29:18 <megm_> Is  Evkonst here?
20:30:24 <megm_> matt, yes, basics first, but are the basics to install the O/S on each node, etc, or to understand what the HA Controller is, etc?
20:31:13 <megm_> And we are constrained by our agreement to follow the structure of the Install Guide as much as possible...
20:33:35 <mattgriffin> megm_, they start with Basic Environment
20:33:53 <mattgriffin> unless that's changing
20:35:20 <mattgriffin> megm_, if anything, the controller node info should be part of the Basic Environment section (like they do in the Install Guide)
20:35:28 <megm_> I'm just looking at what now shows as "HA Intro and Concepts" -- we have "Redundancy and failover" and then we go through all the Controller services, Hardware, Routing,  etc before we get to the active/active vs active passive and quorum info
20:36:27 <megm_> Yes, it may be that what we currently call "Basic Environment" should be "HA Controller"
20:36:51 <mattgriffin> megm_, i think the information listed at https://wiki.openstack.org/wiki/HAGuideImprovements/TOC#HA_Intro_and_Concepts is more of definitions rather than specifics on setting, yes?
20:36:55 <megm_> Rather, "Basic HA facilities" -- or maybe the two "Basic" sections are combined
20:37:42 <megm_> Do those definitions belong in the intro, before the intro to HA concepts?  That is my question.  The material is great but I think it does not belong in the Intro
20:37:43 <mattgriffin> we could combine them
20:38:23 <megm_> I was hoping that Evkonst would be here to explain his/her vision
20:39:23 <mattgriffin> megm_, gotcha.... how about we leave an "HA Intro" section and have a uber-Basic section that includes the Basic content of today (in the 2 sections) as well as the definitions to pair with any, for example, diagrams that might be in the Basic section?
20:39:39 <megm_> Soounds reasonable.
20:40:12 <megm_> What really matters right now is that we know what the main chapters are so we can set up the files -- a main file and a subdirectory of files for subsections for each
20:40:20 <mattgriffin> megm_, ok. i'll reorg the TOC and keep the great content that's already there
20:40:25 <mattgriffin> megm_, ack
20:40:34 <megm_> Cool if you want to do it.
20:41:10 <megm_> Is anyone here other than Matt and me?
20:41:35 <megm_> I'm happy to do the work -- just wanted the discussion.
20:41:42 <mattgriffin> #action mattgriffin reorg the TOC with an "HA Intro" section and a "Basic" section which includes the Basic content of today (in the 2 sections) as well as the definitions
20:41:52 <mattgriffin> megm_, np
20:42:26 <megm_> Do you want me to rework the TOC or do you want to?  I'm willing but you are welcome to it
20:42:50 <mattgriffin> megm_, can i take a first pass and then ping you?
20:43:03 <megm_> Absolutely!
20:43:05 <mattgriffin> cool
20:43:32 <mattgriffin> i've got another meeting in 15 min so move on to other agenda topics?
20:43:37 <mattgriffin> megm_, ^
20:43:50 <megm_> Yes, move on.
20:43:57 <megm_> How much can we do without the others?
20:44:31 <mattgriffin> megm_, let's jump to the last 2 items on the agenda
20:44:52 <mattgriffin> xrefs to Install Guide ... you brought this concern up
20:45:20 <mattgriffin> is this something that we should prototype an approach and confirm how we're thinking this will work?
20:45:26 <megm_> I was hoping that Nick knew what to do ;-)
20:45:38 <mattgriffin> megm_, ok. making that an action item
20:46:17 <megm_> I don't think we have a choice -- the right way is to use the intersphinx facilities but those are not set up so we're going to have to use html links between the two guides
20:46:20 <mattgriffin> #action nickchase: are there potential pitfalls with using xrefs to link to the Install Guide? should we build a prototype?
20:46:36 <mattgriffin> ok
20:47:07 <mattgriffin> hmm... maybe someone will have a bright idea on that topic in Vancouver b/c it sounds like a big need
20:47:08 <megm_> Just FYI, if you are writing something today, what is the URL for a new chapter in the Install Guide?
20:47:25 <megm_> That is the initial problem...
20:48:09 <megm_> For the last item, "Next steps" are to convert docbook->rst, set up new chapter files/subdirectories, and put existing content in the right place.  Nick had said he would do that.
20:48:44 <megm_> Only question is do we commit to a merge of the old info into the new structure with NO fixes?
20:48:50 <mattgriffin> #action convert docbook->rst, set up new chapter files/subdirectories, and put existing content in the right place. ... nick?
20:49:14 <Shamail> hi.
20:49:32 <megm_> Hi, Shamail!
20:49:33 <mattgriffin> megm_, not sure. maybe better to start from scratch?
20:49:36 <mattgriffin> hi Shamail
20:50:33 <megm_> Matt, I have no objections to starting from scratch, but all along, everyone has been adamant about the primacy of preserving the old material.  Is this a change in strategy?
20:52:03 <mattgriffin> megm_, well we'd keep as much of the old material as was relevant. were there objections to copy/paste text to do that?
20:52:12 <mattgriffin> well copy/paste/edit
20:52:49 <megm_> I'm pretty open as to which strategy we take, but I think we need to agree on one
20:53:09 <mattgriffin> megm_, i'll check with the PTL and core reviewers for direction
20:53:44 <megm_> See Step 2 in https://etherpad.openstack.org/p/openstack-haguide-update-next-steps -- that should be modified if we're changing strategy
20:54:19 * mattgriffin clicks
20:56:05 <megm_> I hate six-way merges ;-)
20:56:06 <mattgriffin> megm_, sounds like copy/paste/edit to me
20:56:09 <mattgriffin> haha
20:56:37 <mattgriffin> megm_, but i'll check to confirm
20:56:42 <megm_> Nick, are you here?  Hooray!
20:56:55 <nickchase> wow, what a reception. :)
20:56:57 <nickchase> hey there.
20:57:01 <nickchase> am I late?
20:57:06 <mattgriffin> welcome nickchase
20:57:06 <nickchase> I thought it was starting in 5 minutes?
20:57:15 <mattgriffin> yes. started 55 min ago :)
20:57:22 <nickchase> (facepalm)
20:57:23 <mattgriffin> did the time change again?
20:57:25 <megm_> We've been playing What Would Nick Do?  Please tell us!  ;-)
20:57:30 <nickchase> hahahahaha
20:57:34 <nickchase> OK, so I can tell you:
20:57:41 <nickchase> So here's my update:
20:57:56 <nickchase> 1)  The spec's in and approved, finally, thank you very much Meg for helping there!
20:58:09 <nickchase> 2)  We have a bunch of content that's been added to the wiki, as you may have seen
20:58:29 <nickchase> it needs to be edited, smoothed out, etc. and co-credited to its original authors, but at least we have something to start with.
20:58:30 <Shamail> Lol megm_
20:58:58 <nickchase> So that's my update.
20:59:11 <megm_> And what happens next?
20:59:15 <nickchase> there's more content coming but that was what we could get done by today.
20:59:48 <megm_> I really think we need to get content under git/gerrit and out of the etherpad -- it's starting to get ugly there!  ;-)
20:59:51 <mattgriffin> nickchase: megm_ and i had some concerns about where the new content was slotting into the TOC...
21:00:12 <mattgriffin> we need to talk about that... but i need to run to a meeting now
21:00:20 <mattgriffin> megm_, +1
21:00:28 <nickchase> hey, you guys go for it; my job was to rally people. :)
21:00:30 <nickchase> have run
21:00:33 <nickchase> fun*
21:00:35 <nickchase> sorry I was late
21:00:35 <mattgriffin> :)
21:00:38 <mattgriffin> nickchase, np
21:00:38 <megm_> Matt, should Nick, Shamail, and I continue the meeting?
21:01:05 <mattgriffin> megm_, you can... i'll leave the window open and end it when you're done for the log... just ping me
21:01:14 <Shamail> I have to leave soon too
21:01:22 <megm_> Nick and Shamail, does that work for you?
21:01:36 <Shamail> +1 on moving to git
21:01:44 <nickchase> +1 also
21:01:50 <nickchase> I do not have time to do it, though
21:02:03 <nickchase> not the next 3 weeks, anyway
21:02:21 <megm_> Nick, are you going to set up files?  I'm willing to do some work but I need a little guidance
21:03:09 <nickchase> the setup is done
21:03:13 <nickchase> Andreas did it
21:03:21 <megm_> We don't have chapter files and subdirectories
21:03:28 <nickchase> there are no subdirectories.
21:03:31 <Shamail> Awesome, can you please link?
21:03:36 <nickchase> I'm happy to give guidance
21:03:51 <nickchase> it's in the ha-guide repo, probably under "source"
21:04:00 <megm_> Are we converting the RST files and locating them in the new files?  I thought that was the plan but Matt now seems to think otherwise
21:04:00 <nickchase> I haven't seen it myself; I'm taking Andreas' word for it :)
21:04:11 <Shamail> Okay.  I'll look in the existing area.
21:04:18 <nickchase> No, what we're doing is...
21:04:31 <nickchase> putting in the new content, then filling in the TOC where there's old content that fits.
21:04:47 <nickchase> That was how we "sold" that we needed to do this in RST rather than Docbook.
21:06:03 <megm_> So do we know what the main  chapters are?   I made a list a long time ago but it may need to be revised...
21:06:11 <nickchase> they're in the TOC.
21:07:17 * nickchase just updated his calendar. (facepalm)
21:07:37 <megm_> High Availability Concepts
21:07:37 <megm_> Hardware Setup
21:07:37 <megm_> Install O/S on Nodes
21:07:37 <megm_> Basic Infrastructure
21:07:37 <megm_> Configure Networking on Each Node
21:07:38 <megm_> Install and Configure MySQL
21:07:38 <nickchase> the RST files are not hierarchical like the docbook ones are
21:07:40 <megm_> RabitMQ Message Broker
21:07:41 <nickchase> they're topic-based.
21:07:42 <megm_> Keystone Identity Services
21:07:44 <megm_> Glance image service
21:07:47 <megm_> Cinder Block Storage Service
21:07:48 <nickchase> loosk right
21:07:49 <megm_> Swift Object Storage
21:07:51 <megm_> Storage Backend Options
21:07:53 <megm_> Nova Compute Service
21:07:55 <megm_> Heat Orchestration
21:07:58 <megm_> Ceilometer Telemetry and MongoDB
21:08:00 <megm_> Database Service (Trove)
21:08:02 <megm_> Sahara
21:08:04 <megm_> Other
21:08:06 <megm_> ~
21:08:16 <Shamail> Looks good
21:08:27 <nickchase> +1
21:08:37 <megm_> Should the sections for Controller node services be combined into a single "HA Controller" section with subsections?
21:08:40 <nickchase> if you look in the wiki, there's a bunch of content in there
21:09:07 <nickchase> I don't understand the question
21:10:07 <megm_> The list of "chapters" I submitted...  Do we want to group the Controller stuff or leave each individual?
21:10:10 <Shamail> That might make sense... Effectively can we make a "HA controller" section, document common items for general controller HA, and then have sub-sections for service specific requirements (keystone, cinder, etc.)
21:11:18 <Shamail> I'm sure there will be common things that apply to controller nodes in general.  This might prevent repeating or extensive referencing.
21:11:22 <megm_> Yes, Shamail.  So maybe we have "HA Controller," "HA Storage", "HA Compute"
21:11:36 <nickchase> I think taht you should leave it where it is
21:12:00 <nickchase> because we hashed out this TOC pretty thoroughly, didn't we?  Or did I miss something?
21:12:40 <nickchase> I mean, it's designed to track the install guide.
21:12:49 <megm_> I thought we had but Evknost made massive changes -- added a whole bunch of stuff to Intro that I think may belong in an "Introl toController"'  section
21:12:50 <nickchase> So I'm assuming that the TOC follows that.
21:12:52 <Shamail> We did.  I thought we validated the topics not necessarily the organization of it.  If that was a part of the review too then I agree that we should leave it.
21:12:57 <nickchase> ahhhhhh.
21:13:06 <nickchase> OK, now THAT makes sense;
21:13:16 <nickchase> Intro to controller seems a perfectly reasonable thing
21:13:26 <Shamail> :-)
21:13:27 <nickchase> I thought you were talking about within the body
21:13:34 <megm_> I'm not sure of anything!  Maybe we just need to grab SOME structure and create files!  We can always move stuff later
21:13:49 <nickchase> :)
21:13:55 <nickchase> OK, so here's what I think:
21:13:56 <Shamail> We have consensus! (Can we have consensus on the fact that we actually have it?)
21:14:19 <nickchase> If we're saying take what's there and chuck it in, and combine the intro to controller stuff into one section, then yes.
21:14:37 <megm_> Do we add "Intro to Controller", "Intro to Storage", etc as part of (or right after) the Intro to HA concepts and before they start installation?
21:14:47 <nickchase> +1
21:14:53 <Shamail> megm_: +1
21:14:59 <nickchase> after
21:15:07 <nickchase> no, part of
21:15:08 <nickchase> sorry
21:15:09 <nickchase> part of
21:15:13 <megm_> Or do we do basic installation, then "Intro to Controller" then "How to HA the Controller services" sections....?
21:15:36 <megm_> nick, part of intro?
21:15:52 <nickchase> I mean the following:
21:16:09 <nickchase> 1)  Intro to controller, intro to storage, etc. should be part of Intro to HA.
21:16:33 <megm_> nickchase, I can +1 that
21:16:34 <nickchase> 2)  After the intro, we track the normal install, pointing out the places where things are different for an HA install.
21:16:44 <nickchase> that's what I mean.
21:17:06 <megm_> Nick, what do you mean that RST files are not hierarchical?  Do you mean just one big file for each chapter without subdirectories?
21:17:43 <Shamail> That's perfect.  +1
21:18:10 <nickchase> I mean that we're not doing subdirectories
21:18:24 <nickchase> all the chapters and sections and subsections are in one big source directory
21:18:37 <nickchase> and they're not named like the docbook.  for example...
21:18:45 <megm_> Really?  Aren't we going to trip over each other a lot with so many people contributing?
21:19:25 <nickchase> in docbook, we'd have section_intro_ha.xml and section_intro_ha_compute.xml.  In RST we have only intro_ha.rst and intro_compute.rst
21:19:46 <nickchase> I prefer hierarchical too, but I'm overruled on this.
21:19:52 <nickchase> we have to let git do its thing here.
21:20:06 <megm_> Ah, it is written from a higher source, you're saying?
21:20:14 <nickchase> indeed.
21:21:01 <megm_> Cool, then we're set.  It does make set-up easier ;-)
21:21:22 <Shamail> I have to drop off.  Sorry.  Have a great weekend!  Are we meeting next week or Vancouver is the next one?
21:21:33 <nickchase> I can't meet in vancouver
21:21:41 <nickchase> next week, I assume
21:21:45 <megm_> Would you have an hour or so early next week to give me some guidance and then I could set up files?  Unless Shamail can do it without guidance, of course
21:22:04 <nickchase> if you need me that's fine; check my calendar.
21:22:22 <Shamail> I can't either... So the 1st option is best.
21:22:45 <megm_> It would be good to have the files set up before Vancouver --and before we get more content in ehterpad!
21:22:54 <Shamail> Alright, see you next week then.  Take care Nick chase and megm_
21:23:02 <megm_> Bye
21:23:18 <megm_> Nick, is the Network Guide set up correctly?  Can I study that for some clues?
21:23:32 <megm_> Like for file names and such?
21:26:42 <nickchase> yes
21:26:45 <nickchase> do that
21:29:32 <megm_> I added list of chapters to https://etherpad.openstack.org/p/openstack-haguide-update-next-steps
21:33:09 <nickchase> ok, great.
21:33:18 <nickchase> is there anything els eyou need from me?
21:36:10 <megm_> No, let's call it done for today.  I'll do some studying and ping you for some guidance...
21:36:23 <megm_> I'll ping matt to close the minutes.
21:36:57 <mattgriffin> #endmeeting