20:05:21 <mattgriffin> #startmeeting HA-Guide
20:05:22 <openstack> Meeting started Thu Jun 11 20:05:21 2015 UTC and is due to finish in 60 minutes.  The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:05:25 <openstack> The meeting name has been set to 'ha_guide'
20:05:40 <mattgriffin> #link https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
20:05:44 <megm> I saw the agenda...
20:05:55 <mattgriffin> anyone else here for the HA Guide meeting other than megm and nickchase ?
20:06:16 <mattgriffin> megm, cool. yeah 3 items
20:06:25 <mattgriffin> first ...
20:06:32 <megm> And three people ;-)
20:06:41 <nickchase> I apologize for falling off the face of the earth during the pre=summit/summit/post-summit period. :)
20:07:02 <mattgriffin> ah! i need to reach out to those great people that came to the room during the Summit... doh!
20:07:44 <megm> And a couple other names that have popped up of late as well...
20:07:45 <mattgriffin> #action mattgriffin contact the contributors that came to the room in Vancouver to contribute
20:08:32 <mattgriffin> megm, re: those that popped up, can you DM or email me their names/emails?
20:08:52 <megm> Yes, I'll email them after we're done here.
20:08:56 <mattgriffin> thanks
20:09:04 <mattgriffin> ok... agenda :)
20:09:17 <mattgriffin> first, i wanted to take a stab at a timeline...
20:09:30 <megm> Nice timeline...  How do we get some names assigned to some doc topics/pieces?
20:09:40 <mattgriffin> and I wanted to try out a product management application :) ...
20:09:57 <mattgriffin> i think i can add names to tasks/milestones ... i'll look into it...
20:09:57 <megm> Ah, preparing for the new job, eh?  ;-)
20:10:02 <mattgriffin> here's the link
20:10:03 <mattgriffin> yes
20:10:09 <mattgriffin> #link https://mattgriffin.aha.io/published/d04139fdb37ba3edd4fa88dd0d22728a?page=2
20:10:45 <nickchase> congratulations, mattgriffin
20:10:53 <mattgriffin> it's very high level but just to set expectations with those outside the team regarding what we're delivering and when ... as well as to keep us moving to a goal
20:11:01 <mattgriffin> nickchase, thanks :)
20:11:38 <nickchase> ok, so as far as what I can do, I'm guessing my job is to try and corral the SMEs for reviews, yes?
20:11:48 <nickchase> and do we need more content from them?
20:11:53 <mattgriffin> there are essentially 3 releases: 1. RST migration; 2. New HA Guide reviews and updates; and 3. HA Guide translation
20:12:06 <megm> It seems like we should have more time between completing the RST migration and the New HA Guide... block
20:12:21 <mattgriffin> megm, #2?
20:12:23 <megm> And I think I can complete the RST migration before July 11
20:12:48 <mattgriffin> megm, yeah. i was being conservative. what's realistic?
20:12:57 <megm> Ah, so is #1 more than just what I'm doing?
20:13:26 <mattgriffin> #1 is just migrating the existing guide to RST and the new ToC
20:13:38 <megm> Conservative for the piece that is resourced and in process; extremely aggressive for the real work that doesn't seem to be well-resourced at this point ;-)
20:13:49 <megm> Here is what is done and merged:  http://docs.openstack.org/draft/ha-guide/
20:14:15 <mattgriffin> megm, ack... #2 is the time where the content will be verified, updated, and gaps will be filled in
20:14:19 <megm> I would REALLY like to see a little bit of work done on this before it is published -- it's pretty rough...
20:14:50 <megm> Nick, what sort of Mirantis resources are available?
20:15:30 <megm> Matt, are your percona resources still on-board?
20:15:34 <nickchase> well, the release is almost out the cdoor so we should be able to get the team back totgether
20:15:56 <mattgriffin> megm, need to verify
20:16:41 <megm> People could start working now, actually.  But let's say that I finish the RST conversion -- how do we proceed?
20:16:59 <nickchase> we have two ways to proceed, in my view:
20:17:09 <mattgriffin> megm, re: getting more work before it is published... we can start #2 earlier (before the completion of #1) as sections mature content-wise
20:17:11 <megm> We do have someone from the RabbitMQ team waiting for me to finish that conversion (today) and they will take that over
20:17:14 <nickchase> 1)  convert everything that's there, then start a mini-project to review what's there and kill what's wrong.
20:17:33 <nickchase> 2)  hold the conversion and start a mini-project to note  what's wrong before converting.
20:17:41 <nickchase> megm, you're doing the converting so it impacts you the most.
20:17:58 <megm> I'm thinking we need a little table with "topics" and content owners.
20:18:09 <mattgriffin> +1
20:18:11 <mattgriffin> megm,
20:18:33 <mattgriffin> i can start a spreadsheet on that. ok?
20:18:39 <megm> Matt, does your little project management tool allow that or should we do something more basic
20:19:10 <mattgriffin> yeah. i suppose i could use the tool for that
20:19:11 <mattgriffin> i'll try it out
20:19:27 <megm> mattgriffin, the method of tracking this is up to you -- I'm neutral...
20:20:04 <mattgriffin> nickchase, re: the choices, i'm +1 for #1. my fear is that we will nitpick content updates (which are constantly moving throughout the cycle) and delay the actual RST migration
20:20:58 <mattgriffin> i think we need to migrate first and get people reviewing the content there so RST becomes the right way to update content ... might be a bit rocky this cycle but hopefully we can retire the docbook version in the fall
20:21:32 <megm> I think the RST conversion is going fairly well.  The delay is in getting +1's so stuff gets merged...
20:22:01 <mattgriffin> we know that a big problem is essentially the structure of the entire guide. investing in rebuilding in docbook would be a waste in my opinion
20:22:03 <megm> A few things have gotten merged just arbitrarily -- I have no idea what is causing that but I don't really care.
20:22:11 <megm> The doc core team are very responsive, however.
20:22:40 <mattgriffin> that brings me to my other 2 agenda items...
20:22:51 <megm> I had at one point hoped that some people would do some substantive reviews on the conversion CRs so they weren't quite so crufty when they were merged.
20:22:56 <megm> But this works, too ;-)
20:23:03 <mattgriffin> in my opinion, megm really needs reviews :)
20:23:13 <mattgriffin> and i know that i need to get on that
20:23:19 <megm> mattgriffin, +1
20:23:23 <mattgriffin> :)
20:23:39 <nickchase> I'll help out too. :)
20:23:45 <mattgriffin> excellent
20:23:45 <nickchase> (sorry for missing this week, megm)
20:24:18 <megm> Alternately, we can just tell the doc core people to go ahead and merge everything that is building -- now that junk has been merged, no sense stressing over the rest of it, right?
20:24:19 <mattgriffin> if megm has all links to CRs in https://etherpad.openstack.org/p/openstack-haguide-update-next-steps then i think it's best to go from the top down
20:24:53 <mattgriffin> #action mattgriffin and nickchase will do reviews of megm's CRs
20:24:59 <megm> I think a couple of the CRs there have been merged -- I'll go back and update that after I submit the RabbitMQ CR.
20:25:16 <megm> But I think all the CRs I've done are there -- and looking at the list gives some idea of progress.
20:25:26 <megm> Although I think some of the topics do not have old content.
20:26:57 <mattgriffin> megm, ok. reviewers just need to keep in mind that the goal of this stage is to fit existing HA Guide content into the best spot in the new RST structure ... the next phase will focus on improving the content itself
20:27:05 <megm> I hope to have all of the "install/configure controller" pieces converted by early next week.
20:27:32 <mattgriffin> megm, cool. how do you want me to update the target completion date for the migration ?
20:27:36 <megm> mattgriffin, that is true.  But the next phase can start now for any content that has been merged
20:28:20 <mattgriffin> megm, yeah... i was just going to ask which sections, in your opinion, are pretty much there so nickchase can get some of his colleagues to start to take a look at the content?
20:28:44 <mattgriffin> when the release is out the door
20:28:45 <megm> https://etherpad.openstack.org/p/openstack-haguide-update-next-steps
20:29:33 <nickchase> So do me a favor:  tell me exactly what IO need to have people looking at right now.
20:29:45 <megm> People can start at the top with concepts and hardware now.
20:30:12 <megm> I need to finish RabbitMQ, Keystone, and Heat (if there is anything)
20:30:43 <nickchase> At which URL?
20:30:52 <mattgriffin> #link https://etherpad.openstack.org/p/openstack-haguide-update-next-steps
20:30:55 <mattgriffin> nickchase, ^
20:31:09 <megm> I'd like to finish the conversion by 6/19 and I think that is possible
20:31:26 <nickchase> great.  thx
20:31:48 <mattgriffin> just made notations in the pad
20:32:56 <megm> Pacemaker/Corosync is really important -- I'll convert that after I finish RabbitMQ and hope that "someone" (Bogdan?) can get to work.
20:33:11 <nickchase> Bogdan, yes.
20:33:26 <nickchase> he's been very helpful/willing
20:34:07 <megm> We also need a technical person to own the flow of the doc through having the Controllers configured.  I have zero confidence that these pieces are in the correct order
20:34:44 <megm> Bogdan is a dream!  He knows a lot, writes beautifully...  If we have a big chunk of Bogdan, we're in good shape.
20:34:47 <mattgriffin> #action Need a technical person to own the flow of the doc through having the Controllers configured
20:35:14 <mattgriffin> i need to run soon... can we recap?
20:35:17 <nickchase> getting a big chunk of Bogdan will be problematic but I'll do what I can
20:35:55 <megm> Any chunk of Bogdan is good!  He can always delegate -- just his perspective.
20:35:59 <mattgriffin> so we need to review megm's CRs...
20:36:07 <megm> Nick, do you have people ready to start working on the Networking pieces?
20:36:11 <mattgriffin> we need to clone Bogdan
20:36:24 <megm> Yes, Meg finish conversion, people review so stuff gets merged.
20:36:43 <megm> mattgriffin, clone bogdan!  +4
20:36:47 <mattgriffin> :)
20:37:05 <nickchase> Networking may actually involve linking over to or including from the networking guide.
20:37:24 <megm> Meg to send Matt names of other contributors; Matt to reach out
20:37:37 <radek_> hi everybody, sorry for being late
20:37:41 <mattgriffin> and megm, as you said, will finish conversion... just add notices to the pad when the content can begin to be reviewed ... and i'll pay closer attention to CRs and do reviews faster to keep the train moving
20:37:53 <mattgriffin> ack megm re: names
20:37:54 <megm> Meg to send Matt list of "work topics"; Matt to populate his tool with this info so we can assign owners and track progress
20:38:03 <mattgriffin> #action Meg to send Matt names of other contributors
20:38:26 <mattgriffin> hi radek_ we were actually just wrapping up ... or i need to run
20:38:41 <megm> Shamail owes me some work on Storage Backend options -- he knows it ;-)
20:38:45 <radek_> ok no problem
20:38:48 <radek_> my bad
20:38:52 <mattgriffin> radek_, would love some help with reviewing CRs here...
20:38:58 <mattgriffin> https://etherpad.openstack.org/p/openstack-haguide-update-next-steps ... from top to bottom
20:39:01 <radek_> sure
20:39:04 <megm> Hi, radek!  I can stay online if you want to chat...
20:39:09 <mattgriffin> thanks!
20:39:18 <radek_> just one question
20:39:20 <megm> Radek has been doing a lot of reviews -- I think his reviews are what have gotten some stuff merged
20:39:26 <mattgriffin> :)
20:39:28 <mattgriffin> radek_, ok
20:39:33 <radek_> so we moving all the XML docs to RST now ?
20:39:54 <megm> All of the ha-guide do you mean or all the docs?
20:40:00 <radek_> HA
20:40:00 <mattgriffin> radek_, yes. focusing on migration to RST and the new table of contents ... not the quality of the content yet though
20:40:14 <mattgriffin> :) yes... just the HA Guide content
20:40:30 <megm> mattgriffin, perhaps it's time for us to close contributions to the XML guide?
20:41:00 <megm> Tell people who want to modify content in the meantime to contact me and I'll see that what they need gets converted fast
20:41:09 <mattgriffin> megm, i thought about that and went back and forth. let's do that when the migration is done
20:41:12 <radek_> so one point on this, when I look on some of the RST new files they tend to have kind of random line length
20:41:30 <megm> radek, I believe that some portions of the XML ha guide are not being converted because they are obsolete --
20:41:39 <radek_> ok
20:41:43 <megm> like active/passive RabbitMQ
20:42:08 <megm> I am marking pieces that aren't converted so that someone can verify -- we may need to maintain some of that info even if we don't advocate using it on the latest releases
20:42:09 <radek_> so in other projects the .rst files tend to have 80 chars long lines
20:42:41 <megm> Radek, do you know about https://etherpad.openstack.org/p/openstack-haguide-update-next-steps
20:42:57 <radek_> in the files I see in gerrit this is completely random
20:43:04 <radek_> not yet :)
20:43:11 <megm> That shows the structure of the new doc and which pieces have CRs for converted info
20:43:26 <radek_> need to do my homework
20:43:50 <mattgriffin> hehe
20:44:01 <mattgriffin> gotta run guys. thanks for joining. great meeting ... need to end the meeting to get the log
20:44:02 <radek_> I am new to this so forgive me
20:44:03 <megm> radek, line length...  The OpenStack style says max 70 characters per line except for URLs and commands, etc
20:44:08 <nickchase> thanks mattgriffin
20:44:14 <radek_> ok
20:44:20 <mattgriffin> #endmeeting