21:01:04 <mattgriffin> #startmeeting HA-Guide-Update
21:01:05 <openstack> Meeting started Thu Mar 5 21:01:04 2015 UTC and is due to finish in 60 minutes. The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:08 <openstack> The meeting name has been set to 'ha_guide_update'
21:01:20 <mattgriffin> hi nickchase
21:01:38 <mattgriffin> #topic last week's meeting
21:01:48 <nickchase> hi all
21:02:06 <mattgriffin> nickchase, can you give an update on last week's meeting?
21:02:15 <mattgriffin> megm, said she was going to be a bit late
21:02:18 <nickchase> sure, if you give me a minute
21:02:25 <nickchase> I can't remember that far back. :)
21:02:29 <mattgriffin> heh
21:02:41 <Sam-I-Am> hi nick
21:03:05 <megm> Hi all
21:03:17 <nickchase> hey, all
21:03:20 <mattgriffin> megm, hello
21:03:23 <nickchase> I sent the minutes to the list
21:03:27 <nickchase> but I'm trying to find them
21:03:34 <mattgriffin> here's what i thought we might cover today
21:03:36 <mattgriffin> #link https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:03:39 <mattgriffin> nickchase, cool
21:03:53 <nickchase> found them:
21:03:54 <nickchase> Short meeting today. TOC is still being reviewed, and Meg is adding links to existing material. We agreed on the following:
21:03:54 <nickchase> We need to add strategy information to the TOC. (nickchase, 21:17:11)
21:03:55 <nickchase> We don't want to duplicate existing docs (ie, for Galera) (nickchase, 21:18:57)
21:03:55 <nickchase> We'll take the discussion of RST vs Docbook to the mailing list. (nickchase, 21:26:02)
21:03:55 <nickchase> Action items:
21:03:55 <nickchase> nickchase
21:03:55 <nickchase> nickchase Add structure for HA strategy.
21:03:56 <nickchase> nickchase Create wiki pages for the install guide and ops guide notes and link them from the main HA guide page.
21:03:56 <nickchase> Sam-I-Am
21:03:57 <nickchase> Sam-I-Am Review the install guide for any references that are relevant to HA.
21:03:57 <nickchase> Shamail
21:03:58 <nickchase> Shamail Review the ops guide for any references that are relevant to HA.
21:03:58 <nickchase> Full minutes: http://eavesdrop.openstack.org/meetings/ha_guide/2015/ha_guide.2015-02-26-21.11.html
21:04:03 <nickchase> whoa,s orry about that!!!
21:04:08 <Sam-I-Am> heh
21:04:14 <mattgriffin> :)
21:04:15 <Sam-I-Am> you need to irc better :)
21:04:41 <nickchase> hey, been out of IRC except for these meetings for about a decade and a half.
21:04:51 <nickchase> glad I remember how to /join :)
21:04:56 <Sam-I-Am> we'll eventually fix that
21:05:05 <mattgriffin> should we consider these action items for the next meeting as well. wondering about progess
21:05:44 <nickchase> I apologize I just realized I completely spaced on my action items.
21:05:46 <mattgriffin> question for Sam-I-Am, nickchase, and megm ^
21:06:04 <mattgriffin> nickchase, np
21:06:05 <nickchase> I'm all for considering them for next meeting (for reasons just stated)
21:06:15 <megm> I'm still not quite done with the outline but most of it is there.
21:06:23 <mattgriffin> megm, what was that link again?
21:06:28 <megm> I think there is enough to start discussing content structure
21:06:47 <megm> https://wiki.openstack.org/wiki/HAGuideImprovements/TOC
21:06:57 <Sam-I-Am> yeah, we're getting closer on structure
21:07:03 <Sam-I-Am> i also reviewed the install guide
21:07:49 <mattgriffin> excellent. this is great stuff
21:08:06 <megm> sam-i-am, are things in the right order in the outline?
21:08:15 <nickchase> So the internal Mirantis team is supposed to be letting us know which topics they're going to tackle first.
21:08:15 <Sam-I-Am> megm: not 100%
21:08:26 <nickchase> I'll bug Evgeniy to see where that is
21:08:28 <Sam-I-Am> sort of need to weed things out first, imho
21:08:40 <megm> we also need to identify when one does what is in the install guide and then does the ha steps, versus replacing the install guide steps
21:08:52 <Sam-I-Am> then it sort of makes sense to start with the most system-wide things, like databases... then keystone, etc.
21:09:04 <mattgriffin> nickchase, cool. i can start to see what database parts Percona can take too
21:09:26 <Sam-I-Am> nothing in the install guide does HA, except one part of swift, but thats only because its required minimum config
21:09:41 <mattgriffin> ack
21:10:01 <Sam-I-Am> it wasnt supposed to handle redundancy because its often "too much" for first-timers
21:10:11 <nickchase> right
21:10:14 <Sam-I-Am> redundancy is the second step though
21:10:17 <megm> Agreed about install guide not covering ha.
21:10:18 <Sam-I-Am> and secueity
21:10:24 <Sam-I-Am> security
21:10:45 <megm> But, for instance, do I do the Keystone install/config that is in the Install Guide, then do the "special" stuff that is in HA Guide.
21:11:05 <mattgriffin> so for next meeting, review this TOC page and ensure it's on the mark?
21:11:10 <megm> Or do we just use the Keystone concepts from the install guide, and handle all config in HA guide
21:11:27 <Sam-I-Am> megm: where possible, we should reference the install guide's basic config.
21:11:43 <Sam-I-Am> there may be some services that require complete reconfiguration to do HA
21:11:57 <megm> I agree -- where do we get the definition of "where possible"?
21:12:18 <megm> Do I go through and modify keystone.conf for install guide, then throw that away when I do HA?
21:12:25 <nickchase> Basically if you can do the install steps and then do special for HA, then we reuse it.
21:12:36 <nickchase> If you do something different from start, then it's not possible.
21:12:37 <megm> It needs definition, probably for each component/topic
21:12:45 <nickchase> agreed.
21:12:52 <Sam-I-Am> in some cases its "roughly duplicate this config, with minor changes for X Y Z"
21:13:12 <megm> I think we agreed on the strategy/component a few weeks ago -- the specifics are what concerns me
21:13:13 <Sam-I-Am> most of the APIs are that way
21:13:39 <megm> Sam, did you do the "Configure networking on each node" piece? Very nice!
21:13:42 <Sam-I-Am> for databases, question is do we want to take a one-node sql database to redundancy, or start from scratch with redundancy?
21:13:48 <megm> Nick, do the networking guide people agree?
21:14:08 <nickchase> agree about thwat?
21:14:12 <nickchase> sorry, not following.
21:14:13 <Sam-I-Am> megm: which "configure networking on each node" ? (which doc)
21:14:36 <mattgriffin> Sam-I-Am, i think start with redundancy - i.e., galera-based
21:14:44 <Sam-I-Am> the question is, do we think most people will start out with the install guide architecture and then add onto it? or will they want to deploy from scratch with redundancy.
21:14:57 <megm> https://wiki.openstack.org/wiki/HAGuideImprovements/TOC -- first header after "Prerequisites"
21:15:23 <mattgriffin> Sam-I-Am, hmm... maybe for the DB we could include a general upgrade procedure from single node to galera
21:15:33 <Sam-I-Am> megm: oh yeah that was me
21:15:58 <Sam-I-Am> megm: that makes sense
21:16:00 <Sam-I-Am> errr mattgriffin
21:16:04 <mattgriffin> :)
21:16:23 <Sam-I-Am> the thing about the install guide is we have a known-good architecture to base off
21:16:34 <megm> sam-i-am, that is an excellent question.
21:16:34 <Sam-I-Am> the install guide was written to make it easy to add more nodes of things
21:16:53 <mattgriffin> Sam-I-Am, i think just add that to the Prerequisites section - general DB upgrade step
21:16:53 <nickchase> I think that ...
21:17:04 <megm> My guess is that people will do a "play" set-up with the Install Guide but, when they are ready to deploy their production system, they will start over
21:17:07 <nickchase> we have an assumption that if someone is doing HA, they are NOT a beginner. I think that...
21:18:01 <nickchase> ti's perfactly acceptable to say, "INstall keystone. (see install guide if you need details)". Now do this."
21:18:01 <nickchase> (darn, my text disappeared :()
21:18:01 <megm> +1 nick... And we can include links to Install Guide (like for Keystone concepts) to help those who aren't experts at some piece or other
21:18:11 <nickchase> (there it is (facepalm))
21:18:30 <Sam-I-Am> yeah.
21:18:34 <Sam-I-Am> agreed.
21:18:34 <mattgriffin> +1
21:18:37 <nickchase> great.
21:18:47 <Sam-I-Am> on the topic of audience, we're not going to handhold basic system things in the HA guide
21:18:51 <Sam-I-Am> like "here's how you edit a file"
21:18:55 <megm> For Keystone example, maybe it should be what you say, but "but modify keystone.conf like this rather than what is in Install GUide"
21:19:20 <nickchase> agreed.
21:19:41 <Sam-I-Am> megm: probably a blanket statement that says "we start with the basic config in the install guide... and then add this stuff. your base keystone config might contain more stuff"
21:19:50 <Sam-I-Am> thats how the network guide is doing it
21:19:53 <nickchase> +1
21:19:56 <mattgriffin> i like it
21:20:03 <Sam-I-Am> "we assume you know about all this other crap you have to configure, here's how to make DVR work"
21:20:23 <megm> Sounds good. I just don't want the HA guide to routinely tell people to undo something they did in Install Guide...
21:20:58 <nickchase> right
21:21:14 <nickchase> we said from the beginning that the first thing we were going to do...
21:21:16 <Sam-I-Am> if there's a case of that, we'll figure it out
21:21:28 <megm> Is the outline in the correct order? How do we determine that?
21:21:39 <nickchase> was tell people, "Look, here's the basic install procedure, and here are the steps that will be different for HA. Now let's get into the details."
21:21:46 <nickchase> megm: we do it.
21:21:53 <Sam-I-Am> megm: let me look over it again here
21:22:28 <nickchase> we'll have an overview to start. and if there isn't one in the TOC, please add one while you're looking, Sam-I-Am
21:22:32 <Sam-I-Am> megm: ntp probably comes right around host networking, but its pretty simple (in fact, people should probably know how to do this)
21:23:00 <megm> sam-i-am, you can always email me directly at meg.mcroberts@yahoo.com
21:23:06 <Sam-I-Am> other than that, it mostly makes sense. start with host stuff, then system services, then openstack services.
21:23:20 <Sam-I-Am> the openstack services should probably go in the order of most-common to least-common
21:23:30 <Sam-I-Am> and also based on dependencies
21:23:44 <Sam-I-Am> like... if you HA keystone, you're going to have to change all these other services.
21:23:50 <megm> +1 sam
21:24:40 <Sam-I-Am> keystone -> glance -> nova -> neutron -> cinder -> swift -> trove -> ??? -> ceilometer
21:24:57 <Sam-I-Am> and i think we do ceilometer last because it requires installing more agents for a bunch of other services
21:25:13 <Sam-I-Am> in other words, ceilometer redundancy itself isnt the hard part
21:25:24 <Sam-I-Am> its as you add more nodes and make other services redundant, you have to deploy more agents
21:25:50 <Sam-I-Am> or for each service that has special ceilometer steps, we could say "do these steps if you run ceilometer"
21:26:43 <megm> The "Prerequisites" list needs to be looked at critically -- should NTP be there?
21:27:13 <mattgriffin> megm, i think it should be there from the install guide
21:28:21 <megm> Yes, NTP is from Install Guide but at what point? It may be required earlier for HA, right?
21:28:31 <mattgriffin> megm, http://docs.openstack.org/havana/install-guide/install/yum/content/basics-ntp.html
21:28:33 <Sam-I-Am> so, with NTP... the only real suggestion would be running servers on each controller node, then configuring each other hosts to use all of the controllers for sync. we can doc it, but its not complex.
21:28:36 <mattgriffin> hmm... maybe
21:28:50 <Sam-I-Am> mattgriffin: aaaaaa dont look at the guide that old :/
21:28:53 <Sam-I-Am> it hurtses me
21:28:57 <mattgriffin> haha... oops
21:29:08 <megm> Instructions are not complex, but order might be wrong in current outline.
21:29:11 <Sam-I-Am> its a system level thing that is good practice for any server
21:29:21 <Sam-I-Am> megm: yes
21:29:21 <mattgriffin> google likes havana
21:29:28 <Sam-I-Am> it'll be easy to doc i think
21:29:31 <Sam-I-Am> mattgriffin: tell me about it
21:29:34 <megm> outline has link to current ntp instructions
21:29:59 <megm> This is just a question of order -- I'm thinking that they should install O/S on all nodes then configure NTP before going further
21:30:05 <Sam-I-Am> yeah, in the most basic case, ntp needs to at least run on every node.
21:30:17 <Sam-I-Am> megm: i'd say yes
21:30:19 <Sam-I-Am> ntp comes early
21:30:28 <Sam-I-Am> bad time screws up all sorts of things
21:30:39 <mattgriffin> ok. 0 min left. document action items for next week?
21:30:56 <megm> Okay, I'll move it. But that's one example of a bad ordering in current outline
21:31:10 <megm> Meg and Sam finish outline?
21:31:21 <megm> Nick get Mirantis owners for some pieces
21:31:23 <Sam-I-Am> yeah, i can poke at it. i'll be at mid-cycle ops next week though.
21:31:29 <mattgriffin> #action Meg and Sam finish outline
21:31:41 <Sam-I-Am> so hopefully i can get to it tomorrow, or in any spare time before next thursday's meeting
21:31:42 <mattgriffin> #action Nick get Mirantis owners for some pieces
21:31:53 <nickchase> and also my action items from last week
21:31:59 <mattgriffin> nickchase, :)
21:32:02 <Sam-I-Am> i'm also going to ask ops about their HA at the ops meetup
21:32:10 <Sam-I-Am> that was something someone asked me to do
21:32:14 <Sam-I-Am> and i'll be there
21:32:18 <mattgriffin> #action matt check with percona on where we can help more
21:32:30 <Sam-I-Am> so chances are there will be some TOC updates post-ops
21:32:34 <mattgriffin> Sam-I-Am, good idea
21:32:44 <Sam-I-Am> no reason to document things no one uses
21:32:57 <megm> Are we targeting Kilo or Juno? Blueprint says Kilo
21:33:20 <nickchase> I would think Kilo.
21:33:28 <Sam-I-Am> kilo, although thats kind of soon at this point
21:33:37 <Sam-I-Am> i'm pretty tied up with the install guide and network guide
21:34:00 <mattgriffin> should we write something up for the rest of the Docs community with our plans. make sure they're +1. i can start a pad and share it with you guys.
21:34:13 <megm> Sounds good
21:34:36 <mattgriffin> #action matt start an HA Guide update for the Docs list
21:34:48 <mattgriffin> anything else?
21:34:49 <Sam-I-Am> if we get enough writers, this might go quicker
21:34:53 <mattgriffin> aye
21:34:57 <Sam-I-Am> but right now its... not many.
21:35:05 <Sam-I-Am> the networking guide was a juno thing :)
21:35:09 <Sam-I-Am> and now kilo
21:35:10 <Sam-I-Am> and...
21:35:19 <mattgriffin> :)
21:35:29 <Sam-I-Am> turns out, this stuff is a lot of work and requires some specialized people
21:35:42 <mattgriffin> shocking
21:35:52 <Sam-I-Am> (and those people need time to write)
21:36:04 <mattgriffin> ok. i'm going to end the meeting then. thanks all!!! have a great rest of your week
21:36:13 <Sam-I-Am> thanks
21:36:15 <mattgriffin> #endmeeting