19:59:05 <asalkeld> #startmeeting heat
19:59:06 <openstack> Meeting started Wed Dec  5 19:59:05 2012 UTC.  The chair is asalkeld. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:09 <openstack> The meeting name has been set to 'heat'
19:59:25 <asalkeld> roll call ...
19:59:53 <jpeeler> jpeeler here
20:00:32 <asalkeld> #chair jpeeler asalkeld zaneb
20:00:33 <openstack> Current chairs: asalkeld jpeeler zaneb
20:00:38 <asalkeld> hey zaneb
20:00:44 <zaneb> heya
20:00:59 <asalkeld> #chair jpeeler asalkeld zaneb radez
20:01:00 <openstack> Current chairs: asalkeld jpeeler radez zaneb
20:01:15 <asalkeld> radez, you are here right
20:01:16 <radez> here,
20:01:21 <asalkeld> cool
20:01:26 <radez> yea, sry on a diff screen
20:01:50 <asalkeld> well small meeting today, shardy tomas away
20:02:12 <asalkeld> so topics
20:02:50 <asalkeld> #agenda Review last week's actions, web ui update, g2
20:02:59 <asalkeld> any others?
20:03:33 <asalkeld> #topic Review last week's actions
20:03:50 <asalkeld> put heatclient in pypi
20:03:57 <asalkeld> is that done?
20:04:11 <asalkeld> stevebake, ^
20:04:35 <asalkeld> well i enabled tag pushing
20:04:47 <asalkeld> so some of it is possible
20:05:02 <asalkeld> "make a bug to update the ubuntu tdls to install a recent version of boto"
20:05:40 <asalkeld> I think that is still at todo
20:05:45 <stevebake> here, mobile internet is working
20:05:54 <asalkeld> hey stevebake
20:06:01 <asalkeld> put heatclient in pypi
20:06:08 <asalkeld> stevebake, did that happen?
20:06:14 <stevebake> 0.1.0 has been released to pypi
20:06:21 <asalkeld> well done
20:06:26 <stevebake> sudo pip-install python-heatclient!
20:06:49 <asalkeld> stevebake, so how did you do that (so someone else can do it)
20:06:59 <asalkeld> just push the tag?
20:07:38 <stevebake> Its a secret! Actually we should submit a ci change to automatically release to pypi when a tag is pushed
20:07:59 <asalkeld> #action stevebake should submit a ci change to automatically release to pypi when a tag is pushed
20:08:03 <asalkeld> :)
20:08:16 <zaneb> asalkeld: shouldwe also kill the heat-api/python-heatclient repo?
20:08:17 <stevebake> python setup.py sdist upload <-- otherwise
20:08:39 <asalkeld> #action asalkeld kill the heat-api/python-heatclient repo
20:09:08 <stevebake> Can we talk GettingStarted.rst?
20:09:25 <asalkeld> sure
20:09:35 <asalkeld> #topic GettingStarted.rst?
20:10:05 <stevebake> I started porting it to python-heatclient, but it parses results so it will take a bit of effort.
20:10:36 <asalkeld> is see
20:10:40 <asalkeld> I see
20:10:47 <stevebake> When I first started on Heat it the structure of the doc confused me because it mixed image building, server and client hosts
20:11:16 <zaneb> well, it's the getting started guide
20:11:23 <zaneb> not the deploy openstack guide
20:11:35 <asalkeld> well we could explain it a bit better
20:11:38 <stevebake> i wonder if that structure is dictated by its dual role as an integration test
20:11:52 <zaneb> yes, we could definitely explain better
20:12:09 <zaneb> stevebake: maybe
20:12:26 <zaneb> the idea of that was that we can try what we're actually telling people to do
20:12:33 <zaneb> see if it actually works
20:12:44 <asalkeld> #action stevebake look at make the gettingStart easier to understand
20:13:01 <stevebake> and still make it runnable for now?
20:13:05 <zaneb> I'm fine with splitting it up into separate files
20:13:38 <asalkeld> text should not effect the script part
20:13:44 <zaneb> Is this still most people's entry point to heat?
20:13:53 <zaneb> if so, then we should keep it runnable
20:14:01 <stevebake> good question, on fedora it probably is
20:14:04 <asalkeld> not sure, maybe devstack
20:14:34 <asalkeld> after grizzly maybe not
20:14:36 <stevebake> I'll have a play
20:14:52 <zaneb> one option is to focus on devstack for devs and RPM for everyone else
20:15:05 <zaneb> in that case, maybe a lot of that guide could go away
20:15:08 <asalkeld> yip
20:15:10 <stevebake> so what will be the first easy way of installing on Ubuntu? PPA? pip?
20:15:16 <stevebake> git?
20:15:19 <asalkeld> rpm/deb
20:15:20 <zaneb> but it will require a bunch of work on RPMs
20:15:26 <zaneb> and even more on .debs
20:16:06 <asalkeld> would help if we had a keen user that helped with packaging
20:16:15 <asalkeld> on deb
20:16:22 <asalkeld> so lets move on to webui
20:16:31 <asalkeld> #topic webui status
20:16:32 <radez> Hopfully you all got a chance to look at my email to the list.
20:16:35 <radez> Happy to take feedback.
20:16:37 <stevebake> i'll need to go in 4 minutes
20:16:47 <radez> My plan of action is as partially mentioned in the email:
20:16:49 <radez> - setup Launchpad & create blueprints (been working on that this afternoon)
20:16:51 <radez> - unit tests
20:16:53 <radez> - deployment on devstack
20:16:55 <radez> - update docs
20:16:57 <radez> thoughts?
20:17:29 <asalkeld> does it need the lauchpad presence?
20:17:35 <stevebake> radez: do you want to switch to the released python-heatclient? it probably has enough now
20:17:53 <radez> I've been using master stevebake
20:17:53 <zaneb> haven't looked yet unfortunately. still need to find a computer that will actually play those
20:18:01 <asalkeld> when we get to core/whatever it will be merged into horizon?
20:18:18 <radez> is there a big difference between master and released?
20:18:36 <radez> asalkeld: maybe not, should I scratch the LP setup?
20:18:50 <asalkeld> well I am just asking
20:18:57 <stevebake> radez: currently not, but using a released version will help new users get started
20:19:03 <radez> I don't know for certain if it will be merged in
20:19:18 <asalkeld> why not ask the horizon guys
20:19:23 <zaneb> seems like now Heat is in incubation, we should at least ask about merging it
20:19:31 <radez> kk, I'll get intouch with them
20:19:32 <asalkeld> what their opinion is
20:19:46 <asalkeld> just less work for you
20:19:59 <asalkeld> admin stuff is a pita
20:20:33 <asalkeld> so radez you happy with the progress
20:20:57 <stevebake> radez: do you want help with devstack?
20:21:07 <radez> I think so, I'd like some feed back on what you guys would like to see it in
20:21:21 <asalkeld> ok
20:21:32 <asalkeld> I haven't yet - still morning
20:21:45 <radez> I'm starting to get pulled into another project so we need to have a plan if I'm to continue developing it
20:21:46 <stevebake> I'll look at the screencast when I have bandwidth
20:21:50 <asalkeld> I'll get there and give you some feedback
20:22:00 <radez> cool  thx
20:22:14 <asalkeld> #action checkout the demo
20:22:31 <asalkeld> #topic g2
20:22:50 <asalkeld> so we need to release on jan 10
20:23:04 <asalkeld> with the holidays in the middle
20:23:31 <asalkeld> so we have maybe 2 weeks now and 1 week after
20:23:37 <asalkeld> (the holiday)
20:23:41 <stevebake> i will be around mostly
20:23:54 <zaneb> I'll be on holiday until the 14th
20:23:55 <asalkeld> so we should start looking at bugs a bit more
20:24:02 <stevebake> apart from stats
20:24:03 <asalkeld> ok
20:24:21 <asalkeld> and pay attension to the target release
20:24:27 <stevebake> and docs
20:24:29 <asalkeld> (of the bugs)
20:24:37 <asalkeld> yea, that's right
20:24:52 <asalkeld> so are all the bp done?
20:25:07 <asalkeld> they don't say so
20:25:21 <asalkeld> Add an OpenStack ReST API
20:25:27 <asalkeld> zaneb, you done right?
20:25:29 <stevebake> zaneb: could you update that?
20:25:33 <zaneb> sure
20:25:38 <asalkeld> it says unknown
20:25:54 <zaneb> not to say there's nothing more to do, but the feature exists
20:26:04 <asalkeld> stevebake, quantum is still in progress
20:26:29 <stevebake> they keep adding features!
20:26:33 <asalkeld> zaneb, done if the feature work done - we can raise bugs after that
20:26:45 <zaneb> yep
20:26:56 <asalkeld> stevebake, well you have to define what you are going to do
20:27:06 <asalkeld> can't have a moving target
20:27:12 <stevebake> yep, i'll break up the bp
20:27:22 <zaneb> done
20:27:42 <asalkeld> cool
20:28:22 <asalkeld> seems like a bunch of ubuntu related bugs
20:28:55 <asalkeld> ok - well I think you get the idea, lets make our first openstack release good
20:29:12 <stevebake> whew, walking and typing is hard
20:29:27 <asalkeld> #topic open discussion
20:29:42 <jpeeler> fyi, openstack common has been updated to depend on something not packaged in fedora (extras)
20:29:51 * stevebake is sitting in a room with 300 kids
20:30:01 <asalkeld> stevebake, sssh
20:30:13 <asalkeld> ;)
20:30:18 <asalkeld> back to school
20:30:22 <stevebake> jpeeler: our setup.py should handle that now
20:30:34 <zaneb> I hate dependencies like that
20:30:37 <jpeeler> oh really? ok then
20:30:49 <asalkeld> so the other projects will drag it in too
20:31:01 <jpeeler> stevebake: actually, via a pip install? going to create a packaging mess
20:31:03 <asalkeld> (if it is in oslo)
20:31:04 <stevebake> will have to wait for packaging. lifeless_ wrote extras
20:31:27 <asalkeld> lovely name
20:31:28 <stevebake> jpeeler: for devstack it will do a pip-install
20:32:02 <stevebake> we may as well use it for our conditional imports
20:32:18 <asalkeld> I am done, anything else ...
20:32:32 <stevebake> nope
20:32:35 <asalkeld> #endmeeting