20:00:11 <sdake> #startmeeting heat
20:00:12 <openstack> Meeting started Wed Feb 13 20:00:11 2013 UTC. The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:15 <openstack> The meeting name has been set to 'heat'
20:00:17 <sdake> hidey ho
20:00:28 <sdake> #topic rollcall
20:00:30 <sdake> sdake here
20:00:34 <stevebaker> beep
20:00:35 <SpamapS> o/
20:00:39 <asalkeld> hi
20:00:44 <jpeeler> jpeeler here
20:00:44 * nijaba lurks while preping the ceilometer meeting
20:00:49 <sdake> zaneb and shardy wont make it
20:01:12 <sdake> lets go ahead and get started
20:01:17 <sdake> #topic blueprint review
20:01:40 <sdake> stevebaker you have quite a few blueprints outstanding - need any help?
20:01:51 <echohead> \o
20:01:53 <stevebaker> I'm getting traction on them now
20:02:09 <stevebaker> vpc, subnet, networkinterface done
20:02:09 <Slower> here
20:02:16 <sdake> https://launchpad.net/heat/+milestone/grizzly-3
20:02:29 <stevebaker> working on internet gateway now, will tackle route stuff last
20:02:45 <SpamapS> https://blueprints.launchpad.net/heat/+spec/rest-xml ... is this really grizzly critical?
20:02:51 <sdake> i spoke with shardy about https://blueprints.launchpad.net/heat/+spec/stack-rollback said he is about 1 week out
20:03:26 <sdake> spamaps we descoped that from grizzly
20:03:52 <stevebaker> should I set the goal to no value?
20:03:57 <SpamapS> ah its still set as Series goal: grizzly
20:04:05 <sdake> ya i just changed that
20:04:08 <SpamapS> perhaps its time to setup havana?
20:04:11 <sdake> i think zane didn't push all the right buttons
20:04:20 <sdake> yes, going to setup havana so we can start targeting
20:04:23 <stevebaker> he probably only unset the milestone
20:05:11 <sdake> spoke with shardy about https://blueprints.launchpad.net/heat/+spec/stack-rollback he siad one week
20:05:20 <sdake> just so folks know, the schedule is here:
20:05:51 <sdake> #link http://wiki.openstack.org/GrizzlyReleaseSchedule
20:06:04 <sdake> Feature freeze is in 7 days
20:06:14 <sdake> that means blueprints not finished by then will be kicked to havana
20:06:21 <sdake> this most likely affects stevebaker
20:06:25 <stevebaker> hrm
20:07:03 <sdake> on that schedule the week of the 28th and 7th are pure bug fix and test cycle days
20:07:08 <SpamapS> https://blueprints.launchpad.net/heat/grizzly .. really impressive set of features :)
20:07:11 <sdake> then we have 3 RCs
20:07:17 <stevebaker> I see new resources as low risk commits, if they're broken, don't use them ;)
20:07:37 <sdake> ya, however, we should follow the os process as much as possible
20:07:54 <sdake> if you need some aide with them stevebaker now time to ask ;)
20:07:55 <stevebaker> yeah, i know
20:08:15 <stevebaker> I could easily delegate some stuff
20:08:29 <sdake> asalkeld interested in taking one?
20:08:31 <sdake> and I'll take one
20:08:48 <asalkeld> I could, but just fighting with my setup atm
20:09:00 <asalkeld> as soon as it is working...
20:09:01 <sdake> ya im in same boat actually - devstack grumpy
20:09:01 <stevebaker> you'll need a working quantum setup
20:09:15 <asalkeld> also need to get v2 api into ceilometerclient
20:09:35 <stevebaker> chances are I'll get it all in
20:09:45 <sdake> ok stevebaker let me try to get quantum rolling - i'll ping you in heat channel if I can take one off your plate so you have more time
20:09:55 <stevebaker> ok, ta
20:10:06 <sdake> no guarantees though since i reloaded my ws with f18 my life has been a mess ;)
20:10:16 <sdake> #topic incubation review
20:10:26 <stevebaker> one thing that would help is prompt code reviews
20:10:33 <sdake> we went through the first step of incubation review Tuesday
20:10:44 <sdake> which is "why we think we are ready"
20:10:51 <asalkeld> nice job with that sdake
20:10:57 <sdake> Folks can read the logs if they missed the meeting at 2000 UTC but i think it went pretty well overall
20:11:24 <sdake> next step is for the tc to review our architectural stability
20:11:41 <sdake> we also had a review of how well we fit into the os dev model - which got good reviews
20:11:44 <sdake> so nice work everyone ;)
20:12:05 <sdake> any questions?
20:12:15 <sdake> thanks asalkeld
20:12:45 <sdake> #topic open items
20:12:47 <asalkeld> next step is people look at the code?
20:12:50 <sdake> so short meeting
20:12:55 <sdake> asalkeld i am not entirely clear on that
20:13:00 <asalkeld> ok
20:13:11 <sdake> I would expect so - or that they have already had a brief look
20:13:11 <SpamapS> I have two questions..
20:13:14 <sdake> shoot
20:13:35 <SpamapS> 1) blueprints for havana. I've been setting them up.. should we propose them by next meeting?
20:14:03 <SpamapS> 2) we're developing a set of OpenStack Heat templates, as in, templates specifically for deploying OpenStack using Heat...
20:14:22 <sdake> I think a good time to review blueprints would be weeks of the 14th, 21st and 28th : http://wiki.openstack.org/GrizzlyReleaseSchedule
20:14:24 <stevebaker> I don't see why blueprints can't be proposed throughout the H cycle for H development
20:14:26 <sdake> ie: during the rc cycle
20:14:26 <SpamapS> I think they should be hosted in heat's tree... but they're a bit less pragmatic than the templates in /templates
20:15:06 <stevebaker> we need a separate repo of heat templates, curated into examples, useful things, etc
20:15:13 <sdake> stevebaker i think some OS projects have different take on this - as we are just in incubation I'd like to follow the processes outlined but even in this cycle we added stuff after the cycle started
20:15:23 <SpamapS> Ok so that sounds like a set of bugs to tackle. :)
20:15:59 <SpamapS> blueprints post-summit are fine. The reason they might be frowned upon is if they are major features which the community at large may want to weigh in on.. hence the summit.
20:16:04 <sdake> spamaps that could go in the main repo assuming the base functionality was there
20:16:36 <SpamapS> sdake: I will go ahead and put them together and propose to add them to /templates .. and we can worry about reorganizing as a larger effort.
20:16:45 <asalkeld> I thought it was bp that needed discussion, have talks at summit
20:16:50 <stevebaker> Can we do what puppet/chef do with their modules/recipes? I think they have a root repo, and people clone that and add their own stuff
20:17:09 <asalkeld> +1 stevebaker
20:17:13 <sdake> ya - we have had some talk of a separate master repo for all templates
20:17:37 <sdake> this may make sense for H, although I'd rather not rock the boat with G much at this point in the codebase
20:17:42 <sdake> even if it is only moving templates around
20:17:48 <stevebaker> agreed
20:18:05 <SpamapS> I will create a BP
20:18:09 <SpamapS> "template organization"
20:18:10 <stevebaker> SpamapS: as long as its a public repo, it probably doesn't matter where your templates are for now
20:18:14 <sdake> btw stevebaker feel free to move the cfntools repo into wherever you were planning to move it
20:18:17 <SpamapS> we can come up with some ideas and have a short session at the summit
20:18:24 <sdake> sounds good spamaps
20:18:36 <sdake> f18 + oz f18 guests is broke
20:18:37 <SpamapS> stevebaker: right, the desire is for there to be a single place for collaborators on the "deploy openstack using heat" effort.
20:19:05 <stevebaker> sdake, heat-cfntools is already there, the old ones need to be expunged from heat-jeos though
20:19:16 <sdake> ya - i think you mentioned packaging in pypi or something
20:19:24 <sdake> not sure only so many brain cells ;)
20:19:30 <asalkeld> the cfntools are also out of sync too
20:19:30 <stevebaker> its already getting released to pypi
20:19:37 <jpeeler> i just synced heat-cfntools, so now would be a good time
20:19:39 <sdake> yes, jpeeler has been pushing stuff in
20:19:49 <asalkeld> well done jpeeler
20:20:09 <stevebaker> jpeeler: sweet, thanks
20:20:14 <sdake> #action review blueprints for havana week of 14th, 21st ,28th
20:20:40 <sdake> ok anything else?
20:20:49 <SpamapS> https://blueprints.launchpad.net/heat/+spec/template-organization btw
20:20:58 * SpamapS is done
20:21:30 <sdake> ok thanks guys - 1 week left in cycle lets get er done - then 2 weeks of intensive test+bugfix then 3 weeks of rc bugfix
20:21:34 <sdake> almost done with g ;)
20:21:39 <stevebaker> Its worth mentioning to non-core developers, if you do enough contributions and reviews then you may be nominated for core
20:22:12 <SpamapS> \o/
20:22:15 <asalkeld> yea
20:22:19 <sdake> yar
20:22:24 <sdake> just like any other OS project ;)
20:22:26 <stevebaker> ... and when that happens we should probably remove non-reviewing core members out until they become active again
20:22:42 <asalkeld> should define that
20:22:48 <asalkeld> but +1
20:23:15 <asalkeld> like query review < 10 reviews a month and you are out
20:23:18 <sdake> needs more discussion but would rather focus on g for time being - perhaps we can take that up at summit or during 14th-28th
20:23:38 <stevebaker> ok
20:23:39 <sdake> I tend to have a viewpoint of "people who have put in their time" model
20:23:50 <asalkeld> sure, I just need my setup working!
20:23:56 <SpamapS> summit is definitely a good time to have a few nominations already stacked up so you can have face to face with potential core devs
20:24:22 <sdake> hate to boot people out of core because some other activity taking up their time for a cycle
20:24:36 <SpamapS> make sure they won't go mad with power or try to control you with mind control
20:24:39 <asalkeld> I woundn't be stressed
20:24:44 <stevebaker> actually, I'm just trying to encourage more reviews ;)
20:24:48 <sdake> lol
20:24:50 <asalkeld> get back into it and get it back
20:25:21 <SpamapS> http://www.start-news.com/images/New%20Dinner%20For%20Schmucks%20Clip%20Introduces%20Zach%20Galifianakis.jpg ... suggestion: -1 this guy
20:25:24 <sdake> probably need a good look at what other projects do as well on this point
20:25:45 <sdake> ok anything else?
20:25:48 * imbrandon tried to mind control SpamapS once ... that did not end well for me :)
20:26:03 <stevebaker> heh
20:26:13 <asalkeld> seems like we done
20:26:17 <sdake> #endmeeting