20:00:12 <shardy> #startmeeting heat
20:00:13 <openstack> Meeting started Wed Apr 24 20:00:12 2013 UTC.  The chair is shardy. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:16 <openstack> The meeting name has been set to 'heat'
20:00:23 <shardy> #topic rollcall
20:00:34 <stevebaker> here (technically on holiday)
20:00:34 <shardy> shardy here :)
20:00:40 <harlowja> here
20:00:42 <zb> I'm here
20:00:48 <hanney> me too
20:00:48 <graflu0> here
20:00:58 <SpamapS> o/
20:01:06 <jpeeler> hi
20:01:14 <fsargent> Hi
20:01:19 <fsargent> Good to see you all again!
20:01:28 <fsargent> (read you all again?)
20:01:57 * mordred lurking
20:02:11 <randallburt> hi there
20:02:17 <kebray> My first meeting… will be observing.
20:02:21 <tspatzier> Hi all
20:02:24 <harlowja> howdy, just sent out a big thing about the future of heat, check openstack-dev :-p
20:02:31 <harlowja> zookeeper ftw, haha
20:02:45 <shardy> cool, good to see you all :)
20:02:45 <stevebaker> heh
20:02:54 <shardy> #topic Review last week's actions
20:03:02 * shardy looks, I don't think there were any
20:03:18 <harlowja> *go to summit, behave at summit ?
20:03:20 <zaneb> definitely not from *last* week ;)
20:03:23 <harlowja> i mostly behaved
20:03:43 <SpamapS> there was one. "Take a week to recover liver function"
20:03:44 <shardy> zaneb: haha, yeah last *meeting* ;)
20:03:55 <shardy> lots of actions from last week, which brings us to..
20:04:00 <shardy> #topic Summit review, action summary
20:04:22 <shardy> So I've had a first pass over the BPs, trying to capture the Heat actions from all the discussion last week
20:04:42 <harlowja> https://etherpad.openstack.org/task-system is a big one, maybe more just discussion also
20:04:44 <shardy> Can everyone please review, and check that I've not missed anything, that details and links are OK etc
20:05:06 <shardy> harlowja: I raised a BP for that earlier but didn't have the link:
20:05:10 <harlowja> kk
20:05:12 <harlowja> thx
20:05:38 <shardy> #link https://blueprints.launchpad.net/heat/+spec/workflow-library
20:05:56 <harlowja> good good
20:06:10 <shardy> I've not yet targetted that to havana as I'm unsure who will do the work
20:06:27 <harlowja> ya, its a big cross-project topic
20:06:40 <kebray> shardy:  I will put some resources on task-library
20:06:42 <harlowja> *with discussion still ongoing
20:06:43 <shardy> We have this so far (which already looks like a lot of work):
20:06:45 <SpamapS> In starting to look at how rolling updates will be done, it may require a task library too
20:07:01 <shardy> #link https://blueprints.launchpad.net/heat/havana
20:07:17 <shardy> #action everyone to review havana BPs
20:07:30 <shardy> kebray: great, lets talk after the meeting
20:07:43 <shardy> Anyone else got anything summit-action related to mention?
20:08:02 <harlowja> shardy: also maybe we can talk about how said workflow-library could even be done (especially without affecting the other people working on heat/nova), that last part is the tricky one :-p
20:08:41 <zaneb> harlowja: that almost needs a separate meeting
20:08:42 <shardy> harlowja: agree, I think it's a good idea, but there are still too many questions to commit to doing it for havana IMHO
20:08:55 <zaneb> harlowja: but I think more discussion on the ML is required first
20:09:08 <shardy> zaneb: agree, should we pick that up in #heat and/or the ML?
20:09:11 <SpamapS> one thing from the summit that bears repeating: Lots of working coming in will mean the heat core team will need help reviewing..
20:09:16 <harlowja> zaneb shardy agreed, but u have to start with baby-steps, and baby-steps seem possible in havana
20:09:26 <SpamapS> so, get out there and get reviewing. :)
20:09:57 <stevebaker> using zookeeper seems to be polarizing, can someone summarize the argument against using it?
20:10:10 <harlowja> zaneb shardy i just don't want it to turn into, oh to big for havana, than oh to big for "I" series, then oh to big for "J" series :-p
20:10:27 <SpamapS> stevebaker: starts with j, ends in ava ..
20:10:42 <zaneb> harlowja: agreed. baby steps. I haven't read your mailing list post yet, but I will look later
20:10:45 <harlowja> stevebaker: polarizing, i hope not, its a requriement in distributed systems imho, but maybe thats the polarizing aspect, haha
20:10:51 <stevebaker> SpamapS: lol
20:10:59 <harlowja> zaneb: thx
20:11:02 <shardy> harlowja: If someone steps up and presents a clear design/plan and some code, then we can target it to havana, not saying definitely no
20:11:25 <zaneb> zookeeper sounds like a big dependency to be taking on
20:11:29 <shardy> Anyone want to take an action to formulate a plan in a wiki page?
20:11:29 <harlowja> shardy: of course, i'd like to have some code in both places, heat and nova starting to do the right thing with 'baby-steps'
20:11:36 <zaneb> I guess that is what makes it polarising
20:11:45 * shardy things harlowja is volunteering ;)
20:11:47 <SpamapS> There are alternatives to zk
20:11:52 <shardy> s/things/thinks
20:12:02 <SpamapS> the *concept* is definitely one that should be investigated.
20:12:04 <kebray> shardy harlowja   When does a "clear" plan need to be presented by for Havana?
20:12:09 <harlowja> shardy: haha, i'm gonna make it happen, i'm just trying to figure out how to get there also ;)
20:12:10 <randallburt> agreed. zk is a possible solution to distributed state management
20:12:15 <zaneb> SpamapS: excellent. let's hear 'em ;)
20:12:39 <SpamapS> zaneb: https://github.com/ha/doozerd
20:13:08 <SpamapS> written in go.. MIT license
20:13:10 <harlowja> i just wonder about the maturity of all of those other ones, pretty much every big distributed system out there is using ZK :-p
20:13:16 <SpamapS> so its not a slam dunk for OpenStack ;)
20:13:19 <shardy> kebray: I'm not proposing a hard deadline, we can decide when we have a plan and resources to implement
20:13:30 <SpamapS> harlowja: and yet, ZK still doesn't have SSL... :-/
20:13:49 <shardy> #action someone to create workflow-library wiki page
20:13:53 <harlowja> i can push for that hard @ yahoo (where ZK came from) if thats what we want
20:13:55 <zaneb> SpamapS: Go? Oh well, nice try ;P
20:14:26 <shardy> Ok, anything else from summit or can we move on?
20:14:55 <shardy> #topic Bug triage/milestone assignment
20:15:35 <shardy> Ok, so I'd like everyone to change the bug states from "New" to something else (Triaged/Confirmed) when they assign a bug to themselves or someone else
20:15:51 <stevebaker> ok
20:16:06 <sandywalsh> #link https://github.com/knipknap/SpiffWorkflow
20:16:15 <shardy> Also please target the bug to the next release, so we can track all the assigned bugs for each milestone
20:16:38 <shardy> I can do this, but it will make it much easier (for me ;) if everybody just does it when they change the assignee
20:16:46 <shardy> it that's cool with everyone that is ;)
20:16:56 <SpamapS> shardy: should we target bugs we don't actually know we'll fix?
20:16:58 <harlowja> sandywalsh: all for libraries, but we need to nail down something simple first imho, haha
20:17:00 <SpamapS> s/know/think/
20:17:16 <SpamapS> I'd think that we only want bugs we're willing to commit to at least trying to fix
20:17:21 <stevebaker> shardy: do you know about ttx.py?
20:17:24 <shardy> SpamapS: If you're assigned a bug then I'm assuming you will either fix it or close it
20:17:52 <shardy> Then we'll bump any bugs which aren't fixed before we tag a release (to the next milestone)
20:17:52 <SpamapS> shardy: some bugs have medium/low priority and get done more when the time is right, not "now or never"
20:18:08 <stevebaker> shardy: launchpad sanity checking script https://github.com/ttx/bp-issues
20:18:25 <shardy> SpamapS: Ok, well that's pefectly fine, just change the status to something other than New
20:18:35 <SpamapS> Right, Triaged seems appropriate for that :)
20:18:56 <SpamapS> like "I have looked, I ack its a bug and is workable by a dev.. but Medium/Low probably means it isn't getting done soon.
20:19:07 <shardy> I'm just trying to keep some sort of bug pipeline organised without doing pointless-clicking myself all day :)
20:19:16 <shardy> stevebaker: thanks, I'll check it out
20:20:11 <shardy> Ok, anything else on bug workflow?
20:20:41 <shardy> #topic Blueprint review for Havana
20:21:07 <shardy> #link https://blueprints.launchpad.net/heat/havana
20:21:38 <shardy> So is everyone happy with BPs they are assigned atm?
20:22:04 <shardy> I probably have too many so shout if anyone sees something I've got that they'd like to take ;)
20:22:23 <stevebaker> it will change over time, no doubt
20:22:45 <shardy> stevebaker: Yep, just want to make sure we're all vaguely happy for now :)
20:22:49 <SpamapS> hm
20:22:51 <harlowja> shardy: i'd keep the workflow-lib open, i think the picture will get clearer soon i hope
20:22:56 <SpamapS> which one of those is "run n+1 engines" ?
20:22:59 <harlowja> hoping for baby-steps in hava :)
20:23:17 <SpamapS> to me that is the only Critical BP we discussed at the summit
20:23:20 <stevebaker> shardy: I've been mulling over trusts, so I may be asking where it is in your queue at some point
20:23:34 <SpamapS> as in, Heat is pretty craptastic for any sort of large scale usage without it.
20:23:46 <shardy> https://blueprints.launchpad.net/heat/+spec/multiple-engines
20:23:58 <shardy> SpamapS: I've not targetted that one correctly, thanks
20:24:17 <shardy> fixed
20:24:21 <SpamapS> shardy: np, just wanted to make sure it wasn't lost (in fact I keep losing it and forgetting the name.. ;)
20:24:44 <stevebaker> who wants to be assigned to it for now?
20:25:06 <SpamapS> seems like asalkeld was most actively pursuing it
20:26:03 <shardy> I'll speak to asalkeld and see if he's happy to take it
20:26:32 <shardy> If anyone wants to take any of the remaining unassigned ones, please do, then we can take another look next week
20:26:48 <stevebaker> too late, I assigned him ;)
20:26:54 <shardy> If anyone spots any other errors please let me know
20:27:00 <shardy> stevebaker: haha :D
20:27:09 <randallburt> shardy: sorry for my ignornace but is it just core devs who can sign up, or can us new guys take one
20:27:18 <zaneb> stevebaker: that will teach him not to show up to the meeting ;)
20:27:26 <shardy> randallburt: absolutely anyone can take one
20:27:42 * shardy would be very very happy to see some non-core devs on that list ;)
20:27:42 <randallburt> cool. I guess I'll take the dsl one unless there are objections
20:27:59 <shardy> randallburt: Ok, thanks
20:28:29 <shardy> I guess that one will be a bit of a team-effort, perhaps we'll need to create some child-BPs when we've fully defined what needs to be done
20:28:38 <stevebaker> randallburt: an approved blueprint is just a vague indication that you're not wasting your time developing something
20:28:49 <randallburt> shardy:  agreed
20:29:17 <shardy> Yep, and the message I have ringing in my ears from summit is people want dsl/hot, so we definitely approve of that BP ;)
20:29:23 <randallburt> I can ride herd and expect the work to be broken up quite a bit
20:29:39 <shardy> randallburt: Ok, cool, well thanks for offering to drive it
20:29:43 <kebray> Thanks randallburt.
20:29:44 <randallburt> my pleasure
20:29:52 <SpamapS> randallburt: right, the BP assignee is really just the one who answers the "how is it going" question at the meetings. You can break it up into a bunch of bugs or even sub-blueprints.
20:29:55 <zaneb> shardy: the message I heard was that people want features that cloudformation does not support
20:30:10 <randallburt> cool, thanks!
20:30:25 <shardy> zaneb: Ok, true, that is a more accurate statement
20:30:50 <shardy> people certainly talked about alternate template language a lot too tho ;)
20:30:56 <shardy> anyway..
20:30:59 <randallburt> a *lot*
20:31:12 <zaneb> developers talked about that a lot
20:31:29 <shardy> Anything else on BP's before we move on to open discussion?
20:31:57 <shardy> #topic Open discussion
20:32:11 <stevebaker> I'm on leave next week
20:32:39 <shardy> So I'm in the process of getting openstack/heat-templates repo created, ref ML discussion
20:32:51 <SpamapS> shardy: sweet. :)
20:32:57 <stevebaker> shardy: start by doing it in a personal github repo
20:33:06 <randallburt> lol
20:33:09 <shardy> haha
20:33:34 <stevebaker> then import happens magically when you do the gerrit review to openstack-ci-puppet
20:33:47 <SpamapS> oh
20:33:54 <SpamapS> do we still want to move to testr?
20:33:59 <stevebaker> YES
20:34:02 <SpamapS> I'm happy to take that on
20:34:07 <shardy> stevebaker: I assumed we just wanted a new empty repo?
20:34:08 <stevebaker> cool
20:34:14 <SpamapS> is there already a bug?
20:34:23 <shardy> since I guess we don't care about template revision history that much?
20:34:27 <stevebaker> shardy: you could have a crack at an initial structure
20:35:03 <shardy> stevebaker: Yep, I'm planning to create a tentative dir structure, copy in the CFN templates and heat-jeos TDLs
20:35:17 <shardy> then other stuff can be added later
20:35:47 <stevebaker> SpamapS: I though there was one, maybe there is a project-wide bug we can attach to
20:36:26 <SpamapS> https://bugs.launchpad.net/heat/+bug/1172468
20:36:27 <uvirtbot> Launchpad bug 1172468 in heat "Replace nose with testr" [Medium,Triaged]
20:37:23 <stevebaker> SpamapS: just remove the integration tests, I'll be looking at tempest soon
20:37:39 <shardy> any other topics or did we all do too much talking last week :)
20:37:58 * SpamapS has been feeling fairly antosocial since Friday
20:38:03 <SpamapS> anti even
20:38:55 <shardy> randallburt: did you have any dsl interpreted versions of the example templates to share, or is that still in-progress?
20:39:19 <SpamapS> I saw a few
20:39:26 * shardy must've missed the link
20:39:37 <randallburt> still in progress
20:39:48 <shardy> randallburt: ok, cool
20:39:56 <kebray> I thought Adrian added some to his articles, no?
20:39:56 <randallburt> we have a couple of the simple ones but are still refining
20:39:58 <SpamapS> one thing I saw that was missing that I want is a separation from describing "an app" and "a vm"
20:40:31 <SpamapS> but I think thats just because I don't know how to read them yet :)
20:40:32 <randallburt> we should probably get together soon and get everyones input since this will be a bit of a bear
20:40:43 <randallburt> final input that is.
20:40:53 <shardy> kebray: they were just example snippets, I'm talking about fully converted versions of those in https://gist.github.com/hardys/5408410
20:41:04 <shardy> (not necessarily all of them ;)
20:41:11 <randallburt> shardy: Andrew and I are working on that this week
20:41:13 <kebray> shardy   got it.  Ok, definitely something randall can help ride herd on.
20:41:29 <shardy> Ok, cool, not chasing just wondered if there was anything to look at yet :)
20:41:35 <randallburt> k
20:41:46 <shardy> If there's nothing else we can end the meeting early?
20:41:46 <randallburt> we'll ping the list when we get something to show
20:41:55 <SpamapS> early +1
20:42:00 <shardy> randallburt: Ok, great, thanks
20:42:19 <tspatzier> randallburt: if you want to have some offline discussion on the samples, I'd be happy to discuss
20:42:31 <randallburt> tspatzier: very much. thanks!
20:42:45 <shardy> Ok, we can follow up re templates etc on ML and #heat, thanks
20:42:49 <shardy> #endmeeting