20:00:42 <shardy> #startmeeting heat
20:00:43 <openstack> Meeting started Wed Oct  2 20:00:42 2013 UTC and is due to finish in 60 minutes.  The chair is shardy. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:47 <openstack> The meeting name has been set to 'heat'
20:00:52 <shardy> #topic rollcall
20:00:54 <asalkeld> o/
20:00:59 <stevebaker> \o
20:01:01 <shardy> Hi all, who's around?
20:01:09 <sdake_> o/
20:01:44 <kebray> o/
20:01:49 <shardy> zaneb, jpeeler, therve, SpamapS?
20:01:55 <jpeeler> hey i'm here
20:01:57 <adrian_otto> hi
20:02:00 <MikeSpreitzer> I'm here too
20:02:22 <shardy> Ok, let's get started, not much on the agenda today, maybe we can have a short meeting ;)
20:02:25 <SpamapS> shardy: sick today, barely here
20:02:31 <shardy> #topic Review last week's actions
20:02:44 <shardy> Actually I don't think there were any:
20:02:54 <sdake_> nope
20:02:57 <shardy> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda
20:03:12 <shardy> #link http://eavesdrop.openstack.org/meetings/heat/2013/heat.2013-09-25-20.00.html
20:03:24 <gokrokve> Hi
20:03:27 <randallburt> hello
20:03:43 <tspatzier> Hi
20:03:51 <sdake_> yo
20:03:51 <shardy> #topic RC1 status
20:04:05 <shardy> So, branching for RC1 is imminent:
20:04:09 <shardy> #link https://review.openstack.org/#/c/49384/
20:04:11 <stevebaker> yay!
20:04:18 <sdake_> did asalkeld have a chance this morning to look at that last lingering issue?
20:04:41 <asalkeld> I woke up 7 minutes ago
20:04:47 <sdake_> morning :)
20:04:48 <asalkeld> :-)
20:05:10 <stevebaker> shardy: should we be reviewing that change?
20:05:16 <sdake_> asalkeld there is sa template attached to that bug now
20:05:22 <asalkeld> ok
20:05:49 <shardy> stevebaker: No, I just acked it since we're ready to branch, and it's a one line change bumping the version
20:06:06 <shardy> #link https://launchpad.net/heat/+milestone/havana-rc1
20:06:21 <shardy> So master will be open for Icehouse after than lands
20:06:54 <shardy> however it would be really great if we can focus some effort on testing the Havana branch (ie RC1) over the next few days
20:07:08 <shardy> as we have ~2weeks to catch any remaining issues which may require an RC2
20:07:09 <asalkeld> sdake_ what is the bug with the attachment?
20:07:24 <sdake_> i dont have the bug # handy
20:07:31 <asalkeld> ok, no worries
20:07:36 <zaneb> I'm awake
20:07:36 <stevebaker> so fixes land in master and get backported to the release branch?
20:07:39 <zaneb> sorry, y'all
20:08:16 <shardy> sdake_: So asalkeld fixed bug #1233882, but the Ref issues may or may not be an issue, we haven't yet confirmed
20:08:18 <uvirtbot> Launchpad bug 1233882 in heat "neutron resources don't have the "show" attribute as used in the example templates" [High,Fix committed] https://launchpad.net/bugs/1233882
20:08:38 <shardy> If we need to, we'll fix them and do an RC2
20:08:46 <sdake_> sounds good
20:09:01 <shardy> Any other comments or questions re the Havana release?
20:09:31 <shardy> really, please everyone do test it, as we're still finding pretty significant issues..
20:09:37 <asalkeld> shardy, the f17 LB?
20:10:01 <asalkeld> I have a local f19 one
20:10:11 <asalkeld> but you wanted to go to f18?
20:10:16 <shardy> asalkeld: Yeah, we should bump that to F18/19
20:10:27 <asalkeld> I'll make a bug for that
20:10:28 <shardy> asalkeld: I don't mind, anything that works and isn't EOL is OK with me
20:10:47 <shardy> let's fix it in master after the branch and we can consider backporting
20:11:08 <shardy> asalkeld: Can we reimplement the LB as a provider template now, ie during Icehouse?
20:11:10 <stevebaker> has anyone tried the neutron loadbalancer?
20:11:13 <shardy> seems like we probably can
20:11:48 <asalkeld> yea, I can give that a go
20:12:20 <shardy> asalkeld: cool, would be great to get rid of all the hard-coded nested templates :)
20:12:34 <asalkeld> yip
20:13:23 <asalkeld> https://bugs.launchpad.net/heat/+bug/1234375
20:13:26 <uvirtbot> Launchpad bug 1234375 in heat "the aws loadbalancer use Fedora 17 and needs to be upgraded to f18 or f19" [Undecided,New]
20:13:43 <shardy> #link https://bugs.launchpad.net/heat/+bug/1234375
20:14:31 <shardy> Ok, well great work everyone on Havana, we delivered 42 blueprints and 251 bug fixes!
20:14:48 <sdake_> lots of bug fixes
20:14:52 <asalkeld> yeah, that's good
20:14:55 <shardy> thanks to all, looking forward to the next push for Icehouse
20:14:57 <zaneb> how many bug creations? ;)
20:15:05 <shardy> zaneb: ha, true..
20:15:15 <asalkeld> feature dev == bug creation
20:15:26 <zaneb> :)
20:15:32 <shardy> Yeah, hence my plea for testing :)
20:15:39 <shardy> #topic open discussion
20:15:49 <asalkeld> so when is the summit sessions closed?
20:16:14 <shardy> So I think they need to be wrapped up in the next couple of weeks, by mid Octover
20:16:18 <shardy> October even
20:16:27 <asalkeld> ok
20:16:31 <MikeSpreitzer> the ides of October
20:16:41 <radix> ok, sorry I got distracted for the body of the meeting
20:16:47 <shardy> I've not approved any, as I expected we'd want some discussion (at next week's meeting), and the new PTL can approve them
20:17:16 <shardy> I've actually got a couple to propose too, so if anyone else has, please add them before next week:
20:17:32 <shardy> #link http://summit.openstack.org/
20:17:46 <sdake_> the ui lets you join stuff together or break them apart as well
20:18:01 <shardy> sdake_: Cool, that will be useful
20:18:03 <sdake_> new ptl can expect to spend 4-5 hours preparing those talks
20:18:11 <stevebaker> I'll be a bit quiet this week (ear infection)
20:18:28 <radix> 13 proposed sessions so far
20:18:34 <shardy> #info summit session agenda to be discussed at next week's meeting
20:18:43 <gokrokve> Do you plan to have Software orchestration design meeting?
20:18:44 <shardy> #action all to add remaining summit proposals
20:18:53 <stevebaker> gokrokve: yes
20:19:12 <shardy> gokrokve: yes, the software config BP related discussion definitely warrants a session
20:19:16 <shardy> (IMHO)
20:19:29 <gokrokve> Can we start some discussions before summit?
20:19:37 <zaneb> stevebaker: will you be quiet, or will it just seem quiet to you?
20:19:39 <sdake_> mailing list
20:19:40 * zaneb ducks
20:19:58 <shardy> gokrokve: Yes, of course, but I wanted to ensure we have the full list of proposals before we start prioritizing too much
20:19:58 <radix> I want to call attention to the thread that therve started on the mailing list about autoscaling and load balancing. there's a workable solution being proposed but it needs some discussion
20:19:59 <asalkeld> you need to start a etherpad gokrokve
20:20:08 <stevebaker> gokrokve: yes, I'm hoping to write some design docs to kick off some pre summit discussion
20:20:33 <gokrokve> stevebaker: That will be great.
20:20:42 <shardy> asalkeld: +1, etherpads will help with the discussion re priorities too
20:20:44 <stevebaker> gokrokve: are you on Murano?
20:20:58 <shardy> ie details as some of the proposals are pretty sparse
20:21:12 <gokrokve> stevebaker: Yes.
20:21:15 <sdake_> one thing that i would have found handy in previous summit years was a master list of etherpads in one etherpad eg summit2013novheat
20:21:18 <sdake_> or something similar
20:21:22 <sdake_> with links to each specific etherpad
20:21:34 <MikeSpreitzer> +1
20:21:40 <tspatzier> +1
20:21:41 <gokrokve> We see that we have some code which actually better fits to Heat orchestration agenda then to Murano.
20:22:15 <stevebaker> gokrokve: OK, at some point I'd like to understand why Windows software config needs a whole new API - or maybe I don't ;)
20:22:17 <zaneb> gokrokve: yes, that sounds really interesting and we definitely want to discuss that
20:22:34 <shardy> zaneb: +1
20:22:49 <gokrokve> stevebaker: That is the whole point. It does not require specific API.
20:22:56 <shardy> sdake_: Sounds like a good idea
20:23:04 <shardy> #link http://summit.openstack.org/cfp/topic/8
20:23:09 <shardy> that's the heat proposal list
20:23:10 <gokrokve> stevebaker: So we want to pass this stuff to Heat instead of doing this by ourselves.
20:23:24 <sdake_> shardy non-ptls get "forbidden" on that link
20:23:25 <MikeSpreitzer> that URL gets me "Forbidden"
20:23:40 <sdake_> website presents different urls for ptl vs nonptl
20:23:41 <stevebaker> gokrokve: I'm hoping that the software config proposal I'm putting together will fit well with Murano, even if you're writing your own non cloud-init agent
20:23:43 <radix> yeah that's a real bummer
20:23:50 <shardy> Hmm, ok sorry, I'm not sure how to get a topic filtered link then
20:24:05 <asalkeld> ctrl-f "Heat"
20:24:06 <sdake_> you have to link them one at a time from your ui
20:24:08 <sdake_> pretty weak :)
20:24:24 <zaneb> seriously, only the PTLs can see a list
20:24:35 <zaneb> why are the openstack web devs so user-hostile?
20:24:46 <shardy> I thought you'd all see the list, only without the review option
20:24:48 <shardy> sigh
20:24:53 <zaneb> what did we do to them?
20:24:54 <gokrokve> stevebaker: our agent is very simple it actually listens on rabbitMQ queue and receive scripts and commands to execute. It can be anything except cloud-init.
20:25:09 <randallburt> zaneb:  you know what you did… ;)
20:25:12 <tspatzier> you can sort the list by project
20:25:24 <sdake_> one suggestion is to make a master list with links to etherpads
20:25:26 <shardy> gokrokve: so are you using cloudbase-init, or did you replace it with your agent?
20:26:05 <asalkeld> tspatzier, that's as good as it gets
20:26:06 <zaneb> randallburt: I may have questioned their parentage once or twice, but only after they started pulling this stuff ;)
20:26:16 <gokrokve> shardy: we use cloud-init to do initial first boot configuration. After that cloud-init does not work on Windows as it is executed only once ant first boot.
20:26:39 <randallburt> lol
20:26:43 <sdake_> gokrokve you can use cfn-hup for that
20:26:47 <gokrokve> shardy: So we have to use our own agent to execute commands after VM restart.
20:26:48 <stevebaker> gokrokve: if you really wanted to align with Heat you could poll for metadata changes instead of listening to rabbitmq
20:27:27 <gokrokve> sdake_: I think yes. We can use anything that can execute scripts.
20:27:33 <radix> hmm
20:27:34 <shardy> Yeah, there seem to be significant areas of overlap - and an FAQ from users I've spoken to is Heat windows instance support
20:27:48 <shardy> (which we currently don't have)
20:27:49 <sdake_> well lets not invent yet another whole set of agents for a new project
20:27:56 <sdake_> lets try to have one set of agents :)
20:28:10 <gokrokve> sdake_: Totally agree.
20:28:18 <zaneb> I take it all back, go to http://summit.openstack.org/ and click on 'Topic' and it sorts the list
20:28:21 <sdake_> agent overhead is hard on everyone - image builders etc
20:28:32 <gokrokve> sdake_: We created windows agent as there were no one.
20:29:06 <stevebaker> gokrokve: so you should look at os-collect-config for fetching the metadata, then use that to trigger your own tool to do the configuration
20:29:39 <asalkeld> end of meeting?
20:29:53 <gokrokve> I have another BP to discuss.
20:30:01 <asalkeld> ok
20:30:10 <gokrokve> https://blueprints.launchpad.net/heat/+spec/stacks-reservation
20:30:14 <spenceratx> any idea why heat doesn't show up in the Openstack-dev subscribe list? http://lists.openstack.org/cgi-bin/mailman/options/openstack-dev
20:30:21 <gokrokve> This is for Climate.
20:31:04 <gokrokve> We have a team who now actively works on CLimate development. They want to integrate soem CLimate capabilities to Heat.
20:31:20 <gokrokve> Can someone review this BP and related proposal on Wiki?
20:31:22 <zaneb> spenceratx: because nobody added it
20:31:35 <MikeSpreitzer> So Climate would be a separate service, making a reservation does not directly interact with any scheduler?
20:31:40 <spenceratx> ok
20:31:51 <zaneb> spenceratx: but I don't have an answer to your follow-up question ;)
20:32:20 <asalkeld> gokrokve, sounds interesting
20:32:34 <spenceratx> zaneb: touche
20:32:46 <radix> here's that thread I mentioned earlier. could use some input at some point :) http://lists.openstack.org/pipermail/openstack-dev/2013-October/015912.html
20:33:02 <shardy> #link http://lists.openstack.org/pipermail/openstack-dev/2013-October/015912.html
20:33:06 <radix> thanks :)
20:33:24 <gokrokve> Our enginners who are working on CLimate are in UTC+3 timezone. It would be nice if we can chat in IRC or talk around 8-9am PDT
20:33:47 <shardy> gokrokve: We can review the BP, we're still getting Havana finished, so there are lots of Icehouse (or potential Icehouse) BP's which are unreviewed at this point
20:33:51 <MikeSpreitzer> what would be the atomic operation?
20:34:03 <stevebaker> gokrokve: that blueprint is currently too high-level to act on, it really needs some climate people to break it down into some more specific feature blueprints
20:34:37 <shardy> Yeah, looking at the wiki page I'm not even sure what it has to do with Heat at all
20:34:46 <shardy> needs much more detail
20:35:04 <MikeSpreitzer> If the atomic operation is reserving all the resources of a stack at once, I see a connection to Heat
20:35:05 <asalkeld> shardy, well they could have a reservation resource
20:35:05 <sdake> shardy I think they want heat to tell climate about the reservations
20:35:33 <asalkeld> and the other resources in the template ref' the reservation
20:35:39 <gokrokve> MikeSpreitzer: atomic means that you will reserve the whole bunch of resources (IP, VM, floating IP, volume) as a one object. At least this is my understanding.
20:36:11 <randallburt> I read it as Climate (Reserve this stack) -> Heat -> Climate (Reserve these individual resources)
20:36:13 <shardy> Ok, well lets say that in the BP rather then "Heat stacks Reservation support for the OpenStack Reservation service"
20:36:49 <tspatzier> So something like 'heat stack-reserve' that guarantees that a later 'heat stack-create' will succeed since you got sufficient resources?
20:37:08 <sdake> i dont think you need a new api call
20:37:09 <gokrokve> Here is more details: https://wiki.openstack.org/wiki/Heat/Reservation
20:37:21 <sdake> you can just stack-create and it will reserve and create atomically vs what is done now
20:38:15 <shardy> gokrokve: Yeah, I'm saying that page needs more specifics, what does Heat need, new Resource implementation, API integration with existing services, new API actions, or ..?
20:38:16 <radix> sdake: yeah, agreed
20:38:26 <zaneb> sdake: reservations can be created well in advance of creating the stack
20:38:30 <tspatzier> sdake, yeah, that's another way to look at it.
20:38:41 <gokrokve> shardy: Ok. Makes sense.
20:38:55 <MikeSpreitzer> If a reservation is created well in advance, what happens to the physical capacity in the meantime?
20:38:56 <sdake> these sound like questions for gokrokve to answer zaneb, radix, tspatzier :)
20:39:00 <gokrokve> What will be the best to discuss the details? openstack-dev ?
20:39:12 <zaneb> gokrokve: +1
20:39:39 <stevebaker> gokrokve: Are climate peeps coming to Hong Kong?
20:39:49 <gokrokve> stevebaker: Yes.
20:40:10 <shardy> Ok, shall we wrap up the meeting and continue this on the ML?
20:41:06 <gokrokve> shardy: Yes. We will proceed with the discussion in ML for both Murano and Climate.
20:41:19 <shardy> Ok then, lets do that, thanks all!
20:41:23 <shardy> #endmeeting