20:00:19 <mspreitz> #startmeeting heat
20:00:20 <openstack> Meeting started Wed Jun 18 20:00:19 2014 UTC and is due to finish in 60 minutes.  The chair is mspreitz. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:23 <openstack> The meeting name has been set to 'heat'
20:00:58 <mspreitz> roll call
20:01:01 <randallburt> hi
20:01:03 <skraynev> o/
20:01:09 <tspatzier> hi
20:01:09 <stevebaker> \o
20:01:12 <tango> o/
20:01:20 <zaneb> mspreitz volunteered to chair this week, btw
20:01:45 <zaneb> currently taking volunteers to chair a fortnight from now
20:02:01 <zaneb> that's in 2 weeks, for my American friends ;)
20:02:10 <randallburt> :P
20:02:25 <mspreitz> Pls respond directly to Zane about chairing
20:02:34 <mspreitz> #topic review action items from last meeting
20:02:41 <SpamapS> o/
20:02:53 <d0ugal> o/
20:02:57 <mspreitz> Zane, you had three, some in concert with others
20:03:16 <zaneb> do you have the link handy?
20:03:27 <mspreitz> #link http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-06-11-12.00.html
20:03:36 <zaneb> ta
20:03:46 <zaneb> zaneb sync with andrew_plunk on rackspace CI job
20:03:54 <zaneb> I didn't do that
20:04:19 <mspreitz> #info zaneb sync with andrew_plunk on rackspace CI job - not yet
20:04:25 <zaneb> doesn't look like he's around to give us an update
20:04:35 <zaneb> zaneb sync with stevebaker on heat-slow job & making it voting
20:04:38 <randallburt> zaneb:  poked him. he'll be here shortly
20:04:43 <zaneb> stevebaker: got any update on that?
20:04:58 <randallburt> afaik, we have the job set up and running but I haven't seen it vote yet
20:05:11 <stevebaker> so there was a fix recently, most of the failures were caused by IP address clash
20:05:27 <zaneb> randallburt: because it's passing, or because voting is not working?
20:05:44 <randallburt> zaneb:  I think because its not working, but andrew_plunk is here now
20:05:47 <stevebaker> I hoped that would make heat-slow reliable enough to be voting for everyone
20:06:00 <andrew_plunk> yeah it is setup randallburt, zanb
20:06:20 <andrew_plunk> I assumed it was voting, if nobody has seen a vote from raxci then I will double check
20:06:22 <stevebaker> Its better, but there are still failures http://status.openstack.org/elastic-recheck/ bug #1297560
20:06:23 <uvirtbot> Launchpad bug 1297560 in tempest "*tempest-dsvm-neutron-heat-slow fails with WaitConditionTimeout" [Undecided,In progress] https://launchpad.net/bugs/1297560
20:06:43 <zaneb> #info raxci job is set up and should be voting
20:07:02 <stevebaker> there are no longer fedora boot timeouts, but set_hostname failures
20:07:31 <stevebaker> tl;dr, I'd like to hold out on fixing the job to be voting for everyone
20:07:34 * SpamapS blames systemd
20:07:43 <zaneb> zaneb sync with stevebaker on metadata api compat patch
20:07:49 <stevebaker> SpamapS, I'm not so sure. I'd like to blame neutron
20:07:53 <zaneb> I think that one went in, right?
20:08:04 <SpamapS> stevebaker: neutron has been integrated into systemd.
20:08:08 <zaneb> blaming neutron is usually a safe bet :D
20:08:09 <SpamapS> along with bash and corn flakes.
20:08:16 <bgorski> o/ sorry I'm late
20:08:51 <mspreitz> Is there a consensus on holding off making the job voting?
20:09:02 <SpamapS> Leave it non-voting
20:09:04 <stevebaker> zaneb, its in. I'd like to re-propose this backport which includes restoring the metadata attribute https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:stable/icehouse+topic:bug/1306743,n,z
20:09:06 <zaneb> stevebaker: but we were going to make it voting for just heat, right?
20:09:08 <SpamapS> It needs to be really solid.
20:09:19 <mspreitz> right, voting just for heat was the plan
20:09:22 <SpamapS> We don't want to be the gate crashers.
20:09:48 <stevebaker> zaneb, we were, one thing that occured to me though is that any other project could break heat-slow with one commit, then we can't land anything
20:09:49 <SpamapS> it is still a problem if it only votes on Heat
20:09:53 <zaneb> ok
20:09:54 <SpamapS> because a heat fail == gate reset
20:10:12 <zaneb> #agreed heat-slow job will remain non-voting until current issues are fixed
20:10:15 <SpamapS> We can add it back in when it gets back up to 90% pass.
20:10:22 <mspreitz> yes.  next
20:10:42 <mspreitz> is the API compatability patch merged?
20:10:47 <zaneb> mspreitz: yes
20:11:05 <mspreitz> #info zaneb sync with stevebaker on metadata api compat patch - merged
20:11:18 <mspreitz> #topic additional agenda items
20:11:28 <zaneb> Mid-cycle meetup
20:11:33 <mspreitz> Already on the agenda
20:11:43 <zaneb> oh, good :)
20:12:04 <zaneb> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda
20:12:08 <mspreitz> Anybody got anything else?
20:12:43 * mspreitz hears crickets
20:12:54 <mspreitz> #topic mid-cycle meetup
20:13:19 <zaneb> #link https://etherpad.openstack.org/p/heat-juno-midcycle-meetup
20:13:21 <mspreitz> Zane, what's the latest?
20:14:08 <mspreitz> We are now discussing two meetups
20:14:10 <zaneb> I think shardy and stevebaker are definitely going to attend the TripleO meetup
20:14:11 <SpamapS> shadower: can you clarify your entry in https://etherpad.openstack.org/p/heat-juno-midcycle-meetup ?
20:14:16 <stevebaker> I could go to either tripleo or heat meetup, but I've decided going to tripleo with shardy
20:14:40 <zaneb> it seems like most people can go to both
20:14:51 <zaneb> or either, I should say
20:14:58 <stevebaker> I'm assuming I'll be seeing you ugly mugs in Paris
20:15:14 <SpamapS> stevebaker: I think that's the right call, and you and shardy will be in high demand as TripleO will likely want to chat about https://review.openstack.org/#/c/97939/
20:15:26 <zaneb> SpamapS can't go to the TripleO one, and would be struggling in August
20:15:36 <zaneb> and tspatzier can't go in August
20:15:42 <SpamapS> I'm wide open after 8/13
20:15:57 <SpamapS> have blocked the entire last half of August off for this just in case. ;)
20:15:59 <stevebaker> SpamapS, yes, probably actually good that you won't be there (no offense ;)
20:16:02 <tspatzier> zaneb: yeah, bad timing, but I think we can get someone from our team there
20:16:08 <zaneb> SpamapS: from, or after?
20:16:18 <zaneb> SpamapS: August 13 is a Wednesday
20:16:36 <SpamapS> 8/13 - 8/31 I can travel to timbuktu if need be.. wherever Heat needs me. :)
20:16:41 <SpamapS> zaneb: fully aware
20:16:56 <zaneb> actually, tspatzier can't make either week, so I guess we could do it the second week
20:16:57 <SpamapS> zaneb: 8/13 is the third first day of school in a row for my three sons.
20:17:09 <zaneb> forgot that new piece of info
20:17:11 <SpamapS> as in, 8/11 is 1st day of school at new school for 2 year old..
20:17:15 <tspatzier> yep, do not make it depend on my schedule
20:17:19 <SpamapS> 8/12 is 1st day at new school for 4 year old..
20:17:26 <SpamapS> 8/13 is 1st day at new school for 11 year old
20:17:34 <SpamapS> highly stressful week.
20:17:47 <zaneb> does anyone else have a preference?
20:18:08 <zaneb> anyone need/want to work with shardy and stevebaker at the meetup?
20:18:42 <zaneb> lifeless: does the TripleO team have a preference on whether you get shardy+stevebaker only or all of us?
20:18:50 <stevebaker> I'm assuming the heat meetup will be mostly about convergence?
20:19:14 <zaneb> I think that will be a big part, but not the only part
20:19:15 <mspreitz> Convergence and convergence, I expect
20:19:50 <stevebaker> tripleC
20:20:12 <zaneb> the other data point is that SpamapS can potentially bring some of his new team if we have it in August
20:20:18 <mspreitz> I meant that a meeting that late will probably be also talking about getting to a coherent end-point
20:21:04 <SpamapS> Right.
20:21:06 <zaneb> mspreitz: heh, terminology overload
20:21:55 <mspreitz> So I'm hearing questions but not a lot of answers from people about attendance
20:21:56 <lifeless> zaneb: I don't think so - its a working event not a planning event for us
20:22:38 <mspreitz> When does the bug fixing push begin?
20:22:43 <zaneb> so, one one hand, it'd be good to have a meetup with the people who will be working on Convergence
20:23:01 <zaneb> otoh, it sucks to have that conversation without shardy and stevebaker in the room
20:23:20 <SpamapS> So it's not a time to have big conversations.
20:23:26 <SpamapS> It is a time to land code.
20:23:31 <randallburt> punt and try again with more planning in k?
20:23:36 <stevebaker> I shall be there in spirit
20:23:50 <SpamapS> We should actually be planning the K mid cycle now too.
20:24:01 <randallburt> SpamapS:  +1
20:24:06 <tspatzier> +1
20:24:09 <zaneb> +1
20:24:17 <BillArnold> +1
20:24:20 <mspreitz> #agreed no second meetup
20:24:34 <mspreitz> #agreed start planning K early
20:24:41 <zaneb> wait, what are we +1'ing?
20:24:52 <SpamapS> Since the summit is in .fr .. and mid-cycle is in the winter.. I suggest we host it in Los Angeles. :) Unfortunately, HP has no facility here. ;)
20:25:04 <tspatzier> zaneb: to plan a k mid-cycle meet up early
20:25:04 * randallburt was only agreeing with early planning for the k mid-cycle.
20:25:16 <SpamapS> zaneb: that we shouldn't wait until the summit to start planning the mid-cycle.
20:25:23 <randallburt> punting on this mid-cycle still seems to be up in the air.
20:25:29 <zaneb> that's what I thought
20:25:36 <mspreitz> Oh
20:25:41 <mspreitz> Let me do this carefully
20:25:52 <zaneb> mspreitz: I think you can do #undo
20:25:58 <mspreitz> #undo
20:25:59 <openstack> Removing item from minutes: <ircmeeting.items.Agreed object at 0x2690c50>
20:26:05 <mspreitz> #undo
20:26:06 <openstack> Removing item from minutes: <ircmeeting.items.Agreed object at 0x2365550>
20:26:12 <zaneb> perfect
20:26:22 <mspreitz> who agrees to have just one meetup this cycle, the one with tipleO?
20:26:28 <mspreitz> and who disagrees?
20:26:49 <mspreitz> separately we will talka bout K
20:26:51 * zaneb is on the fence
20:27:20 * randallburt is on the same fence
20:27:20 <zaneb> SpamapS: what's your gut instinct?
20:27:48 <stevebaker> As someone who is not going, I think a second meetup is a good idea. SpamapS can get some momentum going on convergence in an environment less intense than Summit
20:27:58 <SpamapS> zaneb: If it is only me pulling people to the separate meetup, I say just have the one.
20:28:36 <SpamapS> But it is also (potentially, unconfirmed) a few more HP developers that can only come to the later one, and shadower.
20:29:00 <SpamapS> So even if just me and shadower and 3 guys from Bangalore got together somewhere for 3 days, I'd be for doing it.
20:29:36 <SpamapS> Because we get a lot of clarity from pair-programming on real code.
20:29:56 <randallburt> SpamapS:  you need one more guy then ;)
20:29:59 <mspreitz> If Rackspace continues to be willing to host, I see no reason to squash
20:30:06 <zaneb> ok, I'm starting to lean toward August
20:30:08 <randallburt> RedHat was hosting
20:30:11 <SpamapS> randallburt: there's always somebody on break. Union rules. ;)
20:30:16 <randallburt> last I checked.
20:30:18 <zaneb> mspreitz: yeah, Red Hat
20:30:19 <mspreitz> sorry, mixed up my Rs
20:30:32 <zaneb> I'm told that's not a problem
20:30:45 <mspreitz> If we have a willing host and some willing attendees, then let's go ahead
20:31:15 <zaneb> ok
20:31:22 <mspreitz> I move for unanimous consent to have the August meetup too
20:31:34 <randallburt> sounds good to me then. Will need a pretty solid agenda soon, though.
20:31:38 <zaneb> what do people think about duration? 3 days?
20:31:46 <randallburt> no more than 3 IMO.
20:31:58 <SpamapS> right, 3 working days is good.
20:32:03 <zaneb> this would be week of Aug 19-23
20:32:11 <zaneb> so maybe 19-21
20:32:28 <SpamapS> Tu - Th, maximum family convenience. ;)
20:32:30 <mspreitz> Wed--Fri
20:32:57 <mspreitz> (I was just translating dates)
20:33:18 <mspreitz> Agreement on Tu--Th ?
20:33:30 <zaneb> oops
20:33:35 <zaneb> I actually meant 18-20
20:33:46 <zaneb> ie Mon-Wed
20:33:50 <mspreitz> Aug 18 is Monday
20:33:53 <zaneb> but if people are happy with Tue-Thu
20:33:56 <mspreitz> I goofed too
20:34:15 <SpamapS> M-W is fine .. any day that week is fine.
20:34:20 <zaneb> forgot I put the dates in etherpad as Tu-F
20:34:30 <mspreitz> Does anybody have a preference?
20:35:03 <zaneb> ok, let's go M-W
20:35:26 <mspreitz> going ... going ...
20:35:34 <zaneb> I'll attempt to book the space and then make an announcement on the ML
20:35:47 <mspreitz> #agreed have the second meetup, Aug 19--21
20:36:01 <mspreitz> Next: K
20:36:13 <zaneb> #action zaneb book space for the meetup and then make an announcement on the ML
20:36:20 <mspreitz> Do we agree to plan an early mid-cycle meetup in K?
20:36:32 <zaneb> +1
20:36:35 <BillArnold> +1
20:36:44 <randallburt> yes
20:36:51 <randallburt> at least I hope we do
20:37:00 <stevebaker> Brisbane?
20:37:11 <mspreitz> That planning to be done during a Heat session at the summit?
20:37:32 <zaneb> or before
20:37:47 <zaneb> but we probably don't need to do it right now
20:37:51 <mspreitz> During a meeting in the runup to the summit?
20:38:13 <zaneb> let's dump this responsibility on the next PTL ;)
20:38:25 <tspatzier> stevebaker: Brisbane would be interesting. Or Wellington?
20:38:48 <mspreitz> Remind me: when is election result, compared to meeting cessation before summit?
20:38:57 <zaneb> tspatzier: I'm guessing you've never flown from Germany to NZ before ;)
20:39:13 <stevebaker> tspatzier, I'd be happy to host, but believe me, flights would be complicated and expensive
20:39:21 <zaneb> mspreitz: iirc it's a couple of weeks before
20:39:30 <tspatzier> zaneb, stevebaker: I can imagine ;-)
20:39:48 <mspreitz> I'm OK with dumping this on the next PTL then.
20:39:53 <mspreitz> Any objection?
20:40:17 <zaneb> certainly not from me ;)
20:40:50 <mspreitz> #action ${next PTL} before summit plan an early mid-cycle meetup
20:41:09 <mspreitz> #topic critical issues
20:41:20 <mspreitz> Anybody got any?
20:41:23 <zaneb> #action add mid-cycle meetup planning to Heat PTL guide on wiki
20:41:54 <zaneb> #link https://bugs.launchpad.net/heat/+bug/1331720
20:41:56 <uvirtbot> Launchpad bug 1331720 in heat "missing TripleO heat metadata" [Undecided,In progress]
20:41:57 <SpamapS> We had the one critical issue
20:42:05 <zaneb> that ^ seems to be breaking everyone today :(
20:42:06 <SpamapS> yeah that one
20:42:13 <SpamapS> in the gate now
20:42:16 <zaneb> my bad
20:42:23 <SpamapS> well
20:42:32 <SpamapS> I think it is time to have cfn API tempest tests
20:42:45 <SpamapS> pretty simple to catch this one.
20:42:47 <mspreitz> +1
20:42:59 <SpamapS> I will take that action
20:43:02 <zaneb> and also time to have native APIs for in-instance stuff
20:43:19 <SpamapS> since I've written a non-boto based CFN API implementation already in os-collect-config
20:43:24 <stevebaker> SpamapS, they should be implemented as tempest boto thirdparty
20:43:29 <SpamapS> zaneb: we have native API's for in-instance
20:43:32 <mspreitz> zaneb: what do you mean by that?
20:43:48 <SpamapS> stevebaker: boto's cfn is _entirely_ broken
20:44:03 <SpamapS> hence os-collect-config :)
20:44:11 <zaneb> signalling to waitconditions goes through the cfn API, and that sucks
20:44:18 <SpamapS> zaneb: not anymore
20:44:20 <zaneb> also, alarms
20:44:24 <zaneb> orly?
20:44:40 <stevebaker> SpamapS, once custom images can be built os-*-config can be tested. https://review.openstack.org/#/c/92731/
20:44:46 <zaneb> why are you still using the cfn api then?
20:44:58 <zaneb> not that I am going to complain if you write tests for it
20:45:22 <mspreitz> SpamapS: a bit of explanation please?
20:45:23 <SpamapS> zaneb: https://git.openstack.org/cgit/openstack/heat/tree/heat/api/openstack/v1/resources.py
20:45:59 <SpamapS> zaneb: because this hasn't landed yet https://review.openstack.org/#/c/94527/
20:46:26 <zaneb> ah, excellent
20:46:37 <SpamapS> mspreitz: we didn't used to have native ways of inspecting meta-data or sending signals. stevebaker fixed that
20:46:39 <stevebaker> until tokens get re-used, cfn will be quicker
20:46:47 <zaneb> signal() needs a docstring ;)
20:46:58 <SpamapS> stevebaker: right, the patch chain leading up to that is implementing an on-disk token cache. :)
20:47:08 <stevebaker> SpamapS, \o/
20:47:16 <stevebaker> I need to go now, school run
20:47:32 <zaneb> I think we are about done anyway
20:47:38 <SpamapS> TripleO reviewers are buried tho.. so unfortunately it will take some time. :-P
20:47:59 <mspreitz> Anything else on this topic?
20:48:31 <SpamapS> nay say I unto thee
20:48:40 <mspreitz> #topic opens
20:48:48 <mspreitz> Anybody want to raise anything else?
20:49:07 <SpamapS> Please review specs!
20:49:25 <SpamapS> if you have not done so yet, add heat-specs to your subscribed repos
20:49:47 <tspatzier> +1 SpamapS - that's what everyone should do!
20:49:58 <zaneb> #info if you have not done so yet, add heat-specs to your subscribed repos
20:50:14 <zaneb> that's one for the minutes ;)
20:50:23 <mspreitz> OK, done.
20:50:29 <mspreitz> Anything else?
20:50:38 <zaneb> mspreitz: excellent job, thank you sir
20:50:46 <mspreitz> I have one item myself
20:51:17 <mspreitz> I have a bug regarding a combo: flat DHCP nova networking, new autoscaling group, scale up webhook fails
20:51:29 <mspreitz> is any body or bot testing this?
20:51:41 <BillArnold> mspreitz bug #?
20:51:53 <mspreitz> one other factor: giving network name to OS::Nova::Server
20:52:14 <mspreitz> #link https://bugs.launchpad.net/heat/+bug/1327406
20:52:17 <uvirtbot> Launchpad bug 1327406 in nova "The One And Only network is variously visible" [Undecided,In progress]
20:53:26 <mspreitz> I'm not clear on what the gate is testing in this neighborhood
20:55:03 <mspreitz> Pathology is this: scale up webhook -> nova call whose context says is-admin = false -> no networks visible -> lookup name fails
20:55:27 <zaneb> so it's a problem with the trust-token?
20:55:33 <mspreitz> I think that last part is a Nova bug, but maybe there is also a problem with Heat or Keystone or Nova wrt trusts here
20:55:50 <zaneb> or the problem is that we're not using the trust-token when we should be?
20:56:02 <mspreitz> A trust is being made and used
20:56:11 <mspreitz> but by the time it gets into Nova it has is-admin=false
20:56:26 <mspreitz> webhook hit causes trust to be translated into token
20:56:35 <mspreitz> when nova gets that token the context says is-admin=false
20:57:11 <zaneb> this single-flag-for-admin-ness needs to diaf
20:57:41 <zaneb> mspreitz: I suggest you talk to shardy
20:57:55 <zaneb> he is expert in the ways of keystone
20:58:03 <mspreitz> zaneb: thanks
20:58:14 <mspreitz> time winding down
20:58:30 <mspreitz> last call
20:59:02 <mspreitz> #endmeeting