12:02:10 <shardy> #startmeeting heat
12:02:11 <openstack> Meeting started Wed Jun 25 12:02:10 2014 UTC and is due to finish in 60 minutes. The chair is shardy. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:02:14 <openstack> The meeting name has been set to 'heat'
12:02:21 <shardy> #topic rollcall
12:02:23 <tspatzier> hi all
12:02:27 <mspreitz> here
12:02:29 <shardy> hi all, who's around?
12:02:30 <pas-ha> o/
12:02:35 <nikunj2512> Hi everyone
12:02:44 <tspatzier> shardy: I think zaneb said last week that he would be out Mo-Wed
12:02:53 <BillArnold__> hi all
12:03:01 <shardy> Oh yeah, and therve was supposed to run the meeting!
12:03:12 <shardy> therve: sorry, I forgot, do you want to take over?
12:03:12 <therve> Hi! :)
12:03:18 <therve> shardy, Please continue :)
12:03:22 <shardy> :)
12:03:47 <dkoper> I'm here. Dies Koper. First time here.
12:03:50 <Qiming> o/
12:03:58 <shardy> dkoper: Hi, welcome!
12:04:14 <andrearosa> Hi all
12:04:42 <avquadri> Hi All. First time me too
12:04:52 <shardy> Hi avquadri, welcome!
12:04:57 <shardy> Ok, lets get started
12:05:01 <shardy> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda
12:05:15 <shardy> #topic review last weeks actions
12:05:26 <shardy> #link http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-06-18-20.00.html
12:05:43 <shardy> zaneb book space for the meetup and then make an announcement on the ML
12:05:48 <shardy> I think that was done
12:06:09 <shardy> #info zaneb booked space for heat mid-cycle meetup and announced on ML
12:06:14 <therve> I saw the email
12:06:28 <shardy> ${next PTL} before summit plan an early mid-cycle meetup
12:06:35 <shardy> Ok I guess that's ongoing
12:06:45 <shardy> #info ongoing action ${next PTL} before summit plan an early mid-cycle meetup
12:06:59 <shardy> add mid-cycle meetup planning to Heat PTL guide on wiki
12:07:06 <shardy> Not sure if that happened..
12:07:40 <shardy> #action zaneb add mid-cycle meetup planning to Heat PTL guide on wiki
12:07:59 <shardy> Anything else from last meeting?
12:08:16 <shardy> #topic Adding items to the agenda
12:08:26 <shardy> Anyone have anything to add?
12:08:40 <mspreitz> How about an action to put a link to that Heat PTL guide somewhere that can be found?
12:08:59 <shardy> mspreitz: it should be linked from https://wiki.openstack.org/wiki/Heat
12:09:17 <mspreitz> shardy: as far as I can tell, it is not
12:09:30 <therve> shardy, I added some items in the wiki already about specs
12:09:31 <shardy> mspreitz: I know, that's why I just actioned zaneb to do it again
12:09:40 <shardy> mspreitz: it's not been done yet
12:10:04 <shardy> therve: yup, saw those, thanks
12:10:20 <shardy> #topic Mid-cycle meetup
12:10:21 <mspreitz> shardy: I meant "#action put link to PTL guide in Heat wiki page"
12:10:48 <shardy> #action zaneb put link to PTL guide in Heat wiki page
12:11:07 <shardy> poor Zane is getting all the actions today ;)
12:11:18 <shardy> I'll add a link if I can find it
12:11:45 <shardy> So zaneb posted info about the mid-cycle meetup, does anyone have anything they want to discuss about it?
12:11:46 <mspreitz> A link from the agenda page to the project page would not be bad either
12:11:54 <pas-ha> #link https://wiki.openstack.org/wiki/Heat/PTLGuide#Mid-cycle_Meetup
12:11:57 <mspreitz> just for convenience
12:11:58 <therve> Put your names on https://etherpad.openstack.org/p/heat-juno-midcycle-meetup
12:12:02 <shardy> mspreitz: feel free to add it :)
12:12:43 <shardy> pas-ha: thanks, I hadn't seen that
12:13:08 <pas-ha> could you repeat what would be the focus of the meetup? convergence drafting/crafting?
12:13:31 <shardy> #info Heat mid-cycle meetup confirmed
12:13:36 <shardy> #link http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg27516.html
12:13:58 <shardy> pas-ha: That is tbc, but it will be more about doing work than planning
12:14:02 <jyoti-ranjan> Hi, I am first time here
12:14:10 <shardy> jyoti-ranjan: hi, welcome
12:14:21 <jyoti-ranjan> Do we have any link where we have agenda for meet-up?
12:14:28 <jyoti-ranjan> I did not find at https://wiki.openstack.org/wiki/Heat/PTLGuide#Mid-cycle_Meetup.
12:14:37 <therve> There is no agenda, except "Do stuff"
12:14:42 <shardy> jyoti-ranjan: not yet, the exact agenda is still tbc
12:15:06 <jyoti-ranjan> I understand, thanks
12:15:22 <shardy> depends on what folks want to do, but I expect update enhancements and convergence will feature prominently
12:15:57 <pas-ha> updates - cool :)
12:16:07 <therve> Althought that should happen at the previous one too
12:16:45 <shardy> therve: Yeah, myself and stevebaker will be at the tripleo meetup to represent heat
12:16:53 <therve> shardy, Sweet
12:16:57 <shardy> I won't be at the heat-specific event unfortunately
12:17:03 <shardy> not sure about stevebaker
12:17:33 <shardy> Ok lets defer further meetup planning for when zaneb is back next week
12:17:39 <shardy> #topic Spec backlog: review items, have a spec review day
12:17:48 <shardy> therve: care to take this one?
12:17:54 <therve> Yes
12:18:11 <therve> I talked to ttx about our spec repository
12:18:22 <therve> We have some backlog, nothing to worry about, but we should start kicking it a bit
12:18:43 <therve> I told him we were a bit afraid of the first merge or so it seemed :)
12:19:00 <shardy> therve: Yeah I agree, although with specs generally (not just heat) I worry there's the risk of rat-holing on details before there is any code
12:19:10 <therve> He suggested to have a review day so that we can all talk about it and just land them
12:19:23 <therve> shardy, Yeah that's one issue
12:19:34 <shardy> It's good to have details, but we don't want the process to introduce huge overhead, just get consensus on the direction and top-level design
12:19:37 <therve> I think we should emphasize that you can make the specs evolve
12:19:45 <therve> It's not like we print them on stone tablets
12:19:57 <shardy> therve: +1, get the outline agreed, then push it
12:20:06 <shardy> revise if necessary if the implementation evolves
12:20:21 <therve> Yeah it'd be nice to keep them somewhat in sync
12:20:36 <shardy> folks reviewing the code should check that the spec reflects roughly what has been implemented
12:21:01 <BillArnold__> therve +1, necessary to keep specs in sync with implementation
12:21:10 <pas-ha> how one should ref the new spec in the commit?
12:21:21 <shardy> pas-ha: reference the blueprint
12:21:25 <mspreitz> Do we keep spec in line with impl going forward?
12:21:31 <shardy> then the spec should be linked from the blueprint
12:21:35 <pas-ha> looks like it would be roundtrip gerrit-launchpad-gerrit
12:21:36 <andrearosa> shardy: if we see that the code is not impelmenting what is defined in the specs we should cahnge the specs? it doesn't seem to me correct
12:21:58 <therve> pas-ha, If there are too many round trips it means you don't know what you're doing :)
12:22:00 <shardy> mspreitz: yes, that's what was just mentioned
12:22:10 <mspreitz> Indefinitely?
12:22:25 <therve> mspreitz, No just until the bp has been implemented
12:22:48 <shardy> mspreitz: No, I think it's just a sanity-check thing, where if folks propose one thing, and implement something substantially different, reviewers pick it up when reviewing the code
12:23:08 <mspreitz> thanks
12:23:15 <shardy> mspreitz: ultimately the spec represents a "design document" of sorts, so it's worthless if it's completely different to the code
12:23:25 <shardy> IMO we should resist super-detailed specs though
12:23:40 <mspreitz> ultimately, I'd like to have maintained design docs, but I thin that's too much to ask here now
12:23:44 <tspatzier> shardy: +1
12:24:17 <shardy> tspatzier: IMO your action-aware-sw-config one strikes a good balance
12:24:18 <andrearosa> shardy: I agree with that but the code can't diverge too much from the specs
12:24:31 <tspatzier> thanks shardy :-)
12:24:43 <shardy> detailed discussion of the use-case and interfaces, consideration of backwards compatibility, but not too many details on the exact implementation
12:25:05 <shardy> #link https://review.openstack.org/#/c/98742/
12:25:09 <tspatzier> yep, otherwise we end up in a waterfall model
12:25:10 <shardy> everyone copy tspatzier ;)
12:25:44 <shardy> therve: so you think we need a review-day, or just a general push to get things merged?
12:25:59 <shardy> The convergence stuff looks mostly nearly there, I need to revisit it
12:26:10 <therve> shardy, Maybe lt's give it another week, and if nothing moved we can talk during the next meeting?
12:26:21 <shardy> therve: Ok, sounds good
12:26:40 <shardy> #info reviewers to review specs, revisit progress at next meeting
12:27:29 <shardy> #topic Discuss spec approval deadline
12:27:39 <therve> Something that came up during project meeting
12:27:53 <shardy> therve: so you're thinking we need a feature proposal freeze for specs?
12:27:56 <therve> Nova is adopting some deadlines around specs
12:28:11 <avquadri> In case anyone wants to contribute for testing the heat, is their any testplan or test case document available?
12:28:19 <therve> A proposal one and a approval one, I think an email has been sent
12:29:29 <shardy> IMO for big features we do need a proposal one, but I wouldn't want to block small features which are posted near FPF just because they need a spec
12:29:49 <therve> #link http://lists.openstack.org/pipermail/openstack-dev/2014-June/038475.html
12:30:04 <therve> So we talked about it during the meeting, and I don't think we need this
12:30:10 <mspreitz> particularly if we get picky about requiring a spec for anything that changes observable behavior
12:30:17 <therve> Projects are free to choose their policy, fwiw
12:30:36 <shardy> therve: FWIW I think that is too early for heat
12:30:42 <therve> So I suggest not having specific deadlines outside of the Feature proposal freeze
12:31:09 <shardy> If simple specs get proposed early in J3 I'd be OK with that, provided they don't impact too much existing code
12:31:31 <therve> Yeah I feel we can have small enough spec that it doesn't matter
12:31:50 <therve> Nova already has a 154 specs backlog, so has to set some expectations
12:32:07 <shardy> therve: +1, Ok well I guess it's up to zaneb to have the final say on this, but I don't think strictly aligning with the nova timetable makes sense for heat
12:32:22 <therve> shardy, agreed
12:32:27 <tspatzier> +1
12:33:05 <therve> That's all I had :)
12:33:46 <shardy> #topic Critical issues sync
12:34:08 <shardy> So we had some gate-affecting issues, I know therve fixed one, and stevebaker posted a fix for another
12:34:14 <mspreitz> Has anybody successfully exercised an OS::Heat::AutoScalingGroup whose member type is a nested stack?
12:34:33 <shardy> Anyone else have any critical issues to raise?
12:34:34 <therve> mspreitz, My example used to work some weeks ago
12:34:47 <shardy> mspreitz: we need a tempest test for it IMO
12:34:51 <Qiming> Hi, I have got another issue for the team to consider, not a new one
12:35:00 <therve> shardy, stevebaker problem has been reverted first, no?
12:35:03 <Qiming> it is actually about scenario test
12:35:13 <mspreitz> shardy: Yes, I think we need to get Tempest exercising some of the heat-templates
12:35:26 <shardy> therve: my patch exposed a race, but didn't cause it, so it got reverted
12:35:46 <therve> Ah so there is an underlying bug
12:35:50 <shardy> therve: last night stevebaker found a fix to the DB session lockup which was related to lock stealing on delete
12:35:58 <therve> Cool
12:36:04 <shardy> therve: Yeah, my code just made things run faster, so it broke more regularly
12:36:21 <therve> Less cool
12:36:22 <therve> :)
12:36:26 <BillArnold__> shardy that means your token patch is back?
12:36:36 <shardy> therve: https://review.openstack.org/#/c/102377
12:36:38 <therve> Qiming, yeah?
12:36:55 <shardy> BillArnold__: it's queued after that one I just posted
12:37:01 <shardy> so it's coming back ;)
12:37:03 <Qiming> there are many scenarios where simple unit tests are not adquate to find problems
12:37:24 <shardy> Qiming: The answer is more tempest tests
12:37:31 <Qiming> these scenarios can be treated as heat-very-very-slow, e.g. softwareconfig, autoscaling ...
12:37:46 <shardy> I've been working on some, but getting them in is proving extremely slow and frustrating
12:38:02 <shardy> Qiming: That's what the tempest heat-slow job is for
12:38:09 <shardy> it already has an autoscaling test
12:38:16 <shardy> (not for the native resources yet)
12:38:21 <Qiming> okay, just don't know how slow is that :)
12:38:41 <shardy> https://github.com/openstack/tempest/tree/master/tempest/scenario/orchestration
12:38:43 <mspreitz> shardy: what is making it slow and frustrating to land more heat-slow tests?
12:39:15 <Qiming> an example is that a recent patch to ceilometer broke autoscaling, though the original intent was to make metadata matching capable of handling 'or' clauses ...
12:39:16 <shardy> someone just asked about test plans - tempest is the place to look, although it's not a "plan" as such
12:39:26 <shardy> mspreitz: lack of tempest-core reviewer attention
12:40:03 <shardy> my most recent attempt at adding a new test has taken three months so far
12:40:27 <mspreitz> shardy: I presume lack of attention slows down landing of all sorts of tempest tests. Ugh!
12:40:39 <shardy> Qiming: IMO, every time we have a functional regression, we should add a new test in tempest to catch it
12:40:50 <mspreitz> shardy: +1
12:40:59 <mspreitz> I was going to sugget that myself
12:41:01 <Qiming> shardy, but 3 months is terrible ...
12:41:07 <BillArnold__> shardy, +1, in that case the bug was a ceilometer bug
12:41:09 <avquadri> shardy, thanks. any document on adding a new tempest test would be appreciated. will help in getting started
12:41:16 <shardy> Qiming: Then tag it as Related-Bug to the original bug in the commit, e.g like
12:41:19 <shardy> https://review.openstack.org/#/c/90143/
12:41:31 <Qiming> got it
12:41:42 <mspreitz> But how do we solve this problem: (a) regression discovered; (b) new test proposed --- and rejected because it fails!
12:41:53 <shardy> avquadri: The best thing is looking at reviews like the one I posted above, also tempest documentation is OK
12:42:21 <therve> mspreitz, Considering what shardy just talked about regarding lack of review attention, it shouldn't be a problem
12:42:27 <shardy> mspreitz: fix regression, propose tempest test, test accepted so we catch it next time
12:42:48 <avquadri> thanks
12:42:51 <mspreitz> shardy: but that means there is no testing that the test actually catches the regression
12:43:11 <shardy> I actually think the whole model of having tempest-core review all projects test-cases is broken, but that's another discussion
12:43:21 <shardy> mspreitz: testing that is up to the test author
12:43:45 <mspreitz> shardy: there is no annotation that means "expect this to fail until bug NNN is fixed" ?
12:43:46 <therve> Like other unit tests really
12:44:05 <shardy> mspreitz: Or, you could post it before the fix, see it fail, then recheck after the fix lands
12:44:30 <shardy> mspreitz: Yeah, there is also a skip_because(bug...) decorator in tempest, but you're not allowed to land skipped tests
12:44:38 <mspreitz> shardy: it's obvious that the test author can test once, I was just thinking about whether something a little more robust is possible/desirable
12:44:58 <shardy> mspreitz: given the review latency, probably not at this point
12:45:07 <therve> We haven't had that problem yet, let's just write tests and see
12:45:12 <shardy> therve: +1
12:45:25 <shardy> Ok, 15mins left, any other things to discuss?
12:45:44 <shardy> #topic open discussion
12:46:14 <therve> The oslo.messaging patch is ready for me, any additional testing would be welcome
12:46:30 <therve> I hope it won't stay around too long because it's costly to maintain
12:46:48 <shardy> #link https://review.openstack.org/#/c/99648/
12:47:02 <shardy> #info oslo messaging patch about to land, please test/review it
12:47:05 <pas-ha> could core team take a look at new Sahara resources? https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/sahara-as-heat-resource,n,z
12:47:12 <avquadri> any tips for new contributors for heat?
12:47:51 <therve> avquadri, Review patches, fixes small bugs
12:48:04 <therve> Have a look at heat-templates and try to run them
12:48:12 <andrearosa> small bugs are tagged as low-hanging-fruit?
12:48:13 <shardy> avquadri: and do reviews, it will help you get familiar with the code, and reduce the time your patches wait for review
12:48:15 <therve> Read documentation carefully :)
12:48:31 <pas-ha> get to know gerrit and git review :)
12:48:32 <avquadri> thanks a lot :)
12:49:08 <shardy> avquadri: https://wiki.openstack.org/wiki/Heat/DevelopmentProcess
12:49:53 <avquadri> thanks, these things should get us started
12:49:55 <shardy> avquadri: Mostly they're not, but perhaps we should start doing that
12:50:12 <shardy> avquadri: If you need help finding small bugs, come ask in #heat
12:50:32 <shardy> Ok, anything else or shall we wrap things up?
12:50:42 <avquadri> great ... sure
12:51:21 <shardy> Actually, I have one thing, someone said to me it's weird that we have #heat now we're integrated
12:51:35 <shardy> Does anyone thing we should move to a #openstack-orchestration or something?
12:51:44 <therve> No :)
12:51:55 <shardy> I don't have strong opinions about it, just passing on an observation ;)
12:51:59 <mspreitz> I really don't care.
12:52:03 <shardy> therve: fair enough ;)
12:52:25 <mspreitz> It's all random enough I have to look it up until I learn
12:52:27 <therve> We could open the channel and redirect to #heat though
12:52:32 <shardy> mspreitz: neither does anyone who knows what the channel is already, it's about making it more discoverable for new folks I guess
12:52:44 <mspreitz> There's a wiki page for that
12:52:58 <mspreitz> That's what I was saying, I look up in wiki page rather than trying to guess
12:53:05 <BillArnold__> shardy openstack-heat would be easy to type
12:53:37 <shardy> BillArnold__: yeah, it's just like ceilometer moved to #openstack-metering after integration
12:53:38 <mspreitz> and #orchestration would be pointless, but rounds out the quartet that any guesser would start with
12:54:00 <shardy> anyway, probably not important, let's leave it as something to think about ;)
12:54:11 <therve> shardy, It didn't ?
12:54:31 <pas-ha> actually for conformity with other projects it should be openstack-heat
12:54:44 <jyoti-ranjan> Yes, it good to aling rest of Openstack world like openstack-heat.
12:54:48 <mspreitz> #link https://wiki.openstack.org/wiki/IRC
12:54:56 <shardy> therve: Oh, am I wrong? I thought they moved.
12:55:15 <therve> shardy, Well it's openstack-ceilometer, maybe they move from ceilometer
12:55:35 <Qiming> #openstack-metering points to the same channel
12:55:58 <therve> Qiming, No?
12:55:59 <shardy> Ok, lets stay in #heat and look into getting a redirect to align with other projects then
12:56:32 * shardy is regretting bringing up this topic
12:56:43 <therve> Heh
12:56:47 <Qiming> :)
12:56:54 <shardy> Ok, let's leave it at that, thanks everyone!
12:56:58 <shardy> #endmeeting