20:01:12 <zaneb> #startmeeting heat
20:01:13 <openstack> Meeting started Wed Jul 16 20:01:12 2014 UTC and is due to finish in 60 minutes.  The chair is zaneb. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:16 <openstack> The meeting name has been set to 'heat'
20:01:42 <zaneb> still accepting volunteers to chair, btw
20:01:54 <zaneb> #topic roll call
20:02:01 <shardy> o/
20:02:03 <tspatzier> hi
20:02:07 <jasond> o/
20:02:14 <iqbalmohomed> Hello
20:02:15 <andrearosa_home> hey
20:02:16 <skraynev> o//
20:02:21 <vijendar> hi
20:02:24 <jpeeler> hi
20:03:29 <zaneb> #topic Review action items from last meeting
20:03:32 <stevebaker> here, but completely out of touch
20:03:42 <zaneb> shardy, jasond and randallburt to discuss pluggability of WaitCondition implementations
20:03:54 <zaneb> we had a discussion on the mailing list
20:04:02 <ryansb> here
20:04:08 <zaneb> I don't know that it resulted in any conclusion
20:04:09 <jasond> unfortunately randallburt is out
20:04:23 <shardy> zaneb: my understanding was that for now jasond and I would align the properties and we'd possibly do the pluggable transports thing later
20:04:33 <jasond> +1
20:04:52 <zaneb> ok
20:04:59 <shardy> given that there wasn't clear consensus over the deployer choosing one implementation in all situations
20:05:13 <zaneb> #topic Adding items to the agenda
20:05:20 <zaneb> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-07-16_2000_UTC.29
20:05:44 <zaneb> anybody got something to add to the agenda?
20:06:13 <skraynev> may be problem with constraint validation :)
20:06:20 <zaneb> :(
20:06:26 <skraynev> or I may ask it later
20:06:27 <bgorski> o/
20:06:37 <zaneb> #topic Juno-2 release
20:07:01 <zaneb> the J-2 milestone is next week
20:07:22 <zaneb> unfortunately I am away from tomorrow until Tuesday
20:07:37 <zaneb> so I need a volunteer that russellb can pester about it
20:07:48 <russellb> o/
20:07:54 <shardy> zaneb: I'm happy to do it, unless anyone else is keen
20:07:55 <zaneb> the process is a lot simpler than it used to be
20:08:07 <russellb> the task is to make sure the juno-2 roadmap in launchpad is beated down until everything that's left is implemented
20:08:08 <zaneb> russellb: shardy can be your victim :)
20:08:12 <russellb> excellent
20:08:26 <zaneb> I'll try to get online at some point
20:08:30 <stevebaker> russellb: are you ttx?
20:08:36 <russellb> for juno-2, yes
20:08:44 <zaneb> but I'll be travelling on Tuesday, so availability is uncertain
20:09:08 <zaneb> afaik there is nothing urgent, anyway
20:09:17 <zaneb> stuff either makes it or it doesn't
20:09:25 <zaneb> which brings me to...
20:09:28 <russellb> ok
20:09:32 <russellb> would like to aim for tuesday then
20:09:44 <zaneb> #topic Juno-2 blueprints
20:09:44 <russellb> and tag then unless there's something you really want to wait for
20:09:55 <shardy> #link https://launchpad.net/heat/+milestone/juno-2
20:10:04 <zaneb> damn, too slow
20:10:12 <shardy> ;D
20:10:30 <zaneb> if you have a blueprint on this list, please update its status
20:10:46 <zaneb> I updated randallburt's for him yesterday
20:11:22 <zaneb> I'm bumping mine to j-3 right now :/
20:11:58 <zaneb> we also have three High priority bugs not assigned
20:12:06 <shardy> Anyone know how to run the docs job for contrib resources locally?
20:12:19 <zaneb> bug #1299259 	FloatingIP needs a hidden dependency on Routers
20:12:21 <uvirtbot> Launchpad bug 1299259 in heat "FloatingIP needs a hidden dependency on Routers" [High,Triaged] https://launchpad.net/bugs/1299259
20:12:21 <shardy> I need to fix that for my Ironic plugins...
20:12:28 <ryansb> shardy: I don't, but if you'd like to teach me I can write it up
20:12:42 <zaneb> stevebaker: any interest in grabbing that one?
20:12:53 <stevebaker> zaneb: sure
20:13:06 <zaneb> sold
20:13:06 <shardy> ryansb: thanks, I'll trawl the logs and work out how to do it ;)
20:13:25 <zaneb> thanks stevebaker
20:13:51 <zaneb> bug  	#1302578 	Required credentials are missing when heat-engine calls heatclient operations
20:13:52 <uvirtbot> Launchpad bug 1302578 in heat "Required credentials are missing when heat-engine calls heatclient operations" [High,Triaged] https://launchpad.net/bugs/1302578
20:14:08 <stevebaker> I'll add client-plugins to j-2 and give it a push for the rest of this week
20:14:32 <zaneb> ok
20:14:48 <shardy> We've not really made any progress on fixing abandon/adopt - anyone know if vijendar is working on any of the problems?
20:15:14 <stevebaker> shardy: cd docs ; make clean html
20:15:16 <vijendar> shardy: I have not started working on that
20:15:25 <vijendar> shardy: I will start on that next week
20:15:29 <zaneb> this one (#1302578) is auth + software config... I'll let stevebaker & shardy fight over it ;)
20:15:42 <stevebaker> its his fault!
20:16:02 <stevebaker> (haven't seen it yet)
20:16:38 <zaneb> stevebaker: and yet you commented on it extensively ;)
20:16:47 <zaneb> bug #1301486 	Stack update on "OS::Nova::Server" resource fails due instance port still in use
20:16:48 <uvirtbot> Launchpad bug 1301486 in heat "Stack update on "OS::Nova::Server" resource fails due instance port still in use" [High,Triaged] https://launchpad.net/bugs/1301486
20:16:55 <zaneb> this is waiting on a fix in nova
20:16:59 <stevebaker> oh, that
20:16:59 <zaneb> so I will bump to j-3
20:17:00 <skraynev> zaneb: wait solution from nova
20:17:06 <shardy> ugh, standalone mode :(
20:17:29 <stevebaker> shardy: I have an idea, should be reasonably easy
20:17:29 <skraynev> zaneb: +1 for moving to j-3
20:17:41 <zaneb> shardy: is it really High priority then?
20:17:48 <shardy> stevebaker: Ok, cool, let me know if there's anything I can help with
20:17:53 <shardy> zaneb: not IMO, no
20:18:06 <shardy> (disclaimer, I've never used standalone mode..)
20:18:07 <zaneb> ok, dropped to medium
20:18:14 <zaneb> that solves that problem ;)
20:18:45 <shardy> I'll propose a fix for the stack domain project abandon thing tomorrow
20:19:12 <zaneb> if anyone has a blueprint they expect to get merged before Tuesday and it is *not* in the list, please let me know *today* after the meeting
20:19:17 <shardy> but that doesn't fix the adopt part of it ref bug #1301314
20:19:19 <uvirtbot> Launchpad bug 1301314 in heat "Abandon/adopt don't consider project" [Medium,Triaged] https://launchpad.net/bugs/1301314
20:19:52 <shardy> zaneb: The native waitcondition series, if we manage to get the rest of the reviews done
20:20:03 <shardy> I guess I'll move it back if the reviews happen in time
20:20:32 <zaneb> shardy: ok, I'll let you target it and give it a priority
20:20:57 <shardy> zaneb: Ok, thanks
20:21:35 <zaneb> #topic Gap analysis
20:21:47 <zaneb> #link https://etherpad.openstack.org/p/heat-gap-analysis
20:21:59 <zaneb> the TC did the gap analysis yesterday
20:22:06 <zaneb> results here:
20:22:15 <zaneb> #link http://eavesdrop.openstack.org/meetings/tc/2014/tc.2014-07-15-20.03.html
20:22:44 <zaneb> overall, we are in excellent shape
20:22:55 <zaneb> tl;dr "more tests"
20:23:11 <zaneb> some of which are already in progress
20:23:33 <shardy> zaneb: easy to say but the experience of actually getting stuff into tempest is not good :(
20:23:59 <zaneb> I made that point in the etherpad
20:24:09 <stevebaker> we should keep an eye on efforts to allow our tempest tests to live in the heat tree
20:24:20 <shardy> stevebaker: +1000
20:24:22 <zaneb> apparently there was a ML thread about maybe moving the tests out into individual projects in the medium term
20:24:34 <zaneb> I would support that
20:24:50 <shardy> IMO that makes far more sense, at least then we'd have some control over the review wait
20:25:08 <jpeeler> yes, good stuff
20:25:17 <zaneb> yep, but I don't think that is going to happen in the short term
20:25:29 <stevebaker> having tests closer to the code would probably lead to more contributions too
20:25:34 <shardy> e.g we've just been bitten my a volume attachment regression for a second time because it's taken 4 months to get my test not merged
20:25:47 <shardy> stevebaker: +1
20:26:02 <zaneb> anyway, I have to create a plan for closing the gaps
20:26:13 <zaneb> I'll certainly mention the issue there
20:26:28 <skraynev> stevebaker: what about scenario tests? I see, that autoscaling test is still skipped :(
20:26:33 <zaneb> #action zaneb create plan for issues identified in gap analysis
20:26:55 <zaneb> there was also one minor housekeeping thing - add the mission statement to the governance repo
20:27:24 <zaneb> that should be a fun review
20:28:14 <stevebaker> skraynev: I have a change to unskip it, but I need to check how working it is currently https://review.openstack.org/#/c/44967/
20:28:53 <skraynev> stevebaker: ok, thx
20:29:33 <zaneb> #topic Stevedore for resource plugins
20:29:52 <zaneb> asalkeld is not about so there's probably no point having this discussion today
20:30:40 <stevebaker> I haven't read the ml thread since I replied
20:31:16 <zaneb> I was happy with the compromise where we used Stevedore Hooks instead of Extensions
20:31:31 <zaneb> but it's not clear that we reached a consensus on that
20:31:31 <stevebaker> is there a patch?
20:31:56 <zaneb> there was before the discussion already, and it has not (yet) changed as a result
20:32:32 <stevebaker> ok
20:32:39 <shardy> stevebaker: https://review.openstack.org/#/c/103044/
20:33:36 <zaneb> last comment was "Zane, you must have a really sucky editor if this is hard:-O"
20:34:00 <zaneb> oddly enough it was him who convinced me to switch to vim
20:34:21 <shardy> lol
20:34:22 <zaneb> I never did learn anything about vim plugins though
20:34:39 <zaneb> the packaging was too hard to figure out...
20:34:48 <zaneb> #topic Critical issues sync
20:35:02 <zaneb> who has critical issues?
20:35:14 <skraynev> may I ?
20:35:35 <zaneb> you may :)
20:36:35 <skraynev> we already have patch about related problem with validation https://review.openstack.org/#/c/93080 , when one resource has dependence from other one which is not created too
20:37:42 <skraynev> this fix works only for basic constraints. If I try to use custom constraint it raises error StackValidationFailed: Property error : port1: network Error validating value u'None': Unable to find network with name 'None'
20:38:01 <zaneb> imo we really need to split validation that can be done statically out from validation that can only be done at create time
20:38:07 <zaneb> and give them different names
20:38:17 <zaneb> it's incredibly confusing atm
20:38:51 <stevebaker> we need to do something. Its silly that we're validating things which are not there
20:38:56 <zaneb> and this was a mistake we've been making continuously for 2 years already
20:40:11 <skraynev> so it should be two different validations (before creating and during creating), right?
20:40:34 <zaneb> yes
20:41:02 <zaneb> validate_structure and validate_data, or something
20:41:34 <skraynev> should current fix be rejected?
20:42:01 <skraynev> and should be created BP for this or will be enough bug?
20:42:32 <zaneb> I don't think the fix should be rejected
20:42:54 <zaneb> a bp would be nice; I'd say no spec required at this stage though
20:43:27 <shardy> zaneb: so we're not mandating specs for all new features then?
20:43:31 * shardy wasn't sure
20:43:54 <skraynev> ok, and what about custom constraints ?
20:44:06 <zaneb> think of specs as replacing the link to the wiki in the old system
20:44:17 <shardy> zaneb: Ok, thanks
20:44:38 <zaneb> they don't replace blueprints, they're there for when you need more info than fits in launchpad comfortably
20:44:48 <skraynev> should fix for them be add in existing patch or we create one more?
20:44:49 <zaneb> or when it needs sider discussion
20:45:06 <stevebaker> zaneb: if we create a spec, do we still create the bp in lp?
20:45:06 <shardy> zaneb: Ok, cool, I just wasn't sure if they were now a neccary precursor to a BP
20:45:16 <shardy> good to know they're not for simple BP's :)
20:45:25 <shardy> necessary even
20:45:29 <zaneb> stevebaker: yes
20:45:47 <zaneb> there was a plan at one point to create the bps in launchpad from the specs using a script
20:45:59 <zaneb> but that doesn't appear to be happening any time soon
20:46:20 <zaneb> in any event, every approved spec will need a blueprint
20:46:36 <zaneb> so just create one
20:46:53 <andrearosa_home> please put as much information as you can in the BP, even if it's simple for newcomers is a good starting point for understanding the context
20:47:27 <zaneb> skraynev: in the same patch or same series is fine.
20:47:52 <skraynev> zaneb: got it, thx :)
20:47:59 <zaneb> skraynev: I'm surprised custom constraints are failing though, given that validate_constraints() is not being called at all
20:48:20 * zaneb shrugs
20:48:26 <zaneb> #topic open discussion
20:48:38 <zaneb> anything else before we wrap up?
20:49:49 <zaneb> tumbleweeds
20:50:03 <zaneb> thanks everyone!
20:50:04 <skraynev> zaneb: I am not sure, that it so clear. Just got this error, when was testing fix. need more digging to understand root of problem
20:50:29 <zaneb> o/
20:50:32 <zaneb> #endmeeting