12:00:39 <zaneb> #startmeeting heat
12:00:40 <openstack> Meeting started Wed Aug  6 12:00:39 2014 UTC and is due to finish in 60 minutes.  The chair is zaneb. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:43 <openstack> The meeting name has been set to 'heat'
12:01:21 <zaneb> tspatzier: interested in chairing today?
12:01:31 <tspatzier> zaneb: sure
12:01:41 <asalkeld> zaneb, getting weary of the chair
12:01:47 <zaneb> #chair tspatzier
12:01:47 <openstack> Current chairs: tspatzier zaneb
12:01:55 <mspreitz> hi
12:01:58 <BillArnold> hi
12:02:08 <tspatzier> zaneb: ok, let's see how I do ;)
12:02:09 <Qiming> o/
12:02:15 <zaneb> asalkeld: it's 8am, hard enough to just function normally ;)
12:02:15 <openstack> tspatzier: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
12:02:21 <skraynev> hey :)
12:02:27 <pas-ha> o/
12:02:28 <asalkeld> 10pm here
12:02:29 <bgorski> o/
12:02:39 <zaneb> tspatzier: I already started the meeting, but I set you as a chair
12:02:50 <tspatzier> ok
12:02:58 <tspatzier> #topic rollcall
12:03:10 <asalkeld> o/
12:03:12 <BillArnold> hi
12:03:15 <skraynev> again?))
12:03:50 <tspatzier> sorry guys, doing this the first time, so bare with me ;)
12:04:20 <mspreitz> I'll keep my clothes on, if you don't mind
12:04:28 <tspatzier> #topic Review last week's actions
12:04:34 <zaneb> ugh, I didn't create the agenda for this week
12:04:45 <pas-ha> and there were no actions
12:04:55 <skraynev> tspatzier: norm, do not worry :)
12:05:08 <tspatzier> there were no actions :)
12:05:23 <tspatzier> so moving on
12:05:31 <tspatzier> #topic adding items to the agend
12:05:34 <tspatzier> #topic adding items to the agenda
12:05:43 <zaneb> hmm, we should have had an action for stevebaker to update the gap closing wiki page
12:05:55 <pas-ha> btw, speaking of actions = what happened to Rax CI/CD job? is it on?
12:06:04 <tspatzier> according to the log there was none
12:06:05 <zaneb> #action zaneb check with stevebaker about progress on gap coverage plan
12:06:50 <tspatzier> ok, regarding the agenda: https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-07-30_2000_UTC.29
12:06:54 <tspatzier> anything to add?
12:07:08 <tspatzier> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-07-30_2000_UTC.29
12:07:15 <zaneb> that's last week's
12:07:22 <tspatzier> damn
12:07:38 <ryansb> https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-08-06_1200_UTC.29
12:07:42 <zaneb> #link: https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-08-06_1200_UTC.29
12:07:42 <ryansb> ftfy
12:07:54 <zaneb> I just added it like 1 minute ago
12:07:55 <asalkeld> how do we keep up with the convergence meetup?
12:08:03 * zaneb is not very organised this week
12:08:49 <zaneb> asalkeld: you mean the heat meetup, not the tripleo meetup right?
12:08:55 <asalkeld> yip
12:09:04 * asalkeld feeling left out
12:09:19 <asalkeld> might be hard given the tz difference
12:10:16 <zaneb> ok, let's put that on the agenda
12:10:25 <tspatzier> doing it right now...
12:10:33 <zaneb> it's going to be a short meeting anyway, I suspect :)
12:11:27 <tspatzier> #topic Keeping up to date on the Heat mid-cycle meet-up
12:11:43 <tspatzier> so this is the only topic before critical issues synch
12:11:57 <asalkeld> given the large review list, is there a way for us to priortise reviews?
12:12:12 <asalkeld> (so I can focus my reviewing ...)
12:12:15 <zaneb> btw, small announcement: if you are going to the meetup, check my mailing list post and make sure you are signed up
12:12:40 <zaneb> otherwise security will bounce you
12:13:22 <ryansb> zaneb: checked + signed in. Is starting at 9am still the plan?
12:13:27 <zaneb> yep
12:13:55 <zaneb> ryansb: in your case, bring your employee badge an you'll have no trouble ;)
12:13:58 <skraynev> zaneb: sound like you have iron man as security :)
12:14:22 <ryansb> zaneb: Yup. It lives in my suitcase so I won't forget it.
12:14:35 <zaneb> ryansb: smart :)
12:14:53 * ryansb has a problem with forgetting identification when going places
12:15:13 <zaneb> asalkeld: so etherpads would be one way for folks to keep up
12:15:28 <zaneb> but as you said, with the time zones it's going to be tricky
12:15:33 <asalkeld> zaneb, yip was thinking of that
12:15:45 <asalkeld> what is planned?
12:15:48 <zaneb> what parts are you interested in following?
12:15:55 <ryansb> maybe do a bluejeans sync-up either early morning or late evening to accomadate tz's?
12:16:00 <asalkeld> in general
12:16:10 <asalkeld> but maybe the cont. observer
12:16:19 <zaneb> ok
12:16:27 <tspatzier> I'll be on vacation, so would be interested to read things afterwards. etherpads?
12:16:48 <zaneb> I think the idea is to actually start hacking, more than to just talk about stuff again
12:17:17 <zaneb> so maybe daily pushes of working branches to e.g. GitHub might help as well
12:17:32 <asalkeld> review is better
12:17:36 <asalkeld> wip
12:17:44 <tspatzier> so reviews for everyone to stay up to date
12:18:29 <zaneb> #info try to push WIP reviews during meetup so non-attendees can follow along at home
12:18:50 <BillArnold> zaneb +1 that would be very helpful
12:18:58 <ryansb> +1
12:18:59 <skraynev> may be make sense to have one common tag for these reviews? it will allow search easier
12:19:22 <asalkeld> also a "how to run", so we can give it a go and help out
12:19:30 <zaneb> skraynev: that's a great idea
12:19:31 <asalkeld> 24hr hacking
12:20:08 <skraynev> asalkeld; sounds awesome :)
12:20:37 <skraynev> asalkeld: and a little crazy ;)
12:20:49 <asalkeld> just don't want a massive code dump on the reviews that I know nothing about
12:21:13 <asalkeld> it's better to get involved early
12:21:18 <zaneb> #info use branch name "juno-midcycle" to ensure easy filtering of reviews
12:21:28 <skraynev> zaneb: thx
12:21:45 <tspatzier> great, sounds like we have a plan. anything else on this topic?
12:22:25 <tspatzier> so moving on ...
12:22:33 <tspatzier> #topic Critical issues sync
12:23:00 <tspatzier> is there anything critical at the moment?
12:23:58 <tspatzier> does not seem so
12:24:06 <tspatzier> #topic open discussion
12:24:19 <tspatzier> does anyone have anything?
12:24:29 <mspreitz> I wouldn't mind a little follow-up to last week's beating over ASG health
12:25:00 <mspreitz> I have a plan B to discuss
12:26:21 <mspreitz> khkhkjhkj
12:26:31 <mspreitz> ok then..
12:26:41 <mspreitz> Plan B is in two parts...
12:27:07 <mspreitz> one is to get LB pool member health info into Ceilometer samples; that is not Heat work
12:27:19 <mspreitz> the other part is a stop-gap while waiting for automatic convergence...
12:27:51 <mspreitz> What do you think of this idea: let a scaling group do a check for undermined members and remove them, as part of a resize
12:28:16 <mspreitz> undermined = the underlying thing has been deleted, leaving a record in the Resource table whose nova_instance refers to no existing thing
12:28:25 <mspreitz> ?
12:28:41 <zaneb> mspreitz: we know we need something to allow the application to choose members to delete on scale-down, so this may tie in with that
12:29:19 <mspreitz> zaneb: I think these can be mods to distinct parts of the code...
12:29:42 <mspreitz> my mod affects the list of existing members handed to the method that produces the new template; Bill's part modifies that method.
12:29:43 <zaneb> yeah, I saw your definition of 'undermined' after I wrote that
12:30:30 <zaneb> so the 'stack check' reviews are I think close to landing
12:30:45 <mspreitz> although, maybe, there is one little interaction..
12:30:54 <zaneb> it would make sense to me if the autoscaling code used something like stack check to check for member health during scaling operations
12:31:11 <mspreitz> the scale down plugin will be given a list of members already decided to remove; maybe that should include ones detected as undermined.
12:31:33 <mspreitz> OK, I'll look at those
12:33:12 <zaneb> #link https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/stack-check,n,z
12:33:39 <mspreitz> thanks for the link
12:33:53 <zaneb> np
12:35:01 <mspreitz> I am done
12:35:06 <mspreitz> with that topic
12:35:10 <tspatzier> mspreitz: I think you and BillArnold had some specs. Are they current?
12:35:23 <tspatzier> I mean specs on that topic ...
12:35:31 <mspreitz> I think the spec about autoscaling across AZs is current
12:35:40 <mspreitz> I will let Bill speak to his
12:36:00 <ryansb> What's the current status of the config change for qpid? Did that go out yesterday?
12:36:05 <BillArnold> Yes, scaledown plugpoing is current
12:36:12 <mspreitz> My network is flaky right now, can not do much with openstack.org
12:36:54 <tspatzier> ok, so that might be worth looking at.
12:37:07 <tspatzier> #link https://review.openstack.org/#/c/110379
12:37:09 <zaneb> ryansb: is this upstream, or in RDO?
12:38:15 <ryansb> I think RDO, but I'm not sure, lemme dig up the bug.
12:39:19 <BillArnold> tspatzier also stack lifecycle plugpoint spec - https://review.openstack.org/#/c/106468/
12:39:32 <zaneb> ryansb: this is probably the wrong forum to discuss then
12:39:59 <ryansb> zaneb: right, it is.
12:40:02 <ryansb> Sorry
12:40:04 <tspatzier> BillArnold: that one actually looks pretty complete to me.
12:40:14 <zaneb> ryansb: np, we can discuss after
12:40:23 <tspatzier> #link https://review.openstack.org/#/c/106468/
12:40:58 <tspatzier> ^^if some cores could look at this if this is good to go?
12:41:14 <tspatzier> anything else for this meeting?
12:41:57 <tspatzier> no - then thanks everyone!
12:42:03 <asalkeld> zaneb, what's up with the plugin stuff? should I dump that
12:42:17 <asalkeld> tspatzier, you can end it
12:42:21 <tspatzier> ok
12:42:24 <asalkeld> we can chat in #heat
12:42:24 <tspatzier> #endmeeting