12:03:32 <asalkeld> #startmeeting Heat
12:03:32 <openstack> Meeting started Wed Sep  3 12:03:32 2014 UTC and is due to finish in 60 minutes.  The chair is asalkeld. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:03:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:03:36 <openstack> The meeting name has been set to 'heat'
12:03:53 <asalkeld> right haven't done this for ages
12:04:04 <asalkeld> shardy, o/
12:04:09 <skraynev> https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-09-03_1200_UTC.29
12:04:16 <shardy> Hey guys, sorry, bit late
12:04:33 <asalkeld> I am just getting the agenda
12:04:34 <bgorski> you are just in time
12:04:37 <ryansb> log from last time: http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-08-27-20.00.txt
12:05:05 <skraynev> ryansb: thx :)
12:05:06 <asalkeld> #topic review actions
12:05:11 <KanagarajM> i have topic to discuss for the review https://review.openstack.org/#/c/110557/, could some one bring this to today's agenda
12:05:21 <shardy> Item to add is probably review of J3 status, unless it's already been added
12:05:25 <asalkeld> were there any actions?
12:05:41 <ryansb> looks like the only actions were
12:05:51 <ryansb> 1) stevebaker raise bugs for rstrip(None) issue from ask.openstack
12:06:09 <ryansb> and 2) review the mission statement https://review.openstack.org/#/c/116703/
12:06:20 <asalkeld> not sure steveb's around
12:06:38 <asalkeld> everyone had a look at the mission?
12:06:41 <ryansb> right, this is the week it's at a ridiculous time for him
12:06:56 <asalkeld> let's move on
12:07:06 <asalkeld> #topic new agenda items
12:07:15 <asalkeld> shardy, ...
12:07:47 <asalkeld> let's do that now
12:07:48 <shardy> asalkeld: Yeah we should probably review https://launchpad.net/heat/+milestone/juno-3
12:08:06 <asalkeld> #topic review juno-3
12:08:16 <asalkeld> all your shardy
12:08:19 <asalkeld> your's
12:09:07 <shardy> So the two I spotted which probably need a status update:
12:09:10 <shardy> https://blueprints.launchpad.net/heat/+spec/cancel-update-stack
12:09:11 <shardy> and
12:09:13 <asalkeld> pas-ha,
12:09:27 <asalkeld> looked quite risky
12:09:27 <shardy> https://blueprints.launchpad.net/heat/+spec/troubleshooting-low-level-control
12:09:47 <shardy> I looked at the reviews and neither looked like imminent merge candidates
12:09:47 <pas-ha> shardy, yes, i think I just nailed it. will post new patch asap
12:10:06 <asalkeld> cool
12:10:08 <shardy> pas-ha: Ok, cool, if you think it's ready, lets try to get it reviewed and gating asap
12:10:19 <shardy> asalkeld: I saw you had concerns re the patch update
12:10:27 <shardy> thing we'll be deferring that one?
12:10:33 <shardy> s/thing/think
12:10:37 <asalkeld> I don't know
12:10:48 <asalkeld> I just not a big fan of it
12:10:57 <asalkeld> but if someone thinks it's ok
12:11:05 <asalkeld> then i don't mind
12:11:46 <asalkeld> do we really need a bp for the funct. tests?
12:11:59 <asalkeld> not at all production effecting
12:12:17 <shardy> asalkeld: I think it's just a way of tracking progress
12:12:29 <shardy> so a BP is appropriate, but a spec is not
12:12:35 <shardy> (IMO at least)
12:12:52 <asalkeld> ok
12:13:33 <shardy> pas-ha: is anything blocking https://blueprints.launchpad.net/heat/+spec/handle-update-for-security-groups other than reviews?
12:13:49 <pas-ha> shardy, no
12:14:31 <shardy> Same question re https://blueprints.launchpad.net/heat/+spec/implement-ec2eip-updatable but I'm not sure tiantian is around
12:15:12 <shardy> Ok I guess that's all the BP's, are there any bugs there (or not targetted) which can't wait until RC1?
12:15:37 <shardy> we have a couple of weeks after J3 to go into test/bugfix mode, so we will defer any bugs not fixed today until RC1
12:16:02 <asalkeld> that's what rc's are for ?
12:16:03 <shardy> So if you find a critical issue, please mark it as such and target it to J3, so we know it's a blocker
12:16:18 <asalkeld> shardy, how is your bp?
12:16:26 <shardy> asalkeld: Yeah, but if possible, we don't want to release J3 with any known critical issues
12:16:38 <asalkeld> sure
12:16:48 <shardy> asalkeld: Better after your help, but I'm still working on the rest of the series
12:16:51 <asalkeld> is says implemented, but i know better;)
12:17:02 <asalkeld> ok
12:17:04 <shardy> asalkeld: It does?
12:17:19 <asalkeld> yip
12:17:24 <shardy> https://blueprints.launchpad.net/heat/+spec/decouple-nested
12:17:39 <shardy> It's Beta Available, deferred to RC1, pending a FFE
12:17:55 <asalkeld> ok, i was looking at nested
12:18:04 <shardy> I'll try to get the patches in shape, then we can have a discussion about whether it makes sense to push for a FFE or just defer to Kilo
12:18:21 <shardy> asalkeld: Yeah list-nested is done (other than a heatclient patch, which isn't part of J3)
12:18:44 <shardy> Ok, anyone have anything else re J3 or the release process in general?
12:19:16 <asalkeld> maybe a link, i should read up on it
12:19:21 <shardy> ok then, thanks all :)
12:19:30 <asalkeld> #topic Can we have a grenade testing update
12:19:38 <asalkeld> i put this in
12:19:45 <shardy> asalkeld: be PTL for a cycle, you'll soon get the hang of it :D
12:20:00 <asalkeld> :-O
12:20:13 <shardy> asalkeld: Ok, so I posted this patch $months ago:
12:20:23 <KanagarajM> shardy: right now this bp targets only the nested stack, how about other resources and app-config,etc ?
12:20:24 <asalkeld> shardy, so you and EmilienM are working on that grenade pathc
12:20:28 <shardy> https://review.openstack.org/#/c/86978/
12:20:50 <asalkeld> #link https://review.openstack.org/#/c/86978/
12:20:52 <shardy> KanagarajM: You mean the decoupling BP?
12:21:01 <KanagarajM> shardy: yes
12:21:23 <asalkeld> KanagarajM, let's keep on topic
12:21:26 <shardy> KanagarajM: well the config and deployment resources are already decoupled, because they're addressed via Rest calls to heat
12:21:29 <shardy> asalkeld: +1
12:21:53 <asalkeld> KanagarajM, you wanted to talk about: https://review.openstack.org/#/c/110557/
12:21:58 <KanagarajM> yes
12:22:00 <asalkeld> i'll change topic
12:22:03 <shardy> The grenade thing, so we've been drip fed some reviews, and EmilienM has helped get it working
12:22:08 <asalkeld> #topic https://review.openstack.org/#/c/110557/
12:22:13 <shardy> but basically, I/we need help getting it actually merged
12:22:18 <EmilienM> shardy: hey
12:22:28 <KanagarajM> this patch is summited for the cloumn name change and its been suggested to support 'zero downtime migration'
12:22:45 <shardy> I've got limited experience with grenade, and don't really know how to push it further, given that so far I've failed to get it working locally at all
12:23:12 <KanagarajM> right now no service support for  'zero down time migration' for this one.
12:23:42 <asalkeld> thanks shardy
12:23:55 <asalkeld> KanagarajM, we chatted about this in #heat
12:24:05 <asalkeld> i said there:  seems like a cosmetic change really
12:24:05 <asalkeld> and potentially effecting upgrades
12:24:05 <asalkeld> we *really* need to plan how we are going to tell users to upgrade to minimise downtime
12:24:05 <asalkeld> I think we need a summit session on how to achieve this
12:24:27 <KanagarajM> yes
12:24:30 <asalkeld> do others feel the same/different
12:24:45 <ryansb> +1 (definitely worth a summit session)
12:24:50 <unmeshg> +1
12:24:51 <skraynev> +1
12:24:52 <pas-ha> +1
12:24:54 <shardy> asalkeld: I agree, and in the meantime, limiting disruptive non-functional migrations seems like a reasonable step
12:24:57 <BillArnold_> +1
12:25:06 <asalkeld> ok, cool
12:25:19 <KanagarajM> ok, shall i summit for design session in K ?
12:25:25 <asalkeld> #agreed limiting disruptive non-functional migrations seems like a reasonable step
12:25:32 <KanagarajM> i will come with initial approach i have identified
12:25:40 <asalkeld> KanagarajM, you/me/someone else
12:25:51 <asalkeld> we will get a session there
12:26:00 <asalkeld> for upgrades in general
12:26:17 <asalkeld> KanagarajM, we can move on?
12:26:22 <KanagarajM> ok. i will update my findings and share you all .
12:26:27 <KanagarajM> yes sure. THanks
12:26:38 <asalkeld> any other topics?
12:26:48 <asalkeld> #topic open discussion?
12:26:58 <asalkeld> free for all
12:27:14 <BillArnold_> we need this patch in keystone client https://review.openstack.org/#/c/118383/
12:27:20 <ryansb> remember to review the mission statement if you haven't already https://review.openstack.org/#/c/116703/
12:27:31 <shardy> BillArnold_: Is that a backwards-incompatible regression in the keystone API?
12:27:36 <BillArnold_> y
12:27:42 <shardy> it sounded like it from the bug
12:27:44 <BillArnold_> shardy y
12:27:48 <shardy> :(
12:28:05 <shardy> Are they planning to fix the API, or just paper over it in the client?
12:28:36 <BillArnold_> shardy i don't know, was investigating it enough yesterday to get some tests working again
12:29:21 <shardy> BillArnold_: Ok cool, I'm glad we've solved the heat issue, just concerned about the wider issue of the API change
12:29:43 <mspreitz> shardy: right, this sounds like a serious botch
12:29:53 <shardy> it looked from the docs like keystone were doing minor version deprecations without any corresponding bump to the actual API version
12:30:15 <shardy> was looking for clarification as to whether that was actually the case
12:30:20 <ryansb> (sad versioning trombone plays)
12:30:55 <shardy> anyway, probably a bit OT for here, I'll ask ayoung or jlennox later
12:31:04 <KanagarajM> https://review.openstack.org/#/c/118383/, keystone work with both region and region_id in juno for backward compatibility
12:31:24 <asalkeld_> sorry, flaky wifi
12:31:53 <KanagarajM> and i have patched it keystone for region and region_id. but its worth to make this change in the middleware as well in juno, though we have backward compatibility
12:33:41 <asalkeld_> all we all done, so fast? nothing else...
12:33:45 <unmeshg> I would like to get comments regarding the approach for moving check calls to Observer https://review.openstack.org/118143
12:34:58 <unmeshg> please give it a look and leave comment if anything looks incorrect
12:35:18 <asalkeld_> unmeshg, i think after the releases are done we will all be very keen to look
12:35:37 <asalkeld_> everyone is maybe a bit push for time atm
12:35:58 <unmeshg> ok
12:36:21 <asalkeld_> shardy, anything else?
12:36:40 <shardy> asalkeld_: not from me
12:36:50 <asalkeld_> #endmeeting
12:36:50 <skraynev> shardy: re https://review.openstack.org/#/c/116615/, I thought about our idea with handling error for different versions
12:37:01 <skraynev> ok I will continue in #heat ;)
12:37:15 <asalkeld_> i think my new nick has no powers:(
12:37:32 <asalkeld> #endmeeting