20:02:01 <zaneb> #startmeeting heat
20:02:02 <openstack> Meeting started Wed Sep 10 20:02:01 2014 UTC and is due to finish in 60 minutes. The chair is zaneb. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:06 <openstack> The meeting name has been set to 'heat'
20:02:23 <mspreitz> o/
20:02:24 <zaneb> #topic roll call
20:02:28 <tspatzier> hi
20:02:30 <stevebaker> \o
20:02:32 <shardy> Hi all
20:02:33 <tango> Hi
20:02:43 <zaneb> does anybody want to chair this week?
20:02:59 <jpeeler> hi
20:02:59 <zaneb> I have a cold & definitely not feeling it right now
20:03:24 <pas-ha> hi
20:03:55 <zaneb> one day I will go to a wiki page and not have to log in *again*
20:03:58 <zaneb> one day.
20:04:12 <ryansb> single sign on: where you sign on. Every. Single. Time.
20:04:12 <stevebaker> I think there is a setting for that
20:04:38 <zaneb> stevebaker: excuse me while I go look for that right now
20:04:43 <SpamapS> ryansb: #winning
20:05:55 <stevebaker> ok, I can chair
20:06:02 <zaneb> #topic Review action items from last meeting
20:06:07 <zaneb> #chair stevebaker
20:06:08 <openstack> Current chairs: stevebaker zaneb
20:06:10 <zaneb> cheers
20:06:31 <zaneb> #link http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-09-03-12.03.html
20:06:34 <zaneb> none!
20:06:41 <zaneb> slackers
20:07:18 <stevebaker> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-09-10_2000_UTC.29
20:07:34 <stevebaker> #topic Adding items to the agenda
20:07:40 <stevebaker> anythunk to add?
20:07:53 <shardy> I wanted us all to sync on FFE's for Juno
20:07:54 <zaneb> I guess a FFE update would be in order
20:08:38 <stevebaker> already added that
20:08:47 <zaneb> sneaky
20:10:17 <stevebaker> #topic Critical issues
20:10:52 <stevebaker> I don't see any burning issues in https://bugs.launchpad.net/heat
20:11:08 <stevebaker> nothing on fire, only smouldering
20:12:29 <ryansb> \o/
20:12:42 <stevebaker> #topic FFE status
20:12:57 <stevebaker> so anything left in juno-rc1 has an FFE
20:13:05 <zaneb> #link https://launchpad.net/heat/+milestone/juno-rc1
20:13:34 <zaneb> pas-ha: I bumped your update-cancel one to next, sorry
20:13:52 <pas-ha> np, I was indeed quite late
20:14:00 <zaneb> the Low priority ones need to be in this week to make it
20:14:09 <zaneb> the rest have until early next week
20:14:24 <zaneb> I'm pretty sure we are very close to landing almost all of them
20:14:36 <shardy> I was looking at one of asalkelds patches earlier: https://review.openstack.org/#/c/103484/
20:14:39 <stevebaker> 2 blueprints that I recall being deferred are https://blueprints.launchpad.net/heat/+spec/implement-autoscalinggroup-availabilityzones and ...
20:14:43 <pas-ha> although I'd reaaly like you to check it, as I've ended up with a way to send arbitrary "signals" into a running thread
20:15:03 <shardy> zaneb: I noticed you'd +2'd it recently, and I nearly approved it, then realized the BP wasn't targetted correctly
20:15:10 <stevebaker> https://blueprints.launchpad.net/heat/+spec/oslo-i18n
20:15:22 <shardy> since we've not discussed FFE's on the list, I wasn't really sure (it's not targetted to RC1)
20:15:37 <zaneb> shardy: what are stevebore-plugins anyway
20:16:14 <stevebaker> shardy and I are stevebores
20:16:23 <shardy> lol :)
20:16:29 <zaneb> TBH I don't even regard that as blueprint-worthy. it's just a refactoring. I would really like that patch in though
20:16:41 <zaneb> less excited about the rest of the series ;)
20:16:52 <stevebaker> does anyone have strong feelings either way about implement-autoscalinggroup-availabilityzones? I commented the following on the bp
20:16:53 <stevebaker> stevebaker: I think the spec and the change need some more review attention before this can land. I'm going to defer to Kilo. If you'd like to apply for a FFE then mail openstack-dev so we can discuss. The intention is to refactor the auto scaling unit tests during juno-rc1 so that it is less painful to add changes like this and blueprint decouple-nested.
20:16:57 <shardy> zaneb: Ok, maybe we just get Angus to remove the typo commit tag then ;)
20:17:16 <zaneb> meh, just ship it
20:17:39 <jpeeler> honestly a url as a commit message body doesn't seem the best either
20:17:56 <jpeeler> but i'm not gonna -1 on that...
20:18:04 <zaneb> stevebaker: I feel we are way late to merge implement-autoscalinggroup-availabilityzones
20:18:37 <mspreitz> I wish it were otherwise, but can not disagree
20:18:50 <zaneb> the patch still needed a lot of work when I last saw it a week and a half ago
20:18:58 <shardy> +1, lets defer and get in into early kilo
20:19:04 <zaneb> ++
20:19:16 <tango> Can we plead for code review for the patches on FFE? :)
20:19:35 <zaneb> tango: yes, I think that's only fair ;)
20:19:40 <stevebaker> tango, absolutely
20:19:44 <shardy> And all the bugs targetted to RC1 which are in-progress, please :)
20:20:04 <stevebaker> #action all to focus review attention to the 3 remaining blueprints on https://launchpad.net/heat/+milestone/juno-rc1
20:21:03 <stevebaker> anything else on FFE?
20:21:23 <zaneb> pas-ha: https://review.openstack.org/#/c/88548/ needs a comment from you
20:22:11 <zaneb> (that is all, carry on)
20:22:13 <pas-ha> yep, seen that, will implement "selective" update tomorrow, less disruptive going it is to be
20:22:27 * pas-ha yoda off
20:22:43 <stevebaker> #topic Integration tests
20:22:45 <zaneb> pas-ha: cool, a comment to that effect will help reviewers :)
20:23:20 <shardy> stevebaker: This is interesting, I thought there was consensus re splitting stuff out of tempest, only then there wasn't based on ML discussions
20:23:36 <shardy> stevebaker: do we have a clear way forward now?
20:25:18 <zaneb> shardy: damn the torpedoes?
20:26:33 <shardy> zaneb: Ha, +1 on that ;)
20:26:45 <stevebaker> There is a desire for integration tests to all be in one place and a need for heat integration tests to be controlled by heat developers. This is one thing which needs to be resolved.
20:26:45 <stevebaker> My last email on that thread proposed what I think we should do, which is
20:27:15 <shardy> While there is some truth to the communication on both sides thing, I hounded folks for reviews for months before finally completely losing the will to live re tempest
20:27:30 <zaneb> write tests first. worry about where they should live later
20:27:35 <stevebaker> heat_integrationtests is where integration tests are written and incubated. Minimal tests which just test integration with other openstack components get duplicated into tempest and get run on the integrated gate
20:27:57 <zaneb> shardy: did you know they had a section of their meeting dedicated to us? I had no idea
20:28:20 <stevebaker> complex tests in heat_integrationtests eventually get full API mocking and get moved to a yet-to-be-created heat_functionaltests
20:28:28 <shardy> zaneb: me neither, nobody ever mentioned it
20:28:39 <zaneb> weird
20:28:47 <stevebaker> new features don't land unless they at very least have something in heat_integrationtests
20:28:57 <stevebaker> mtreinish, are you about by any chance?
20:29:43 <stevebaker> so personally I don't see any blockers to continue reviewing https://review.openstack.org/#/c/110496/ etc while we figure all this out
20:29:44 <zaneb> stevebaker: that may be a little excessive, depending on how you define 'feature'
20:29:57 <stevebaker> zaneb, well, I mean new resources
20:30:14 <zaneb> ah, ok
20:30:46 <mtreinish> stevebaker: yes, what's up?
20:31:19 <stevebaker> mtreinish, we're just discussing heat integration tests, functional tests, and tempest
20:32:23 <stevebaker> mtreinish, did you see my last email on that thread? I've suggested heat_integrationtests is where integration tests are written and incubated. Minimal tests which just test integration with other openstack components get duplicated into tempest and get run on the integrated gate
20:33:15 <shardy> stevebaker: FWIW, I think the most urgent thing is real coverage of actual scenarios, e.g integration between resources and several underlying services
20:33:37 <shardy> e.g scenario tests where we've failed to get any real traction in tempest
20:33:53 <mtreinish> stevebaker: that sounds fine, I think the criteria for what gets run as part of tempest will evolve over time
20:34:07 <mtreinish> because we have such limited coverage right now, it's hard to know what will be a good fit
20:34:10 <shardy> The functional tests for resources thing sounds like a nice-to-have, but mostly should be covered by unit tests (I mean "unit") atm
20:34:35 <mtreinish> but starting with minimal tests for basic integration is a good place to start
20:36:11 <stevebaker> as soon as the first change in https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/functional-tests,n,z lands I'll flatten the others in the series so they depend on master
20:36:41 <shardy> stevebaker: are we waiting on any non-heat patches to make us actually gate on these?
20:36:48 <mtreinish> stevebaker: I also liked the comment at the end about metric based graduation. That's something I've been working on, getting longer term per test data out of the gate.
20:40:33 <stevebaker> shardy, I just need an approve on https://review.openstack.org/#/c/116533/ from someone awesome like clarkb
20:40:33 <stevebaker> that will probably do for now, any other comments on integration tests?
20:40:33 <stevebaker> #topic Open discussion
20:40:46 <stevebaker> I need to do the school run, so my need to leave y'all to it
20:41:03 <zaneb> \o thanks stevebaker
20:41:24 <ryansb> \o stevebaker
20:41:31 <pas-ha> Just running unittests and seeing this "instance_user" option warning. Should we have already removed it?
20:41:59 <stevebaker> that warning should be mocked out
20:42:25 <pas-ha> stevebaker, not since recently again
20:42:28 <shardy> But yes, we probably should given that the warning says to be removed in Juno
20:42:49 <shardy> shadower is probably not around, but I think he added that warning
20:43:10 <shardy> I'll check with him tomorrow and post a patch removing the option if there's no objections?
20:46:42 <zaneb> ok, if nobody has other business, I'm going to wrap it up
20:50:37 <zaneb> #endmeeting heat