20:00:32 <asalkeld> #startmeeting heat
20:00:33 <openstack> Meeting started Wed Oct  8 20:00:32 2014 UTC and is due to finish in 60 minutes.  The chair is asalkeld. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:37 <openstack> The meeting name has been set to 'heat'
20:00:44 <asalkeld> #topic rollcall
20:00:49 <jpeeler> hey
20:00:49 <stevebaker> \o
20:00:51 <topol> o/
20:00:58 <tango> o/
20:01:00 <pas-ha> o/
20:01:01 <spzala> Hi
20:01:08 <CaioBrentano> hi
20:01:09 <dougwig> o/
20:01:20 <asalkeld> zaneb, help - iti's 6am - where is the agenda
20:01:22 <skraynev> o/
20:01:26 <tspatzier> hi
20:01:27 <ryansb> o/
20:01:35 <zaneb> lol
20:01:41 <shardy> o/
20:01:44 <ryansb> https://wiki.openstack.org/wiki/Meetings/HeatAgenda
20:01:45 <asalkeld> no coffee
20:01:51 <stevebaker> agenda == coffee
20:01:54 <zaneb> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-10-08_2000_UTC.29
20:01:59 <asalkeld> yeah
20:02:00 <ryansb> stevebaker: that's just item 1.
20:02:29 <asalkeld> #topic last weeks actions
20:02:31 <zaneb> asalkeld: we should probably put discussing meeting times for Kilo on the agenda
20:02:48 <asalkeld> ok - done
20:03:14 <zaneb> #link http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-10-01-12.01.html
20:03:25 <zaneb> (none)
20:04:02 <asalkeld> yeah - just found that
20:04:05 <asalkeld> moving on
20:04:11 <asalkeld> #topic new items
20:04:23 <zaneb> meeting times for Kilo
20:04:26 <asalkeld> #topic new items to the agenda
20:04:46 <asalkeld> yip - i am agreeing with that!
20:05:44 <asalkeld> i'll add one, cross project duties
20:06:18 <stevebaker> should we spend spare time discussing Paris sessions?
20:06:33 <zaneb> stevebaker: +1
20:06:37 <asalkeld> sure
20:06:41 <tspatzier> good idea, I was wondering when planning starts
20:06:41 <zaneb> it's never too early
20:06:46 <zaneb> sneaks up on you
20:07:04 <asalkeld> ok, let's get into the topics
20:07:25 <asalkeld> #topic meeting times for kilo
20:07:49 <asalkeld> how are these meeting times working for everyone else?
20:08:08 <tspatzier> fine for me
20:08:14 <stevebaker> I don't feel too left out by missing every second one
20:08:17 <ryansb> fine for me (us-east)
20:08:20 <pas-ha> quite fine for me, although 1-2 hours earlier would not hurt
20:08:22 <zaneb> fine for me ;)
20:08:37 <asalkeld> i can do both (6am, 10pm for me)
20:08:48 <shardy> fine for me
20:08:53 <zaneb> but the feedback I got 6 months ago is that folks feel really strongly that the PTL needs to be at both
20:08:55 <asalkeld> maybe someone else can run the 6am one;)
20:09:01 <stevebaker> lol
20:09:11 <stevebaker> 9am here now, I can do some of them
20:09:11 * pas-ha remembers winter time when it is actually going to be 1 hour earlier
20:09:12 <topol> get a clone :-)
20:09:33 <asalkeld> and send him to europe
20:09:49 <stevebaker> how is the attendence at the alt time?
20:10:06 <asalkeld> last week it was smaller
20:10:09 <zaneb> we've trained a few people on how to chair now, so it shouldn't be hard to find someone
20:10:20 <zaneb> stevebaker: typically it's not great
20:10:35 <pas-ha> we should also note that in a 2-3 weeks or so most of the world will shift clocks
20:11:03 <skraynev> pas-ha: not everyone :)
20:11:13 <asalkeld> (the rest of australia has just done that - but not brisbane, cos' we special)
20:11:20 <stevebaker> skraynev: are you in Russia?
20:11:24 <pas-ha> so if AU and asalkeld do it too it is going to be 5am for him
20:11:34 <skraynev> stevebaker: yeah :(
20:11:46 <asalkeld> brisbane doesn't have "summer time"
20:11:47 <stevebaker> skraynev: how are the times for you?
20:11:58 <asalkeld> cos' the weather is always awesome
20:11:58 <pas-ha> asalkeld, fine for you then :)
20:12:02 <pas-ha> tru
20:12:29 <asalkeld> ok, let's leave it until someone has a genius idea
20:12:35 <zaneb> asalkeld: I though it was because daylight savings is a socialist plot?
20:12:42 * asalkeld not genius atm
20:12:49 <asalkeld> :)
20:12:55 <skraynev> stevebaker: I am ok, just this meeting more difficult for me 12 AM - 1 AM, alt meeting is 4 PM (I mean local time)
20:13:00 <ryansb> non-genius idea: how about move meeting one hour later, then it'll become one hour earlier in a month or so.
20:13:13 <ryansb> (due to daylight savings)
20:13:48 <asalkeld> ryansb, maybe - but that just makes it easier for pas-ha
20:13:54 <stevebaker> ryansb: the bottom half of the world goes in the other direction
20:13:57 <pas-ha> yep
20:14:03 <ryansb> hrm. right. Hemispheres.
20:14:06 <ryansb> :(
20:14:08 <asalkeld> it's fine for now
20:14:14 <asalkeld> #topic midcycle meetup
20:14:25 <stevebaker> ryansb: except for Brisbane, because they're "special"
20:14:28 <asalkeld> who can talk to that ^
20:14:43 <mspreitz> Sorry I have to miss this week's meeting, got an overriding meeting.  But remain interested in getting settlement on transition period for HARestarter.
20:15:10 <stevebaker> speaking of special Brisbane, Red Hat could likely host a mid-cycle meetup there
20:15:12 <asalkeld> mspreitz, ok - let's add it to the end
20:15:23 <mspreitz> sorry, I will be driving
20:15:29 <mspreitz> I will have to catch up later
20:15:33 <asalkeld> ok
20:15:39 <mspreitz> but if you guys agree on something great, I will be happy
20:15:47 <asalkeld> in brisbane stevebaker?
20:15:53 <stevebaker> hard for some people to get to, but easy for asalkeld and I
20:15:59 <stevebaker> asalkeld: yes
20:16:02 <asalkeld> no one will come but us
20:16:24 <zaneb> btw kebray_ also offered a rackspace facility of our choice for a mid-cycle
20:16:26 <stevebaker> just an idea. If it is combined with tripleo then there are a bunch of au and nz who would attend
20:16:31 <topol> come back to Raleigh!
20:16:49 <shardy> stevebaker: +1 on a trip to Brisbane ;)
20:16:50 <stevebaker> Austin would be good too
20:16:58 <zaneb> yes, Raleigh was an excellent location imho ;)
20:17:06 * shardy worries about his flight cost
20:17:09 <topol> zaneb +++
20:17:21 <spzala> zaneb: +1 :)
20:17:22 <zaneb> shardy: you won't say that after the plan flight. trust me.
20:17:30 <zaneb> *plane
20:17:32 <asalkeld> ok, maybe an etherpad with venues bla...
20:17:42 <asalkeld> anyone want to drive this?
20:17:49 <shardy> zaneb: Yeah, I've done it before, jet lag was killer
20:17:50 <asalkeld> help with organising
20:18:02 <zaneb> do we want to co-locate with tripleo?
20:18:04 <shardy> sunshine and beer made up for it ;)
20:18:11 <stevebaker> shardy, zaneb: ZERO sympathy
20:18:15 <asalkeld> shardy, we have that here
20:18:33 <shardy> stevebaker: lol ;)
20:18:44 <skraynev> asalkeld: beer and sunshine?
20:18:47 <zaneb> stevebaker: didn't expect any ;)
20:18:53 <asalkeld> skraynev, yip
20:19:04 <stevebaker> probably no compelling reason to co-locate with tripleo at this point
20:19:11 <skraynev> so go to Australia :)
20:19:28 <asalkeld> https://etherpad.openstack.org/p/kilo-heat-midcycle-meetup
20:19:36 <asalkeld> add ideas there ^
20:19:56 <asalkeld> i'll send an email to the mailing list too
20:20:02 <ryansb> #link https://etherpad.openstack.org/p/kilo-heat-midcycle-meetup
20:20:09 <asalkeld> ask for venues/ideas
20:20:37 <asalkeld> i'll move on
20:20:41 <asalkeld> #topic CrossProjectLiaisons
20:20:57 <asalkeld> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
20:21:15 <asalkeld> we need people to sign up
20:21:32 <asalkeld> so if you have an interest, sign up pleaes
20:21:58 <asalkeld> ooo, randall has signed up for docs
20:22:15 <asalkeld> don't know what the question mark is for
20:22:21 <stevebaker> I can do QA
20:22:23 <asalkeld> not a good docs start
20:22:26 <shardy> I can do oslo this time, unless therve is keen to continue
20:22:33 <asalkeld> it's yours
20:22:48 <asalkeld> awesome, done
20:22:51 <asalkeld> that was easy
20:22:54 <asalkeld> phew
20:23:37 <asalkeld> #topic critical issue sync
20:23:54 <stevebaker> are we looking at an rc2?
20:24:02 <zaneb> stevebaker: yes
20:24:07 <stevebaker> kk
20:24:20 <zaneb> https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:proposed/juno,n,z
20:25:02 <zaneb> #link https://review.openstack.org/#/q/project:openstack/heat+branch:proposed/juno,n,z
20:25:10 <zaneb> that's a better link ^
20:25:19 <zaneb> shows the ones that have merged already
20:25:42 <zaneb> I didn't see anything else urgent, but if anybody has something, shout *now*
20:25:55 <asalkeld> not from me
20:26:32 <asalkeld> zaneb, all good? move on?
20:26:42 <zaneb> #link https://launchpad.net/heat/+milestone/juno-rc2
20:26:44 <zaneb> yep
20:26:53 <asalkeld> #topic Request for python-heatclient project to adopt heat-translator
20:27:07 <stevebaker> spzala: yo
20:27:17 <asalkeld> tspatzier, spzala
20:27:18 <spzala> stevebaker: :) Hi
20:27:31 <asalkeld> $topic ^
20:27:38 <zaneb> technically only Programs can adopt projects</boring>
20:27:52 <spzala> I added this in the agenda. Had a quick chat with zaneb and we thought it's good to discuss it in agenda.
20:27:53 <zaneb> so it would be the Heat program doing the adopting
20:28:15 <zaneb> yeah, so I heard no strong objections on the ML?
20:28:30 <asalkeld> i happy for heat to adopt the translator
20:28:33 <zaneb> shardy had some questions, but I believe they're resolved?
20:28:36 <stevebaker> I initially thought that heat-translator should have its on CLI tools to do transforms.
20:28:39 <asalkeld> but is the client the best place?
20:28:50 <asalkeld> stevebaker, +1
20:28:50 <shardy> zaneb: Yeah I think we resolved them on the ML
20:29:07 <zaneb> asalkeld: so at this stage we're just adopting the repo as it is
20:29:18 <asalkeld> ok sounds fine to me
20:29:24 <tspatzier> what would adopt really mean?
20:29:25 <stevebaker> I'm happy for the project to adopt heat-translator, but I don't think python-heatclient should take heat-translator as a dependency and be responsable for transformations
20:29:30 <shardy> I still somewhat thing integrating all-the-things into heatclient is a bit non-unixy, but if that's what folks want then fair enough
20:29:38 <asalkeld> i haven't test driven the code at all tho'
20:29:52 <zaneb> asalkeld: where the code fits in the architecture is still a good discussion for the future though
20:29:52 <shardy> my main concern was the scope not aligning with what heat can do long term etc
20:30:19 <asalkeld> shardy, for now it's just a part of heat program
20:30:25 <spzala> asalkeld: zaneb: agree, we can do a code  walk through somet
20:30:26 <spzala> ime if that's a good idea
20:30:38 <stevebaker> shardy: my idea was that heat-translator would become an anything->anything transformer, not just tosca->hot
20:30:44 <zaneb> tspatzier: it would mean the project officially comes under the OpenStack (and Heat) umbrella
20:30:52 <spzala> stevebaker: that's true
20:31:00 <asalkeld> zaneb, isn't there a checklist you made
20:31:02 <spzala> stevebaker: I remember that's what we discussed when starting the project
20:31:11 <topol> zaneb, I thin its simlar to what identity did with pycadf
20:31:11 <stevebaker> it would move to the openstack/ git namespace
20:31:19 <shardy> stevebaker: Yeah, that's cool, my question was really what happens if $anything is not in scope for heat
20:31:22 <tspatzier> zaneb: ok, thanks. but no big move arounds of code etc, right?
20:31:29 <zaneb> asalkeld: that was being discussed in the TC, but events have overtaken it for now
20:31:29 <shardy> e.g non-simple tosca
20:31:38 <zaneb> topol: yeah
20:31:50 <shardy> then we have a translation tool owned by us which we can't fully maintain
20:31:53 <asalkeld> zaneb, ok - but maybe we run through that anyway?
20:32:03 <zaneb> tspatzier: it moves from stackforge/heat-translator to openstack/heat-translator, and that's about it for now
20:32:10 <stevebaker> shardy: we could consider using stevedore to allow out-of-tree transformations to be integrated with heat-translator
20:32:19 <topol> shardy, the cores for  heat translation dont go anywhere
20:32:38 <tspatzier> shardy: if $anything would be out of scope for heat, it would be out of scope for heat-translator as well by definition, IMO
20:32:46 <shardy> stevebaker: Sure, making it pluggable makes sense
20:32:48 <stevebaker> spzala: are there plans for a command line tool?
20:32:59 <topol> shardy what we did with pycadf is the core for pycadf remained and then all the keystone cores were added to pycadf
20:33:15 <spzala> stevebaker: yes, that's how I see it for now as a commad line tool
20:33:26 <shardy> tspatzier: Ok, provided the output is destined for heat then sounds good to me
20:33:40 <asalkeld> zaneb, what is that thing the tc asks from projcets - what is the core functionality?
20:33:56 <asalkeld> would the translator be a part of that?
20:34:01 <asalkeld> my guess is no
20:34:03 <tspatzier> shardy: I think that's the plan for now. Everything else would have to be a layer on-top.
20:34:09 <zaneb> asalkeld: so the TC doesn't currently have a process for evaluating this
20:34:28 <zaneb> imho it's not out of scope
20:34:29 <topol> asalkeld what dolphm did was add something to a governance doc somehwere
20:34:51 <zaneb> although if I ever finish the mission statement it would be easier to agree on that ;)
20:34:53 <asalkeld> but you gave someone a list of features that work "core" didn't you?
20:34:54 <topol> so pycadf was listed as part of the keystone world
20:35:18 <asalkeld> s/work/were
20:35:32 <dolphm> topol: https://github.com/openstack/governance/blob/master/reference/programs.yaml#L54
20:35:38 <topol> I think there is a process and dolphm would know it
20:35:45 <topol> dolphm, THANKS
20:35:50 <dolphm> topol: just propose changes to openstack/governance
20:35:53 <dolphm> via gerrit
20:35:59 <spzala> thanks dolphm
20:36:08 <zaneb> i.e. no process ;)
20:36:11 <asalkeld> well i don't see any "no don't add it"
20:36:26 <asalkeld> so spzala just send a patch to that i guess
20:36:32 <dolphm> the TC will eventually put it on the agenda for discussion, and might request a mailing list discussion to establish precedence depending on the complexity of the issue
20:36:47 <zaneb> asalkeld: what the TC will look for is agreement from the project
20:36:50 <asalkeld> ok thanks dolphm
20:36:57 <zaneb> which is the purpose of this meeting
20:36:58 <spzala> asalked: patch for the file dolphm just mentioned  ?
20:37:12 <zaneb> so if we're agreed we should #agree to note it in the minutes
20:37:14 <stevebaker> spzala: moving projects might still require gerrit downtime, so you'll need to coordinate with #openstack-infra
20:37:17 <asalkeld> spzala, phew 'what ever is needed'
20:37:30 <spzala> :-)
20:37:45 <asalkeld> #agree add the translator to the orch. progam?
20:37:47 <spzala> stevebaker: sure will do it
20:38:08 <asalkeld> can we see some +/-1's
20:38:10 <asalkeld> +1
20:38:13 <shardy> +1
20:38:14 <tspatzier> +1
20:38:19 <stevebaker> +1
20:38:23 <zaneb> asalkeld: #agree isn't usually a question ;) you're thinking of #vote
20:38:25 <zaneb> +1
20:38:25 <stevebaker> asalkeld: it needs to be #agreed
20:38:29 <spzala> this is great. THANKS everyone!!!
20:38:31 <pas-ha> +1
20:38:34 <jpeeler> +1
20:38:43 <asalkeld> #agreed add the translator to the orch. progam
20:38:49 <skraynev> +1
20:38:50 <ryansb> \o/
20:38:58 * asalkeld seeems to be newbie'ish
20:39:16 <asalkeld> right what's next
20:39:42 <asalkeld> did i miss anything, or is it open discussion time?
20:39:52 <stevebaker> I have a PSA
20:40:04 <asalkeld> a what?
20:40:29 <stevebaker> public service announcement
20:40:40 <zaneb> stevebaker: TMI... oh
20:40:57 <asalkeld> #topic speak stevebaker
20:41:01 <asalkeld> :)
20:41:32 <stevebaker> the check-heat-dsvm-functional job is now running real tests and passing, but it is still non-voting. So please take note of it if it fails on your change.
20:41:43 <asalkeld> ooo, nice
20:41:51 <stevebaker> that is all. Back to your regularly scheduled open discussion
20:41:54 <asalkeld> #topic open discussion
20:42:03 <zaneb> what does dvsm mean?
20:42:12 <shardy> stevebaker: awesome!
20:42:14 <zaneb> I always wanted to know
20:42:16 <ryansb> sweet
20:42:26 <pas-ha> devstack machine?
20:42:32 <stevebaker> zaneb: devstack virtual mumble mumble
20:42:34 <shardy> Perhaps we can get that voting soon, so we don't just revert every test which finds a bug ;)
20:43:09 <zaneb> shardy: that's crazy talk
20:43:42 <skraynev> shardy: may be will be better to have one or two bug days to fiix all these bugs ?:)
20:43:44 <ryansb> Devstack Virtual Something Mumble
20:44:15 <tspatzier> another question: I've seen "-Core-Review" statuses in gerrit recently, i.e. no score or so. What does it mean? Some change in gerrit?
20:44:23 <stevebaker> ah, its dsvm Dev Stack Virtual Machine
20:45:02 <asalkeld> tspatzier, that's stevebaker removing the -2?
20:45:03 <tspatzier> ah, I meant "-Code-Review"
20:45:05 <pas-ha> tspatzier, I believe it was -Code-Review
20:45:17 <tspatzier> pas-ha: :) right
20:45:23 <stevebaker> reverse ban hammer
20:45:38 <tspatzier> so moving from -2 to -1?
20:45:48 <stevebaker> should be -2 to 0
20:45:49 <zaneb> yeah, it does that when you set the vote back to 0
20:46:00 <asalkeld> also don't forget to review specs people
20:46:14 <asalkeld> mike has a bunch that need discussion
20:46:29 <tspatzier> ah, makes sense.
20:46:36 <asalkeld> imho the ha ones need a summit session
20:46:48 <tspatzier> asalkeld: +1
20:46:59 <asalkeld> not convinced about the balancing one either
20:47:07 <zaneb> weren't summit sessions supposed to be on the agenda for today?
20:47:21 <shardy> asalkeld: +1, the ImmediateResource one in particular is a puzzling one
20:47:23 <stevebaker> is this HA of heat or HA of nova servers?
20:47:31 * shardy is still processing that
20:47:32 <tspatzier> zaneb: yeah, when do we start collecting topics?
20:47:36 <asalkeld> guests
20:47:45 <stevebaker> tspatzier: now https://etherpad.openstack.org/p/kilo-heat-summit-topics
20:47:58 <zaneb> #link https://etherpad.openstack.org/p/kilo-heat-summit-topics
20:47:59 <asalkeld> note: also be aware of the cross project one
20:48:14 <tspatzier> stevebaker: thanks
20:48:34 <asalkeld> #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
20:48:54 <asalkeld> that ^ has an HA (but of services)
20:49:19 <stevebaker> for the testing session it would be good to start with tempest, then in-tree integration, then in-tree functional, then unit tests. That way there could be QA folk who can come for the start then leave mid session
20:50:28 <zaneb> stevebaker: I actually wish python-*clients ran our _unit_ tests in their gates
20:50:54 <asalkeld> #action please add topics to the summit topic etherpad
20:51:13 <asalkeld> #action asalkeld send email to ml re: midcycle meetup
20:51:16 <stevebaker> zaneb: I suggested that and the response was outrage
20:51:23 <kebray> hello.. long time since I've been able to join.  just tuning in.
20:51:31 <asalkeld> hi kebray
20:51:32 <zaneb> stevebaker: lol. link?
20:51:42 <zaneb> kebray: o/ :)
20:52:23 <kebray> still open topics?
20:52:28 <asalkeld> yip
20:52:51 <kebray> cool.. so, fyi, we've finally moved off our proprietary orchestration system.. moved all our customers to Heat now.
20:52:59 <stevebaker> zaneb: https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg29660.html
20:53:05 <asalkeld> well done kebray
20:53:17 <kebray> eh, it wasn't me.. but thank you to the team.
20:53:26 <kebray> you all helped too :-)
20:53:36 <zaneb> wow, that's exciting, congrats y'all!
20:53:37 <asalkeld> kebray, feedback would be great too
20:53:50 <asalkeld> operations sticking points etc...
20:53:55 <kebray> I think it's a big win for OpenStack heat.  Yeah. will definitely have some feedback.  Unfortunately I didn't get a talk in to the summit this time.
20:54:18 <zaneb> kebray: maybe we can get that into the operator (or design) summit?
20:54:29 <zaneb> the talk you did last time was really useful
20:54:39 <asalkeld> kebray, https://etherpad.openstack.org/p/kilo-heat-summit-topics
20:54:40 <kebray> thx zaneb ... yeah, I need to refresh it.
20:54:59 <stevebaker> kebray: yay! fyi there is finally action on a chef software-config hook. Now would be a good time to get involved if you're still considering migrating your ChefSolo resources to it
20:55:33 <kebray> k.. makes since stevebaker.  My staff has thinned out a bit :-(  working to build it back up.
20:56:33 <stevebaker> kebray: ok, we're getting closer to everything working on keystone v2 too, by using swift TempURLs
20:56:48 <kebray> nice.
20:57:50 <asalkeld> 3mins left
20:58:46 <stevebaker> sounds like we're out of puff
20:58:51 <asalkeld> yeah
20:58:55 <asalkeld> i am
20:59:07 <asalkeld> i'll put us out of our misery
20:59:09 <zaneb> nap time ;)
20:59:15 <asalkeld> #endmeeting