12:00:02 <asalkeld> #startmeeting heat
12:00:03 <openstack> Meeting started Wed Apr 29 12:00:02 2015 UTC and is due to finish in 60 minutes.  The chair is asalkeld. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:06 <openstack> The meeting name has been set to 'heat'
12:00:22 <asalkeld> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda
12:00:38 <asalkeld> #topic rollcall
12:00:49 <shardy> o/
12:01:00 <asalkeld> yea one person
12:01:05 <asalkeld> :)
12:01:06 <ramishra> o/
12:01:10 <rpothier> o/
12:01:45 <tspatzier> hi
12:01:48 <ryansb> \o
12:01:57 <asalkeld> #topic Adding items to the agenda
12:02:03 <skraynev> I am here ;)
12:02:16 <sirushti> o/
12:02:21 <asalkeld> we could add the gate status to the agenda
12:02:25 <rakesh_hs> o/
12:02:35 <asalkeld> anything else?
12:02:50 <asalkeld> #topic Any critical bugs to stop rc2 becoming the release?
12:03:23 <pas-ha> o/
12:03:32 <asalkeld> any super important bugs (critical) that would prevent rc2 being the final release
12:03:48 <asalkeld> (other bugs can be backported later)
12:04:06 <inc0> o/
12:04:16 <shardy> asalkeld: not a release blocker, but just FYI the hooks interfaces we landed have ended up being not that useable
12:04:16 <asalkeld> well I'll watch the bug list
12:04:28 <asalkeld> really?
12:04:45 <skraynev> https://review.openstack.org/#/c/175868/
12:04:47 <shardy> I'm implementing client side workarounds as it's too late to fix the API, but we'll have to rework during L
12:04:53 <skraynev> asalkeld: ^
12:04:56 <asalkeld> ok
12:05:07 <shardy> asalkeld: yeah, the exposing of hitting hooks only via events turns out to be not-so-great
12:05:27 <shardy> as you have to poll and filter (client side) every single event from all the stacks in the tree
12:05:34 <skraynev> I 'd like to see this one, because it fix bug with common case:)
12:05:54 <asalkeld> skraynev: that seems like a corner case or no?
12:06:32 <asalkeld> skraynev: if we want that in, we would have to move very quickly
12:06:45 <asalkeld> and get it merged into master
12:06:58 <skraynev> asalkeld: do you mean today?
12:07:10 <pas-ha> asalkeld, not really - we hit that quite often with say server with ports that is unable to boot due to "no valid host found"
12:07:28 <asalkeld> skraynev: it needs to get into master fast
12:07:39 <asalkeld> then we need to chat to ttx
12:07:41 <zaneb> \o
12:07:49 <asalkeld> hi zaneb
12:07:58 <skraynev> I have reviewed it yesterday.
12:07:58 <pas-ha> zaneb, please take a look at https://review.openstack.org/#/c/175868/
12:08:10 <skraynev> and wnated to get feedback from zaneb
12:08:13 <ananta> hi
12:08:21 <skraynev> *wanted
12:08:39 * zaneb looks
12:08:48 <asalkeld> skraynev: zaneb can you figure out if that really needs to go into kilo-final
12:09:04 <asalkeld> if yes please ping  ttx and say so quickly
12:09:18 <asalkeld> it's after 10pm here
12:09:43 <zaneb> is this a new issue?
12:09:47 <asalkeld> #action zaneb skraynev shardy follow up on https://bugs.launchpad.net/heat/+bug/1446575
12:09:47 <openstack> Launchpad bug 1446575 in heat "Invalid Templete Reference when delete failed stack" [High,In progress] - Assigned to Kairat Kushaev (kkushaev)
12:10:00 <asalkeld> not sure
12:10:13 <skraynev> zaneb: same behavior for Juno
12:10:30 <skraynev> zaneb: two wrong updates may leads to undeletable stack
12:10:43 <zaneb> skraynev: then I don't see a reason to rush it tbh
12:11:04 <asalkeld> well if we can, and it's a common uses case - then why not
12:11:16 <zaneb> I'd be more comfortable getting it in 2015.1.1
12:11:16 <asalkeld> maybe ask ttx how big the hassle is
12:11:29 <asalkeld> zaneb: when is that?
12:12:05 <zaneb> asalkeld: because this is an incredibly fragile piece of the code which has had next to no testing and we are about to release like today
12:12:12 <skraynev> zaneb: anyway I agree to backport it later, if it be more comfortable ;)
12:12:38 <ananta> I agree with zaneb
12:12:40 <skraynev> and safely
12:12:47 <asalkeld> ok, if we are ok with it coming later, then fine
12:13:00 <shardy> +1
12:13:15 <asalkeld> ok lets move on
12:13:16 <zaneb> asalkeld: it's not like it's a regression
12:13:41 <asalkeld> zaneb: sure, but i believe reasonbly common uses case of murano
12:13:43 <skraynev> zaneb: agree
12:13:51 <asalkeld> #topic HOT & Fn::Split (shardy)
12:13:54 <asalkeld> shardy: ...
12:14:30 <shardy> So, I've run into a use-case where we want to split a neutron cidr
12:14:38 <shardy> e.g 1.2.3.4/24
12:14:42 <shardy> by the "/"
12:14:58 <asalkeld> replace?
12:15:03 <shardy> that used to be possible via Fn::Split, but afaics we removed it after the first hot version
12:15:22 <noaKoffman> Hi guys, can anyone please review the blueprint spec https://review.openstack.org/#/c/171781/ ? thanks
12:15:23 <shardy> asalkeld: you don't know either half ahead of time to populate the replace
12:15:43 <shardy> atm, we're kludging it by using get_attr to get each character of the subnet mask
12:15:51 * shardy gets link
12:15:57 <zaneb> yeah, opposite problem
12:16:13 <zaneb> that said, the answer is to pass in the network and mask separately
12:16:19 <shardy> https://review.openstack.org/#/c/177845/3/network/ports/external.yaml
12:16:33 <tspatzier> shardy: is the use case that you want to use one part for a property, or split a string into a list for filling a list type property?
12:16:41 <shardy> zaneb: Yeah, I'm not sure the port resource provides those
12:16:50 <asalkeld> shardy: we would need to make a new template version
12:17:07 <zaneb> shardy: that's fixable :)
12:17:22 <shardy> asalkeld: sure, I guess my question is, am I missing a way to do it, and if not, what would a good interface look like (for L, obviously)
12:17:46 <ryansb> zaneb: sure it is, but a Fn::Split equivalent sure would be nice in any case
12:17:47 <asalkeld> why not just add split
12:18:22 <asalkeld> shardy: instead of coming up with yet another inconsistency
12:18:34 <shardy> tspatzier: the use-case is some attribute-mangling, but it's more general as I think the split feature is useful
12:18:41 <zaneb> asalkeld: because as you just said, we'd need a new template format
12:18:44 <tspatzier> +1 I like split much more than e.g. digest which was added some time back ;-)
12:18:57 <shardy> asalkeld: Yeah, I'm leaning towards just adding a native split
12:19:13 * zaneb is happy if tspatzier is happy
12:19:14 <shardy> zaneb: I think the workaround we have for TripleO is OK for now, but I'd like to define a cleaner way for L
12:19:17 <skraynev> +1 for the split for hot ;)
12:19:40 <shardy> Ok, I'll propose a spec for L and we can bikeshed on interfaces there ;)
12:19:46 <asalkeld> sure
12:19:55 <ryansb> shardy: indeed, I'll bring my book of paint swatches.
12:20:00 <asalkeld> #topic open discussion
12:20:05 <shardy> thanks all
12:20:14 <asalkeld> #topic open bikeshedding
12:20:16 <zaneb> shardy: you know that attaching a mask length to an actual IP address makes no sense, right?
12:20:19 <asalkeld> :-)
12:20:22 * zaneb scratches head
12:20:31 <ryansb> zaneb: uh, yes it does?
12:20:50 <ryansb> CIDR notation is pretty universal for network-y folks
12:20:54 <shardy> zaneb: it does if you want to configure an interface
12:21:06 <ryansb> ^ also that
12:21:21 <zaneb> ryansb: right. a network address has a mask length. an ip address is just an ip address
12:22:31 <ryansb> hrm.
12:22:31 <shardy> zaneb: I'll follow up with dprince on why/where the subnet is used in this case
12:22:47 <zaneb> maybe it's just too early in the morning and I am losing it
12:22:58 * asalkeld sleepy
12:23:16 <tspatzier> has anyone ever thought about combining MultiPartMime with SoftwareDeployment? Currently, it seems it can only take a simple config. Use case is that somebody would like to use CloudConfig with SoftwareDeployment which does not seem to work today.
12:23:49 <shardy> tspatzier: it does work, but you have to do the SoftwareDeployment after cloud-init runs
12:23:56 <inc0> well, ip can be represented by /32 cidr
12:24:09 <tspatzier> shardy: do we have an example for this?
12:24:22 <shardy> https://github.com/openstack/heat-templates/blob/master/hot/software-config/example-templates/example-os-apply-config-plus-cloud-config.yaml
12:24:38 <shardy> tspatzier: also, we're doing the same in the TripleO heat templates
12:24:54 <shardy> https://review.openstack.org/#/c/170137/
12:25:08 <tspatzier> shardy: great, thanks! One of my colleagues was looking for something like this, so he'll be happy to see this :-)
12:25:18 <shardy> there, you can pass any cloud-config via multi-part-mime, and then we do a bunch of subsequent SoftwareDeployments
12:25:39 <shardy> tspatzier: np :)
12:25:46 <zaneb> inc0: the given example is taking the masklen from the network address and mashing it on the end of the IP
12:26:07 <dprince> zaneb: with ipaddress/CIDR you can get everything you need
12:26:33 <asalkeld> zaneb: dose it matter, the mask - well masks the unused bits out?
12:26:38 <inc0> all I'm saying - CIDR can represnt both network as single address
12:26:50 <dprince> zaneb: some of our tooling makes use of this compressed format in TripleO already
12:27:09 <zaneb> yeah, it probably doesn't matter and is orthogonal to the actual problem here
12:27:42 <asalkeld> zaneb: missing working on mulitcast protocols
12:27:43 <ryansb> tl;dr we need split
12:28:07 <zaneb> asalkeld: not in the least :)
12:28:14 <asalkeld> haha
12:28:39 <asalkeld> we seem to be running out of topics
12:29:04 <asalkeld> end or some bright ideas?
12:29:11 <inc0> do we accept all sessions from etherpad?
12:29:25 <inc0> (I don't know if its free discussion yes?:)
12:29:29 <asalkeld> inc0: it's purely a matter of space
12:29:33 <ryansb> inc0: it is
12:29:51 <inc0> yeah, I think we can't fit it all already?
12:29:55 <asalkeld> (how many on the etherpad vs. slots)
12:30:21 <asalkeld> o, i nearly forgot
12:30:28 <asalkeld> release notes!
12:30:41 <asalkeld> we have an eathpad
12:30:46 <shardy> asalkeld: one thought, to the extent that is possible, it'd be good to juggle sessions to avoid collisions with TripleO
12:30:51 <asalkeld> and we need to get all official
12:31:04 <shardy> given that quite a few of us are now working on both
12:31:08 <asalkeld> shardy: maybe - chat to the baker
12:31:15 <shardy> oh yeah
12:31:51 <asalkeld> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
12:31:55 <asalkeld> doh
12:31:58 <asalkeld> wrong
12:32:48 <asalkeld> #link https://wiki.openstack.org/wiki/ReleaseNotes/Kilo
12:33:20 <asalkeld> please have a look (and edit) https://etherpad.openstack.org/p/heat-kilo-releasenotes
12:33:28 <asalkeld> i'll move that into the wiki
12:33:39 <pas-ha> asalkeld, no-op, etherpad is not working
12:33:55 <asalkeld> #action asalkeld update the kilo release notes
12:34:04 <asalkeld> pas-ha: works for me
12:34:22 <asalkeld> #link https://etherpad.openstack.org/p/heat-kilo-releasenotes
12:34:29 <skraynev> asalkeld: pas-ha: for me too
12:34:42 <asalkeld> it says 4 people are on there
12:34:43 <skraynev> I mean wfm ;)
12:35:44 <asalkeld> ok that's all from me
12:36:02 <asalkeld> last chance or i end the meeting
12:36:14 <asalkeld> #endmeeting