07:01:35 <pas-ha> #startmeeting heat
07:01:36 <openstack> Meeting started Wed Sep  2 07:01:35 2015 UTC and is due to finish in 60 minutes.  The chair is pas-ha. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:01:38 <rakesh_hs_> o/
07:01:39 <openstack> The meeting name has been set to 'heat'
07:01:52 <pas-ha> #topic rollcall
07:01:57 <tiantian> o/
07:02:00 <sirushti> o/
07:02:01 <Drago1> o/
07:02:14 <asalkeld> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282015-09-02_0700_UTC.29
07:02:17 <xek> o/
07:02:17 <asalkeld> o/
07:02:27 <pas-ha> #topic adding items to agenda
07:03:14 <asalkeld> convergence-status?
07:03:56 <pas-ha> asalkeld, added
07:04:39 <skraynev> o/
07:05:07 <pas-ha> let's start then
07:05:17 <pas-ha> #topic heat reviews
07:05:30 <pas-ha> #link https://etherpad.openstack.org/p/heat-reviews
07:06:01 <pas-ha> I think we should now focus on l3 and put a link there
07:06:08 <asalkeld> #link https://launchpad.net/heat/+milestone/liberty-3
07:06:24 <asalkeld> plenty there to review ^
07:07:11 <skraynev> looks, like we have several bug fixes, which need review
07:07:20 <asalkeld> ~11
07:07:41 <pas-ha> what's up with RG/ASG refactoring?
07:08:02 <pas-ha> zaneb is most probably sleeping
07:08:09 <asalkeld> rc1?
07:08:09 <skraynev> https://bugs.launchpad.net/heat/+bug/1488921 - looks like it was merged...
07:08:11 <openstack> Launchpad bug 1488921 in heat "SoftwareDeploymentGroup doesn't support path based attributes" [Medium,In progress] - Assigned to Steven Hardy (shardy)
07:08:21 <skraynev> shardy: ^ is it fixed?
07:08:50 <rakesh_hs_> asalkeld: convergence almost all patches have landed, but gate tests are failing recently
07:09:00 <pas-ha> looks like we already on topic..
07:09:12 <pas-ha> #topic prep for l3 release
07:09:45 <pas-ha> I advise people to concentrate on those L3 bugs next 2-3 days
07:09:51 <xek> https://review.openstack.org/#/c/190183/ - I didn't submit a bug about object not being initialized, should I?
07:09:57 <ricolin> o/
07:10:06 <ramishra> hi
07:10:53 <pas-ha> xek, sure, please submit a bug and describe what's exaclty the problem and how it can manifest itself
07:10:59 <asalkeld> rakesh_hs_: yeah
07:11:11 <xek> pas-ha, ok
07:11:15 <asalkeld> so we are shooting for a friday release
07:11:22 <asalkeld> so not much time to get stuff in
07:12:08 <skraynev> asalkeld: btw, convergence job failing due to timeout ?
07:12:17 <skraynev> (again)
07:12:33 <asalkeld> skraynev: yeah, it might be back to the fast update
07:13:01 <asalkeld> or something else
07:13:17 <asalkeld> http://logs.openstack.org/89/215489/7/check/gate-heat-dsvm-functional-convg-mysql/e27a365/console.html
07:13:18 <pas-ha> also, today I saw at least 2 failures due to fedora-heat-test-image not being available on the gate
07:13:30 <asalkeld> pas-ha: i had a patch for that
07:13:42 <asalkeld> https://review.openstack.org/#/c/219533/
07:13:49 <pas-ha> ok, thanks, will check
07:13:55 <asalkeld> new default cli options to glance
07:14:20 <pas-ha> ah, it's the glance client... AFAIK it broke not only us :(
07:14:30 <asalkeld> *might* have to rebase some patches
07:14:41 <asalkeld> gate is *really* slow
07:14:51 <asalkeld> everyone trying to get stuff in
07:15:27 <skraynev> asalkeld: yeah :) it's the hottest time for coding :)
07:15:30 <asalkeld> be kind to the gate
07:15:53 <asalkeld> (no unneeded patches/rechecks)
07:16:04 <pas-ha> #topic convergence status
07:16:21 <asalkeld> so i have made some bugs
07:16:23 <pas-ha> rakesh_hs_, anything to add?
07:16:26 * asalkeld getting links
07:17:08 <asalkeld> #link https://bugs.launchpad.net/heat/+bugs?field.tag=convergence-bugs
07:17:26 <asalkeld> so take the bugs if you are interested
07:18:22 <asalkeld> so i think the state of convergence is mostly good, but will need some testing/bug fixing (as expected)
07:18:23 <pas-ha> rakesh_hs_, re *almost all* patches, could you revisit and repopulate the review hot list on etherpad with those specific which still have to land?
07:19:07 <rakesh_hs_> pas-ha: ishant is implementing the comments for scenario tests, he will pushing a patch soon
07:19:12 <rakesh_hs_> https://review.openstack.org/#/c/203661/
07:19:18 <rakesh_hs_> I will add to the list
07:19:49 <pas-ha> rakesh_hs_, thanks
07:20:16 <stevebaker> hai everybody!
07:20:25 <skraynev> stevebaker: hi
07:20:42 <pas-ha> stevebaker, hi, we are almost out of topics already :)
07:20:43 <stevebaker> sorry I'm late, household carnage
07:21:19 <pas-ha> stevebaker, anything you wanted to put a focus on?
07:21:20 <ricolin> hihi
07:21:33 <stevebaker> pas-ha: FFE blueprints
07:21:34 <asalkeld> also if i may make a request, can you only put you name on a bug if you are actually working on it?
07:22:08 <pas-ha> stevebaker, do we have any?
07:22:12 <stevebaker> asalkeld: +1
07:22:17 <pas-ha> asalkeld, +1
07:22:38 <pas-ha> stevebaker, from l3 LP chart looks like everything is implemented
07:22:43 <ricolin> +1
07:22:53 <asalkeld> stevebaker: these? https://launchpad.net/heat/+milestone/liberty-rc1
07:23:31 <asalkeld> i thought any bp in rc1 was a FFE
07:23:34 <stevebaker> deciding what BPs get a feature freeze exception is entirely up to us (officially me). Anything I've put in rc1 I think deserves to have an FFE, but I'm open to suggestions on things to remove or add.
07:23:36 <pas-ha> wow, this list is much longer than l3 :(
07:24:01 <asalkeld> pas-ha: just the blueprints
07:24:06 <asalkeld> 4 of them
07:24:35 <pas-ha> skraynev, what's the status with rich network prop?
07:24:51 <stevebaker> pas-ha: we're talking blueprints only here. we're still allowed to fix bugs in rc1 but every change needs to get backport to the stable/liberty branch which will be a pita. so any bug commit which we land in the next 24 hours will save busywork
07:25:29 <pas-ha> stevebaker, sure. so again, when do you plan to cut the stable? Thu, Fri?
07:25:36 <asalkeld> so normally only High+ bugs go in
07:25:56 <stevebaker> pas-ha: euro-thursday. I'll be on leave so asalkeld will make the call
07:26:09 <shardy> o/
07:26:09 <pas-ha> ok, 24 hours indeed
07:26:16 <pas-ha> shardy, ho
07:26:18 <stevebaker> yeah
07:26:21 <stevebaker> shardy: hey
07:26:24 <shardy> morning all, sorry, running late today!
07:26:26 <skraynev> pas-ha: need to add unittests for patches on review and also I think, that the most important thingm which was no done yet (we are working on it) - processing internal port during replace and rollback
07:26:26 <ricolin> hi
07:26:37 <stevebaker> shardy: about as late as me
07:26:47 <pas-ha> skraynev, yeah, that might be complex
07:27:01 <shardy> stevebaker: heh, it's the public holiday we just had actually, I thought it was Tuesday! ;)
07:27:22 <pas-ha> shardy, I was under impression you are working on https://blueprints.launchpad.net/heat/+spec/nested-validation, no?
07:27:36 <stevebaker> skraynev: do you have a plan for when a port has a fixed IP and the server is replaced? (2 ports with the same IP is not allowed)
07:27:38 <skraynev> pas-ha: not sure, that very complex, plan to upload patch with PoC today
07:27:41 <shardy> pas-ha: I was running out of time so jdob has offered to help with it
07:27:41 <asalkeld> shardy: is working on *everything*
07:27:58 <shardy> pas-ha: it's not clear if it will actually make it, but he's posted some initial code
07:28:00 <pas-ha> I was just curious on assignees of BPs/bugs
07:28:35 <shardy> pas-ha: Yeah, that's my only BP/spec that actually landed IIRC, but I have lots of bugs, welcome to take some if you have bandwidth :)
07:28:41 <stevebaker> shardy: I've put nested-validation in rc1, so I'm proposing it has an FFE https://launchpad.net/heat/+milestone/liberty-rc1
07:28:50 <pas-ha> stevebaker, +1
07:29:08 <shardy> stevebaker: Ok, looking at the code... I'm not sure, but lets do that and see how it shapes up over the next couple of days
07:29:24 <asalkeld> when is rc1?
07:29:28 <skraynev> stevebaker: yes, it's should be covered in the same way, like a case above (with replace), i.e. detach port and remove fixed ip, and after update add fixed_ip and attach port
07:29:29 <stevebaker> shardy: yeah, its the only one which is a bit of a long shot
07:30:00 <stevebaker> skraynev: ok'
07:30:48 <stevebaker> asalkeld: earlish octoberish? https://wiki.openstack.org/wiki/Liberty_Release_Schedule
07:31:24 <asalkeld> O, that's heaps of time
07:31:30 <shardy> stevebaker: ah, I assumed we only had a couple of weeks max :)
07:32:02 <stevebaker> first rc could be sept 25
07:32:11 <stevebaker> first rc could be sept 21
07:32:13 <skraynev> shardy: let's think, that we have a couple weeks :) it makes coding faster ;)
07:32:18 <stevebaker> which is the same week as........
07:32:22 <stevebaker> PTL ELECTIONS
07:32:23 <shardy> skraynev: haha ;)
07:32:35 <stevebaker> who wants to be heat ptl
07:32:37 <stevebaker> ?
07:32:40 <asalkeld> we need some new victim
07:32:55 <stevebaker> pas-ha: gosh, you are so good at running these meetings :)
07:32:56 <skraynev> stevebaker: I may try :)
07:33:03 <stevebaker> oh, that reminds me
07:33:08 * pas-ha blushes
07:33:09 <skraynev> or pas-ha ;)
07:33:51 <asalkeld> probably need thinking about summit sessions at some point too
07:33:58 <pas-ha> asalkeld, +1
07:33:58 <stevebaker> we need to request how many slots we need at summit
07:34:09 <shardy> I'm willing to run again if nobody else is keen, happy to defer if other folks are willing :)
07:34:10 <stevebaker> here was the allocation in Vancouver (Fishbowl/Work
07:34:12 <stevebaker> rooms/Meetup):
07:34:26 <stevebaker> Heat 5, 10, 1
07:34:40 <pas-ha> afaik the venue in Tokyo would be tighter
07:34:53 <asalkeld> stevebaker: i think we need an ops/user meeting (fishbowl) which we didn't have last time
07:35:04 <stevebaker> yes, and fishbowl/workroom ratio is about 2/1
07:35:07 <skraynev> asalkeld: +1
07:35:08 <asalkeld> (unless i just missed it)
07:35:30 <ricolin> asalkeld: +1
07:35:30 <asalkeld> 6/8/1 ?
07:35:33 <stevebaker> asalkeld: I thought we did. It may have been more user experience
07:35:52 <pas-ha> stevebaker, last day in VAncouver?
07:36:18 <asalkeld> less convergence to talk about, i wonder what we will talk about :-O
07:36:24 <stevebaker> I was thinking that if we got exactly the same as last time (or a proportional amount thereof)
07:36:35 <stevebaker> asalkeld: convergence pt 2
07:36:47 <asalkeld> maybe
07:36:48 <stevebaker> so 5/10/1
07:36:53 <asalkeld> stevebaker: sounds fine
07:36:55 <stevebaker> or 4/8/1
07:37:23 <pas-ha> first variant sounds better :) but we must collect ideas on topics first
07:37:25 <skraynev> asalkeld: I'd like to discuss some scale issues, which are actual for Tripleo and Sahara
07:37:27 <asalkeld> shoot for more, and let them beat us down if needed
07:37:50 <pas-ha> asalkeld, alwasy ask for twice you need :P
07:38:10 <stevebaker> pas-ha: I think the nature of this process means we get the space first, then fill it. Especially since it will be a new PTL deciding on the sessions
07:38:24 <pas-ha> stevebaker, sounds reasonable
07:39:08 <pas-ha> its not like we won't have anything to fill up extra slots we might get :)
07:39:21 <stevebaker> ok, I'll ask for 5/10/1 again.
07:39:26 <asalkeld> +1
07:39:29 <skraynev> +1
07:39:32 <pas-ha> +1
07:39:34 <ricolin> +1
07:39:58 <pas-ha> #agreed stevebaker asks 5/10/1 slots for M summit
07:39:58 <stevebaker> I'm pretty sure that is all I had
07:40:23 <stevebaker> review all the things! https://launchpad.net/heat/+milestone/liberty-3
07:40:26 <pas-ha> #topic open discussion
07:40:43 <pas-ha> anyone has his pain point to discuss?
07:41:35 <stevebaker> or hers
07:41:54 <pas-ha> ending early?
07:41:58 <skraynev> need more review for batching for RG on create
07:42:03 <xek> pas-ha, I submitted a bug https://bugs.launchpad.net/heat/+bug/1491258 , also linked to it from my patch https://review.openstack.org/#/c/190183/
07:42:04 <openstack> Launchpad bug 1491258 in heat "versioned objects not registered" [Undecided,In progress] - Assigned to Grzegorz Grasza (xek)
07:42:13 <pas-ha> xek, ok, thanks
07:42:36 <skraynev> https://review.openstack.org/#/c/185385/
07:42:43 <skraynev> this one ^
07:43:10 <stevebaker> skraynev: does that clash with zane's series? (which you should all be reviewing)
07:43:30 <pas-ha> stevebaker, zaneb has some comments to this regard
07:43:34 <stevebaker> https://review.openstack.org/#/c/213549/
07:44:05 <skraynev> stevebaker: yes. but Zane was agree to land it (he told, that it may be not totally compatible with his change)
07:44:20 <shardy> I think it's not impossible to rebase this on zane's series, as has been suggested in the comments
07:44:38 <shardy> AFAICT most of zaneb's patches are ready to land
07:45:09 <shardy> I'm going to finish reviewing them this morning, so can we rebase this patch and then we can land the lot for rc1?
07:45:24 <skraynev> shardy: ok. we may try to rebase, but anyway more review is appreciated :)
07:45:29 <pas-ha> shardy, sounds like a plan
07:45:30 <stevebaker> ok, btw gate will be broken until this lands https://review.openstack.org/#/c/219533/ so you may need to nurse it in
07:45:32 <shardy> skraynev: sure, will do
07:46:03 <stevebaker> shardy: the more that lands in l3 the better I think
07:46:28 <shardy> stevebaker: sure, how long do we have to merge stuff?
07:46:39 <skraynev> one more thing is https://review.openstack.org/#/c/199442/ <- get_attr without parameters
07:46:59 <stevebaker> shardy: about 24 hours, or however long you can convince asalkeld to hold off
07:47:14 <shardy> stevebaker: haha, Ok, will focus on reviews today then :)
07:48:32 <stevebaker> skraynev: ok, I've put that in rc1
07:48:44 <skraynev> stevebaker: ok. thx
07:50:09 <stevebaker> shall we wind up?
07:50:16 <shardy> +1
07:50:19 <skraynev> nothing else from me
07:50:37 <pas-ha> anything else? anyone?
07:50:44 <pas-ha> three...
07:50:52 <pas-ha> two...
07:50:57 <ricolin> : -)
07:50:58 <skraynev> sold
07:51:01 <pas-ha> one..
07:51:03 <stevebaker> 2.5
07:51:08 <stevebaker> oh, 1.5
07:51:12 <pas-ha> thanks everyone :)
07:51:14 <skraynev> :)
07:51:17 <pas-ha> #endmeeting