06:59:08 <skraynev> #startmeeting Heat
06:59:09 <openstack> Meeting started Wed Oct 14 06:59:08 2015 UTC and is due to finish in 60 minutes.  The chair is skraynev. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:59:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:59:12 <openstack> The meeting name has been set to 'heat'
06:59:25 <skraynev> #topic rollcall
06:59:38 <stevebaker> \o
06:59:43 <sirushti> o/
06:59:43 <shardy> o/
06:59:44 <KanagarajM> hi
07:00:10 <ramishra> hi
07:00:28 <tspatzier_> hi
07:01:34 <skraynev> #topic Adding items to agenda
07:01:48 <skraynev> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282015-10-14_0700_UTC.29
07:02:02 <skraynev> we have really short agenda for today
07:02:18 <skraynev> any additional topics?
07:02:19 <Qiming> hi
07:02:21 <elynn> o/
07:02:45 <stevebaker> I've seen nothing to warrent an rc3
07:03:28 <skraynev> stevebaker: feel free to add, I thought, that it may be part of "Updates from meeting with release team"
07:04:05 <skraynev> stevebaker: I have not any specific info about it.
07:04:33 <stevebaker> ah, we're on target for release then, thats all the news I have
07:04:43 <skraynev> #topic Updates from meeting with release team
07:05:00 <skraynev> yeah. I wanted to say something like that :)
07:05:04 <stevebaker> I've retagged the remaining liberty-rc-potential with liberty-backport-potential
07:05:28 <skraynev> ttx mentioned during meeting, that we 2 days before release
07:06:05 <skraynev> stevebaker: thank you. I just recently started to use liberty-backport-potential
07:06:12 <stevebaker> there was a new Kilo release today with *heaps* of fixes
07:07:01 <stevebaker> https://launchpad.net/heat/kilo/2015.1.2
07:07:27 <skraynev> #info please use liberty-backport-potential tag instead of liberty-rc-potential for bugs which will be backported to Liberty
07:07:43 <asalkeld> o/
07:08:34 <skraynev> stevebaker: is it ok, that some bugs have Fix Committed status?
07:08:42 <skraynev> instead of Fix released
07:09:22 <stevebaker> skraynev: hmm, I saw that. I'll chase up and see if they made it in the release
07:09:28 <asalkeld> skraynev: not sure why that is
07:10:05 <skraynev> asalkeld: probably you don't want to release them ? :)
07:10:23 <asalkeld> i don't set that, it's all automagical
07:10:47 * skraynev scratches his head
07:10:51 <asalkeld> once the fix is merge it goes to fix commited
07:11:08 <asalkeld> then when it is tagged , it gets set to released
07:11:37 <stevebaker> asalkeld: I suspect the release manager has to run a script to make everything go to Fix Released. When I release things the 'script' is my clicky finger
07:11:38 <skraynev> asalkeld: I thought, that ttx did it manually
07:11:56 <ttx> stevebaker: genearlly bugs that are FixCommitted means they are fixed in the master branch but were not published in any RC or milestone yet
07:12:16 <ttx> I take all FixCommitted and turn them into FixReleased when I do a milestone
07:12:24 <ttx> so there should not be leftovers
07:12:32 <asalkeld> ttx https://launchpad.net/heat/kilo/2015.1.2
07:12:38 <stevebaker> ttx: we're looking at the 3 FixCommited in the last kilo release https://launchpad.net/heat/kilo/2015.1.2
07:12:41 <ttx> oh. That
07:12:47 <asalkeld> ttx there are some there, and we are a bit confused about those
07:12:51 <ttx> I don't handle that myself
07:13:01 <ttx> so it's extremely possible that they miss things
07:13:07 <asalkeld> k
07:13:25 <skraynev> ttx: thx.
07:13:49 <ttx> one of the many reasons why we drop synchronized point releases with stable/liberty :)
07:14:01 <stevebaker> I'll set them to Released once I've confirmed they're in stable/kilo
07:14:11 <asalkeld> we should asking Doug, but habbits hard to change
07:14:50 <skraynev> stevebaker: ok. please fix it.
07:15:31 <asalkeld> skraynev: is the session track sorted yet?
07:15:37 <asalkeld> (for summit)
07:15:48 <skraynev> asalkeld: it's next topic in agenda
07:15:59 <skraynev> #topic Summit topics final revision
07:16:00 <asalkeld> oops
07:16:09 <skraynev> #link https://etherpad.openstack.org/p/mitaka-heat-sessions
07:16:30 <skraynev> I have sorted them by time and slots, so please review it
07:16:47 <skraynev> I have some doubts about couple items
07:17:18 <skraynev> e.g. Convergence Phase 2 was moved to metup, because we had huge discussion about it before
07:17:49 <skraynev> so probably we may just take a look on specs
07:18:06 <stevebaker> skraynev: if this was a fishbowl then the projector could be used to bikeshed the new commands: 12. Complete heat support in python-openstackclient
07:18:52 <stevebaker> skraynev: maybe swap with 14.?
07:18:57 <skraynev> yes. it was my doubt
07:19:09 <skraynev> sure
07:19:15 <asalkeld> skraynev: it looks mostly fine to me
07:19:57 <skraynev> stevebaker: updated
07:19:58 <asalkeld> tho' if you are short of tracks this might not need a whole session "Do we need an ops tool to migrate stacks to/from convergence?"
07:20:37 <asalkeld> could merge into the general convergence talks / or leave as-is
07:20:52 <stevebaker> skraynev: 5. 15. and 13. are all user-facing features, so maybe one of them would be better in the fisbowl instead of 0.
07:20:53 <skraynev> asalkeld: I prefer second variant
07:20:57 <shardy> skraynev: if you need to, we can combine 5 & 15 but I'm happy to leave them separate if we have enough time
07:21:33 <shardy> stevebaker: if we do that I'd favor moving the parameters one
07:22:04 <tspatzier> 7 and 14 look somehow related - does it make sense to merge them?
07:22:04 <skraynev> stevebaker: not sure, that one fishbowl will be enough...
07:22:12 <asalkeld> tho' it seems we have nicely filled our slots
07:22:37 <asalkeld> so any merging will mean an empty slot?
07:22:50 <skraynev> asalkeld - yes
07:22:57 <asalkeld> imho - ship it~
07:23:18 <stevebaker> were we going to have a convergence phase 2 session? or is that 8.?
07:23:20 <skraynev> tspatzier: I think, that 14 is mostly about Senlin and future refactoring RG, ASG
07:23:50 <asalkeld> stevebaker: the friday session
07:23:51 <skraynev> tspatzier: 7 was aimed on potential problems on big scale
07:24:08 * stevebaker scrolls
07:24:09 <tspatzier> skraynev, but still about scaling. maybe those should at least be adjacent sessions?
07:24:11 <stevebaker> ahh
07:24:24 <skraynev> stevebaker: was moved to meetup
07:24:34 <stevebaker> good call
07:24:49 <shardy> tspatzier: FWIW I see those as separate, as it's more about working at scale than automated scaling
07:24:54 <Qiming> skraynev, can we move 14 around? I have a talk during 9:50am-10:30am Thursday morning
07:25:08 <shardy> e.g TripleO faces the same issues mentioned in (7) but currently doesn't use ASG at all
07:25:22 <tspatzier> shardy, ok, got it now ... this subtle difference of "scale" ;-)
07:25:31 <skraynev> Qiming: is it ok to move at 9.00 ?
07:25:51 <Qiming> skraynev, 9.00 sounds better, :)
07:26:39 <skraynev> tspatzier: 7 scale deployment, 14 scaling VMs in stack
07:27:04 <tspatzier> skraynev, I'm bought into it :-)
07:27:14 <skraynev> Qiming: done
07:27:20 <Qiming> thx
07:28:00 <skraynev> tspatzier: playing around word "scale" :)
07:28:49 <skraynev> stevebaker: shardy: so what decide about 15 and 5 ?
07:29:21 <skraynev> empty slot we may feel by convergence phase 2 talks
07:29:27 <stevebaker> skraynev, shardy: should we swap 5 and 0?
07:29:41 <shardy> skraynev: I updated the title to remove the "scaling" word ;)
07:30:14 <skraynev> shardy: thx. looks better
07:30:16 <Qiming> lol
07:30:36 <skraynev> stevebaker: now I think - yes
07:31:02 <shardy> skraynev: if you need the slot, I'm happy to combine 5 & 15
07:31:03 <skraynev> because convergence is not production ready (we wanted to finish it during M)
07:31:07 <stevebaker> skraynev, shardy ug, I meant 15 and 0
07:31:14 <shardy> they're somewhat related I guess
07:32:08 <stevebaker> I don't really mind which
07:32:47 <skraynev> shardy: not sure that zaneb will be happy to see slot for Convergence Phase 2, but I think it will be useful (if you think, that will discuss everything in one slot)
07:33:36 <shardy> skraynev: Ok that's fine
07:34:22 <skraynev> shardy: ok. I will merge 5 & 15, swap it with 0 and add (1) on empty slot
07:34:33 <stevebaker> if we have a slot for phase 2 we can always continue any overflow on the meetup day
07:35:00 <skraynev> stevebaker indeed
07:36:40 <skraynev> shardy: oops
07:37:02 <skraynev> could you swap them yourself?
07:37:08 <skraynev> 5 with 0
07:37:28 <shardy> skraynev: sorry, I'm done, combined 5 & 15
07:37:41 <skraynev> shardy: ok, then I will continue
07:39:46 <skraynev> shardy, stevebaker, asalkeld, zaneb: please review final result
07:40:41 <asalkeld> skraynev: lgtm
07:40:44 <skraynev> asalkeld: stevebaker:  "Team review/triage session for specs" 9 was moved to meetup according comments
07:40:59 <stevebaker> lgtm
07:41:08 <skraynev> I also agreem that it will be the best time for such talk
07:41:33 <shardy> skraynev: looks good, thanks
07:41:38 <skraynev> #action skraynev will migrate all topics to sched.org
07:41:51 <skraynev> Good. Thank you for the help.
07:42:18 <skraynev> I will do it during today and tomorrow and will send email :)
07:42:40 <skraynev> #topic Open discussion
07:43:18 <skraynev> I forgot to mention about crossproject specs
07:43:35 <skraynev> They are in meetup section
07:43:53 <skraynev> #link https://review.openstack.org/#/c/214817/
07:44:17 <skraynev> #link https://review.openstack.org/#/c/181393/
07:44:25 <shardy> I wanted to ask if anyone else has seen any racy behavior with either ResourceGroup or SoftwareDeploymentGroup lately
07:44:27 <skraynev> #link https://review.openstack.org/#/c/221163/
07:44:42 <shardy> I know there's been a bunch of changes, but I'm failing to reproduce https://bugs.launchpad.net/heat/+bug/1503694
07:44:42 <openstack> Launchpad bug 1503694 in heat "A bad or out-of-range value was supplied:The Resource (0) could not be found in Stack" [High,Triaged] - Assigned to Steven Hardy (shardy)
07:45:09 <shardy> In this scenario a RG of size 3 was created, but the first resource is missing
07:45:43 <shardy> If anyone sees anything similar, please update the bug with how you reproduced :)
07:46:00 <skraynev> shardy: I have not met such issue
07:46:11 <skraynev> if will seen on gate will ping you
07:46:44 <shardy> skraynev: thanks, I assume we've not got gate coverage of it it was more of a general cry for help :)
07:47:00 <ramishra> shardy: I've not seen any.  There are some other issues, like https://bugs.launchpad.net/heat/+bug/1503180, but I've not seen them in the last week.
07:47:00 <openstack> Launchpad bug 1503180 in heat "functional.test_autoscaling.AutoscalingGroupUpdatePolicyTest heat_integrationtests.common.exceptions.StackBuildErrorException" [Medium,Confirmed] - Assigned to Rabi Mishra (rabi)
07:47:47 <skraynev> ramishra: heh. we fix bugs without any specific fixes...
07:48:01 <ramishra> The above issue only happened twice and then I've not seen it.
07:48:09 <shardy> ramishra: Yeah, I was thinking of the races you fixed, but I couldn't see how they could create the wrong number of resources
07:48:26 <ramishra> same for this one https://bugs.launchpad.net/heat/+bug/1503955
07:48:26 <openstack> Launchpad bug 1503955 in heat "functional.test_validation.StackValidationTest.test_stack_validate_provider_references_parent_resource" [Medium,Confirmed] - Assigned to Rabi Mishra (rabi)
07:48:31 <shardy> anyway, something to keep an eye out for - I'm going to attempt a stress test later & try to trigger it
07:49:00 <ramishra> sure, I'm having a watch too:)
07:50:30 <skraynev> #info if gate fails with similar issue like in https://bugs.launchpad.net/heat/+bug/1503694 https://bugs.launchpad.net/heat/+bug/1503180 https://bugs.launchpad.net/heat/+bug/1503955, please ping shardy or any core-reviewer
07:50:30 <openstack> Launchpad bug 1503694 in heat "A bad or out-of-range value was supplied:The Resource (0) could not be found in Stack" [High,Triaged] - Assigned to Steven Hardy (shardy)
07:50:32 <openstack> Launchpad bug 1503180 in heat "functional.test_autoscaling.AutoscalingGroupUpdatePolicyTest heat_integrationtests.common.exceptions.StackBuildErrorException" [Medium,Confirmed] - Assigned to Rabi Mishra (rabi)
07:50:33 <openstack> Launchpad bug 1503955 in heat "functional.test_validation.StackValidationTest.test_stack_validate_provider_references_parent_resource" [Medium,Confirmed] - Assigned to Rabi Mishra (rabi)
07:51:16 <skraynev> one more thing
07:51:22 <skraynev> need to update https://etherpad.openstack.org/p/heat-reviews
07:51:26 <skraynev> #link https://etherpad.openstack.org/p/heat-reviews
07:51:56 <skraynev> looks like it obsolete
07:52:52 <skraynev> if there is nothing else, we may finish
07:53:27 <asalkeld> +1
07:53:43 <skraynev> ok. thanks all ;)
07:53:47 <skraynev> #endmeeting