15:00:13 <zaneb> #startmeeting heat
15:00:13 <openstack> Meeting started Wed Aug 17 15:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is zaneb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'heat'
15:00:20 <zaneb> just like riding a bike
15:00:43 <zaneb> #topic roll call
15:00:52 <ramishra> hi
15:00:54 <jasond> o/
15:00:54 <spzala> :) o/
15:01:01 <yohoffman> \o
15:01:06 <syjulian> o/
15:01:21 <cwolferh> o/
15:01:33 <duvarenkov> hi
15:01:47 <xenogear> o/
15:01:58 <shizhihui> hi, I am new
15:02:07 <zaneb> shizhihui: welcome!
15:02:28 <zaneb> ok, good turnout
15:02:36 <shizhihui> zaneb ,thank you
15:02:41 <zaneb> #topic Adding items to agenda
15:02:55 <zaneb> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282016-08-17_1500_UTC.29
15:03:09 <zaneb> anybody got anything else?
15:04:02 <zaneb> I'll take y'all's silence as a 'no'
15:04:12 <zaneb> #topic bp for cinder quota as heat resource
15:04:18 <zaneb> syjulian: is this you?
15:04:27 <zaneb> #link https://review.openstack.org/#/c/355627/
15:04:30 <syjulian> yes
15:04:44 <zaneb> syjulian: then you have the floor :)
15:07:40 <syjulian> so we basically want to be able to manage cinder quotas as a heat resource
15:07:40 <zaneb> I scanned the bp and I'm mentally filing this under 'weird things that admins want to do (for some reason) with Heat, of which we already support a bunch'
15:07:40 <zaneb> I'm not inclined to draw the line here, so I think this is fine
15:07:40 <zaneb> *provided* that it is limited to admin-only so regular users won't see it
15:07:40 <ramishra> yeah, we have quite a few admin only resources, one more to the list:)
15:07:40 <yohoffman> Yes, this would be strictly admin-only
15:07:40 <yohoffman> we can't have users updating their quota can we...
15:07:40 <zaneb> do we have docs somewhere on how to create an admin-only resource type?
15:07:56 <zaneb> I know we added support for that, but every time I go looking to figure out how to do it i come up empty-handed
15:07:59 <syjulian> that would help a lot :)
15:08:43 <ramishra> I'm not sure if  we have anything like that.
15:09:32 <zaneb> ramishra: you're not sure if the feature exists or if it's documented?
15:10:07 * zaneb sometimes gets the sinking feeling that some of this stuff happened only in my head
15:10:43 <syjulian> also who would be good to add as reviewers for this spec?
15:11:05 <ramishra> zaneb: both, I don't think there is anything to differentiate the admin resources or any docs on how to write them,
15:11:49 <ramishra> but we have the keystone resources as mentioned in this spec, which can be used by admin only.
15:11:57 <ramishra> atleast that's what I know.
15:12:07 <zaneb> maybe I'm losing it then
15:12:28 <yohoffman> We can try and help write up some documentation as we go if that would be helpful.
15:13:19 <zaneb> yohoffman: so there's either a feature that says that the user must have a certain keystone role to use a particular resource type, or there isn't
15:13:42 <zaneb> I thought we added one as a condition of moving all these resource types from /contrib into the main tree
15:14:34 <yohoffman> Oh, I thought we said there are other admin-only resources already out there?
15:14:43 <cwolferh> https://review.openstack.org/#/c/317329/
15:15:35 <zaneb> yes! thank you cwolferh
15:15:51 <cwolferh> yep :-)
15:15:56 * cwolferh thanks git log
15:16:07 <yohoffman> Looks simple enough =)
15:16:13 <zaneb> yohoffman: so yeah, it needs to be added to the list in policy.json
15:16:21 <zaneb> maybe mention that in the spec
15:16:40 <zaneb> ok, next topic?
15:16:41 <yohoffman> sure, can do
15:16:52 <yohoffman> So no docs necessary then?
15:16:55 <ramishra> zaneb: Is that what you were looking for? the policy for resource types. may be I misunderstood.
15:17:13 <zaneb> ramishra: yes, pretty sure that's what I was looking for
15:17:27 <zaneb> yohoffman: some docs would be a nice bonus :)
15:17:42 <zaneb> I think we have a plugin authors guide, right?
15:17:59 <yohoffman> Alright, we'll look around and see where we can fit it
15:17:59 <jezogwza> Regarding next topic. If we are ok with this Cinder Quota Resource Type, we have equivalent request for Nova and Neutron quotas
15:18:56 <zaneb> jezogwza: I have no objection to that either
15:19:28 <zaneb> #topic Newton-3
15:19:28 <prazumovsky> If all of them will be admin only, why not then
15:19:39 <syjulian> \o/
15:19:44 <xenogear> :)
15:19:55 <zaneb> I'm guessing this is happening RSN
15:20:02 * zaneb looks up release schedule
15:20:24 <zaneb> #link http://releases.openstack.org/newton/schedule.html
15:20:59 <zaneb> feature freeze for most projects is ~end of next week
15:21:16 <zaneb> we're not on the calendar, but traditionally we have observed the same FF
15:21:42 <zaneb> so let's take a look and see what is in danger of not landing
15:22:02 <zaneb> #link https://launchpad.net/heat/+milestone/newton-3
15:22:29 <zaneb> condition functions are close I think
15:22:50 <zaneb> please review those; I will try to take another look too
15:23:18 <zaneb> ramishra: what is the status of the environment merging?
15:23:31 <ramishra> It's up for review
15:24:03 <ramishra> it's mostly done from my side, reviews are welcome, I think shardy has looked at it and is ok with it.
15:24:15 <zaneb> ok, changed it to "needs code review"
15:24:17 <ramishra> though formal review is still waiting from hoim
15:24:26 <prazumovsky> My two cents: yesterday I send email about convergence get live state status
15:24:50 <ramishra> I think some of the bps should move to octa
15:24:54 <zaneb> ramishra: is this still do-able/safe before FF do you think?
15:25:13 <zaneb> agree
15:25:28 <zaneb> pretty sure the HOT generator one is not close to landing
15:25:35 <ramishra> I think so, it's quite simple, though without reviews I don't know;)
15:26:11 <ramishra> I think external resources thing has landed.
15:26:53 <ramishra> I changed it's status.
15:27:23 <zaneb> convergence-migrate-stack appears to be done, is that right?
15:28:07 <ananta> https://review.openstack.org/#/c/280836/
15:28:18 <zaneb> don't see ochuprykov here, so I'm gonna change it and he can scream later if it's wrong
15:29:15 <zaneb> tempest-plugin-support is still in progress
15:30:09 <zaneb> files-show seems to be done but the functional tests haven't merged yet
15:30:47 <zaneb> waiting on a heatclient release by the looks of it
15:31:06 <zaneb> so basically done, but I'll leave it open for now
15:31:46 <zaneb> sfc-heat appears to have merged, closing
15:32:41 <zaneb> observe-reality was discussed on the ML as prazumovsky said before he dropped out
15:33:28 <zaneb> lbaas-l7-rules-support second patch seems to be stalled, needs rebase
15:33:44 <ramishra> network-sfc, quite a few patches still to be reviewed or not attended by the author.
15:34:55 <zaneb> neutron-dns-resolution is now marked implemented
15:35:09 <ramishra> I think it would be good to move it to octa, or I'm missing something?
15:36:03 <zaneb> ramishra: oh, you're right. I only looked at the last one
15:36:36 <zaneb> ah, that was just the spec
15:36:44 <zaneb> yeah, let's move to Ocata
15:38:51 <zaneb> migrate-to-glance-v2 also gets bumped (again)
15:39:47 <ramishra> yeah, the issue of image location and the dicussion goes on from cycle to cycle;)
15:39:54 <zaneb> lol
15:40:06 <zaneb> ok, the list is looking a lot tidier
15:40:24 <zaneb> thanks everyone for sitting through this painful exercise ;)
15:41:03 <zaneb> #action cores, please give high priority to reviewing the remaining features on that list before FF next week
15:41:18 <zaneb> #topic Open Discussion
15:41:29 <zaneb> anybody got anything else to bring up?
15:41:44 <ramishra> too many gate failures in the last few days.
15:42:25 <ramishra> I've created a tempest bug report FWIW https://bugs.launchpad.net/tempest/+bug/1614078
15:42:25 <openstack> Launchpad bug 1614078 in tempest "heat api tests failing with Max retries exceeded with url" [Undecided,In progress] - Assigned to Rabi Mishra (rabi)
15:43:32 <zaneb> ramishra: yeah, it seems like it may have been premature to make the apache gate job voting?
15:44:10 <ramishra> it's affecting any job using tempest tests like grenade
15:44:51 <zaneb> ah, ok
15:45:02 <ramishra> gate-grenade-dsvm-heat is also failing quite a number of times.
15:45:36 <zaneb> so somebody else changed it and we are dealing with the fallout
15:45:49 <ramishra> I don't know how to bring it to the attention of the tempest team.
15:46:00 <ramishra> my previous experience is not that good;)
15:47:22 <zaneb> ramishra: can we change it in our config?
15:47:32 <zaneb> or does it have to be in the tempest config?
15:48:21 <ramishra> It's the tempest config I think. I'm not sure of the solution too. don't know much about tempest;)
15:48:50 * zaneb neither
15:49:10 <zaneb> ah well, let's hope that bug report gets some attention
15:49:55 <zaneb> #info recheck grenade/apache job errors with bug 1614078
15:49:55 <openstack> bug 1614078 in tempest "heat api tests failing with Max retries exceeded with url" [Undecided,In progress] https://launchpad.net/bugs/1614078 - Assigned to Rabi Mishra (rabi)
15:50:10 <zaneb> ananta: this one also worries me: https://bugs.launchpad.net/heat/+bug/1607814
15:50:10 <openstack> Launchpad bug 1607814 in heat "Error acquiring lock for resource" [Undecided,New]
15:50:27 <ananta> looking
15:50:53 <ananta> zaneb: will investigate
15:51:04 <zaneb> ananta: thanks! :)
15:51:23 <ramishra> one more thing, we've the devstack plugin in tree, I proposed a workaround to make it work, though any better ideas would be good too.
15:51:37 <ramishra> we probably should fix it before n3
15:52:26 <zaneb> sounds sensible
15:52:37 <zaneb> I'll defer to someone who uses devstack on that ;)
15:53:29 <zaneb> ok, I think this is a good point to wrap up
15:53:47 <zaneb> thanks everyone! your host next week will be ramishra :)
15:54:09 <zaneb> #endmeeting