15:00:48 <ricolin> #startmeeting heat
15:00:49 <openstack> Meeting started Wed Mar 29 15:00:48 2017 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <openstack> The meeting name has been set to 'heat'
15:01:04 <ricolin> #topic roll call
15:01:32 <therve> Yop
15:01:33 <ramishra> hi
15:01:38 <ricolin> hi!
15:01:38 <cwolferh> hello
15:01:40 <tiantian> hi
15:02:46 <ricolin> #topic adding items to agenda
15:02:51 <therve> Have to go in a few
15:03:00 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282017-03-29_1500_UTC.29
15:03:16 <ricolin> therve okey:)
15:04:08 <ricolin> Anything would like to discuss today?:)
15:05:16 <therve> The py3 gate is almost green!
15:05:25 <therve> The amqp gate is still slow!
15:05:30 <therve> Do reviews!
15:05:31 <ramishra> therve: I've seen one more test failing
15:05:37 <zaneb> o/
15:05:39 <ramishra> I've a patch for it
15:05:53 <therve> ramishra, There are some intermittent failures, but I mostly see the zaqar one now
15:06:07 <therve> Which relies on heat-agents using py3 I believe
15:06:13 <zaneb> +1000 for do reviews :)
15:06:26 <ricolin> therve and clue on the zaqar one?
15:07:01 <therve> ricolin, Yeah heat-config-notify can't find the keystone lbi
15:07:04 <therve> lib
15:07:23 <ramishra> I think test_preview is failing too
15:07:37 <therve> I just pushed a patch that tries to use py3 to call it, but I don't think it'll work just yet
15:07:39 <ramishra> though it's itermittent and I know the issue
15:07:43 <therve> Ah ok
15:08:10 <ramishra> I'll push the patch after the meeting
15:08:59 <therve> We could make it voting if we feel brave after that
15:09:36 <ricolin> voting+1
15:09:51 <ramishra> May be change it to convergence? I assume it's using legacy now. Though there should not be any issue
15:10:30 <ricolin> yeah, convergence should be better way
15:10:50 <ricolin> When will we deprecate legacy?:)
15:12:19 <zaneb> ricolin: let's not go there today :)
15:12:38 <ramishra> ricolin: when we reduce memory usage;)
15:12:59 <ricolin> zaneb, ramishra fine!
15:13:19 <zaneb> lol
15:13:33 <ramishra> I've one topic, I've not added it though
15:13:45 <ricolin> sure
15:14:02 <ricolin> it's yours!
15:14:15 <ramishra> If there is nothing else we can discuss about neutron forcing us to use openstacksdk
15:14:29 <ramishra> It seems all new features are in openstacksdk and not neutronclient
15:14:44 <therve> Yeah
15:14:45 <ramishra> Segments are implemented only in openstacksdk
15:14:47 <ricolin> yep
15:14:52 <therve> Which is one feature, but still :)
15:15:02 <ramishra> However there are stuff like tags not in openstacksdk
15:15:11 <therve> ramishra, tags?
15:15:22 <ramishra> tiantian is working on that
15:15:39 <therve> You mean it's in neutronclient?
15:15:51 <ramishra> therve: yeah
15:16:10 <therve> ramishra, We should only use the sdk for new features though, not port everything
15:16:12 <tiantian> yes, I am working on tags for neutron resources
15:16:22 <therve> trunks aren't in sdk as well for example
15:16:40 <tiantian> and tags is in neutronclient
15:16:40 <ramishra> I think neutron team is not going to maintain neutronclient anymore
15:16:44 <therve> Basically just use openstacksdk for segment resources
15:16:52 <therve> ramishra, I think it's more complicated than that
15:17:00 <tiantian> it's a 'old' feature
15:17:20 <ricolin> how about trunk segment? openstacksdk+neutronclient?
15:17:55 <ramishra> I think for neutron team it's openstacksdk and osc as the future
15:18:11 <ramishra> yeah we can start with new features with openstacksdk
15:18:14 <therve> Maybe, but it's not there yet
15:18:30 <therve> They have plenty of time to change their mind
15:18:39 <ramishra> therve: lol
15:18:40 <ricolin> ramishra you mean new heat feature:)?
15:18:41 <therve> Like the time to actually implement the features there
15:19:38 <ramishra> ricolin: I'm working on segment resource
15:20:01 <zaneb> hey everybody do you remember that time we added _LI() around all the log messages and then removed it again?
15:20:18 <zaneb> that was fun, we should do more stuff like that
15:20:30 <cwolferh> lol
15:20:30 <ricolin> lol
15:20:34 <ramishra> :)
15:20:37 <prazumovsky> hah
15:20:42 <ricolin> `#action`?
15:20:51 <ricolin> :)
15:20:54 <zaneb> ricolin: lol
15:21:03 <tiantian> :)
15:21:50 <ramishra> ricolin: I'm done with openstacksdk thing
15:21:58 <ricolin> ramishra cool:)
15:22:17 <ricolin> any other topic to discuss?
15:22:25 * zaneb is done making snarky jokes
15:22:41 <tiantian> so I can continue the tags patches with neutronclient?
15:22:48 <therve> tiantian, +1
15:22:53 <ricolin> yeah
15:23:39 <tiantian> ok
15:24:02 <zaneb> +1
15:24:16 <ricolin> nice!
15:24:26 <ricolin> shall we end the meeting and get back to code:)?
15:24:39 <zaneb> I have a feeling gfidente is about to raise a topic :)
15:24:46 <ricolin> okey
15:24:56 <tiantian> one more thing, hope more stable cores
15:24:58 <gfidente> zaneb no no, only lurking
15:25:18 <gfidente> :)
15:25:25 <tiantian> we merge the backport so slowly :(
15:25:31 <zaneb> gfidente: ok :)
15:25:59 <ramishra> tiantian: Add the stable-maint cores are reviewers
15:26:23 <zaneb> tiantian: agree. I think you have probably done the most reviews on stable, so I think we should nominate you as a stable core :)
15:26:38 <ricolin> tiantian let's propose new stable core before boston, and we all review more stable branch more before that:)
15:27:08 <tiantian> zaneb, thank you :)
15:27:44 <zaneb> ricolin: I guess that's my job?
15:27:57 <ricolin> zaneb yes!
15:28:06 <zaneb> ok
15:28:23 <zaneb> I will take a #action
15:28:25 <ricolin> zaneb just thinking the way to deal with stablemint core team
15:29:25 <ricolin> #action zaneb to nominate stable core reviewers
15:30:10 <ricolin> tiantian problem solved!:)
15:30:24 <tiantian> great!!
15:30:59 <zaneb> well, we still need everybody else to do more stable reviews too so we can nominate more people in future
15:31:17 <zaneb> ricolin: so no slacking ;)
15:32:01 <ricolin> zaneb: cheers!
15:32:08 <zaneb> on another topic...
15:32:16 <zaneb> everybody please read http://lists.openstack.org/pipermail/openstack-dev/2017-March/114687.html
15:33:03 <zaneb> that is all.
15:33:34 <ricolin> zaneb thx:)
15:34:42 <ricolin> also we probably should discuss about onboarding training and project update session in next week meeting
15:35:16 <ricolin> Any other topic:)?
15:35:34 <zaneb> ricolin: btw I _will_ be in Boston
15:35:42 <ricolin> Good!
15:35:50 <ricolin> I need you there!!!
15:35:57 <zaneb> if I ever get around to booking...
15:36:25 <ricolin> you can just drive 2hr to there!
15:36:36 <tiantian> https://review.openstack.org/#/c/407328/ hope your reviews
15:36:54 <tiantian> :) proposed for a long time
15:37:00 <zaneb> ricolin: America is much bigger than it looks ;)
15:37:15 <ricolin> zaneb prove it!
15:37:54 <tiantian> then nothing from me :)
15:38:32 <ricolin> We will do Pike-1 around 4/1x so would like guys do more review for bp or old patches:)
15:38:50 <ricolin> that's all:)
15:39:47 <ricolin> Anything we should aware of?:)
15:40:03 <zaneb> we really need to land the stack-definition series IMO
15:40:18 <zaneb> it's blocking other stuff
15:40:45 <zaneb> all of the remaining non-WIP patches are short-ish
15:41:08 <tiantian> zane, will have a look tomorrow :)
15:41:16 <zaneb> tiantian: thanks!
15:41:24 <ricolin> I'm fine with landing it mostly, since you already give out walk through at PTG for us:)
15:42:00 <zaneb> yes, it should be an easy review for everyone who was at the PTG ;)
15:42:41 <zaneb> also thanks to the folks who reviewed the long-ish patches at the beginning already?
15:42:58 <zaneb> why did a question mark show up there?
15:44:55 <ricolin> that's make it landed at pike-1:)
15:45:30 <ricolin> Anything else? :)
15:46:34 <ricolin> Then I guess that's all, thanks guys
15:46:38 <ricolin> #endmeeting