15:00:53 <ricolin> #startmeeting heat
15:00:54 <openstack> Meeting started Wed Apr 12 15:00:53 2017 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:59 <openstack> The meeting name has been set to 'heat'
15:01:03 <ricolin> #topic roll call
15:01:35 <ramishra> hi
15:01:42 <ricolin> hi:)
15:01:43 <jasond> o/
15:01:50 <cwolferh> hello
15:01:52 <pbourke> o/
15:02:58 <ricolin> #topic adding items to agenda
15:02:59 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282017-04-12_1500_UTC.29
15:04:33 <ricolin> okey first topic!
15:04:35 <ricolin> #topic Announcement
15:04:57 <ricolin> so we have release heat pike-1!
15:05:01 <ricolin> yeah!
15:05:15 <ramishra> ricolin: great
15:05:25 <ricolin> all looks clean
15:05:38 <ricolin> also will release python-heatclient 1.9.0
15:05:59 <ramishra> I was hoping to land the translation patches before that but anyway it does not matter
15:06:09 <ricolin> and heat-agents from 1.1.0 to 1.1.1
15:06:21 <ricolin> yeah, me to
15:06:33 <ricolin> will get it landed as soon as we can :)
15:06:37 <ramishra> reg heat-agents, we did a release just a few days back right? do we need one more?
15:07:50 <ricolin> there actually only increase one commit between, so I'm free to release or not:)
15:08:10 <ricolin> that's why I only jump from 1.1.0 to 1.1.1
15:08:24 <ricolin> what guys think about it?
15:08:29 <pilgrimstack1> Sorry I have to leave, next time we should speak about non floating IP providers ;)
15:08:44 <ricolin> pilgrimstack1
15:08:47 <ricolin> pilgrimstack1 ok
15:09:04 <ricolin> pilgrimstack1 ok I will help to add to agenda next week:)
15:09:25 <ramishra> This was on 5th April https://review.openstack.org/#/c/452986/
15:10:03 <ramishra> So not sure if we want one more now
15:10:25 <ricolin> sure, then I can abandon this one https://review.openstack.org/#/c/455876/
15:11:13 <ricolin> ramishra abandoned:)
15:11:22 <ramishra> ricolin: :)
15:11:27 <ricolin> how about python-heatclient?
15:11:45 <ricolin> #link https://review.openstack.org/#/c/455873/
15:12:20 <ramishra> I think that one was not done after ocata, so should be ok I think
15:12:45 <ricolin> ramishra thx:)
15:13:20 <ricolin> Also I have send goals response to release
15:13:25 <ricolin> #link https://review.openstack.org/#/c/455121/
15:13:39 <ricolin> s/release/governance/
15:14:07 <ramishra> ricolin: yeah, I have seen that
15:14:08 <ricolin> would like guys can help to review and correct any mistake before it merged
15:15:04 <ramishra> does it mention about the py35 dsvm job?
15:15:17 <ricolin> I think so
15:15:31 <ramishra> but anyway, it's just to agree that we're doing it this cycle
15:15:36 <ricolin> I can update more words if it's not clear
15:15:58 <ricolin> ramishra yeah:)
15:16:26 <ricolin> so on top of that
15:16:28 <ricolin> #topic py35 gate jobs
15:16:53 <ramishra> So it seems to green most of the time, I've not seen many failures
15:17:08 <ramishra> I've the project-config patch ready to make it voting
15:17:13 <ricolin> I think it's all green
15:17:20 <ramishra> but there are few things to consider
15:17:40 <ricolin> like what?:)
15:17:45 <ramishra> 1. We've disabled swift related tests
15:17:59 <ricolin> yes
15:18:11 <ramishra> 2. There are some infra changes planned in this and next week
15:18:27 <ramishra> So may be we wait for some more time before enabling it
15:18:40 <ramishra> but If we all agree I can push that change though
15:18:47 <ricolin> oh, I see what you talking about now
15:18:55 <ricolin> agree with you
15:19:11 <ricolin> also can you share your patch about voting?
15:19:28 <ramishra> I've not pushed it yet:)
15:19:35 <ricolin> okey:)
15:19:51 <ramishra> Let me do that with WIP
15:20:06 <ricolin> just like to make sure we do that with your patch
15:20:16 <ricolin> ok:)
15:20:54 <ricolin> #action ramishra will send the voting patch for heat py35 test later
15:21:31 <ramishra> https://review.openstack.org/#/c/456253/1
15:21:37 <ramishra> done:)
15:21:55 <ricolin> #link https://review.openstack.org/#/c/456253
15:21:59 <ricolin> nice:)
15:22:06 <ricolin> also I would like to propose about adding py35 job for python heat client and heat cfntools
15:22:39 <ricolin> I already have patch wip, but would like to know what guys think about it
15:22:46 <ricolin> before I send it out
15:23:44 <ramishra> we already have gate-python-heatclient-python35?
15:24:04 <ricolin> right I mean heat-agents:)
15:25:19 <ramishra> I think therve wanted to land https://review.openstack.org/#/c/425057/ before adding the py35 job for heat-agents
15:25:26 <ricolin> Thomas already have some py35 fix (https://review.openstack.org/#/c/425057/)
15:25:45 <ramishra> So that we can simply add a voting job
15:26:01 <therve> Yeah steve wasn't super nice
15:26:11 <ricolin> yeah, I'm totally +1 with that:)
15:26:17 <ricolin> lol
15:26:19 <therve> Blocking my patch and not proposing the project-config patch is not cool
15:27:00 <ricolin> that's why I would like to make it a team's call to make it land first or not:)
15:27:29 <ramishra> I'll check with stevebaker tomorrow morning if he can unblock it then:)
15:27:44 <ricolin> ramishra thx
15:29:19 <ricolin> okey
15:29:23 <ricolin> #topic Open discussion
15:30:15 <ricolin> therve ramishra I would like to know is this the basic define test we talk about in PTG?
15:30:19 <ricolin> #link https://review.openstack.org/#/c/454222/
15:30:41 <therve> ricolin, What does "define test" mean?
15:31:38 <ricolin> therve we have agree about to give out a test list for refstack team for define if the environment contain `heat service`
15:32:02 <ricolin> in the list we agree about basic api tests (which rabit implemented)
15:32:44 <ricolin> and a basic sceniro test which use the basic core services(nova, cinder, neutron, etc)
15:34:05 <ricolin> so I write that test for team to make sure if that's what we talking about
15:35:30 <ricolin> as long as we can running all those test well in tempest command, I think refstack team is okey with it
15:36:17 <ricolin> guys, any idea?
15:36:27 <therve> I don't care
15:37:48 <ricolin> okey!
15:38:13 <ramishra> ricolin: I'll check, but I'm not very clear about the refstack team expectations
15:38:57 <ricolin> I think it's about to let them have something to propose to TC about making heat a core project
15:39:34 <ricolin> they actually don't might with the detail of tests as long as it's okey by heat
15:40:34 <ricolin> Any other topic to discuss this week?:)
15:42:26 <ricolin> I think we can end the meeting if no other topic this week:)
15:43:02 <ramishra> +1
15:43:08 <ricolin> thanks all:)
15:43:10 <ricolin> #endmeeting