15:00:52 <ricolin> #startmeeting heat
15:00:56 <openstack> Meeting started Wed May 17 15:00:52 2017 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'heat'
15:01:03 <ricolin> #topic roll call
15:01:16 <zaneb> \o
15:01:24 <LanceHaig> \o
15:01:40 <ricolin> LanceHaig, good to see you here:)
15:01:48 <LanceHaig> Happy to be here
15:02:00 <ramishra> hi
15:02:00 <kazsh> \o
15:02:19 <ricolin> kazsh, hi:)
15:02:44 <kazsh> hi ricolin :)
15:03:22 <ricolin> #topic adding items to agenda
15:03:29 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282017-05-17_1500_UTC.29
15:04:55 <ricolin> #topic weekly report
15:05:13 <ricolin> we have on critical bug this week
15:05:15 <ricolin> #link https://bugs.launchpad.net/heat/+bug/1690936
15:05:16 <openstack> Launchpad bug 1690936 in heat "Need to stop using image/floating_ip passthroughs in novaclient" [Critical,Fix released] - Assigned to Thomas Herve (therve)
15:05:34 <ricolin> which fixed by ramishra and therve
15:06:00 <therve> I just approved the tests that were removed
15:06:05 <ricolin> thanks nova:)
15:06:09 <therve> We need to fix the nova network resources now
15:06:19 <ricolin> yes
15:06:20 <zaneb> thanks everyone who worked on that
15:06:36 <zaneb> it was like 5.30pm when I found it
15:07:02 <ricolin> that's what we have to discussed about, what's the best way to fix like nova floating ip?
15:07:32 <ricolin> we can do like "OS::Nova::Floatingip": "OS::Neutron::Floatingip"
15:07:46 <ricolin> but the properties seems so different
15:07:49 <therve> Alias to None?
15:08:00 <therve> I don't think the alias to neutron would work
15:08:24 <therve> I think it's similar to the ceilo one, the backend doesn't support it
15:09:05 <zaneb> ricolin: I didn't realise the properties were different
15:09:23 <zaneb> I think we need to reimplement the Nova one to use the neutron client
15:09:32 <ricolin> therve, I was thinking maybe we can use something like that
15:09:34 <ricolin> #link https://review.openstack.org/#/c/439433/9
15:09:51 <ramishra> I was thinking may be we keep the resource hidden/deprecated and change the nova calls to neutron ones
15:09:51 <ricolin> therve, which will still allow delete on exists
15:09:53 <zaneb> the nova client was previously calling Neutron for us, now we have to do it ourselves
15:10:06 <ramishra> in those resources
15:10:10 <zaneb> ramishra++
15:10:10 <therve> zaneb, Hum... was it?
15:10:17 <therve> I thought it was nova network stuff
15:10:40 <zaneb> therve: I believe so, for clouds that had Neutron
15:10:45 <ramishra> therve: it used to work for both nova-network and neutron
15:10:51 <therve> Hum, okay
15:10:54 <ramishra> so now it would only work with neutron
15:11:02 <zaneb> IIUC that was part of their migration plan
15:11:27 <ricolin> for example in nova floating ip create
15:11:29 <ricolin> self.client().floating_ips.create(pool=pool)
15:12:15 <ramishra> ricolin: we will convert these to neutron calls
15:12:29 <ricolin> ramishra, okay
15:12:31 <therve> OK, that sounds like a plan then
15:13:17 <ramishra> yep, I can do that tomorrow if no one takes a stab at it when I'm sleeping;)
15:13:21 <ricolin> TBH directly use None will be easier but maybe you guys are right
15:13:54 <ricolin> ramishra, I sleep when you sleep:)
15:14:02 <zaneb> ricolin: no way to delete existing stuff if you alias to None
15:14:46 <ricolin> zaneb, how about alias to None and overwrite handle_delete?
15:15:10 <therve> ricolin, If you alias to None you don't have a  delete method?
15:15:19 <therve> You mean inheriting None?
15:15:24 <ricolin> doh!
15:15:39 <ricolin> sorry, and yes inheriting!
15:15:54 <therve> I prefer ramishra's idea
15:16:09 <ricolin> therve, actually me too now:)
15:16:15 * zaneb too
15:16:18 <therve> OK let's move on then :)
15:16:36 <ricolin> still on weekly report!
15:16:36 <zaneb> SOLD to ramishra
15:17:07 <ricolin> #action ramishra will help on nova legency resource
15:17:31 <ricolin> We also has two high bug this week
15:17:40 <ricolin> #link https://bugs.launchpad.net/heat/+bug/1689689
15:17:41 <openstack> Launchpad bug 1689689 in heat "retryError when detach interface" [High,New] - Assigned to huangtianhua (huangtianhua)
15:17:49 <ricolin> #link https://bugs.launchpad.net/heat/+bug/1691355
15:17:49 <openstack> Launchpad bug 1691355 in heat "Error raised when stack-create" [High,In progress] - Assigned to huangtianhua (huangtianhua)
15:18:02 <ricolin> Also in Summit
15:18:30 <ricolin> we been reported by numbers of user about the lack of document from heat
15:18:54 <therve> documentation?
15:19:36 <ricolin> Basically tutorial
15:19:51 <ricolin> therve, yes
15:20:06 <therve> Yeah that'd be nice
15:20:16 <therve> Docs are hard to write though
15:21:02 <LanceHaig> We have something in our project that I think is a good tutorial
15:21:02 <ricolin> like short of rolling upgrade doc, software config doc, template samples, and some basic user friendly tutorial
15:21:03 <LanceHaig> https://github.com/heat-extras/heat-tutorial
15:21:39 <LanceHaig> It takes you from basic heat to software deployments
15:22:06 <ricolin> LanceHaig, and his team will step out to help btw:)
15:22:14 <therve> LanceHaig, Oh that's really cool
15:22:35 <LanceHaig> We saw  need when we were trying to show others
15:22:38 <therve> It'd be nice if it was in Heat itself :)
15:22:56 <LanceHaig> so florin merged a number of resources that he credits there into a tutorial
15:23:22 <LanceHaig> Well that was the discussion ricolin had with florin
15:23:46 <LanceHaig> I think florin is happy to merge hi stuff into an official repo
15:23:59 <LanceHaig> I am not sure how that would be done thoug
15:24:10 <ramishra> +1, we can probably add them to heat
15:24:10 <ricolin> LanceHaig, yeah, I think we really need those stuff:)
15:24:33 <ramishra> may be heat-templates repo?
15:24:54 <ricolin> LanceHaig, I already look through your repo, really a lot of stuff can merge back in heat
15:25:07 <therve> ramishra, Rather see heat, so that it's in the official doc site
15:25:12 <LanceHaig> We also have created a library for our customers and have started an open source version that is here https://github.com/heat-extras/heat-lib
15:25:13 <ricolin> for tutorial should be in heat repo
15:25:14 <therve> We don't have rst doc in heat-templates
15:25:22 <ramishra> therve: OK
15:25:31 <LanceHaig> we would also be happy to add that to an official repo as well
15:26:12 <ricolin> LanceHaig, feel free to raise discuss about which cool stuff should goes to which repo:)
15:26:22 <LanceHaig> the heat-lib is still a work in progress as we had to create it from scratch due to IP issues with customers
15:26:44 <therve> LanceHaig, It's that mostly template stuff?
15:27:09 <LanceHaig> also we started creating "solutions" based on the heat-lib to deploy complex applications with heat using just a few parameters
15:27:33 <LanceHaig> therve, it is a library of templates that makes deploying things easier for users
15:27:39 <LanceHaig> it has been useful for our customers
15:28:11 <LanceHaig> we have seen adoption of heat as the deployment method increase since providing this
15:28:15 <therve> Cool
15:28:32 <LanceHaig> therve, it also has some software deployments for applications as well mysql apache reverse proxy etc
15:28:41 <LanceHaig> as per our demo in Boston
15:29:04 <LanceHaig> it is like a toolkit for new clouds
15:29:24 <ricolin> #action LanceHaig and his team will help to join their force back to heat(which will be a great job)
15:29:35 <LanceHaig> ricolin, I am not sure how to start the discussions you mention as I am a newbie OS project person
15:29:41 <LanceHaig> I have just been a user until now
15:30:29 <LanceHaig> happy to help
15:30:34 <ricolin> #link https://www.youtube.com/watch?v=TVYNVsqBiqU&t=1399s
15:31:57 <ricolin> LanceHaig, I think we can start from what ever you feel like to go first, and let's keep discuss every time we meet online and in person:)
15:32:10 <LanceHaig> Ok cool
15:32:24 <LanceHaig> I think we need to investigate testing templates as well
15:32:24 <ricolin> also we got some guy from China said they will help on rolling upgrade with test and document it:)
15:32:31 <LanceHaig> we chatted in the channel about it
15:32:36 <LanceHaig> and I think it is important
15:32:51 <LanceHaig> ok
15:34:04 <ricolin> LanceHaig, I think we can do both template and tutorial, there definitely value there:)
15:34:17 <ramishra> I like the idea of using heat-templates for out gate testing, but that would be good chunk of work to do
15:35:15 <zaneb> ramishra, LanceHaig: let's focus on getting a gate that verifies the templates by calling 'heat template-validate'
15:35:21 <ricolin> ramishra, +1
15:35:37 <LanceHaig> the heat-lib has some complex items like Lb cluster or resource group etc.. so i think that this could be useful way to test and provide users with examples and a library to use
15:35:51 <ramishra> zaneb: I thought we already do that no?
15:35:52 <LanceHaig> zaneb, +1
15:35:54 <zaneb> that'll be much better than what we have + much easier than actually spinning up all that stuff
15:36:10 <zaneb> ramishra: afaik we only check that's it's valid YAML
15:36:37 <therve> zaneb, No no we call validate
15:36:38 <ricolin> zaneb, yes
15:37:19 <gfidente> LanceHaig sorry I didn't go through the repo but is the library meant to deploy services (eg. mysql) or a set of resources (eg. two servers and a balancer)
15:37:29 <zaneb> apparently opinions differ? :D
15:38:18 <therve> We used to, at least. I wrote the support.
15:38:22 <LanceHaig> gfidente, it does both
15:38:38 <LanceHaig> therve, I can't see it in the box file
15:38:43 <LanceHaig> therve, I can't see it in the tox file
15:39:01 <therve> LanceHaig, Well yeah you can't use tox for validation
15:39:04 <therve> It needs a running heat server
15:39:11 <zaneb> there is a gate-heat-templates-dsvm job it appears
15:39:15 <gfidente> LanceHaig so the target is to deploy a service but in doing so it might create a few resources working together?
15:39:27 <therve> http://logs.openstack.org/15/460215/1/check/gate-heat-templates-dsvm/bdb0fca/console.html.gz#_2017-04-26_16_51_06_426047
15:39:53 <therve> It still calls the tool at least
15:40:09 <ricolin> therve, okay good to know:)
15:40:37 <LanceHaig> gfidente, there is a tests directory that can explain it better than I can :-)
15:40:44 <zaneb> therve: "--ignore-errors", "99001" makes me wonder how much stuff is actually getting checked
15:40:45 <therve> And http://logs.openstack.org/15/460215/1/check/gate-heat-templates-dsvm/bdb0fca/logs/screen-h-eng.txt.gz has some validation calls :)
15:40:51 <therve> zaneb, A bit
15:41:06 <ramishra> https://github.com/openstack/heat-templates/blob/master/tools/post_test_hook.sh#L20
15:41:13 <therve> Adding neutron would be a good thing at least
15:41:13 <zaneb> #link http://git.openstack.org/cgit/openstack/heat-templates/tree/tools/validate-templates
15:41:20 <therve> Maybe zaqar and mistral too
15:41:22 <LanceHaig> I just found that
15:42:57 <therve> ricolin, Can you add an action to add more services to that test run?
15:43:32 <LanceHaig> We need to see what is ignored by --ignore-errors
15:43:43 <therve> LanceHaig, http://logs.openstack.org/15/460215/1/check/gate-heat-templates-dsvm/bdb0fca/logs/screen-h-eng.txt.gz has some logs
15:43:55 <LanceHaig> as I think some of it might be broken
15:44:45 <ricolin> #action We should add more services to validate test run, at least Neutron Zaqar, Mistral
15:45:03 <zaneb> LanceHaig: it ignores errors where you use a resource for a service that isn't in the catalog
15:45:20 <LanceHaig> zaneb, ok
15:45:21 <zaneb> (that's the error "99001")
15:45:27 <LanceHaig> therve, thanks
15:45:39 <zaneb> oddly, that's literally the only error that has a number
15:45:51 <ricolin> We shall see what we can do before next week meeting:)
15:46:20 <ricolin> LanceHaig, feel free to raise discussion any time in heat channel
15:46:42 <ricolin> We're a global team 24H :)
15:47:09 <ricolin> we only got 14 mins left shall we move to next topic now:)
15:47:21 <LanceHaig> yup
15:47:33 <zaneb> therve: I wonder if we can just set up a fake catalog with every service in it... it's not like we need them to be actually running to validate
15:47:44 <ricolin> #Template Guide docs, location thereof
15:47:55 <therve> zaneb, Interesting idea :). That would make the job much faster too
15:47:59 * therve got to go now
15:48:10 <LanceHaig> zaneb, +1
15:48:17 <ricolin> therve, thanks for join:)
15:48:26 <zaneb> therve: o/
15:48:30 <ricolin> who now what this is about?
15:48:33 <ricolin> the topic
15:48:34 <zaneb> ricolin: #topic?
15:48:42 <ricolin> @topic Template Guide docs, location thereof
15:48:47 <ricolin> #topic Template Guide docs, location thereof
15:48:47 <zaneb> fail
15:48:58 <zaneb> I added this one
15:49:40 <zaneb> I talked to asettle at the summit about moving the template guide out of the (Heat) developer-facing documentation (where nobody) can find it
15:50:12 <zaneb> apparently the docs folks are planning to propose allowing projects to build user-facing docs from their own repos
15:50:19 <zaneb> like we already do with the install guide
15:50:36 <LanceHaig> This would be a good idea
15:50:41 <zaneb> this seems like the way to go to me
15:50:52 <ricolin> zaneb, +1
15:51:19 <zaneb> I'm not 100% clear on whether this will be the new way to build the existing user guide, or if this is in addition
15:51:41 <ricolin> We definitely got to move those user doc to where user feel comfortable to find it
15:51:47 <zaneb> yeah
15:52:00 <LanceHaig> ricolin, +1
15:52:35 <ricolin> zaneb, what you think is the first step as action of this
15:53:16 <ricolin> zaneb, I see you already collect some info of heat doc for Alexandra Settle
15:53:21 <zaneb> ricolin: I told her it sounded like a good plan to me. for now we can probably just wait for them to make the change
15:53:24 <ricolin> see/saw
15:54:14 <zaneb> ricolin: yes, I cc'd you on the emails so you already know about it
15:54:16 <ricolin> zaneb, sure, so let's add more tutorial and wait
15:54:50 <ricolin> zaneb, yes, just feel like to give her some better answer after this meeting
15:55:12 <zaneb> ricolin: yeah, you can give the Official PTL response :)
15:55:13 <ricolin> zaneb, which you already give it to her:)
15:55:44 <ricolin> sure! right away sir!
15:56:01 <ricolin> let's go to next topic before time's up!
15:56:14 <ricolin> #topic Custom Resource type managed by Mistral Workflows (feedback/reviews)
15:56:20 <ricolin> gfidente, yours
15:56:36 <gfidente> ricolin thanks
15:56:46 <gfidente> so I am basically working on this spec https://blueprints.launchpad.net/heat/+spec/mistral-new-resource-type-workflow-execution
15:57:03 <gfidente> togerher with a few heat folks already
15:57:28 <gfidente> purpose is to make it possible to control a mistral workflow execution as part of the stack deployment
15:57:58 <gfidente> that is, not with a signal after the stack has completed, but during the stack deployment and fail if the execution itself fails
15:58:42 <zaneb> that's one interpretation ;)
15:58:51 <gfidente> in doing so, we discussed a rather general approach for the new resource which allows for example triggering different workflows based on the action (create/update/...)
15:59:28 <gfidente> zaneb right but this is sort of what I wanted to get to
15:59:44 <gfidente> we're basically booked in tripleo on using it for the pike release
16:00:14 <gfidente> so feedback/reviews on the submission are highly appreciated :)
16:01:06 <ricolin> I think it's some great feature that now already approved, so feel free to help on review stuffs:)
16:01:07 <gfidente> and that's all from me , unless you have questions
16:01:50 <zaneb> gfidente: I haven't looked since patch set 9, is the env stuff implemented now?
16:02:11 <gfidente> zaneb no indeed, I haven't added that yet as I didn't understand how to use execution environments in mistral
16:02:20 <gfidente> now I think I figured, so it should be the last part missing
16:02:52 <zaneb> https://review.openstack.org/#/c/267770/9/specs/pike/custom-resource-mistral-workflows.rst@84
16:03:04 <zaneb> ok
16:03:11 <ricolin> gfidente, would be greate if you can find some where to document the entire stuff down
16:03:23 <zaneb> gfidente: ping me when that's done & I will re-review
16:03:27 <ricolin> s/greate/great
16:03:55 <ricolin> okay we run out of time
16:03:58 <zaneb> gfidente: to the extent that it's done, it all looks good to me so far
16:04:09 <gfidente> zaneb++ thanks for reviewing it
16:04:17 <gfidente> I miss tests
16:04:24 <ricolin> let's move "heat-template future" to next week?
16:04:48 <zaneb> ricolin: I thought we already talked about it?
16:05:04 <zaneb> but we can come back to it next week
16:05:07 <ricolin> zaneb, High chances:)
16:05:25 <LanceHaig> yum ok
16:05:37 <LanceHaig> yup even
16:05:42 <ricolin> so we going to pass open discussion this week
16:05:57 <ricolin> feel free to raise any discussion in #heat after meeting
16:06:24 <ricolin> thanks all for join, and welcome on board guys:)
16:06:27 <ricolin> #endmeeting