15:00:04 <ricolin> #startmeeting heat
15:00:05 <openstack> Meeting started Wed Jul 5 15:00:04 2017 UTC and is due to finish in 60 minutes. The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <openstack> The meeting name has been set to 'heat'
15:00:13 <ricolin> #topic roll call
15:00:38 <zaneb> o/
15:00:44 <LanceHaig> o/
15:00:47 <ricolin> o/
15:00:51 <kazsh> o/
15:00:54 <kiennt> o/
15:01:23 <ramishra> Hey
15:01:54 <ricolin> #topic adding items to agenda
15:02:04 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282017-07-05_1500_UTC.29
15:04:10 <ricolin> #topic weekly report
15:04:26 <ricolin> we got one gate fail
15:05:04 <ricolin> and got 14 days before feature release
15:05:56 <ricolin> most of our new resource bp already landed
15:07:30 <ricolin> still got the stack define, get resource reality, so do hope we can try to make some of them landing in next week
15:08:00 <ricolin> #topic propose for online video meeting next week
15:08:14 <ricolin> so as we discussed last week
15:08:46 <ricolin> I would like to propose we host a online video meeting next week
15:09:19 <ricolin> We can consider two options zoom or google hangout
15:09:39 <zaneb> ricolin: what is the topic for this meeting?
15:10:05 <ricolin> zaneb, right! "review">
15:10:18 <ricolin> how about review?
15:10:25 <zaneb> ok, that's a good reason to have a video meeting :)
15:10:50 <ricolin> we should choose one host and few patches for it
15:11:51 <ramishra> guys, sorry I've to drop off now, will check the log tomorrow, if there is any action item for me;)
15:12:02 <zaneb> zoom seems like it's worth a try
15:12:10 <ricolin> ramishra, thx will do:)
15:12:27 <ricolin> zaneb, yep, since hangout might not be the best option for our friend in china and zaneb
15:12:49 <ricolin> any third suggestion?:)
15:14:10 <ricolin> zoom it is:)
15:14:41 <ricolin> #action please all prepare for a zoom account for review meeting next week
15:15:26 <ricolin> I can get a zoom's room which can contain 50 people
15:16:29 <LanceHaig> I already have a zoom acc :-)
15:16:55 <ricolin> also for topic, I would like to propose we review BPs first since feature freeze is near
15:17:15 <ricolin> LanceHaig, nice!:)
15:18:10 <zaneb> ricolin: I can find you some patches to review ;)
15:18:48 <ricolin> zaneb, nice
15:19:14 <ricolin> here's some bp patches that we should consider to review
15:19:18 <ricolin> https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/stack-definition
15:19:41 <ricolin> #link https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/support-trunk-port
15:20:05 <ricolin> #link https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/get-reality-for-resources
15:20:34 <zaneb> the stack-definition list is fairly incomplete. I have a lot more patches than that
15:20:57 <ricolin> zaneb, I know:)
15:21:46 <zaneb> basically all but the last 5 in https://review.openstack.org/#/q/owner:zbitter%2540redhat.com+status:open
15:21:52 <ricolin> also I would like to propose the delay resource one so we left just few for BPs
15:22:12 <zaneb> good news though, all but one are pretty small
15:22:25 <zaneb> and the one big one is not as bad as it sounds
15:23:38 <ricolin> zaneb, lol
15:23:41 <ricolin> also
15:23:45 <ricolin> zaneb, I think you should be the host of that meeting:)
15:24:46 <zaneb> ricolin: I can talk through my patches. for the others I suggest we try to get the authors of those to talk through them
15:25:29 <ricolin> zaneb, sure
15:26:23 <ricolin> we will do BPs, so might be some BP authors not there
15:26:27 <ricolin> but anyway
15:26:30 <ricolin> we will see:)
15:26:55 <ricolin> hope we do it right and keep that from time to time and to PTG
15:27:11 <ricolin> #link https://zoom.us/
15:27:27 <ricolin> here is zoom's link if anyone would like to know
15:27:42 <ricolin> #link Report about rolling upgrade and discuss about multinode gate.
15:27:58 <ricolin> #topic Report about rolling upgrade and discuss about multinode gate./
15:28:03 <kiennt> hi everyone, me again :)
15:28:13 <ricolin> kiennt, Hi:)
15:28:13 <kiennt> Last week, I focused on finish testing Rolling upgrade and investigate about multinode gate job as you asked me to do .
15:28:28 <kiennt> About testing, I have recorded a video, if you have time :)
15:28:33 <kiennt> #link https://www.youtube.com/watch?v=yboTuNeaLbI
15:28:44 <kiennt> About multinode gate job, i have some troubles and ideas that was mentioned in new patch set:
15:28:49 <kiennt> #link https://review.openstack.org/#/c/407989
15:29:00 <kiennt> Today i want to ask some questions:
15:29:14 <kiennt> 1. . What kind of multinode job do you want for rolling upgrade testing? Modified Multinode Grenade or Kolla-Ansible gate based on?
15:29:35 <kiennt> 2. Is this gate for Heat only or may be new project like Grenade, but rolling upgrade testing. Because at the moment, no project has mulinode gate job for rolling upgrade testing.
15:30:15 <kiennt> That's all, what's your opinion? Thank all :)
15:31:07 <ricolin> for 1, I think some grenade-based testing yes
15:31:31 <ricolin> and for 2
15:31:43 <ricolin> I already ask TC about it
15:32:01 <ricolin> "Full stack integration testing with services arranged in a mid-upgrade manner is performed on every proposed commit to validate that mixed-version services work together properly. This testing must be performed on configurations that the project considers to be its reference implementations. The arrangement(s) tested will depend on the project (i.e. should be representative of a meaningful-to-operators
15:32:16 <ricolin> rolling upgrade scenario) and available testing resources. At least one representative arrangement must be tested full-stack in the gate."
15:32:52 <ricolin> so appears we have to find a way to test that in gate
15:33:13 <kiennt> Actually, Rabi gave me some comments in spec patch set, but he just drops off. Multinode gate, he wants to setup a Kolla gate based on.
15:33:52 <kiennt> Grenade has some limits, it shuts down all services at once, then bring them back (cold-upgrade)
15:34:07 <kiennt> In rolling upgrade, we need to change the workflow
15:34:29 <kiennt> so it won't shut down all
15:34:30 <kiennt> services at once.
15:34:32 <ricolin> kiennt, I'm fine with both actually, and I think rabi knows better than me on that topic:)
15:35:06 <kiennt> ricolin: yes, too bad he just drop off :(
15:35:20 <ricolin> What ever is the pick, we should talk with QA team before we do it
15:35:41 <kiennt> ricolin: yes, i agree
15:36:09 <zaneb> do we know how other projects with this tag do it?
15:36:24 <zaneb> (maybe there's a magic flag in grenade or something?)
15:36:57 <kiennt> zaneb: i find ironic team want to do this
15:37:09 <kiennt> #link https://github.com/openstack/ironic-specs/blob/master/specs/approved/support-rolling-upgrade.rst
15:37:23 <kiennt> i found this, multinode gate job was mentioned
15:38:13 <zaneb> it seems to me that the best test would be to run both old and new versions of both heat-api and heat-engine simultaneously, and then throw the entire integration test suite at it
15:39:36 <therve> zaneb, Is that a supported scenario?
15:39:43 <therve> I thought we need all the engines updated
15:39:59 <therve> needed
15:40:26 <zaneb> therve: isn't supporting that scenario the point of rolling upgrades?
15:40:53 <therve> zaneb, No, we can support rolling all engines, and *then* rolling all apis
15:41:35 <therve> Though I guess with the vhost stuff maybe that works?
15:41:52 <zaneb> therve: in practice, I don't think anybody does deployments like that
15:42:04 <kiennt> zaneb: i think the best test would be do rolling upgrade (start with old version ,upgrade to new). During this process, throw test at it.
15:42:20 <therve> Our test suite is not reliable enough to do that
15:42:50 <kiennt> i do rolling upgrade with vhost approach :) i think it's good enough :0
15:43:21 <zaneb> kiennt: running old and new versions simultaneously is equivalent to pausing a rolling upgrade in the middle - which is the part we actually want to test
15:45:34 <kiennt> zaneb: okay, i get it. In my test, i did the same thing, 2 heat-api 2 heat-engine. So during rolling, both old and new version are running simultaneously
15:46:47 <zaneb> cool, yeah that's exactly what I meant
15:47:02 <ricolin> kiennt, yep, and if we can run entire heat gate test suite during. that's what zaneb wanted
15:47:36 <zaneb> so we just need to find some test framework, preferably maintained by $somebody_else, that makes that easy :)
15:48:05 <kiennt> ricolin, zaneb: yep, that's what i wanted too. But the implementation isn't easy.
15:49:57 <ricolin> kiennt, maybe you should talk to some guys from QA team and make sure what exactly they want
15:50:13 <ricolin> kiennt, this might make it easier for you
15:51:28 <ricolin> kiennt, thx for your hard work on this:)
15:52:08 <ricolin> kiennt, any other thing to raise on this?:)
15:52:12 <kiennt> ricolin: yes, thank you. I found a patch set about this, but it was abandoned and i don't know why:
15:52:19 <kiennt> #link https://review.openstack.org/#/c/433216/3/specs/grenade/rolling_upgrade.rst
15:52:31 <kiennt> same idea
15:53:33 <kiennt> how can I contact with rabi? To ask his opinion?.
15:53:52 <ricolin> he's always on irc:)
15:54:07 <ricolin> ping him and ask him
15:54:10 <zaneb> except right now :D
15:54:26 <kiennt> ricolin: thank you, i will :D
15:54:28 <ricolin> will, people got to go:)
15:55:14 <ricolin> kiennt, NP
15:55:17 <ricolin> move on
15:55:21 <ricolin> #topic Open discussion
15:55:21 <kiennt> thank you, guys. We can move on now :0
15:55:24 <kiennt> :)
15:55:41 <ricolin> anything to raise or discuss?
15:56:37 <ricolin> zaneb, just find that retrigger replace in convergence never works;/
15:56:42 <ricolin> #link https://bugs.launchpad.net/heat/+bug/1702487
15:56:43 <openstack> Launchpad bug 1702487 in heat "Convergence: Fail to re-trigger replacement" [High,In progress] - Assigned to Rico Lin (rico-lin)
15:57:06 <zaneb> o.O that's not good
15:57:14 <zaneb> we don't have any test coverage for that?
15:57:24 <ricolin> noop
15:57:44 <zaneb> yikes
15:57:59 <ricolin> I can propose some test for that in later patch
15:58:31 <zaneb> ++
15:58:51 <ricolin> 2mins left
15:59:23 <ricolin> any other issue?:)
15:59:37 <ricolin> 9
15:59:37 <ricolin> 8
15:59:38 <ricolin> 7
15:59:38 <ricolin> 6
15:59:38 <ricolin> 5
15:59:39 <ricolin> 4
15:59:40 <ricolin> 3
15:59:41 <ricolin> 2
15:59:43 <ricolin> 1
15:59:45 <ricolin> 0.9
16:00:14 <ricolin> remember to register a zoom account for next meeting
16:00:27 <ricolin> I will send a Mail out
16:00:53 <ricolin> hope everyone can be there:)
16:01:01 <ricolin> thanks guys for join:)
16:01:02 <ricolin> #endmeeting