13:00:35 <ricolin> #startmeeting heat
13:00:36 <openstack> Meeting started Wed Dec 20 13:00:35 2017 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:39 <openstack> The meeting name has been set to 'heat'
13:00:41 <ricolin> #topic roll call
13:00:56 <kazsh> o/
13:01:00 <ricolin> o/
13:01:25 <ramishra> hi
13:01:33 <therve> Hi
13:01:53 <kiennt26> o/
13:02:14 <ricolin> #topic adding items to agenda
13:02:16 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282017-12-20_1300_UTC.29
13:02:52 <ricolin> I got integrationtests and Ceilometer resources
13:02:52 <ricolin> two topics
13:04:10 <ricolin> and btw gerrit is quite unstable for now
13:05:08 <ricolin> #topic Ceilometer resources
13:05:25 <ricolin> Ceilometer api and client was retired https://review.openstack.org/#/c/522183/
13:05:58 <ricolin> Now about our Ceilometer client, Any suggestion on how we deprecate a client plugin?
13:07:09 <ramishra> we don't have any ceilometer resources. it's just threshold alarm(AodhAlarm) resource can't be used and cloudwatch without the ceiloemeter api
13:07:50 <ramishra> ricolin: we can probably leave the plugin around and remove it next cycle
13:08:05 <ramishra> I mean the client plugin
13:08:11 <ricolin> yeah, that part that I'm also wondering maybe we should directly hidden Alarm resource instead of deprecate it?
13:08:23 <ricolin> #link https://review.openstack.org/#/c/517189/
13:09:08 <ramishra> we can hide it, but if we want to follow the standard process then...
13:10:39 <ricolin> ramishra, yeah, I would hope to go for a standard way, but meanwhile it will be a broken deprecated resource right?
13:12:35 <ramishra> yeah, it would break, but I think people can possibly run older ceilometer with heat and get away, I don't know
13:12:54 <ricolin> ramishra, right, that's a fair point
13:14:37 <ricolin> ramishra, So about cloudwatch, deprecate it first as well?
13:15:12 <therve> It's not already?
13:15:42 <ramishra> ricolin: I'm not sure if anyone uses it or it works. I mean the service is deprecated already. I'm fine to just remove it, unless there is any reason
13:16:15 <ricolin> therve, I through it still there
13:16:27 <ricolin> s/through/thought
13:16:52 <ricolin> but anyway, I think we all agree to just remove it out if it is still there:)
13:17:34 <therve> I mean I thought it was deprecated already
13:19:13 <ricolin> therve, you're right, I forgot about that
13:19:33 <ricolin> so in action we will deprecate alarm resources
13:19:43 <ricolin> remove cloudwatch
13:20:06 <ricolin> and remove ceilometer client directly in next cycle
13:20:30 <ricolin> sounds good to all?
13:21:09 <ricolin> let's move on:)
13:21:18 <therve> +1
13:21:26 <ricolin> therve, thx
13:22:21 <ricolin> #action we should deprecate Aodh::Alarm resources, remove cloudwatch and remove ceilometer client directly in next cycle
13:22:27 <ricolin> #topic integrationtests https://review.openstack.org/#/q/topic:ci-test-framework+(status:open+OR+status:merged)
13:22:39 <ricolin> #link https://review.openstack.org/#/q/topic:ci-test-framework+(status:open+OR+status:merged)
13:23:23 <ricolin> I have propose patches for change integration tests
13:23:25 <ramishra> ricolin: do we still want to call the in-tree tests 'integration tests'? functional/regression would probably be better name?
13:24:48 <ricolin> ramishra, sure but any suggestion with just one word?
13:25:08 <ricolin> I don't like to call it in-tree as well:)
13:25:33 <ramishra> I would just call them 'functional' tests
13:25:41 <ricolin> okay
13:25:47 <ricolin> I will change it
13:27:04 <ricolin> I current propose add first two categorize to plugin
13:27:40 <ricolin> and directly use tox to run tests for functional tests as we usually do in heat
13:28:01 <ricolin> #link https://etherpad.openstack.org/p/heat-integration-test-categories
13:28:37 <ramishra> Also I think it would be better to revive(leave the tests in-tree) https://review.openstack.org/#/c/521263/ after we've the way to test all tests in-tree
13:29:03 <ramishra> but anyway
13:31:44 <ricolin> ramishra, yeah, you can integrate that with rest patch if you like
13:32:20 <ramishra> I think we can also truncate the config for in-tree tests, but that can probably be done later
13:32:43 <ricolin> I think it's good idea
13:34:00 <ramishra> As we expect those to be only used for gate testing, we can possibly do whatever changes we want
13:34:19 <ricolin> ramishra, yeah
13:34:45 <ricolin> Let's land and settle down current tests so other patch can go on
13:35:14 <ricolin> like on multinode grenda job patch is currently block by this
13:35:55 <ricolin> s/grenda/grenade/
13:36:09 <ramishra> why? I think genade jobs should only use tests from heat-tempest-plugin
13:37:06 <ricolin> ramishra, oh, I mean block by when we try to decide where tests should locale at
13:37:24 <ricolin> use tests from plugin +1
13:38:29 <ricolin> #action please help to review https://review.openstack.org/#/q/topic:ci-test-framework+(status:open+OR+status:merged)
13:39:14 <ricolin> It will be better if we can done this this week
13:39:36 <ricolin> so it will catch up with interop team's plan
13:39:51 <ricolin> Anyway, will see
13:40:11 <ricolin> #topic Open discussion
13:40:26 <ricolin> Any to discuss?:)
13:41:12 <kiennt26> Nothing from me :)
13:41:34 <ricolin> kiennt26, thx
13:41:37 <ricolin> kazsh, how's heat-dashboard:)
13:42:01 <ramishra> ricolin: I suggested to just change the flavor used in test_server_signal_userdata_format_software_config, that would reduce the failure rate I think
13:42:28 <ricolin> ramishra, I agree with you on that
13:42:43 <ricolin> so raw only fail two times this week
13:42:50 <kazsh> ricolin: going well :)
13:43:09 <ricolin> but 25 times for test_server_signal_userdata_format_software_config,
13:43:34 <ricolin> kazsh, cool!:)
13:44:13 <ricolin> And after few recheck I think it's fine to land fedora 27 image changes
13:45:25 <ricolin> if that's all, I think we can end the meeting, now:)
13:46:05 <ramishra> +1
13:46:08 <ricolin> thx all:)
13:46:12 <ricolin> #endmeeting