13:00:10 <ricolin> #startmeeting heat
13:00:12 <openstack> Meeting started Wed Jan 10 13:00:10 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:15 <openstack> The meeting name has been set to 'heat'
13:00:17 <ricolin> #topic roll call
13:00:38 <ramishra> hi
13:00:44 <ricolin> o/
13:01:14 <kazsh> o/
13:01:57 <ricolin> #topic adding items to agenda
13:02:04 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-01-10_1300_UTC.29
13:02:39 <ricolin> wondering if we should swift maybe one hour later
13:03:17 <kazsh> yea better for other cores from us/eu
13:04:16 <ramishra> ricolin: Not sure how many US folks would join other than zaneb, but if that works for others, I'm ok
13:05:02 <ricolin> let's see if we need to do it later:)
13:06:00 <ricolin> if no topics we just jump to open discussion
13:06:29 <kazsh> I don't have any topic :)
13:06:43 <ricolin> also ramishra I think the gate is broken
13:06:47 <ramishra> ricolin: what about M3? It's next week or week of 22nd?
13:06:57 <ramishra> ok, the week after
13:07:03 <ricolin> the week after next week
13:07:07 <ricolin> yes
13:07:20 <ramishra> we've plenty to be reviewed
13:08:13 <ricolin> ramishra, try to catch on reviews, will be better if we got more reviewer:(
13:08:39 <ramishra> we should probably get the octavia resources reviewed before FF, unless we plan to push them to next cycle https://review.openstack.org/#/q/project:openstack/heat+branch:master+topic:bug/1737567
13:08:41 <ricolin> ocata resource will be great if we can land it in queens
13:08:52 <ricolin> d'oh!
13:09:02 <ricolin> sorry, octavia resources:)
13:09:59 <ramishra> I can't make the functional test working without https://review.openstack.org/#/c/529934/ and osc-lib release
13:10:05 <ricolin> ramishra, it might be harmful, if neutron team try to do something in next, we should absolutely land it in queens
13:10:28 <ramishra> https://review.openstack.org/#/c/529480/ is the test
13:11:00 <ramishra> they're simple patches though;)
13:11:16 <ricolin> thanks, will check
13:11:34 <ramishra> ricolin: may be we can have a etherpad with the patches that must land before M3
13:12:03 <ricolin> also we should finish functional tests migrate in this release
13:12:07 <ramishra> Looks like zaneb has a series on convergence performance improvements
13:12:38 <ramishra> ricolin: yep
13:12:58 <ricolin> ramishra, yes, I like that series, not sure it will make it in m3 but we can surly try
13:13:10 <ricolin> I will create a etherpad for it
13:13:38 <ricolin> let's do it here
13:13:39 <ricolin> https://etherpad.openstack.org/p/heat-queens-m3-target-patches
13:13:42 <ricolin> #link https://etherpad.openstack.org/p/heat-queens-m3-target-patches
13:15:27 <ramishra> looks like the infra image issue is fixed now
13:15:44 <ricolin> also we will release heat-tempest-plugin ASAP https://review.openstack.org/#/c/530108/
13:16:35 <ricolin> ramishra, yeah, so do we still needs upgrade our image version?
13:16:51 <ramishra> ricolin: no, we don't
13:17:18 <ramishra> I mean we can do it later, that would not fix any issue
13:17:35 <ricolin> okay,
13:18:55 <ramishra> I think gate is farily stable these days, with a few known type for failures
13:19:07 <ricolin> http://logs.openstack.org/15/529715/2/gate/openstack-tox-py27/c93c044/job-output.txt.gz#_2018-01-10_08_36_21_983278
13:19:38 <ricolin> ramishra, yeah, if we can figure out why this happen and unlock the gate:)
13:19:57 <ramishra> ricolin: yeah, this one seems to be fixed by infra, but I can't access status page now
13:20:36 <ricolin> ramishra, I will try to look into, just not quick have clue for it
13:20:40 <ricolin> yet
13:21:42 <ricolin> That's all from me now:)
13:22:01 <ramishra> ricolin: that's not heat specific, it's infra issue and I think someone mentioned in #openstack-infra that it's fixed now
13:22:35 <ricolin> okay, I must missing that
13:22:46 <ricolin> I will recheck it and see
13:22:47 <ricolin> thx
13:25:09 <ricolin> about meeting time, I will ask zaneb later if he got any other valid options
13:25:35 <ricolin> Anything else?
13:25:41 <kazsh> ah I have one
13:26:29 <ricolin> kazsh, go ahead:)
13:26:35 <kazsh> in the end of last year, I had a chat with Blazar guy, they want Heat's support for Blazar
13:26:39 <kazsh> thx:) ricolin
13:27:01 <kazsh> I'm thinking to contribute the resource plugin for Blazar
13:27:24 <kazsh> they also acked this my proposal
13:27:42 <kazsh> how should I start this work ?  prob..making bp first ?
13:28:04 <ricolin> kazsh, yes, have some chat with Blazar PTL as well, feel free to do it if that's needed
13:28:41 <ramishra> kazsh: Isn't it the resource reservation service? kind of quota stuff in a single place?
13:28:42 <kazsh> ricolin: sounds good, thx:)  I will work for this.
13:28:53 <ricolin> ramishra, yes
13:29:19 <ricolin> ramishra, it's a little tricky what Blazar doing
13:29:24 <ramishra> we don't have good experience with all those Quota resources we implemented earlier. Not sure if anyone is using it
13:29:42 <ricolin> but it's between nova and blazar
13:30:03 <ramishra> but I know nothing about it;)
13:30:44 <ricolin> me too:)
13:30:56 <kazsh> ;)
13:31:18 <kazsh> ok, that's it from me, thx ricolin
13:31:48 <ricolin> kazsh, thx for picking this up, make sure Blazar PTL knows you're working on this
13:32:15 <kazsh> yep, will sync up with you :)
13:32:16 <ricolin> kazsh, because last time we talk(in Summit), he think he will do it
13:32:22 <ricolin> kazsh, thx:)
13:32:32 <kazsh> ah yea
13:32:41 <kazsh> will sync up with him too
13:32:44 <kazsh> ;)
13:33:22 <ricolin> anything else?:)
13:34:18 <ricolin> #action working on target review for m3 (etherpad: https://etherpad.openstack.org/p/heat-queens-m3-target-patches)
13:34:48 <ricolin> than I think that's all for now, let's keep in sync in #heat :)
13:34:59 <ricolin> thx ramishra kazsh
13:35:00 <ricolin> #endmeeting