14:00:43 <ricolin> #startmeeting heat
14:00:44 <openstack> Meeting started Wed Jan 24 14:00:43 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:47 <openstack> The meeting name has been set to 'heat'
14:00:52 <ricolin> #topic roll call
14:01:23 <ramishra> hi
14:01:30 <ricolin> o/
14:01:37 <kazsh> o/
14:01:41 <kiennt26> o/
14:02:09 <sshnaidm> o/
14:02:46 <ricolin> #topic adding items to agenda
14:02:48 <weshay|mtg> o/
14:03:01 <ricolin> hi sshnaidm  weshay|mtg :)
14:03:10 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-01-24_1400_UTC.29
14:05:26 <ricolin> #topic Changes to TripleO experimental CI jobs for Heat (sshnaidm ref https://review.openstack.org/#/c/537372)
14:05:51 <ricolin> this is actually landing now
14:06:10 <ricolin> but would like to know what's the replace for it
14:06:13 <sshnaidm> We remove ovb experimental job that was running on rh1 cloud, because of disabling this cloud and we need to consider adding different job to experimental/non-voting pipeline. We have ovb job in 3d party CI or any of current multinode tripleo jobs
14:06:14 <ricolin> sshnaidm, ?
14:06:49 <ramishra> our merge rate is very poor lately, it seems infracloud is gone from nodepool
14:07:02 <ricolin> sshnaidm, is there any possible for others to see this CI?
14:07:29 <sshnaidm> ricolin, jobs will post to patch "RDO third party" messages with logs of course
14:07:29 <ramishra> sshnaidm: if the experiemental job expected to break anything, unless removed?
14:07:31 <ricolin> ramishra, bad timing to remove hardware:(
14:07:55 <ramishra> So not sure when things would land, though that patch is approved now
14:08:00 <sshnaidm> ramishra, sorry, what do you mean?
14:08:22 <ramishra> I mean it's an experimenat job, is it voting anywhere?
14:08:38 <sshnaidm> ramishra, no, experimental jobs can't vote
14:08:59 <ramishra> so it can be removed anytime right?
14:09:07 <ricolin> and it will only run when we check with experimental
14:09:10 <sshnaidm> ramishra, what does mean "removed"??
14:09:20 <sshnaidm> ricolin, yes, of course
14:09:28 <ramishra> I mean the jon definition from heat
14:09:32 <sshnaidm> ricolin, also we can add regular non-voting job too
14:09:53 <ramishra> s/jon/job
14:10:03 <ramishra> anyway, it's approved now
14:10:11 <sshnaidm> ramishra, any job definition could be removed from heat, I didn't understand the question
14:10:17 <therve> sshnaidm, Why the job definition hasn't been changed instead?
14:11:05 <sshnaidm> therve, it will be different pipeline and different job if we want to use multinode, in case of 3d party the changes will be in 3d party repo, not in heat
14:11:32 <zaneb> o/
14:11:34 <sshnaidm> therve, we just configure in our repo to run job on heat and it will appear in your patches :)\
14:11:44 <ricolin> zaneb, o/
14:11:49 <ramishra> sshnaidm: may be I was not clear, my question is what's the hurry for https://review.openstack.org/#/c/537372/1/.zuul.yaml ?
14:11:51 <therve> Hum ok
14:12:06 <therve> ramishra, Just cleanup I guess
14:12:25 <therve> Making sure it's not referenced anywhere before removing it
14:12:38 <sshnaidm> ramishra, the cloud will be disabled, the pipeline will be disabled, and when running check experimental you'll get a lot of errors I think
14:12:57 <therve> sshnaidm, Yeah, but check experimental is non voting, so it doesn't matter much
14:12:59 <therve> Anyway
14:13:02 <ramishra> sshnaidm: my point was it's not blocking anythng
14:13:10 <sshnaidm> therve, yep, it won't break you in any way, but still
14:13:24 <sshnaidm> ramishra, no, no blocking
14:13:34 <zaneb> so what's the replacement when we want to verify changes against tripleo?
14:13:55 <sshnaidm> zaneb, yeah, this question I'd like to talk about
14:13:58 <ricolin> sshnaidm, same question as zaneb said
14:14:05 <sshnaidm> is shardy here?
14:14:28 <sshnaidm> do we want to use experimental job or regular non-voting job?
14:14:49 <sshnaidm> we can make multinode job running on all patches, but non-voting (so won't block you)
14:15:17 <sshnaidm> and we can set up ovb 3d party job in experimental pipeline, pretty close to what it was before
14:15:21 <therve> Given the resource restriction, experimental sounds better
14:15:26 <ricolin> sshnaidm, that sounds like a lot of work for gate
14:15:31 <ramishra> therve: +1
14:15:35 <zaneb> sshnaidm: in the past that's used up too much resources
14:15:36 <ricolin> therve, +1
14:16:01 <sshnaidm> we have new cloud for 3d party and times and resources there are much better
14:16:10 <zaneb> also the tripleo job is much slower than any of our jobs, so our testing would take twice as long
14:16:10 <sshnaidm> regular ovb job takes about 1.5 hours
14:16:31 <sshnaidm> usual multinode job also takes about 1.5-2 hours
14:17:05 <ricolin> sshnaidm, maybe we can add new job for experiment first and discuss later if we need it to be non voting?
14:17:06 <ramishra> infra is struggling at the moment, 1/2 hrs in the queue most of the time, I would prefer to keep it experimental
14:17:26 <sshnaidm> ricolin, ramishra sounds fine for me
14:17:55 <ricolin> sshnaidm, so any plan or suggestion for the new experimental job? :)
14:18:05 <sshnaidm> so, I'll submit a patch for new experimental job
14:18:26 <ricolin> sshnaidm, cool
14:18:29 <sshnaidm> ricolin, I think will configure both multinode and 1 3d party ovb job in experimental pipeline
14:18:37 <sshnaidm> so you can choose :)
14:18:56 <sshnaidm> great, thanks all
14:19:33 <ricolin> sshnaidm, thx:)
14:20:21 <ricolin> #topic queens-3 release https://etherpad.openstack.org/p/heat-queens-m3-target-patches
14:22:29 <ricolin> So currently we have landed some of patches in etherpad, in order to land more feature changes like new octavia resource, or remove resources like cloudwatch and HARestarter
14:22:48 <ricolin> I will release at Friday
14:22:51 <ramishra> may be we skip the tests using fedora image and the PurgeTest to reduce failure rates, therve had suggested that earlier, we probably have no other option
14:23:38 <ricolin> ramishra, therve that's a good idea
14:25:20 <ricolin> the gate is currently slow as well
14:25:38 <ramishra> these test cleanup patches are taking forever to merge
14:25:40 <zaneb> ramishra: note that that will cause conflicts with the duplicate test removal series
14:26:40 <ramishra> zaneb: yeah, or force merge those patches first
14:27:17 <ricolin> zaneb ramishra , I can rebase those cleanup patches to depend on the skip test one if that will make entire process quicker
14:27:50 <zaneb> ricolin: I'm not sure it will, because that means restarting the testing on that whole series
14:28:35 <ramishra> let's keep on rechecking then:)
14:28:55 * zaneb will keep a better eye on the gate today
14:29:09 <ricolin> where we can see the status now
14:29:26 <ricolin> I can't access zuulv3.openstack.org for the entire day
14:29:59 <kiennt26> ricolin: You should try zuul.openstack.org
14:30:05 <ramishra> ricolin: that's gone I think http://zuul.openstack.org/
14:30:10 <ramishra> yep
14:30:18 <ricolin> kiennt26, ramishra thx:)
14:31:13 <ricolin> let's move on
14:31:27 <ricolin> #topic PTG https://etherpad.openstack.org/p/heat-rocky-ptg
14:31:57 <ricolin> good to know you guys will be there:)
14:32:35 <ricolin> Please add topic suggestion
14:33:31 <ramishra> Are we planning for migrate to storyboard like other projects, may be a topic?
14:33:38 <ricolin> which we can decide if that's goals for rocky
14:33:57 <ricolin> zaneb, therve thought?
14:34:34 <ricolin> what's been accept as community goals are
14:34:38 <ricolin> Migration to StoryBoard
14:34:43 <ricolin> Remove mox
14:34:44 <zaneb> I'm happy to migrate when they're ready for us to
14:34:48 <ricolin> Ensure pagination links
14:34:54 <ricolin> Enable mutable configuration
14:35:01 <ricolin> Cold upgrades capabilities
14:35:05 <zaneb> ricolin: have those been accepted, I thought they were just proposals still?
14:35:37 <ricolin> right, sorry
14:35:56 <ricolin> those are current proposed
14:36:12 <ramishra> we probably don't need too many community goals with limited contributors
14:36:23 <ricolin> ramishra, +1
14:37:12 <ricolin> Any of those propose are interesting to any of you?
14:37:20 <ricolin> therve, zaneb ramishra ?
14:37:52 <zaneb> I'm interested in someone (not me) removing mox :)
14:38:05 <ramishra> ricolin: we already have cold upgrade
14:38:28 <ricolin> ramishra, yes, and IIRC we have mutable config as well
14:38:46 <ricolin> for heat
14:39:40 <ramishra> mox removal would be quite a job I think;)
14:40:01 <ricolin> Anyone knows in detail for what's current status for storyboard?
14:40:56 <ricolin> ramishra, it is, at least override 14 python file
14:41:15 <ramishra> I think it's being evaluated by some project teams, I know abt tripleo doing it
14:41:45 <ramishra> there are some feature partiy concerns wrt LP
14:42:02 <ricolin> ramishra, so that means we will not use launchpad at all?
14:42:18 <ramishra> ricolin: yeah, that's my understanding
14:42:55 <ricolin> #action ricolin will see more detail about storyboard
14:43:09 <ramishra> may be only for blueprints and not for bugs though
14:43:28 <zaneb> if it's accepted as a goal then we're migrating bugs too
14:43:43 <ricolin> kiennt26, also shouldn't you add dashboard topic?:)
14:43:56 <zaneb> have to do it before launchpad hits 2000000th bug otherwise bad stuff will happen :D
14:44:38 <ricolin> currently 1745024
14:44:46 <ricolin> :)
14:45:08 <kiennt26> ricolin: I think kazsh is the man who in chair dashboard topic :) I'm working on upgrade patches.
14:45:46 <ricolin> kiennt26, sorry, tag wrong name here :(
14:46:32 <kazsh> ricolin: the dashboard has around 25 bugs which took over from horizon team, not sure it is better way to go together with heat
14:46:49 <kazsh> kiennt26: thx following up:)
14:46:51 <ricolin> #action please add topics(goals) to https://etherpad.openstack.org/p/heat-rocky-ptg
14:47:35 <ricolin> kazsh, for current bugs better settle with horizon team:)
14:48:13 <ricolin> move on:)
14:48:15 <ricolin> #topic Remove heat agents in heat template repo
14:49:01 <ricolin> Is it possible to remove heat-agents in heat-templates in queens?
14:49:51 <ricolin> #link https://review.openstack.org/#/c/489893/
14:50:26 <ricolin> in that way, we can directly remove those code in above patch instead of adding py35 support for it
14:50:43 <ricolin> ramishra, therve zaneb thought?
14:51:21 <zaneb> ricolin: heat-templates doesn't have a release cycle, so the concept of 'in queens' is meaningless :)
14:51:39 <zaneb> that said, I don't see any reason not to just get rid of it now
14:52:45 <ricolin> I guess we can just do it, possibly no one depends on it:)
14:52:59 <ramishra> yeah, it's been a year since we created the separate repo for heat-agents
14:53:36 <ricolin> problem solved:)
14:53:53 <ricolin> #topic Open discussion
14:54:07 <ricolin> Any to discuss?
14:54:27 <zaneb> question about heat-tempest-plugin
14:54:58 <zaneb> is it still the plan to make it branchless? or just branchless from Q onwards? or not branchless at all?
14:55:25 <zaneb> because we have or are in the process of merging a bunch of stuff that will not pass against older branches
14:55:48 <ramishra> zaneb: I would say Q onwards, but we've to make sure we've a way to test new resources added for a release
14:55:49 <zaneb> and we have no mechanism to do e.g. api microversioning for the future
14:56:01 <ricolin> Q onwards if that's fine to all
14:56:07 <zaneb> ok
14:56:21 <zaneb> I added topics for the PTG to discuss this further
14:56:28 <ramishra> Like the tests for octavia resources I've proposed
14:56:34 <zaneb> but I wanted to find out what the latest thinking was
14:56:37 <ricolin> zaneb, you mean the microversion's one?
14:56:55 <zaneb> ricolin: both
14:57:08 <ramishra> we can add some config options for specific features like tempest
14:57:42 <ramishra> I don't see any other project running stable jobs with tempest plugins
14:57:52 <ramishra> so not sure how that is expected to work
14:59:16 <ramishra> sure, we can discuss that further at PTG, but as of now it's not branchless;)
14:59:59 <zaneb> yeah, I'm still a little worried how we will do stuff like https://review.openstack.org/#/c/526480/ in the future
15:00:46 <ramishra> zaneb: we should not break those tests in the plugin somehow:)
15:01:07 <ramishra> or else that's not the place for them
15:01:30 <ricolin> best path must be found:)
15:02:04 <ricolin> anything else?
15:02:06 <kazsh> ricolin: can you release heat-dashboard as q-3 in this week?  because we merged some patches since q-2 & now reviewing the last one which will be merged in a day.
15:02:55 <ricolin> yes we can
15:03:12 <kazsh> ricolin: thx! will let you know soon :)
15:03:15 <ricolin> but I needs your help, on that
15:03:34 <kazsh> ok, what should i do for you ?
15:03:48 <ricolin> so for new release we should write down more detail about what exactly in this release
15:04:14 <kazsh> you mean reno ?
15:04:38 <ricolin> something like that, I will give you more detail later
15:04:54 <kazsh> sure, will do according to your guidance :)
15:05:01 <ricolin> kazsh, cool!
15:05:23 <ricolin> before we end the meeting, anything else?
15:06:28 <ricolin> if none, thanks all for join zaneb therve ramishra kazsh kiennt26 sshnaidm weshay|mtg
15:06:33 <ricolin> #endmeeting