14:00:46 <ricolin> #startmeeting heat
14:00:47 <openstack> Meeting started Wed Apr 18 14:00:46 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <openstack> The meeting name has been set to 'heat'
14:00:54 <ricolin> #topic roll call
14:01:18 <ramishra_> hi
14:01:25 <ricolin> o/
14:02:54 <ricolin> ramishra_, the gate still not stable:/
14:03:02 <zaneb> o/
14:03:09 <ricolin> hi
14:03:32 <ramishra_> ricolin: why is that? I think it should be good after https://review.openstack.org/#/c/559416/
14:03:41 <ricolin> #topic gate issue
14:03:54 <ramishra_> Other than the normal infra issues and purge test failures
14:04:00 <ricolin> we still hitting some performance issue
14:04:35 <ricolin> ricolin, some fail on pbr in devstack install
14:04:50 <ramishra_> ricolin: which one?
14:05:25 <ramishra_> Any logs? I think pip10 is reverted in devstack for all branches, so it should be ok
14:06:11 <ricolin> ramishra_, http://logs.openstack.org/14/558114/1/check/heat-functional-convg-mysql-lbaasv2-non-apache/837890d/job-output.txt.gz#_2018-04-18_12_29_48_967996
14:06:36 <ricolin> I think pip10 fixed for now
14:07:05 <ramishra_> yeah, that's possibly infra issue, slow nodes may be
14:08:31 <ricolin> ramishra_, I think so too
14:08:51 <ricolin> happens few time today, when I rechecking some patch
14:11:26 <ricolin> Anyway, hope the infra will getting better
14:11:44 <ricolin> ramishra_, so there is no other gate issue for now right?
14:12:25 <ricolin> zaneb, http://logs.openstack.org/77/560577/3/check/heat-functional-convg-mysql-lbaasv2-py35/0272aee/job-output.txt.gz#_2018-04-18_12_39_33_288218
14:12:40 <ramishra_> ricolin: As I mentioned other than infra issues we discussed earlier and some known falures, I'm not aware of anything
14:13:16 * zaneb is rechecking a bunch of patches right now
14:13:21 <ricolin> ramishra_, okay, thx
14:13:56 <ricolin> zaneb, thx!
14:14:09 <ricolin> #topic StoryBoard
14:15:07 <ricolin> So right now diable_rojo working on testing for migrate heat's lauchpad projects to Storyboard
14:15:26 <zaneb> oooh, shiny
14:16:07 <ricolin> which includes
14:16:08 <ricolin> https://launchpad.net/python-heatclient
14:16:08 <ricolin> https://launchpad.net/heat-agents
14:16:08 <ricolin> https://launchpad.net/heat-templates
14:16:08 <ricolin> https://launchpad.net/heat-tempest-plugin
14:16:10 <ricolin> https://launchpad.net/heat-translator
14:16:12 <ricolin> https://launchpad.net/heat-cfnclient
14:16:14 <ricolin> https://launchpad.net/heat-cfntools
14:16:16 <ricolin> https://launchpad.net/heat-dashboard
14:16:55 <ricolin> if the test going well, we will be able to migrate to storyboard next week
14:16:57 <therve> Maybe heat too :)
14:17:06 <ramishra_> lol:)
14:17:22 <ricolin> therve, oops, sorry of course!
14:18:07 <zaneb> including but not limited to :)
14:18:16 <ramishra_> Are we planning to do it this cycle? I thought we wanted to see someone else do it first?
14:18:26 <ricolin> So I would like to know any though on what we should do after all our bugs and bps been moved to there
14:18:52 <ricolin> ramishra_, looks like the team been help on migrate for all other teams
14:19:04 <zaneb> fix them all? :)
14:19:17 <ramishra_> I mean some other project migrating successfully first
14:19:39 <ricolin> zaneb, maybe Christmas for that wish:)
14:20:04 <therve> ricolin, What happens to launchpad bug?
14:20:05 <therve> bugs
14:20:32 <ricolin> ramishra_, there are projects already on it
14:20:33 <ricolin> https://storyboard.openstack.org/#!/project/list
14:20:49 <zaneb> I assume they get closed with a comment and a link to storyboard
14:21:05 <ricolin> that's what we need to discuss
14:21:14 <ricolin> what should we do with two side
14:21:31 <therve> That sounds good to me. And keep the list somewhere so that we can revert
14:22:12 <ricolin> I will add that to heat update session in summit , send ML, relase note, etc
14:22:13 <openstackgerrit> Cliff Parsons proposed openstack/heat-tempest-plugin master: Force API test listing even if auth fails  https://review.openstack.org/544025
14:22:57 <ricolin> wonder what else we have to do
14:23:10 <ricolin> therve, good idea
14:23:43 <ramishra_> Should we not do this at the begining of a cycle so there is less confusion, Is there a script for migration?
14:23:59 <therve> ricolin, Need to configure launchpad as well
14:24:50 <ricolin> therve, what you mean?
14:25:22 <therve> ricolin, Either preventing new bugs from being opened, or adding some docs pointing to storyboard
14:25:29 <ricolin> ramishra_, I'm fine with migrate in middle, so depends on what you guys think
14:26:00 <ricolin> therve, thx, get you!
14:27:47 <ricolin> Let's do a quick poll if we start with StoryBoard(after notify and works success) maybe at rocky-2 or rocky-3 will you guys think it's a good idea?
14:27:55 <ricolin> zaneb, therve ramishra_ ^^^
14:28:26 <therve> I can't say I care that much
14:30:04 <ramishra_> ricolin: project already on storyboard are probably less activity projects, though heat can be counted as one now;) so if someone else is doing with docs etc I'm ok
14:30:20 <zaneb> it feels a bit like we are the guinea pigs at this point, but I guess we have to do it eventually
14:31:54 <ricolin> thanks for opinion, let's see the output next week first than(if it's out):)
14:32:24 <ricolin> I can help on doc the migrate when we're doing it
14:32:36 <openstackgerrit> Merged openstack/heat master: Fixing unicode issue when to_dict is called on py2.7 env  https://review.openstack.org/559195
14:32:53 <ricolin> #action ricolin tracking on StoryBoard
14:33:23 <ricolin> Any other topic from you guys?:)
14:34:15 <ricolin> btw zaneb, interop team asking me to join their meeting and discuss that test repo thing
14:34:28 <ricolin> which is 1.5 hours later
14:35:22 <ricolin> #topic Open discussion
14:36:53 <zaneb> ok
14:36:55 <ricolin> Also I find a bug with external reference to Stack
14:37:01 <ricolin> #link https://bugs.launchpad.net/heat/+bug/1764947
14:37:03 <openstack> Launchpad bug 1764947 in OpenStack Heat "external ref. didn't actually validate external ref. on Heat Stack resource" [Medium,In progress] - Assigned to Rico Lin (rico-lin)
14:37:21 <ramishra_> therve: would you be able to review https://review.openstack.org/#/c/529480/? we've configured the octavia services at the gate but not testing the resources
14:38:20 <therve> Sure
14:38:34 <ramishra_> therve: thanks!
14:39:45 <ricolin> We still have some mox removal patch, if you guys have time, please help on review them, at least some major one(like test_stack, test_engine_service, or test_resource) :)
14:39:59 <ricolin> #link https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:mox-removal
14:40:55 <ricolin> Anything else?:)
14:40:59 <zaneb> ricolin: I still have it on my list to re-review those ones you updated
14:41:24 <ricolin> zaneb, thx
14:43:02 <ricolin> if nothing else, let's end it:)
14:43:17 <ricolin> thx all
14:43:17 <ricolin> #endmeeting