14:00:11 <ricolin> #startmeeting heat
14:00:12 <openstack> Meeting started Wed Apr 25 14:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <openstack> The meeting name has been set to 'heat'
14:00:21 <ricolin> #topic roll call
14:00:40 <ramishra> hi
14:00:48 <ricolin> o/
14:01:36 <kazsh> o/
14:02:20 <kiennt26> hi o/
14:03:19 <ricolin> #topic adding items to agenda
14:03:21 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-04-25_1400_UTC.29
14:05:05 <ricolin> #topic Release Rocky-1
14:05:38 <ricolin> Sorry about forgot to mention we're releasing last week
14:05:47 <ramishra> ricolin: I've added a topic to remove neutron-lbaas from gate testing
14:05:53 <ricolin> We released Rocky-1 last week
14:05:58 <ricolin> ramishra, saw that:)
14:06:25 <ricolin> kazsh, I also release heat-dashboard too
14:06:46 <kazsh> ricolin: thanks!
14:07:04 <ricolin> mean while bump version for Pike and Queens
14:07:50 <ricolin> I think the release point is fine, at least gate become stable before release
14:08:07 <ricolin> let me know if any concern on rocky-1
14:08:34 <ricolin> If none, we can focus on rocky-2:)
14:09:09 <ricolin> Do hope most of our plan in PTG can start put effort and patch in rocky-2
14:09:35 <ricolin> kazsh, heat-dashboard too:)
14:09:56 <kazsh> ricolin: yea we will do our best ;)
14:10:11 <ramishra> ricolin: I think gate is quite stable now, not seen any major issues after https://review.openstack.org/#/c/563893/
14:10:18 <ricolin> kazsh, thx
14:11:07 <ricolin> ramishra, yeah, the lower-constrain also fixed
14:12:08 <ricolin> ramishra, should be a clear path for guys to take off!:)
14:12:46 <ricolin> also the nova-client issue for unit test already merged
14:12:53 <ricolin> so looks good to me
14:13:33 <ricolin> #topic Bugs and PBs
14:14:47 <ricolin> ramishra, zaneb We need some review for mox removal patches
14:15:35 <ricolin> please help on that when you got some free time:)
14:15:58 <ramishra> ricolin: sure, will check them. Btw, I've to leave early, may be we discuss neutron-lbaas thing? May be after this one
14:16:11 <ricolin> ramishra, sure
14:16:35 <ricolin> #topic Remove neutron-lbaas service from gate
14:16:47 <ricolin> ramishra, ^^^
14:17:21 <ramishra> yep, we've not octavia resources and tests for them, so we should remove neutron-lbaas service and tests from gate
14:17:46 <ramishra> as it's now deprected and getting some fixes in there is difficult
14:18:33 <ramishra> I was trying to new devstack neutron lib with https://review.openstack.org/#/c/562106/
14:18:37 <ricolin> ramishra, right now we skip those test right?
14:18:58 <ramishra> and it needed https://review.openstack.org/#/c/562261/
14:19:28 <ramishra> but getting that in possibly difficult and recently we were broken neutron change as we use neutron-lbaas
14:20:08 <ramishra> ricolin: not yet, I've skipped them in https://review.openstack.org/#/c/562106/
14:20:55 <ramishra> So not sure if anyone has any concern, it's deprecated, so I don't see any risk not testing the service and dependent resources at the gate
14:22:13 <ricolin> ramishra, I see some project already change to use neutron-lbaas
14:22:36 <ramishra> ricolin: use or __not__ use
14:23:03 <ricolin> sorry, `not use`
14:23:25 <ramishra> yeah, it's deprecated and I don't think anyone cares about them anymore
14:23:42 <ricolin> already +2 on that patch:)
14:23:58 <ricolin> before
14:24:04 <ramishra> we probably don't have enough people now to decide that, but I wanted it to be recorded
14:24:25 <ricolin> ramishra, sure
14:24:45 <ricolin> see zaneb or therve got anything to comment on that change:)
14:24:55 <ramishra> I don't see any issue doing that, but don't know if someone else thinks otherwsie:)
14:25:27 <ramishra> that's all from me, we can move to the next topic
14:25:46 <ricolin> ramishra, we can actually set a point and do that migrate (like one or two weeks):)
14:26:05 <ricolin> cool
14:26:21 <ramishra> ricolin: it does not matter, but whatever we decide
14:26:28 <ricolin> #topic StoryBoard https://storyboard-dev.openstack.org/#!/project_group/36
14:26:50 <ricolin> ramishra, have you look at the StoryBoard out looks yet?:)
14:26:58 <ricolin> kazsh, kiennt26 ^^^
14:27:18 <ricolin> btw that's just a test env
14:27:54 <ricolin> all heat* project has been test success to migrate on it
14:28:07 <ramishra> ricolin: not yet, but will find some time to check this week
14:28:34 <ricolin> #action please take a look on https://storyboard-dev.openstack.org/#!/project_group/36 and let ricolin know if any concerns:)
14:28:51 <kazsh> ricolin: thx will check it
14:29:12 <ricolin> kazsh, if we decide to migrate, heat-dashboard will be together
14:29:35 <ricolin> we can also think about the new architecture for our storyboard
14:29:39 <kazsh> ricolin: sure :)
14:29:51 <ramishra> sorry have to leave now, will check the log later
14:30:00 <kiennt26> ricolin: i've tried to access the link and faced 404 error: "404: GET /api/v1/project_groups/36: Project Group 36 not found"
14:30:02 <ricolin> ramishra, NP thx for join!:)
14:30:46 <ricolin> https://storyboard-dev.openstack.org/#!/project/314
14:30:48 <ricolin> #link https://storyboard-dev.openstack.org/#!/project/314
14:30:52 <ricolin> Try this one
14:31:03 <ricolin> #action please take a look on https://storyboard-dev.openstack.org/#!/project_group/314 and let ricolin know if any concerns:)
14:32:25 <ricolin> We should also decide if we like to merge some of our storyboard as one project or not
14:32:44 <ricolin> since we not actually actively use all of them
14:33:32 <ricolin> so I propose we can create one for heat and once for heat-dashboard and join them in a single group
14:34:08 <ricolin> #topic Stack Reference https://review.openstack.org/#/q/topic:external_stack_reference+(status:open+OR+status:merged)
14:34:47 <ricolin> So I start to think about reference when external_id created
14:34:53 <ricolin> Stack Reference is about to add reference with external_id referencing a resource or stack which created by Heat, will create a reference relation and forbidden the referenced stack been update/delete.
14:35:40 <ricolin> Anyway, just hope guys can take a look and provide some feedback:)
14:36:16 <ricolin> #topic Open discussion
14:36:47 <ricolin> Anything to discuss?:)
14:37:09 <therve> ricolin: What's the point of stack reference?
14:38:08 <therve> I'm not paranoid about process, but there is no doc, spec, bug or anything linked
14:39:09 <ricolin> therve, to grantee the external resource I think
14:39:35 <therve> ricolin: Which one?
14:39:38 <ricolin> therve, and yeah, I will create a BP and spce for that, maybe later
14:41:05 <ricolin> when a external_id adding to a resource, we can at least prevent it got deleted from another side if what it referenced also create by heat too
14:41:22 <therve> Ah
14:41:28 <therve> So -1 from me then
14:41:31 <ricolin> Kind of like a replacement for Cross stack reference
14:43:50 <ricolin> therve, that' fine:) anyway, it's the same discuss we have previous from week
14:44:05 <therve> It's a solution looking for a problem
14:44:22 <therve> But I'd rather look at a document explaining it than code, anyway :)
14:46:11 <ricolin> therve, sure, anyway, no hurry for this, let's solved other plans and go back on this, put code on first since it's already been generated
14:46:47 <therve> Heh, "generated"
14:47:29 <ricolin> generator=ricolin:)
14:48:30 <kazsh> ricolin: a patch for blazar support got +1 from blazar ptl & zuul check, request heat cores to review it again toward rocky-2  https://review.openstack.org/#/c/534576
14:48:56 <ricolin> kazsh, cool, will take a look again today or tomorrow
14:49:10 <kazsh> ricolin: thx!
14:49:24 <ricolin> kazsh, actually not today for sure!
14:49:39 <ricolin> since only one our left:)
14:49:53 <kazsh> ricolin: no worries:)
14:50:32 <ricolin> kazsh, also it might help if you can also create a template for Blazar resource and add it to heat-templates
14:50:57 <kazsh> ricolin: ah that's good, ok will work for that!
14:51:28 <ricolin> Blazar is a service that require some change in code, so maybe not everyone can use it, but if they do, a template will definitely helps:)
14:52:00 <kazsh> ricolin: yep:)
14:52:51 <ricolin> Anything else?
14:54:05 <ricolin> #action please help to review:)
14:54:56 <ricolin> We also need to discuss about our new interop test repo, but I think maybe next week when ramishra is around
14:55:01 * zaneb reads scrollback
14:55:10 <ricolin> zaneb, oh, hi:)
14:56:15 <ricolin> zaneb, anything to said before I type `#endmeeting`?
14:56:20 <ricolin> :)
14:57:35 <zaneb> nope :)
14:57:54 <ricolin> :)
14:57:56 <ricolin> #endmeeting