14:00:29 <ricolin> #startmeeting heat
14:00:29 <openstack> Meeting started Wed May  2 14:00:29 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:32 <openstack> The meeting name has been set to 'heat'
14:00:36 <ricolin> #topic roll call
14:01:16 <ramishra> hi
14:01:20 <chandankumar> Hello
14:01:24 <ricolin> o/
14:03:32 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-05-02_1400_UTC.29
14:03:39 <ricolin> #topic adding items to agenda
14:04:58 <ricolin> #topic Adding containerized undercloud tripleO job against heat (chandankumar) https://review.openstack.org/565482
14:05:02 <ricolin> chandankumar, :)
14:05:32 <chandankumar> ricolin: thanks :-)
14:06:11 <chandankumar> I wanted to add a tripleo based containerized undercloud job which will run heat tempest plugin tests against each heat patches
14:06:30 <chandankumar> Since currently we are testing all the stuff on devstack based
14:06:50 <chandankumar> environment but tripleo deployment is driven by heat a lot
14:07:15 <chandankumar> most of time issues captured in tripleo ci but no in devstack ci
14:07:38 <chandankumar> In order to improve both the projects, I want to propose for the samew
14:07:41 <ramishra> chandankumar: would that run heat tests on the undercloud itself?
14:07:55 <chandankumar> ramishra: yup, we are working on that
14:08:12 <chandankumar> ramishra: currently last week i have made running tempest tests on undercloud
14:08:27 <ramishra> chandankumar: I don't see any tests run here http://logs.openstack.org/82/565482/6/check/tripleo-ci-centos-7-undercloud-containers/a276276/job-output.txt.gz
14:08:29 <ricolin> chandankumar so how often does heat brack TripleO?
14:08:46 <ramishra> chandankumar: Is it still WIP?
14:08:50 <chandankumar> ramishra: http://logs.openstack.org/82/565482/6/check/tripleo-ci-centos-7-undercloud-containers/a276276/logs/undercloud/home/zuul/tempest_output.log.txt.gz#_2018-05-02_12_30_44
14:09:01 <chandankumar> ramishra: the patch is still in work in progress
14:09:19 <chandankumar> I need to add support in python-tempestconf to generate heat tempest conf
14:09:37 <chandankumar> ricolin: most of the time, I donot have the stats currently
14:09:42 <ricolin> s/brack/break/
14:09:44 <openstackgerrit> Julia Kreger proposed openstack/heat master: Delete internal ports for ERROR-ed nodes  https://review.openstack.org/564104
14:09:54 <ramishra> ok, I'm not against the idea, but it seems 1hr 30 mins is a lot, we can probably start as an experimental job
14:10:05 <ramishra> and the move it to the check pipeline
14:10:18 <chandankumar> ramishra: we are also working on decreasing the time
14:10:19 <therve> chandankumar: We break most of the time ? :)
14:10:24 <therve> ramishra: +1
14:11:24 <chandankumar> I am ok with putting it under experimental
14:11:42 <chandankumar> once things will improve we will can add it to check
14:11:51 <ramishra> chandankumar: sounds good
14:12:03 <ricolin> chandankumar, if you can help to provide more data on the failure rate, I will feel more comfortable to put it on pipeline.
14:12:15 <chandankumar> ramishra: once the patch is ready to go ,
14:12:28 <chandankumar> ricolin: I will try to pull the data and share with you
14:12:36 <ricolin> chandankumar, thx
14:13:06 <chandankumar> ricolin: once recent failure was this one https://trello.com/c/e0f3aGDn/721-build-python-gabbi-to-1421-for-heat-tempest-plugin
14:13:43 <chandankumar> that's it from my side
14:13:50 <ricolin> thanks for the info
14:14:48 <ricolin> #topic Remove obsolete identity-v3-only job https://review.openstack.org/#/c/564623/
14:15:43 <ricolin> talking about jobs, Pavlo has propose to remove the v3-only job
14:16:09 <ramishra> ricolin: I still see devstack still has v2 stuff https://github.com/openstack-dev/devstack/blob/master/lib/keystone#L217
14:17:00 <ricolin> ramishra, I saw that too, so my question is what's our state for v2?
14:17:18 <ramishra> Though we can remove it unless we want to still gate with v2 api, I've not checked if those are just left overs in devstack code
14:18:42 <ramishra> As the commit message says it's removed from keystone
14:18:47 <ricolin> ramishra, current service default has moved to use v3, right?
14:19:40 <ramishra> yes, as I said unless we want to gate with v2 (assuming that v2 is still there in keystone) we can remove that job
14:19:41 <ricolin> ramishra, isn't v2 just deprecated for long time?
14:20:16 <zaneb> oh hey
14:20:35 <ricolin> ramishra, not surprised if it does removed:)
14:20:39 <ricolin> zaneb, hi!
14:22:23 <ricolin> so if guys are fine without gating with identity v2, I think we can remove v3 only that job:)
14:22:28 <ramishra> ricolin: I mean all jobs other than that one are supposed to enable both v2/v3 keystone
14:24:22 <zaneb> I think the v2 gating was mostly for Rackspace's benefit?
14:24:36 <ramishra> I'm +1 on removing that anyway:)
14:24:43 <ricolin> zaneb, how come?
14:24:44 <zaneb> I'm happy to drop it for master. we should probably keep it on stable branches
14:24:58 <ricolin> zaneb, yeah, definitely
14:25:16 <zaneb> ricolin: they had their own auth thing that was keystone v2 compatible but was not keystone
14:25:27 <zaneb> because of reasons
14:25:37 <ricolin> zaneb, got it
14:26:04 <ricolin> #action review on https://review.openstack.org/#/c/564623/
14:26:11 <zaneb> https://specs.openstack.org/openstack/neutron-specs/specs/newton/moving-to-keystone-v3.html <- deprecated in Mitaka
14:26:30 <zaneb> therefore theoretically eligible for removal in Ocata, but idk if that happened
14:27:41 <ricolin> move on~
14:27:56 <ricolin> #topic Simplified Template version to use only release name like `rocky`
14:28:34 <ricolin> as we not yet merged rocky version
14:28:35 <ricolin> https://review.openstack.org/#/c/548743/
14:29:01 <openstackgerrit> Eyal proposed openstack/heat-dashboard master: py35 classifier  https://review.openstack.org/564491
14:29:11 <ricolin> I wondering if we can just use release name as new version, and without a `date` for version
14:29:42 <ricolin> like we can just allow rocky version of template `rocky`
14:29:48 <ramishra> yep, we're past one milestone;) Though we've not added anything for a new template version yet:)
14:30:03 <ricolin> not `2018-08-31`
14:30:58 <ricolin> ramishra, I think I will need it for https://review.openstack.org/#/c/564742/
14:32:11 <ramishra> ricolin: Is having the old way to specify the template version makes it confusing or something like that?
14:32:22 <zaneb> I always liked the idea that you could tell at a glance whether you were looking at a stable template version by whether the date was in the future or not
14:32:32 <zaneb> but it turns out that was too cute and nobody cares
14:32:41 * zaneb shrugs
14:33:04 <ricolin> haha, too cute:)
14:33:36 <ricolin> ramishra, no confuse for me, just wondering if that's a good idea
14:33:46 <therve> ricolin: No :)
14:33:58 <ricolin> if not I think we can land the current one now:)
14:35:06 <ricolin> #link https://review.openstack.org/#/c/548743/
14:36:15 <therve> ricolin: Isn't HOTemplate20180831 identical to HOTemplate20180302 ?
14:36:36 <zaneb> ricolin: approved
14:36:43 <therve> Well :)
14:36:44 <ricolin> therve, for now it is
14:36:48 <zaneb> therve: it is _now_
14:36:58 <therve> ricolin: What's the point of duplicating everything?
14:37:33 <therve> HOTemplate20180302 is itself the same as HOTemplate20170901 it looks like
14:37:35 <zaneb> therve: so when we want to change it, the diffs will be an accurate guide to what's changing
14:37:47 <ricolin> therve, I think I was trying to reduce duplicating from versions, but the feedback was try to keep things clear for version
14:37:57 <therve> zaneb: Well, and if we don't ?
14:38:08 <therve> Like last cycle :)
14:38:20 <zaneb> therve: then nothing of value was lost? :)
14:38:46 <therve> Well it's good info to know they haven't changed
14:38:59 <therve> Which is hard to decipher looking at that big blob
14:39:11 <zaneb> ricolin: do we have a document somewhere that lists everything we need to update when a new dev cycle begins?
14:39:26 <zaneb> a script would be even better :)
14:39:48 <ricolin> zaneb, I can try to comes out with a list, but don't think it exists
14:41:46 <ricolin> Any other thing to discuss from you guys?
14:42:34 <ricolin> #topic Open discussion
14:43:23 <ricolin> about interop tempest repo, we not plan to also create a tempest client to it right?
14:43:27 <ricolin> zaneb, ^^^
14:43:35 <zaneb> nooo
14:43:57 <ricolin> zaneb, good, just like to make sure:)
14:44:07 <zaneb> :)
14:44:28 <ricolin> also about StoryBoard, I will start to put effort to migrate it
14:45:06 <ricolin> It should be done at this or next week I think
14:45:45 <ramishra> zaneb: btw congrats, so now we have a TC member watching us:)
14:47:10 <zaneb> ramishra: thanks! you better stay in line then ;-P
14:48:13 <ricolin> zaneb, I think you owe us a beer:)
14:49:21 <ricolin> If no other things, let's end the meeting:)
14:49:49 <ricolin> thx all
14:49:49 <ricolin> #endmeeting