14:03:39 <ricolin> #startmeeting heat
14:03:40 <openstack> Meeting started Wed Jul 25 14:03:39 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:43 <zaneb> let's do the meeting and then we'll have minutes
14:03:43 <zaneb> somebody might care ;)
14:03:44 <openstack> The meeting name has been set to 'heat'
14:03:47 <ricolin> #topic roll call
14:04:34 <therve> Hey
14:04:36 <ramishra> hi, yep, somebody may care;)
14:04:42 <zaneb> o/
14:04:47 <ricolin> :)
14:05:00 <ricolin> #topic adding items to agenda
14:05:14 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-07-25_1400_UTC.29
14:07:03 <ricolin> #topic heat m3, client release - feature freeze
14:07:12 <ricolin> #link https://etherpad.openstack.org/p/heat-rocky-feature-relative-patches
14:07:34 <ricolin> I create this etherpad for collect features
14:07:43 <therve> relative patches? :)
14:07:50 <therve> Incestuous patches?
14:08:27 <ricolin> therve, well, works for features:)
14:08:37 <zaneb> rofl
14:09:01 <therve> zaneb: https://review.openstack.org/#/c/568961/ if you can check this one, as you -1 previously
14:09:29 <ramishra> I was wondering whether we should add these new stuff so late in the cycle, some of them may be reviewed few times, but still
14:09:35 <zaneb> therve: ack, will circle back
14:09:50 <therve> ramishra: Not all of it will land
14:09:59 <therve> I think the swift stuff should
14:10:28 <zaneb> swift stuff seems landable
14:10:37 <ricolin> I sense Vitrage resource still need more works, but rest sounds like good target if we can make them in
14:10:42 <ricolin> zaneb, +1
14:10:46 <ramishra> therve: yeah, I need it to refactor tripleo stuff to use it
14:10:47 <zaneb> I haven't had a proper look at multi-cloud at all :(
14:11:16 <therve> yeah multicloud sounds doubtful
14:11:26 <ricolin> zaneb, please please please do review it:/
14:13:07 <zaneb> ricolin: will try, but it has been surprisingly hard to nail down the spec so I worry about more surprises
14:14:10 <zaneb> blazar resources seems doable, although I haven't looked at them at all
14:14:12 <ramishra> I don't think Blazar and Vitrage resources can make it either, not sure if there are enough users of them
14:14:24 <ricolin> For Hidden resources, I will separate Alarm resource from others since that's where we still got some discussion going, don't hope it stop rest to get in
14:14:33 <ramishra> oh, I contradicted zaneb :)
14:14:55 <zaneb> ramishra: if you've actually looked at them then you know more than I do :)
14:15:24 <therve> Resources are a bit less problematic *if* they are isolated
14:15:41 <therve> ricolin: I tried to reorder the doc a bit
14:16:03 <therve> ramishra: We need the client change in for swift support, no?
14:16:16 <zaneb> right, yeah that was my thought. as long as they don't have bad interfaces that we can never change
14:16:22 <ricolin> therve, yeah, I saw that patch, we should target that one as well
14:16:41 <ramishra> therve: yes, need to update https://review.openstack.org/#/c/551872/
14:17:21 <therve> OK that might be the most import wrt the freeze
14:17:27 <zaneb> ricolin: btw should we be using a worklist in storyboard instead of an etherpad for this?
14:18:06 <ramishra> zaneb: +1, though I still don't yet know how to use storyboard well enough
14:18:13 <ricolin> zaneb, you mean a task say `land XXX`?
14:18:55 <ricolin> or tag the current stories say `rocky-feature-target`
14:19:12 <zaneb> ricolin: yeah, you create a worklist and add all of the tasks (==patches) from the stories we want to land
14:19:23 <ricolin> zaneb, sure
14:19:40 <zaneb> you may be able to do it automagically with tags. I'm not actually sure
14:19:41 <ramishra> ricolin: https://docs.openstack.org/infra/storyboard/gui/worklists.html
14:19:53 <ricolin> Is there anymore target you guys feel like to put in this list
14:20:28 <therve> No that's already way too big :)
14:21:01 <ricolin> therve, yeah... and we only got three day for this
14:21:30 <therve> We should remove the vitrage one, it arrived last week
14:21:31 <zaneb> I know I say this every cycle, but this cycle has gone really quick
14:22:19 <ramishra> We did not do a lot this cycle, so it was quick;)
14:23:46 <therve> blazar and zun changes have been sitting for a while, that'd be bad to push further
14:23:51 <ricolin> I move vitrage out of target for this week
14:24:00 <zaneb> I reviewed the Zun ones
14:24:11 <zaneb> they seem very landable and also very important
14:24:24 <zaneb> ricolin: question for you here btw: https://review.openstack.org/#/c/533426/21/heat/engine/resources/openstack/zun/container.py@62
14:27:33 <ricolin> zaneb, actually don't know why it go from patch 20 to there...
14:27:56 <ricolin> but will leave some comment later
14:28:24 <zaneb> ricolin: https://review.openstack.org/#/c/533426/17/heat/engine/resources/openstack/zun/container.py@187
14:29:37 <ricolin> yes, and that's not what I wondering:)
14:30:15 <zaneb> ok :) we can chat after if you want
14:30:19 <ricolin> ServerNetworkMixin bring the requirement for `NETWORK_ID` since patch 21, so that actually changed:)
14:31:36 <ricolin> zaneb, sure
14:32:40 <zaneb> btw, question for everyone
14:33:07 <zaneb> we agreed to allow merging patches from cores with a single +2
14:33:18 <zaneb> but I don't see people doing it?
14:33:33 <zaneb> even for trivial patches like https://review.openstack.org/570056
14:34:02 <zaneb> I ended up self-approving a bunch of stuff
14:34:26 <zaneb> but I'm just curious why people don't feel confident to make use of the new policy?
14:35:15 <ramishra> zaneb: I think it's probably not about being confident, it's just takes time to get used to the new policy I suppose
14:36:17 <ramishra> And remebering it at the time of revewing stuff
14:36:22 <zaneb> ok. consider this a reminder then :)
14:36:52 <ricolin> I try to give room before release, so I probably will do a lot this week
14:38:06 <zaneb> speaking of trivial patches https://review.openstack.org/#/q/project:openstack/heat-cfntools+status:open
14:38:43 <ricolin> zaneb, you actually remind me
14:38:54 <ricolin> so heat-templates gate broken
14:39:30 <ricolin> I feel what we shound do it remove jobs for deprecated hooks and remove those hooks
14:39:52 <zaneb> +1, it's been ages since we introduced heat-agents
14:40:12 <zaneb> we're not doing anybody any favours by keeping an old copy around
14:41:40 <ricolin> I guess I will add that patch to target too
14:42:24 <ricolin> but it's not limit for this week anyway
14:42:52 <ricolin> (since heat-templates repo isn't for cycle release)
14:43:43 <ricolin> Okay, any other concerns for m-3 target?
14:44:00 <zaneb> I think a lot of the repos we are responsible for have been lacking maintenance
14:44:15 <zaneb> not heat and heatclient, but all the rest
14:46:21 <ricolin> zaneb, I guess that's because neither of us care about it, so yes, we're responsible.
14:46:43 <ramishra> I agree, if there are no patches or bugs we tend to ignore those repo as we don't notice failing jobs too
14:46:46 <ricolin> stuff like AWS relative
14:48:51 <ricolin> we might need to go through those repo and figure out what's the health status
14:49:04 <zaneb> yeah, I keep meaning to do that
14:49:40 <ricolin> that's stuff we can target after this week, or even works for PTG
14:49:58 <zaneb> good idea, let's add that to our PTG list
14:50:00 <ricolin> BTW who will going to PTG?
14:50:09 <ricolin> zaneb, ramishra therve
14:50:13 <zaneb> I will, obviously
14:50:29 <ricolin> zaneb, you can't run away from it!
14:50:52 <zaneb> I don't know that RH has decided on everyone who is going
14:51:04 <ricolin> okay
14:51:18 <ricolin> Also this time ops meetup will be in PTG too
14:51:29 <ricolin> will that means more people from RH will go?
14:51:31 <zaneb> I gather that therve is not but hopefully ramishra will be able to make it
14:51:57 <ricolin> cool
14:51:58 <zaneb> no idea. we don't have that many ops people in RH
14:52:08 <ramishra> zaneb: yeah, I've not got confirmation or a decline yet:)
14:53:14 <ricolin> Thinking about talk less about features, but take more times on improvement
14:53:32 <zaneb> +1
14:53:49 <ricolin> I will generate a etherpad for PTG later
14:54:08 <zaneb> there's a big backlog of bugs that haven't been properly triaged
14:54:41 <zaneb> I'm working on the race condition stuff we talked about at the last PTG now
14:54:59 <zaneb> but starting to worry about what else is buried in storyboard
14:55:04 <ramishra> And migration to SB did not help that cause:)
14:55:10 <zaneb> no :(
14:55:36 <ricolin> #link https://etherpad.openstack.org/p/2018-Denver-PTG-Heat
14:55:38 <zaneb> I think the one about converting check/suspend/resume to convergence is becoming more urgent
14:55:41 <ricolin> zaneb, ramishra therve ^^^
14:56:32 <zaneb> apparently everyone and his dog are now using 'stack check' as the all-purpose cargo-cult recovery from anything that could go wrong all of a sudden
14:56:47 <therve> It checks! Things!
14:56:53 <ramishra> lol
14:57:26 <ramishra> If there is any error do stack check;)
14:57:43 <zaneb> and now you have two errors :)
14:58:10 <therve> Job security, we has it
14:58:21 <ramishra> and db is now incosistent and no backup is there
14:58:33 <ramishra> therve: +1
14:58:48 <zaneb> therve: indeed, but not in a good way
14:59:00 <therve> Certainly not...
15:01:08 <ricolin> #action review targeting features this week, before release m-3(end of this week)
15:01:30 <ricolin> #action propose topics to PTG https://etherpad.openstack.org/p/2018-Denver-PTG-Heat
15:02:06 <ricolin> list two actions for team
15:02:54 <ricolin> and we're running out of time, so let's end meeting if nothing else from you guys
15:03:06 <zaneb> I added some topics
15:03:45 <ricolin> thx zaneb
15:04:32 <ricolin> Okay, that's all for meeting I guess, thanks all
15:04:34 <ricolin> #endmeeting