14:00:39 <ricolin> #startmeeting heat
14:00:40 <openstack> Meeting started Wed Sep 19 14:00:39 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:43 <openstack> The meeting name has been set to 'heat'
14:00:46 <ricolin> #topic roll call
14:01:18 <zaneb> o/
14:02:07 <ricolin> ramishra, therve ?
14:02:14 <ramishra> hi
14:02:14 <therve> Kinda
14:02:32 <ricolin> o/
14:02:42 <ricolin> #topic adding items to agenda
14:02:51 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-09-19_1400_UTC.29
14:05:39 <ricolin> #topic PTG report
14:05:48 <ricolin> #link https://etherpad.openstack.org/p/2018-Denver-PTG-Heat
14:06:34 <ricolin> So we try to make some actions for what we should doing in next cycle or for long-term goal
14:07:23 <ricolin> please give a review on actions
14:09:06 <ricolin> There are some cross project discussion or action from PTG
14:09:17 <ramishra> ricolin: sure, sorry I could not join remotely as discussed earlier, was not 100%
14:09:49 <ricolin> we got discuss with barbican (security-sig) about keypair and ssl option for multicloud
14:10:17 <ricolin> ramishra, NP, we can always work things out online
14:10:52 <ricolin> also trigger Glance team to discuss enable web download for devstack by default(not getting information for that after PTG)
14:11:27 <ricolin> Plan to provide cross-project self-healing tempest test for self-healing-sig
14:11:52 <zaneb> we also had a lot of discussions with the octavia team
14:12:56 <ricolin> And monasca PTL take action to review our Monasca resources and also plan to implement event alarm in Monasca
14:14:17 <ricolin> yeah, and these two story is what we proposed in octavia
14:14:19 <ricolin> #link https://storyboard.openstack.org/#!/story/2003773
14:14:29 <ricolin> #link https://storyboard.openstack.org/#!/story/2003782
14:15:23 <ricolin> and not like a cross-porject but we also provide UC our new user survey https://etherpad.openstack.org/p/heat-user-survey-brainstrom
14:15:28 <ricolin> #link https://etherpad.openstack.org/p/heat-user-survey-brainstrom
14:15:32 <zaneb> also https://review.openstack.org/#/c/602393/2 should improve our gate. I just cleared the workflow-1
14:16:27 <ricolin> which is octavia team's suggestion
14:16:34 <ramishra> zaneb: yeah, just approved
14:16:41 <ricolin> nice
14:17:39 <zaneb> thanks!
14:19:24 <ricolin> I plan to write a ML out for asking people join review and help on implement actions
14:19:47 <ricolin> also mark some low-hanging-fruit
14:20:37 <ricolin> Any of you think we still missing some actions?
14:22:01 <ricolin> Also we need to discuss about consider remove non-apache and amqp1 job
14:22:23 <ricolin> therve, ramishra do we still need those two jobs?
14:22:39 <ramishra> ricolin: I'll check them in detail tomorrow. probably we should prioritize tasks from the beginning of the cycle itself as we don't have many contributors active. We can't do a lot
14:24:50 <ricolin> ramishra, yeah, that's kind of the reason I gonna send mail and ask for help. Also it depends on what you guys most interesting on, so feel free to put your name on any actions if that's something you can do
14:26:36 <ramishra> ricolin: we should be able to remove non-apache job, but those are non-voting atm, We also need to change the job names we are using atm *lbaasv2* and *mysql* etc
14:28:38 <therve> ricolin: the amqp1 job is nice, but we can do without
14:28:55 <zaneb> therve: what's it actually testing?
14:29:13 <ricolin> ramishra, I didn't see much error really concerns about non-apache, did you see any?
14:29:14 <therve> zaneb: Using qrouterd for the messaging bus
14:29:57 <zaneb> I mean, what's it actually testing in Heat?
14:30:16 <zaneb> we don't have any specific code for that, right? it's just oslo.messaging?
14:30:22 <therve> Well, in heat not using rabbit for engine stuff
14:31:36 <therve> It seems mostly nowadays
14:32:13 <zaneb> I'm ok with keeping it if it serves a useful purpose (does anybody use qrouterd?), I'm just not sure it's our job to watch for breakage in that
14:32:20 <zaneb> as opposed to e.g. oslo.messaging's job
14:35:01 <ricolin> I guess we can put it in review and see if anyone find that we should keep any of those two jobs
14:35:38 <ramishra> ricolin: I don't think we check for failures in non-voting jobs anymore, atleast I don't.  (not seen them failing for specific issues). So may be we can just remove those
14:36:26 <ramishra> if we want to save infra resources:)
14:36:45 <therve> zaneb: Well, oslo messaging was not doing its job so I was helping
14:36:55 <zaneb> therve: ok :)
14:37:11 <therve> Also I wished people used qrouterd, but what can I do, beside have a job that works :)
14:38:27 <zaneb> I don't think it hurts to leave it then
14:39:03 <zaneb> we are not sucking up much gate time compared to e.g. TripleO :)
14:39:26 <ricolin> #action please review PTG etherpad and leave comments
14:39:50 <ricolin> let's move on:)
14:39:58 <ricolin> #topic Autoscaling integration
14:40:08 <ricolin> #link https://etherpad.openstack.org/p/autoscaling-integration-and-feedback
14:40:14 <ricolin> #link http://lists.openstack.org/pipermail/openstack-dev/2018-September/134770.html
14:40:39 <ricolin> We been trigger some discussion about improve autoscaling and self-healing
14:41:28 <ricolin> I send a ML out, and now might be a good time to discuss what can we do to improve and integrate autoscaling cross Heat and Senlin
14:41:56 <ricolin> The etherpad is about collect discussion
14:42:14 <ricolin> also use it to discuss in Berlin of we got forum
14:42:24 <ricolin> which I already proposed
14:42:48 <ricolin> s/of/if/
14:43:20 <ricolin> So any idea on how that might works?
14:43:30 <zaneb> I think it's a good thing to discuss, but I'm not clear what integration would look like
14:43:58 <zaneb> actually, maybe we should back up a bit
14:44:14 <zaneb> so what ricolin and I discussed at the PTG was...
14:44:41 <zaneb> lots of people including probably at least half of the world's telco's are using Heat autoscaling
14:44:58 <zaneb> Senlin exists and is probably much better, but people are not using it
14:46:09 <zaneb> so it seems like it might be time to invest in cleaning up the Heat autoscaling code
14:46:42 <zaneb> now the original plan (pre-Senlin) was to spin it out into a library that could then form the basis of an external service
14:47:07 <zaneb> ricolin: and I assume that's what your Forum proposal references?
14:47:15 <ricolin> yes
14:48:10 <zaneb> but I don't know that the Senlin team are going to see anything in it for them at this point
14:48:10 <zaneb> (in fact they're interpreting it as they'll spin the Selin implementation out into a library and Heat will use it)
14:48:19 <ricolin> zaneb, if you see the `why and what` section, is exactly what I proposed to forum so if you like to update more information, I can refresh the proposal
14:48:36 <zaneb> either way, I think it's a very good (and probably overdue) discussion to have
14:49:25 <ricolin> zaneb, agree with you, to clear our ASG structure will help much more to get clear view on how we might be integrating
14:50:43 <ricolin> Also can we kind of set a long-term goal to said let's keep only one group resource (ASG) if that can cover other's (resource group/instance group/etc.) functionality
14:50:58 <zaneb> yeah. we need to rationalise to be able to make any bug fixes or improvements at all really. we have several duplicate implementations (InstanceGroup, AutoscalingGroup, ResourceGroup)
14:51:06 <zaneb> it's a mess
14:52:18 <ricolin> ramishra, therve any though?
14:52:55 <ramishra> ricolin: Do we know why people not using selnin and using heat ASG? may be question for senlin team
14:52:58 <zaneb> anyway, somewhere in my copious spare^W time I'll try to revive the patches I started on and try to figure out what they mean
14:53:39 <therve> zaneb: I'd like sources on "lots of people including probably at least half of the world's telco's are using Heat autoscaling"
14:53:40 <ramishra> I think all efforts earlier to clean up the group resources were kind of stalled as everyone was pointing out that's senlin's job
14:53:49 <ramishra> now we are back to it again;)
14:53:58 <ricolin> for sure that Blizzard using Senlin, and that's why they pick up Senlin and run for PTL
14:54:10 <zaneb> ramishra: one reason is certainly that RH doesn't ship it
14:54:10 <zaneb> but that's a whole other minefield
14:54:52 <zaneb> therve: studies show that 84% of statistics are made up
14:54:53 <therve> Unless you mean ResourceGroup?
14:57:17 <therve> ricolin: What are the particular pain points for the users?
14:57:47 <zaneb> I believe ASG, although at this point RG is almost as big a mess anyway
14:58:21 <ricolin> therve, we got some requests of improvement from public cloud, and telecom
14:58:36 <therve> Okay
14:59:06 <ricolin> the integrating idea is something we try to figure out how can we improve from this point
15:00:03 <ramishra> ricolin: I've not seen any bugs for ASG for sometime, for improvement these vendors need to contribute I suppose, just asking for improvements would not help
15:01:00 <ramishra> I had an improvment patch that merged after 2 years;)
15:01:16 <ricolin> Public Cloud WG promise to help us to get more attention for get specific issue and help
15:02:17 <ricolin> On the other hand we do got some user feel very confuse on Heat and Senlin, and we kind of doing a lot of duplicated works right now
15:03:06 <zaneb> ramishra: tbh I don't think the current code is maintainable enough for anyone to contribute
15:05:01 <ricolin> #action give your feedback/comments to autoscaling idea https://etherpad.openstack.org/p/autoscaling-integration-and-feedback
15:05:26 <ramishra> zaneb: Well we're maintaining it and lots of people using it:) but I get the point, we never spent time on those as senlin was supposed to be the go to thing which I'm hearing has possibly changed now
15:06:14 <ricolin> Okay, let's leave some comments first, and I need to jump around code to see at least how can we improve our self
15:06:20 <ricolin> we already over time
15:06:34 <ricolin> and I really like to raise the last topic at this meeting
15:06:44 <ricolin> sorry about the cutting
15:06:51 <ricolin> #topic Berlin summit
15:06:59 <ricolin> forum brainstorming
15:07:06 <ricolin> #link https://etherpad.openstack.org/p/BER-stein-forum-heat-brainstorming
15:07:39 <ricolin> So I already propose ops/user feedback for heat, and autoscaling integrating forum
15:07:57 * ricolin also propose sig/wgs expose
15:08:21 <ricolin> beside those,
15:08:33 <ricolin> we also have project update, onboarding
15:08:35 <ricolin> session
15:09:04 <ricolin> so anyone will join Berlin summit and help to host those session together?:)
15:09:47 <ricolin> zaneb, ramishra therve ^^^
15:10:18 <therve> I don't plan to
15:10:19 <zaneb> I'll be there obviously and can help
15:10:34 <ramishra> me neither
15:10:46 <ricolin> Okay, thank for the information
15:11:37 <ricolin> for Onboarding, I'm thinking about run some specific scenario like autoscaling and self-healing instead of general look through
15:11:59 <ricolin> feel free to stop me if any of you think that's a bad idea:)
15:12:17 <ricolin> kazsh, will you be in berlin?:)
15:13:00 <ricolin> #action review https://etherpad.openstack.org/p/BER-stein-forum-heat-brainstorming
15:13:19 <ricolin> The CFP for Forum ended next week
15:13:48 <ricolin> so if any idea, or suggesting please do before the deadline
15:15:05 <ricolin> Appears we got some discussion and actions need to be keep going, so let's discuss those next week
15:15:21 <ricolin> Anything to raise before we ended
15:15:30 <ricolin> #topic Open discussion
15:16:43 <zaneb> I'm good
15:16:44 <ricolin> Okay, let's end meeting now and sorry about the overtime
15:16:51 <ricolin> #endmeeting