16:01:42 <schwicke> #startmeeting hierarchical_multitenancy
16:01:43 <openstack> Meeting started Fri Aug 8 16:01:42 2014 UTC and is due to finish in 60 minutes. The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:47 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:02:38 <schwicke> Raildo_: thanks for running the meeting last Friday
16:02:49 <Raildo_> no problem :)
16:02:50 <schwicke> I went through the logs
16:03:27 <schwicke> #topic action items from last meeting
16:03:53 <schwicke> I saw that Sajeesh contacted Joe Gordon
16:04:02 <sajeesh> yes ...I did
16:04:07 <schwicke> there was another update in the BP from him
16:04:15 <sajeesh> yes
16:04:54 <schwicke> saying the dead line holds as well for the reviewers . Hmm ....
16:05:00 <sajeesh> yes
16:05:24 <schwicke> I think the idea was to have the BP discussed in the next nova meeting.
16:05:43 <sajeesh> yes
16:06:12 <Raildo_> +1
16:06:23 <sajeesh> schwicke,once the code is ready we can put our blueprint again
16:06:35 <schwicke> ok, I think that makes sense.
16:06:47 <schwicke> We could try to get some reviewer for the SPEC in any case.
16:06:51 <Raildo_> I can join in the nova meeting if I can help in something.
16:07:03 <sajeesh> raildo,thanks a lot
16:07:13 <schwicke> Raildo_ +1
16:08:07 <schwicke> #action bring up hierarchical projects in the next nova meeting
16:08:51 <schwicke> Need to put that into my calendar and will try to connect as well if possible
16:09:19 <schwicke> which one is it ? The team meeting ?
16:09:23 <sajeesh> ok
16:09:29 <sajeesh> yes
16:09:55 <Nirbhay_> when it is scheduled?
16:10:07 <sajeesh> It is on next Thursday
16:10:12 <Nirbhay_> ok
16:10:14 <VINOD_> Hi
16:10:18 <sajeesh> 11'o clock geneva time
16:10:21 <schwicke> #link https://wiki.openstack.org/wiki/Meetings#OpenStack_Compute_.28Nova.29
16:10:25 <Nirbhay_> ok
16:10:39 <Raildo_> hi VINOD_
16:10:50 <sajeesh> Hi Vinod
16:10:50 <schwicke> hi Vinod
16:10:58 <VINOD_> Hi all, sorry for late
16:11:37 <schwicke> apparently there was a meeting yesterday
16:12:02 <sajeesh> yes
16:12:26 <schwicke> did anybody of you follow it ?
16:12:50 <sajeesh> I couldn't attend it yesterday
16:12:55 <VINOD_> sorry i was travelling and so i couldn't attend the meeting
16:13:16 <schwicke> me neither
16:13:25 <schwicke> #link http://www.timeanddate.com/worldclock/fixedtime.html?iso=20140814T210000
16:13:29 <schwicke> that's the next one.
16:13:36 <Raildo_> I did not participate and the channel has no log =/
16:13:37 <schwicke> The time is not very comfortable for us.
16:13:39 <sajeesh> the timing of meeting is bit difficult to attend
16:13:55 <schwicke> sajeesh: +1
16:14:07 <sajeesh> In india it is early morning 2.30
16:14:19 <schwicke> 23h here
16:14:42 <Nirbhay_> i think i can attend from here
16:14:51 <schwicke> I will try as well.
16:14:52 <sajeesh> Anyway we should try to attend the next meeting
16:14:53 <Raildo_> In Brazil is a good time 18h
16:15:03 <sajeesh> good :-)
16:15:05 <schwicke> lucky you :)
16:15:10 <Raildo_> :D
16:15:22 <sajeesh> once me and Raildo had attended at that time
16:15:49 <schwicke> maybe it makes sense to contact the chair in advance and ask if this could be briefly discussed
16:16:02 <sajeesh> +1
16:16:06 <Nirbhay_> +1
16:16:58 <Raildo_> I do not remember now, but somewhere you can suggest the topics of the next meeting.
16:17:15 <Raildo_> sajeesh, you can ask this in the #openstack-nova
16:17:17 <sajeesh> yes
16:17:29 <sajeesh> ok
16:18:25 <schwicke> well, in theory after logging in one can edit the agenda ..
16:18:34 <schwicke> which I guess is not 100% PC
16:19:17 <schwicke> #action contact chair of nova team meeting and suggest hierarchical projects as a topic
16:19:28 <schwicke> do you want me to do that ?
16:19:52 <sajeesh> If you can,it would be nice
16:20:17 <schwicke> I'll give it a try then
16:20:29 <schwicke> let's move on
16:20:36 <sajeesh> ok
16:20:53 <schwicke> there is one thing which was not discussed in the last meeting I think
16:21:08 <schwicke> Raildo: at some point you said ""There is only a little misunderstanding of how users will be managed in the hierarchy since they are associated with domains.
16:21:08 <schwicke> I believe this is the only point that still needs to be agreed to approve the spec."
16:21:19 <schwicke> has that been sorted out ?
16:21:46 <schwicke> #topic relationship with domains
16:21:47 <VINOD_> #link http://eavesdrop.openstack.org/irclogs/%23openstack-meeting-alt/%23openstack-meeting-alt.2014-08-07.log
16:21:55 <VINOD_> you can find yesterdays logs at the above link
16:22:02 <VINOD_> scroll down to 14:00 Hrs
16:22:43 <VINOD_> I mean yesterdays nova meeting logs
16:22:52 <schwicke> yes, thanks!
16:23:19 <Raildo_> Yes, probably today I will be sending the new version of the spec will probably be the final version, but to summarize, Hierarchical projects will not interfere with user management.
16:23:51 <VINOD_> I think they discussed about the spec freeze and it looks like (after reading the first few comments), no more specs will be accepted
16:25:37 <sajeesh> Ulrich,shall we discuss about Raildo's code test results
16:26:03 <Raildo_> Next week, I plan to be with the code 100% implemented.
16:26:08 <schwicke> Raildo: so nothing else to be discussed on this ?
16:26:20 <schwicke> That's very good news
16:26:24 <sajeesh> raildo, excellent work !!!
16:26:26 <Raildo_> I received a review of sajeesh
16:26:34 <Raildo_> thanks :)
16:26:36 <schwicke> yes, next topic
16:26:55 <schwicke> #topic keystone code tests by Sajeesh
16:27:25 <schwicke> I went through your report, very nice work and very useful I think.
16:27:38 <Raildo_> Well, I believe that left to work with code review and resolve some bugs.
16:28:13 <schwicke> I spotted two issues in the review:
16:28:24 <schwicke> tree reported in wrong order: is this a bug or a feature ?
16:28:46 <schwicke> This was this "project A comes in the middle " thing
16:29:03 <Raildo_> I do not have much time today, because here in Brazil is a holiday, but I intend to respond as soon as possible.
16:29:14 <schwicke> ok, great
16:29:23 <sajeesh> ok,no problem
16:29:40 <schwicke> in any case what is more of an issue is the second thing: missing children list.
16:29:53 <schwicke> I think that is really needed by the quota stuff.
16:30:14 <sajeesh> yes,the immediate children list is required
16:30:32 <Raildo_> Well, as we talked, we will remove the hierarchy of the token and we will create a API call to get the hierarchy
16:31:02 <Raildo_> GET v3/projects/include_hierarchy
16:31:05 <sajeesh> ok
16:31:06 <VINOD_> +1
16:31:11 <Nirbhay_> ok
16:31:26 <Raildo_> it will be sent the full hierarchy
16:31:50 <sajeesh> ok
16:32:25 <schwicke> this will also adress the issue caused by disappearing projects, right ?
16:32:45 <Raildo_> and we intend to begin implementing in the keystone-client
16:33:03 <sajeesh> ok
16:33:04 <Raildo_> schwicke, yes
16:33:04 <schwicke> Nirbhay, Sajeesh: how long will it take to update the quota code accordingly ?
16:33:46 <sajeesh> Shwicke,it will take around 2 weeks
16:33:48 <Nirbhay_> If i need to write whole code againg then it may take some time
16:34:32 <Nirbhay_> 2-3 weeks it will take..
16:35:05 <Raildo_> sorry, the API call to get the hierarchy is: GET v3/projects/{project_id}?include_hierarchy
16:35:13 <schwicke> Nirbhay: let's discuss offline
16:35:18 <Nirbhay_> ok
16:35:30 <schwicke> maybe we find some way to speed this up a bit
16:35:42 <sajeesh> ok...raildo,whether this feauture is there in the current set up
16:35:57 <VINOD_> I think no need to write whole code again...it just requires few changes in the sajeesh code....I guess 1 week is fine...But i still have doubt about our blue print
16:36:00 <schwicke> that would be useful indeed
16:36:02 <Raildo_> #link API documentation review https://review.openstack.org/#/c/111355/
16:36:43 <sajeesh> vinod,if we try we can finish it early
16:37:44 <VINOD_> First we need to some how make our blueprint accepted...If i am right, the deadline for Juno-3 is August 21...and definitely we can finish the code (this is not at all a problem)
16:37:56 <sajeesh> +1
16:38:08 <Raildo_> VINOD_, you are right
16:38:14 <schwicke> +1
16:38:22 <Nirbhay_> agreed with vinod
16:38:23 <schwicke> that's the hard part I'm afraid
16:38:50 <VINOD_> schwicke: yes, if i read the logs of yesterday meeting, i guess it is difficult now for our blueprint to go through Juno-3
16:39:22 <sajeesh> but we can try till the last minute
16:39:31 <VINOD_> Joe gordon has posted a comment on our blueprint "Hi, Unfortunately we have the deadline not only for patch authors but for reviewers. As we already have a tremendous number of outstanding patches that need reviewing."
16:39:36 <sajeesh> yes
16:40:11 <VINOD_> With that comment, it seems negative for the acceptance of the blueprint
16:40:14 <schwicke> which is understandable
16:40:19 <sajeesh> yes
16:40:51 <VINOD_> So the question, how we now proceed (which channel we can use) to ask the reviewers to look about our blue print?
16:41:30 <schwicke> I think we need to find some highly ranked supporters :)
16:41:41 <sajeesh> truely
16:41:47 <VINOD_> I repeat again, code is not a problem..its a promise ...that code will be definitely ready...so please think about the blueprint...
16:41:54 <VINOD_> but how? any idea?
16:42:11 <sajeesh> raildo,can you please suggest ?
16:44:07 <Raildo_> Well, I think we should focus on is that this functionality is directly related to another feature in Keystone
16:44:08 <Raildo_> and the Keystone code will most likely come into Juno-3.
16:44:20 <sajeesh> ++1
16:44:59 <Raildo_> So, the Novacode should also get in Juno-3.
16:45:00 <Raildo_> I think this is the point that we must use to get approval.
16:45:13 <sajeesh> very correct
16:45:35 <VINOD_> +1
16:46:27 <Raildo_> We have to make it clear also that the both code are already well advanced and it can now be tested.
16:46:35 <VINOD_> How can we make our voice heard? Is it through only nova meeting or by contacting some body through e-mail (like Joe Gordon)
16:46:46 <Raildo_> And that's not a feature that began a few days
16:46:55 <sajeesh> yes
16:46:58 <schwicke> +1
16:47:00 <Raildo_> vishy?
16:47:08 <Nirbhay_> +1
16:47:18 <sajeesh> I think vishy is the right person
16:47:30 <schwicke> +1
16:47:32 <Raildo_> I believe he is much interested in this feature and can help it.
16:47:40 <VINOD_> sajeesh: can you do this?
16:47:41 <vishy> hi
16:48:12 <vishy> unless there is an approved blueprint already
16:48:16 <sajeesh> hi vishy
16:48:23 <vishy> there is no way nova code is getting in in juno :(
16:48:46 <vishy> nova merges have been really blocked up. Hopefully we can fix it in k
16:49:04 <vishy> keystone seems possible
16:49:44 <sajeesh> ok
16:50:00 <Raildo_> :( ok
16:50:06 <schwicke> bad luck.
16:50:20 <vishy> for example
16:50:25 <morganfainberg> vishy, we are winding down juno, we have talked about having this work land on a feature branch for J in keystone
16:50:36 <vishy> I had a blueprint + patches 1 week after summit for nova
16:50:40 <vishy> now 3 months later
16:50:48 <vishy> still last 3 patches haven’t merged
16:51:07 <vishy> we need to figure out something to get the review queue down
16:51:23 <vishy> I really appreciate the work you guys have been doing
16:51:30 <morganfainberg> vishy, it may make sense to push the acceptance of the code to early K for Keystone as well, but we were open to a featre branch if we couldn't land it right away.
16:51:35 <vishy> morganfainberg: based on how hard this is to get in
16:51:51 <vishy> it would be awesome to get the keystone side in ASAP
16:52:01 <vishy> just because all the other projects will block on keystone acceptance
16:52:19 <schwicke> that makes sense
16:52:23 <morganfainberg> vishy, ++ not blocking it yet :) lets see if we can hammer out the spec bits and get that finalized, most of the complaints on the spec have been addressed
16:52:40 <morganfainberg> vishy, worst case, we can feature branch and look at a merge once RC is cut for J
16:53:00 <Raildo_> morganfainberg, ++
16:53:23 <vishy> sorry i haven’t been helping much
16:53:35 <vishy> can you link me the various bps and patches so i can help lend support?
16:53:56 <schwicke> #link https://review.openstack.org/#/c/101017/
16:53:57 <sajeesh> ok, sure
16:54:00 <VINOD_> vishy: I have a doubt, If lets say Raildo code is accepted for Juno-3 and that means, there is a difference in the current project hierarchy to the nested hierarchy. The other projects will still be assuming the token in the older format (ofcourse keystone APIs as well)
16:54:05 <schwicke> #link https://review.openstack.org/#/c/110639/
16:54:09 <VINOD_> so, does this pose any problem to other projects?
16:54:19 <Raildo_> vishy, I'll include you as a reviewer in all patches
16:54:38 <morganfainberg> VINOD_, the token format *cannot* change.
16:54:53 <VINOD_> morganfainberg: ok
16:54:59 <morganfainberg> VINOD_, we can look at adding some extra data, but we cannot change it.
16:55:18 <Raildo_> morganfainberg, ++ As we will not modify the token to the other services there is no hierarchy.
16:55:29 <schwicke> #action add vishy as reviewer
16:55:40 <morganfainberg> VINOD_, not unless we bump token version (there is no good story for this in keystone yet, it is on the long list of things we want)
16:56:00 <morganfainberg> VINOD_, but since Raildo_ just said we aren't changing the token version, nbd.
16:56:17 <morganfainberg> s/token verson/token format
16:56:48 <VINOD_> Raildo: So if i am right, then even though there is a support for nested projects in your code, it will still work as the existing one (not to break the other services in the openstack)
16:57:15 <Raildo_> VINOD_, ++
16:57:51 <VINOD_> Raildo: That's great...best of luck for your bp and code
16:57:52 <Raildo_> The way we implemented, only the Keystone is being affected. (we will create tempest test to prove it)
16:57:53 <schwicke> vishy: can you think of any other highly interested reviewer who we can ask ?
16:58:30 <vishy> schwicke: has dolphm or ayoung been reviewing?
16:58:50 <schwicke> vishy: don't think so. Good idea
16:59:10 <schwicke> #action invite also dolphm and ayoung
16:59:18 <VINOD_> vishy: No, only "Tim Bell" and "Joe Gordon" are in the review list
16:59:26 <sajeesh> yes
16:59:55 <schwicke> time is running out guys
17:00:14 <schwicke> need to follow-up via e-mail afaik
17:00:18 <VINOD_> ok
17:00:20 <sajeesh> raildo,I will test the remaining api calls and will get back to you
17:00:23 <Raildo_> ok
17:00:28 <schwicke> #endmeeting