16:08:59 <schwicke> #startmeeting hierarchical_multitenancy
16:09:01 <openstack> Meeting started Fri Sep 12 16:08:59 2014 UTC and is due to finish in 60 minutes.  The chair is schwicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:09:02 <raildo_> hi all
16:09:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:09:05 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:09:12 <schwicke> hi all!
16:09:18 <schwicke> thanks for joining in!
16:09:19 <sajeesh> hi shwicke...sorry ...I was in a function
16:09:28 <schwicke> long time since the last meeting ...
16:09:32 <sajeesh> yes
16:09:36 <raildo_> schwicke yes
16:09:50 <schwicke> we have a couple of things to be discussed
16:10:21 <schwicke> #topic implementation status
16:11:22 <schwicke> raildo: thanks for giving access to the VM
16:11:36 <sajeesh> thanks raildo
16:11:39 <raildo_> schwicke, you're welcome
16:11:54 <schwicke> from the discussions and the mail exchange we had there is a api call which gives access to the full sub-tree, right ?
16:12:01 <sajeesh> yes
16:12:17 <raildo_> We finish the implementation in Keystone, we are now in the process of code review
16:12:30 <schwicke> sajeesh: I think for the implementation that is good enough for now. we can optimize this later
16:12:45 <sajeesh> schwicke +1
16:12:48 <raildo_> And we are developing for openstack-client and Horizon
16:13:00 <sajeesh> schwicke ..I have completed the code
16:13:00 <schwicke> at the end I think it does not matter much if the list of immediate children (which is the only thing we need) is extracted on the keystone or the nova side
16:13:07 <thiagop> and python-keystoneclient
16:13:14 <sajeesh> true
16:13:25 <schwicke> great!
16:13:55 <schwicke> sajeesh: coding is done and available in git ?
16:14:12 <sajeesh> coding is over...I will upload in git
16:14:38 <schwicke> #action: sajeesh will submit the quota code to git
16:15:07 <raildo_> sajeesh, I will want to review the code :)
16:15:20 <sajeesh> raildo..sure..thanks
16:15:27 <schwicke> #action sajeesh to invite reviews, eg raildo
16:16:19 <schwicke> so we can consider this done, right ?
16:16:31 <sajeesh> yes
16:16:44 <schwicke> Next topic then
16:16:51 <schwicke> #topic: horizon
16:17:00 <sajeesh> horizon ?
16:17:09 <schwicke> thanks again to Thiago for joining in
16:17:26 <sajeesh> thanks a lot thiago
16:17:33 <schwicke> and the screen shots
16:17:34 <thiagop> schwicke: not at all, I'm glad
16:17:57 <schwicke> just to understand: for now this is only  a PoC, right ?
16:18:29 <thiagop> yep, in fact it needs a huge ammount of improvement
16:18:44 <schwicke> do you already have a bp draft for this ?
16:18:55 <thiagop> the edit buttons is losing allignment when editting the name of the projects inline
16:19:09 <schwicke> ouch :)
16:19:30 <thiagop> not yet. I'm fixing these front-end problems right now
16:19:49 <schwicke> on our side I have some hope that we can free some man power to help on this. The question is only how to coordinate this.
16:19:58 <thiagop> and I intend to talk with the UX people to get some help (I'm not a very good front-end programmer)
16:20:22 <schwicke> (me neither :D)
16:20:36 <schwicke> A good start would be already to have a list of features which need to be implemented.
16:20:43 <sajeesh> yes
16:20:53 <schwicke> I mean: add/edit/remove projects
16:21:02 <schwicke> add/edit/remove roles
16:21:14 <raildo_> We still have to talk to with the Horizon folks to show the implementation and create a BP for thisd
16:21:44 <raildo_> schwicke, but this will only be for Kilo (probably at the summit)
16:21:49 <schwicke> #action: contact horizon fols to show the implementation and create a bp
16:22:05 <schwicke> raildo: of course, that is obvious :D
16:22:06 <thiagop> I had some problems in obtaining a usable hierarchy to structure that pages. I had to get the whole subtree and process it to get wich project is what level and is son of wich other project and so on...
16:22:40 <schwicke> sure
16:22:51 <thiagop> I can coordinate that, if you don't mind
16:23:02 <sajeesh> +1
16:23:04 <schwicke> sure, that would be great!
16:23:14 <raildo_> +1
16:23:21 <schwicke> #agreed: Thiago will coordinate work on horizon
16:23:30 <thiagop> we have also worked in the add project w/ parent
16:23:38 <sajeesh> ok
16:24:14 <thiagop> edit is a different matter because, AFAIK, this option is not covered in our initial scope for hierarchy on keystone
16:24:54 <sajeesh> ok
16:25:21 <sajeesh> edit means ..changing the parent ?
16:25:21 <schwicke> well, by design we don't allow much to be edited for projects, right ?
16:25:47 <thiagop> right
16:26:03 <thiagop> but, as we are thinking in Kilo, maybe we have some time to add some new steps to enable it on keystone too
16:26:10 <schwicke> what comes to my mind what is useful to be edited is who of the user has an admin role as well as the nova quota values of the children
16:26:11 <sajeesh> ok
16:26:24 <schwicke> that makes sense
16:27:02 <schwicke> actualy, that is what I was aiming at :)
16:27:35 <schwicke> ideally, it would be good if with kilo we could provide a set of patches which actually make the whole thing usable
16:28:06 <schwicke> sajeesh: edit really only means what I mentioned.
16:28:13 <sajeesh> ok
16:28:27 <schwicke> and for the quota part I guess horizon will have to issue nova calls, simply
16:28:39 <raildo_> schwicke, ++
16:28:40 <sajeesh> +1
16:29:02 <thiagop> +1
16:29:10 <schwicke> I think it would make sense if BARC could start to have a look at this, what do you think ?
16:29:27 <schwicke> Nirbhay: welcome !
16:29:34 <sajeesh> hi Nirbhay
16:29:40 <Nirbhay_> Hi to all, sorry for being late
16:30:10 <thiagop> Hi!
16:30:18 <sajeesh> shwicke,we will see that
16:32:06 <schwicke> ok
16:34:48 <raildo_> next topic?
16:35:06 <schwicke> yes
16:35:35 <schwicke> (sorry, got distracted by my 2 years old playing with a knife ...)
16:35:39 <schwicke> #top summit
16:35:46 <schwicke> #topic summit
16:35:46 <raildo_> schwicke, hahahaha
16:35:52 <schwicke> :D
16:35:52 <sajeesh> shwicke,first we need to identify what all things need to be changed with respect to the current horizon dashboard..we can have a offline discussion on this
16:36:12 <schwicke> sajeesh: ok, let's discuss offline
16:36:24 <raildo_> schwicke, I won my ticket and hotel via Travel Support Program
16:36:32 <raildo_> let's go to Paris \o/
16:36:33 <thiagop> I'll prepare a VM with this code as soon as I can
16:36:46 <schwicke> raildo: that's great news!
16:36:50 <sajeesh> raildo,great !!
16:36:55 <Nirbhay_> raildo: congrats
16:37:03 <raildo_> thank you :D
16:37:05 <schwicke> from us there will be a number of people, mainly from the cloud operations team
16:38:02 <raildo_> My intention is to create a design session on cross project,  about hierarchical projects
16:38:04 <schwicke> and one collaborator from BARC, Nirupma
16:38:21 <schwicke> raildo: +1
16:38:26 <raildo_> So, we can discuss Nova, Horizon, keystone and others :)
16:38:28 <sajeesh> +1
16:38:32 <thiagop> +1
16:38:50 <Nirbhay_> +1
16:38:55 <schwicke> +1
16:39:01 <raildo_> #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
16:40:55 <schwicke> unfortunately, I cannot come to Paris due to an expected increase of the family at exactly that time :(
16:41:14 <schwicke> raildo: do you want us to update the etherpad ?
16:41:22 <raildo_> sure
16:41:56 <thiagop> schwicke: I don't know if I should congratulate you of feel sorry for you.
16:42:05 <schwicke> :)
16:42:13 <sajeesh> :-)
16:42:21 <thiagop> I belive it's a 80-20% proportion
16:42:30 <raildo_> schwicke, summit has every six months
16:42:44 <raildo_> schwicke, congrats!
16:42:59 <sajeesh> congrats
16:43:19 <schwicke> back to the topic
16:44:18 <sajeesh> thiago..I will review your code..sorry I was busy last week
16:44:55 <thiagop> No problem, I'll be glad to have some feedback
16:45:08 <schwicke> the etherpad looks pretty generic, isn't it ?
16:45:30 <sajeesh> yes
16:45:32 <schwicke> so it is really about proposing full work shops ?
16:45:38 <raildo_> We have to discuss at the summit:
16:45:39 <raildo_> - Final Implementation at Horizon
16:45:39 <raildo_> - Extension of hierarchical quota for the horizon?
16:45:39 <raildo_> - New features in Keytone (recursive deletion, update parent project ...)
16:45:58 <raildo_> anything else?
16:46:03 <schwicke> also: impact on other projecst
16:46:18 <raildo_> ok
16:46:44 <schwicke> I guess that at some point you might want to distribute you disk quota and delegate that as well. Stuff like that.
16:46:53 <thiagop> I think we should sepparate this horizon stuff in two topics: Hierarchical projects management and quota
16:47:21 <sajeesh> raildo,if there is anything else to discuss...I will inform u ,..I have to think
16:47:35 <raildo_> sajeesh, ok
16:48:14 <schwicke> thiagop: +1
16:48:20 <thiagop> and invite UX people to the cross-project session also
16:48:26 <schwicke> that should make things easier.
16:48:30 <raildo_> schwicke, Do you intend to send someone to Summit?
16:48:43 <schwicke> see above: yes
16:48:50 <sajeesh> raildo,what about what making keystone in sync with other services...I mean notifications
16:48:52 <schwicke> Nirupma will go there from our side.
16:49:50 <schwicke> Belmiro is working with us as well and will be there. He's more from the operations team though
16:49:58 <raildo_> sajeesh, I believe this should be a separate discussion (I think it will be very complicated), but I will suggest to the Keystone folks.
16:50:15 <sajeesh> raildo,sure it is complicated
16:50:46 <schwicke> sajeesh: I imagine that this would be a very hot topic
16:51:02 <sajeesh> very true
16:51:07 <raildo_> schwicke, Certainly!
16:52:02 <sajeesh> shwicke, the kilo spec is likely to be opened at Sept-25
16:52:49 <schwicke> sajeesh: Great! Please submit asap, and invite core developers for review. Usual suspects I'd say
16:53:07 <sajeesh> sure ..I will do it
16:53:32 <raildo_> Time is running out ... Following the suggestions of Vinod's topic  - reduce frequency of meetings?
16:53:52 <schwicke> I think we should brain storm during the week on possible topics and review next friday
16:54:00 <schwicke> to conclude this topic
16:54:02 <sajeesh> ++1
16:54:08 <Nirbhay_> +1
16:54:10 <raildo_> schwicke, sounds good to me
16:54:17 <thiagop> +1
16:54:20 <schwicke> #agreed: brain storm over the week and rediscuss next Friday
16:54:33 <schwicke> #topic: frequency of meetings
16:55:09 <schwicke> I think we have 2 options: we leave the regular schedule but don't use every slot, or we go down to a 2 weeks schedule
16:55:27 <schwicke> thinking about the summit preparation I'm more in favor of the first option ...
16:55:34 <schwicke> Opinions welcome!
16:55:44 <sajeesh> first option sounds good to me
16:56:03 <schwicke> the only issue is that other might might be able to use the slot otherwise
16:56:19 <raildo_> I believe to decrease the meeting for two weeks and maintain contact by email
16:56:52 <schwicke> so next meeting on the 26th ?
16:57:07 <schwicke> at that point we could check if the submission worked fine :)\
16:57:19 <raildo_> I believe we need to have everything well defined for the summit, this meeting is important.
16:57:36 <sajeesh> +1
16:57:38 <schwicke> raildo: I agree with you
16:58:01 <schwicke> at least until the summit we should probably keep the meetings untouched.
16:58:17 <schwicke> Time is running out.
16:58:19 <raildo_> schwicke, ok
16:58:31 <sajeesh> +1
16:58:32 <schwicke> #agreed: keep the meetings as they are until the summit then review
16:58:40 <schwicke> ok, AOB ?
16:58:58 <schwicke> #endmeeting